IBM Support

System Requirements for IBM Mobile Messaging and M2M Client Pack MA9B (superseded)

Detailed system requirements


Abstract

The requirements detailed in this document are for IBM Mobile Messaging and M2M Client Pack MA9B. Note that this client pack has been superseded by the IBM Messaging Telemetry Clients SupportPac MA9C.

Content

To download the replacement SupportPac, see MA9C: IBM Messaging Telemetry Clients.

The system requirements for IBM Mobile Messaging and M2M Client Pack MA9B (superseded) are as follows:

IBM MESSAGING CLIENT FOR JAVASCRIPT
Supported Platforms
All major browser versions, which are compliant with the RFC 6455 (WebSocket) Standard.
Reference Platforms
Samsung Galaxy S III Android 4.1 Firefox (latest up to date level)
Apple iPhone 5 iOS 7.1 Safari (latest up to date level)
Intel (x86-32) Windows 7 Chrome (latest up to date level)
Intel (x86-64) Red Hat 6 Firefox (latest up to date level)

JAVA CLIENTS
Supported Platforms
The Java client runs on any platform that has a suitable Java runtime environment (JRE). The client can be run on the following Java runtimes:

  • JSE 1.5 or higher that is "Java Compatible".
Reference Platforms
Samsung Galaxy S III/Android 4.1/Native (built in) Java runtime for Android
LG Nexus 5/Android 4.4/Native (built in) Java runtime for Android
Samsung Galaxy Tab 2 10.1/Android 4.0/Native (built in) Java runtime for Android
Intel (x86-32)/Windows 7/IBM Java 1.5
Intel (x86-32)/Red Hat 6/IBM Java 1.6

ANDROID SERVICE
Supported Platforms
Android 4.1 and future OS fix packs
Reference Platforms
LG Nexus 5/Android 4.4

IOS CLIENT
Supported Platforms
iOS 7.1 and future OS fix packs
Reference Platforms
Apple iPad 3/iOS 7.1.
Apple iPhone 5/iOS 7.1.

C CLIENTS (SYNCHRONOUS)
Supported Platforms
iOS 6.0 and future OS fix packs
Currently supported platforms for C client in WebSphere MQ Telemetry v7.5.
Reference Platforms
Intel (x86-32)/Windows 7 Professional/VisualStudio 2012.
Intel (x86-32)/Red Hat Enterprise Linux Server 6.0 with glibc 2.12 and kernel 2.6.32.
Intel (x86-64)/Red Hat Enterprise Linux Server 6.0 with glibc 2.12 and kernel 2.6.32.

C CLIENTS (ASYNCHRONOUS)
Supported Platforms
Intel Linux glibc 2.12 and kernel 2.6.32 and future OS fix packs.
Windows XP, Windows Vista, Windows 7 and future OS fix packs.
Reference Platforms
Intel (x86-32)/Windows 7 Professional/VisualStudio 2012.
Intel (x86-32)/Red Hat Enterprise Linux Server 6.0 with glibc 2.12 and kernel 2.6.32.
Intel (x86-64)/Red Hat Enterprise Linux Server 6.0 with glibc 2.12 and kernel 2.6.32.


Cross reference information
Segment Product Component Platform Version Edition
Systems and Asset Management IBM MessageSight MQTT Clients

Product Alias/Synonym

WMQ MQ IBM MessageSight ma9b

Document information

More support for: WebSphere MQ Telemetry
Documentation

Software version: 1.0.0.3

Operating system(s): Linux, Windows, iOS

Reference #: 7036811

Modified date: 23 May 2013


Translate this page: