4.1.x - Platform Support: Agents, Servers and GUI

Technote (FAQ)


Question

What are the supported platforms for the various Tivoli Storage Productivity Center version 4.1.0 and 4.1.1 components? Where can I install it? What databases are supported? What operating systems are supported?

Answer

Supported Platforms

Databases
GUI
Servers
Agents
Multipathing


Databases

Last updated: 2010-08-12
Platform/Database
TPC Server
TPC-R
Repository
Database4
TPC for Databases 1,2,3
DB2 7.2 - 32-bit No No Yes
DB2 7.2 FP8 - 32-bit No No Yes
DB2 8.1 FP9 - 32-bit No No Yes
DB2 8.1 FP7a, 12, 14 - 32-bit No No Yes
DB2 8.2 FP 7a, 14 - 32-bit No Yes Yes
DB2 9.1 FP 2 and above5 - 32-bit and 64-bit Yes Yes Yes
DB2 9.5 - 32-bit and 64-bit Yes Yes Yes
MS SQL Server 7.0 No No Yes
MS SQL Server 2000 No No Yes
MS SQL Server 2005 No No Yes
MS SQL Server 2008 No No Yes
Derby (embedded) No Yes No
Sybase v12.5 No No Yes
Oracle 8i - 32-bit No No Yes
Oracle 9i - 32-bit No No Yes
Oracle 10g -32-bit No No Yes
1 The JDBC driver should be compatible with both the RDBMS type and version. It must also be compatible with JRE version 1.4, which is used by the 4.1 and 4.1.1 Data Agents. The latest available driver may not be the correct driver in some cases. Refer to your RDBMS documentation for further information.
2 Databases installed on clustered servers (e.g. MSCS, HACMP or Veritas clusters) are not supported for monitoring.
3 Multiple database applications per server are supported as long as the database applications are of different types. Tivoli Storage Productivity Center does not support monitoring two databases of the same type. For example, you can monitor an Oracle database and a DB2 database installed on the same server but cannot monitor two separate DB2 databases on the same server.
4 For open systems, Tivoli Storage Productivity Center for Replication version 4.1.x only supports the listed DB2 versions if the customer had DB2 and upgraded from a previous version. New installations will use an embedded database. With z/OS, DB2 v8 and v9 can be used for new installations.
5 Tivoli Storage Productivity Center installation fails when creating the database schema when DB2 9.1 Fix Pack 5 is used on a Windows 64-bit machine with more than 4 GB of memory. See DB2 APAR JR30491 for details. To avoid this problem, use DB2 9.5 with Fix Pack 4.


Servers & GUI
Unless otherwise specified, all of the support in the table below applies to a 32-bit operating system or setting up the operating system to run a 32-bit application using a 64-bit processor.
Platform
Last updated: 2011-04-28
AIX
TPC Server
TPC-R Server
TPC GUI
Agent Manager 2
AIX 5.3
-POWER4
-POWER5
-POWER6
Yes 1
Yes 1
Yes 1
Yes 1
AIX 6.1
-POWER4
-POWER5
-POWER6
-POWER7
Yes 1,3
Yes 1,3
Yes 1
Yes 1
Linux
TPC Server
TPC-R Server
TPC GUI
Agent Manager 2
Red Hat Enterprise Linux AS 4
-x86
Yes
Yes
Yes
Yes
Red Hat Enterprise Linux Base Server and Advanced Platform 5
-x86, EM64T
Yes
Yes
Yes
Yes
VM on VMware
TPC Server
TPC-R Server
TPC GUI
Agent Manager 2
VMware ESX and ESXi 3.0.x, 3.5.x, 4.0.x

TPC 4.1.1.74 and up for ESX and ESXi 4.0.x.

-RedHat Enterprise Linux AS 4
-RedHat Enterprise Linux 5
-Windows 2003
-Windows 2008
Yes
Contact your IBM Representative for more information.
Yes
Yes
Windows
TPC Server
TPC-R Server
TPC GUI
Agent Manager 2
Windows 2003
-Standard Edition
-x86, AMD
Yes
Yes
Yes
Yes
Windows 2003
-Enterprise Edition
-x86, AMD
Yes
Yes
Yes
Yes
Windows 2008
-Standard Edition
-x86, AMD
* R2 not supported
Yes
Yes
Yes
Yes
Windows 2008
-Enterprise Edition
-x86, AMD
* R2 not supported
Yes
Yes
Yes
Yes
Windows Vista (32-bit)
-x86, AMD
No
No
Yes
No
Windows XP (32-bit)
-x86, AMD
No
No
Yes
No
z/OS
TPC Server
TPC-R Server
TPC GUI
Agent Manager 2
v1.8 or later
No
Yes
No
No

1 Recommended minimum AIX levels (updated on 2011-02-16 to avoid known problems):
· For AIX 5.3:
    Technology Level 5300-08 Service Pack 10
    Technology Level 5300-09 Service Pack 7
    Technology Level 5300-10 Service Pack 4
    Technology Level 5300-11 Service Pack 4
    Technology Level 5300-12 Service Pack 1
· For AIX 6.1:
    Technology Level 6100-01 Service Pack 9
    Technology Level 6100-02 Service Pack 8
    Technology Level 6100-03 Service Pack 5
    Technology Level 6100-04 Service Pack 5
    Technology Level 6100-05 Service Pack 1
    Technology Level 6100-06
You can download the package from: http://www-933.ibm.com/eserver/support/fixes/fixcentral/pfixpacks/53 or http://www.ibm.com/eserver/support/fixes/fixcentral/pfixpacks/61.
You must apply AIX TL 5300-06 Recommended Maintenance Level or higher for AIX 5.3 in an IPV6 environment.
2 Agent Manager can run on some operating systems in addition to the ones supported by the Tivoli Storage Productivity Center server component. If you have an Agent Manager server already installed on one of these other operating systems in your environment, it can be used for deploying Data Agents and Fabric Agents. However, it has not been tested by Tivoli Storage Productivity Center in this configuration.
3 POWER7 for AIX 6.1 support is only available with Tivoli Storage Productivity Center and Tivoli Storage Productivity Center for Replication 4.1.1. It is not supported with version 4.1.0.


Agents
Unless otherwise specified, all of the support in the table below applies to a 32-bit operating system or setting up the operating system to run a 32-bit application using a 64-bit processor. For zSeries, it would be 31-bit and 64-bit instead.
Platform
Last updated: 2011-04-28
AIX
Data Agent
Fabric Agent
Storage Resource Agent
AIX 5.3
-POWER4
-POWER5
-POWER6
Yes 1
Yes 1,5
Yes 1
AIX 6.1
-POWER4
-POWER5
-POWER6
-POWER7
Yes 1
(POWER5 and POWER6 only)
Yes 1,5
(POWER5 and POWER6 only)
Yes 1, 6
AIX VIOS 1.5.2 and above
Yes 2
Yes 2
No
HACMP on AIX3
-v5.5.x
-v5.4.0.1 (APAR IY87447) or above
-v5.3.0.4 (APAR IY87534) or above
Yes
Yes
Yes
HP-UX
Data Agent
Fabric Agent
Storage Resource Agent
HP-UX 11i v1 (B.11.11)
-PA-Risc
Yes
Yes
No
HP-UX 11i v2 (B.11.23)
-PA-Risc
Yes
Yes
No
Linux
Data Agent
Fabric Agent
Storage Resource Agent
Red Hat Enterprise Linux AS 4
-x86
-POWER5 and POWER6
Yes
Yes
(x86 only)
Yes
Red Hat Enterprise Linux AS 4
-zSeries
No
No
Yes
Red Hat Enterprise Linux Base Server and Advanced Platform 5
-x86, AMD64/EM64T
Yes
Yes
Yes
Red Hat Enterprise Linux Base Server and Advanced Platform 5
-POWER5, POWER6
-zSeries
No
No
Yes
SuSE Linux Enterprise Server 9
-x86
-POWER5, POWER6
–zSeries
Yes
Yes
(x86 only)
Yes
SuSE Linux Enterprise Server 10
-x86, pSeries, zSeries
No
No
Yes
SuSE Linux Enterprise Server 11
-x86, pSeries, zSeries
*TPC 4.1.1.66 (FP1) and up
No
No
Yes
Solaris
Data Agent
Fabric Agent
Storage Resource Agent
Sun Solaris 9
-SPARC
Yes
Yes
No
Sun Solaris 10
-SPARC
Yes 4
Yes 4
No
VMware VI & vSphere
Data Agent
Fabric Agent
Storage Resource Agent
VI 3.x.x, vSphere 4.0.x
ESX and ESXi 3.0.x, 3.5.x, 4.0.x
Virtual Center 2.5.x
vCenter 4.0.x
No
No
No
VM on VMware
Data Agent
Fabric Agent
Storage Resource Agent
VMware ESX and ESxi 3.0.x, 3.5.x, 4.0.x

TPC 4.1.1.74 and up for ESX and ESXi 4.0.x

Guest OS:
-RedHat Enterprise Linux AS 4.0
-RedHat Enterprise Linux 5
-SuSE Linux Enterprise Server 9
-SuSE Linux Enterprise Server 10
-SuSE Linux Enterprise Server 11
-Windows 2003
-Windows 2008
Yes 6
No
Yes 6
Windows
Data Agent
Fabric Agent
Storage Resource Agent
Windows 2003 & R2
-Data Center Edition
-Enterprise Edition
-Standard Edition
-x86, AMD
Yes
Yes
Yes
Windows 2008
-Data Center Edition
-Enterprise Edition
-Standard Edition
-x86, AMD
*R2 not supported
Yes
Yes
Yes

1 Recommended minimum AIX levels (updated on 2011-02-16 to avoid known problems):
· For AIX 5.3:
Technology Level 5300-08 Service Pack 10
Technology Level 5300-09 Service Pack 7
Technology Level 5300-10 Service Pack 4
Technology Level 5300-11 Service Pack 4
Technology Level 5300-12 Service Pack 1
· For AIX 6.1:
Technology Level 6100-01 Service Pack 9
Technology Level 6100-02 Service Pack 8
Technology Level 6100-03 Service Pack 5
Technology Level 6100-04 Service Pack 5
Technology Level 6100-05 Service Pack 1
Technology Level 6100-06

You can download the package from: http://www-933.ibm.com/eserver/support/fixes/fixcentral/pfixpacks/53 or http://www.ibm.com/eserver/support/fixes/fixcentral/pfixpacks/61.
You must apply AIX TL 5300-06 Recommended Maintenance Level or higher for AIX 5.3 in an IPV6 environment.
2 AIX VIOS only supports Tivoli Storage Productivity Center Data Agents and Fabric Agents installed on the same partition as the VIO server. Tivoli Storage Productivity Center does NOT support the use of virtual storage from the VIO server on other partitions.
3 Refer to the HACMP version compatibility matrix for further details.
4 For Solaris 10, only Global Zone is supported for the Data and Fabric agents. The Non-Global (or local) zones are NOT supported.
5 If you have the AIX Dynamic Tracking feature enabled on your AIX 5.3 or 6.1 host with an inband fabric agent, you should be aware of AIX APAR IZ67335. An official fix is not yet available.
6 POWER7 for AIX 6.1 support is only available with Tivoli Storage Productivity Center 4.1.1. It is not supported with version 4.1.0. It is only available with the Storage Resource Agent and not with the Data Agent or Fabric Agent.
7 Hypervisor monitoring support:
Last updated: 2010-04-01
Vendor
Supported Platform
Supported Function
Supported Storage Systems
VMWare ESX Server 4.0
TPC 4.1.1.74 and up
Monitoring
LUN Correlation
3PAR
EMC Clariion
EMC Symmetrix
HDS 9xxxx
HP EVA
IBM DS4000
IBM DS8000
IBM DS6000
IBM ESS
IBM SVC
IBM XIV
ESXi Server 4.0
TPC 4.1.1.74 and up
vCenter 4.0
TPC 4.1.1.74 and up
ESX Server 3.0.1
ESX Server 3.0.2
ESX Server 3.5
ESXi Server 3.5
VirtualCenter 2.0.1
VirtualCenter 2.5

The following environments are also supported when used with a Data Agent on a supported platform.

Last updated: 2009-10-20
Clustering File Systems NetWare Volume Managers
MSCS Clustering Windows 2003 Edition AIX JFS NetWare 6.0, 6.5 with SP3 and above on x86 AIX Volume Manager
MSCS Clustering Windows 2003 Data Center Edition EXT2, EXT3 HP-UX Logical Volume Manager
Failover Clustering Windows 2008 Enterprise Edition FAT, FAT32 Veritas Volume Manager (VxVM) 3.x and 4.11
-AIX
-HP-UX
-Linux
-Solaris
Failover Clustering Windows 2008 Data Center Edition GPFS on AIX v2.0 and v2.1
GPFS 3.2
HP_HFS
NF
NTFS4, NTFS5
NW_FAT, NW_NSS
REISERFS
SANFS
TMPFS
UFS
VMFS
Veritas File System (VxFS) 3.0+ up to 4.11
-AIX
-HP-UX
-Linux
-Solaris
WAFL
1 Tivoli Storage Productivity Center will support file systems and volumes created through Veritas File System (VxFS) and Veritas Volume Manager (VxVM) release 4.x , as long as those file systems and volumes conform to file systems and volumes created with version 3.x of VxFS and VxVM. TPC cannot work with volumes and file systems with new features specifically introduced with VxFS and VxVM release 4.x.

Multipathing
Last updated: 2010-04-05
Multipathing Product Platform Minimum Version1 Supported Features in TPC
SDD AIX Any Full support
HP-UX 1.6.2.4 Full support
Red Hat 4 Any Full support
SLES 9 Any Full support
Novell Any Data Manager Asset Tree
Solaris Any Full support
Windows 1.6.1.x Full support
SDDDSM Windows 2.1.3.0-1 for 32-bit machines
2.2.0.0-11 for 64-bit machines
Full support
SDDPCM AIX 2.2.0.x Full support
DM-Multipath Red Hat 5 device-mapper-1.02.13-1.el5
multipath-tools-0.4.7-8.el5
Full support
SLES 10 device-mapper-1.02.03-8.2
multipath-tools-0.4.6-25.8
Full support
EMC Powerpath AIX 4.x Probe
Linux 4.x Probe
Windows 4.x Probe

Full support means Tivoli Storage Productivity Center will be able to:
  • Report on the disks accessed using the multipathing product. (Probe)
  • Display multiple paths in the Data manager asset tree. (Data Manager Asset Tree)
  • Report on the multiple paths in the data path explorer. (Data Path Explorer)
  • Configure paths as part of the SAN Configuration Planner. (Planner)

1 Additional information regarding version support for SDD, SDDDSM, SDDPCM, and DM-Multipath can be found on the System Storage Multipath Subsystem Device Driver support site.

Cross reference information
Segment Product Component Platform Version Edition
Storage Management Tivoli Storage Productivity Center for Replication Not Applicable 4.1, 4.1.1
Storage Management Tivoli Storage Productivity Center Basic Edition Not Applicable AIX, Linux, Windows 4.1, 4.1.1

Rate this page:

(0 users)Average rating

Document information


More support for:

Tivoli Storage Productivity Center Standard Edition

Software version:

4.1, 4.1.1

Operating system(s):

AIX, HP-UX, Linux, NetWare, Solaris, Windows

Reference #:

1384678

Modified date:

2011-04-28

Translate my page

Machine Translation

Content navigation