IBM Support

Collecting Data for IBM Spectrum Control: Switch/Fabric problems

Question & Answer


Question

Collecting data documents aid in problem determination and save time resolving Problem Management Records (PMRs).

Cause

Support request for problem determination data.

Answer


Collecting problem data early, even before opening the PMR, helps IBM® Support quickly determine if:

  • Symptoms match known problems (rediscovery).
  • There is a non-defect problem that can be identified and resolved.
  • There is a defect that identifies a workaround to reduce severity.
  • Locating root cause can speed development of a code fix.

Collecting Data: Read First table of contents:

Gathering general information
Manually Gathering General Information
Gathering TPC Switch/Fabric Information
Submitting Information to IBM Support
On-line Self-Help Resources
Related Information



Manually Gathering General Information

From Your TPC Server's command line/shell prompt, follow the process below to gather TPC logs:

These files along with the following files/info should be included as general information:
  • Details of operating system levels including patch level
  • TPC Server specific version (ex: 5.2.15)
  • Netstat -an output

Manually Gathering Spectrum Control Switch/Fabric Information

Please collect the following information in addition to the TPC server and Fabric agent logs:
  • Confirm that the Storage Resource Agent is connected to the fabric where you're seeing the problems, by making sure that the agent's HBA has a fiber connection to the fabric in question and not some other fabric.
  • HBA make, model, firmware, and driver version
  • Screenshot showing the problem.
  • A brief description of what you expect to see versus what you actually are seeing
  • Advise whether there's a firewall between the TPC server and related Storage Resource agents
  • Java version installed on system where TPC GUI/topology viewer is installed (run Java -version from the windows command prompt or Unix shell prompt, and capture the output in a text file)
Submitting Information to IBM Support

After a PMR is open, you can submit diagnostic Collecting Data data to IBM.
-If using ESR, update the PMR to indicate that data has been sent.

The owning engineer will automatically be notified of the upload when this process is followed.

Online Self-Help Resources

[{"Product":{"code":"SS5R93","label":"IBM Spectrum Control"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SS8JFM","label":"TotalStorage Productivity Center for Fabric"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SS5R93","label":"IBM Spectrum Control"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SS5R93","label":"IBM Spectrum Control"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":null,"Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"5.1;5.1.1;5.2;5.2.1;5.2.2;5.2.3;5.2.4;5.2.5;5.2.6;5.2.7","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
22 February 2022

UID

swg21292467