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Setting up an FTP server to upload course packages into Workplace Learning 2.7

 Technote (FAQ)
 
 
Question
You use the Course Upload portlet in IBM® Workplace™ Collaborative Learning 2.7 to import course packages. However, sometimes if the course package size is large, you receive the following error message during Step 1 of 3:
    "An exception occurred during the course import"
An OutOfMemoryException is recorded in the System.log:
    [datetime] 0000008c PivotHandlerW E com.ibm.ws.webservices.engine.PivotHandlerWrapper bindExceptionToResponse WSWS3400I: Info: unexpected exception.
    java.lang.OutOfMemoryError: Unable to allocate 74054446 bytes of direct memory after 5 retries  

How can large course packages be successfully imported?
 
Cause
The OutOfMemoryException error normally occurs during file transfer from the Learning Portal to the Learning server. The WebSphere API reads the course file into memory and then send it as a mime attachment.
 
Answer
This issue was reported to Quality Engineering as SPR# HTTN7J6GZN.
To work around this issue, Product Development recommends that you set up an FTP server to be used in conjunction with the Course Upload portlet. Be sure that the Learning Portal application and the Learning Server application have access to the FTP server.

In order to utilize an FTP server, one or more FTP servers must be defined in the Advanced Settings section of the Admin UI (Advanced Settings --> Learning Server --> FTP panel). If no FTP servers are defined, the course upload will continue to behave as it currently does and the current memory constraints will still be encountered.

Adding a new FTP server to the Learning system:

1. Log into Workplace Learning as an administrator.

2. In Learning Management, click Advanced Settings--> Learning Server --> FTP panel --> Create New.

3. Enter a name for the FTP server that will be used in course upload process.

4. Enter a description of the server.

5. Enter the FTP user name and password.

6. Enter the base URL of the FTP server and click Test to verify a "Connection Successful" message.

7. If the test is successful, click Save.

Once you add an entry for the FTP server on the FTP panel, the Course Upload portlet retrieves the information about the FTP server from the Learning server. It then imports the course package to the FTP server. If this fails, it starts over with the next FTP server defined on the FTP panel.

If the course package cannot be imported using an FTP server, the Course Upload portlet returns to the original method of sending the course package as a WebSphere attachment (using a Web Service call to move the uploaded file from the Learning Portal to the Learning server), and this WebSphere call usually fails for very large courses.

NOTE: For large course packages, the import can take a long time to complete. There are several steps involved in the process and each one takes a while for a large course package:
    -- Uploading the file from the client to the Learning Portal.
    -- Uploading the file from the Learning Portal to the FTP server.
    -- Downloading the file from FTP server to the Learning server.
    -- Unzipping the file on the Learning server.
    -- Importing the course onto the Learning server.

Therefore, for excessively large courses, you may experience a Portal UI timeout which interrupts the import and prevents its completion.
 
 
 

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Document information
 Product categories:
 Software
 Organizational Productivity, Portals & Collaboration
 Learning Software
 Workplace Collaborative Learning
 Course Upload
 Operating system(s):
  AIX, Linux, Solaris, Windows, i5/OS
 Software version:
  2.7
 Reference #:
  1409035
 IBM Group:
 Software Group
 Modified date:
 2009-11-03

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