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No WRT HTTPS data in TEP

Troubleshooting


Problem

There is HTTP data being monitored by the WRT agent, but no HTTPS data.

Symptom

The kfcm120 log: shows this error

(4F731AEA.004E-1:kbbssge.c,52,"BSS1_GetEnv") KFC_SSL_KEYMAP="/opt/IBM/ITM/tmaitm6/wrm/keystore/servermap.csv"

(4F731AEA.004F-1:kfck_config.cpp,291,"ReadKFCKConfiguration") Using Stashfile: /opt/IBM/ITM/tmaitm6/wrm/keystore/wrtkeys.sth

(4F731AEA.0050-1:kfck_config.cpp,408,"ReadKFCKConfiguration") No valid mappings or no valid keys found.

Cause

servermap.csv is missing, empty, or does not have a valid mapping.

Resolving The Problem

Check the system where the WRT agent is installed for the file 'servermap.csv'.

By default, it is <ITM_HOME>/tmaitm6/wrm/keystore/servermap.csv.

servermap.csv should exist and contain entries like this:

9.53.114.111, 443, WRTCert

In this example, HTTPS traffic addressed to host ip address 9.53.114.111 on port 443 will use the certificate with Friendly Name of 'WRTCert' for the SSL handshake.

The servermap.csv file is created during the configuration of the T5 agent in the HTTPS section.

Note that there must actually be a certificate labeled 'WRTCert' in the keystore for the configuration to complete successfully.

[{"Product":{"code":"SS5MD2","label":"Tivoli Composite Application Manager for Transactions"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ITCAM TRANSACT WRT 5724S79WB v710","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.4","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21589501