IBM Support

Cannot log in directly to dispatcher. Login accepted, but returned to initial login screen.

Troubleshooting


Problem

Customer is trying to troubleshoot a problem with the system. To do this, customer tries to log directly into the dispatcher. * When they enter a valid userID and password, they are returned to the screen that asks them to choose a namespace. * If the user intentionally enters invalid credentials, then they get an "Invalid Credentials" error. * The problem occurs in all configured authentication namespaces. * If the customer sets "Allow anonymous logon" to TRUE, then the users can get in. NOTE: The login works OK via the gateway.

Symptom

No errors logged

Cause

The properties for cookies in "Global Configuration" are incorrect.

More Information:
By default, the "Cookie Settings" are blank:


In many cases the "Domain" setting can be left blank.

  • However, in some environments (for example when there is an external load-balancing router between the dispatcher and the gateways) it should be set to be the DNS domain of the server with the dispatcher (not the virtual hostname used by the load balancing router).

If this setting is incorrectly configured, then (when the users connect directly to the dispatcher) the cookies get rejected.
  • This is because the "Domain" does not match the name of the server that the user connected to
  • This causes the system to think that the user has not been authenticated yet.

The "Path" property defines the subset of URLs in a domain for which a cookie is valid.
  • If it is too small a subset, the cookie is not valid for all the URLs it is needed for.
  • The default value for the "Path" property is: /
    • This is the most general path possible

Resolving The Problem

Ensure that the "Domain" and the "Path" settings in the Global Configuration in Cognos Configuration are set to the correct values.

Steps:
1. Launch "Cognos Configuration"
2. Click "Actions" and select "Edit Global Configuration"
3. Choose "Server" tab

4. Modify the "Domain" setting appropriately.

  • TIP: Typically, if this is set it needs to be set to the domain portion of the hostname of the server
  • For example, if the server is: servername.mycompany.com
    • Then the setting should be: .mycompany.com

5. Modify the "Path" setting to be the default value: /

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Connection","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1;10.2.1.1;10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21341494