Rational Host Access Transformation Services 8.0 System Requirement Addendum

Detailed system requirements


Abstract

The tables below identify the additional system requirements for the components of Rational Host Access Transformation Services (HATS) 8.0.

Content

The table below identifies additional operating system requirements for HATS to consider.

Operating system requirements
  1. The HATS Toolkit supports all Windows operating systems supported by the required development tools listed in the System requirements section.
  2. The HATS Web, Portlet, and WebFacing runtimes support all operating systems supported by the required application servers and portal servers listed in the System requirements section.
  3. The HATS Rich client runtime supports all operating systems supported by the required Eclipse platforms listed in the System requirements section.

The table below identifies additional requirements for HATS to consider.

Other requirements
  1. When installing one of the required development tools, the following features are required:
    • For HATS
      • Web development tools
      • WebSphere Application Server version 6.1, version 7.0, or version 8.0 development tools, as appropriate.
      • WebSphere Portal Server version 6.1; version 6.1 on WebSphere Application Server, version 7.0; or version 7.0 development tools feature, as appropriate, for portlet development. Not available with Rational Business Developer.
      • Java client application editor (VE), as appropriate, for visual editing of rich client transformations and templates.
      • Plug-in Development Environment (PDE).
    • For the IBM WebFacing Tool for IBM i feature, also required are:
      • Struts development tools feature (Note: This feature is included as part of the Web development tools feature in IBM Integration Designer 7.5).
      • Rational Developer for Power Systems Software V8.0 and future mod levels and their fix packs, including the RPG and COBOL Development Tools for i feature.
    • For the Portal support for IBM WebFacing Tool for IBM i feature, also required are:
      • IBM WebFacing Tool for IBM i feature.
      • WebSphere Portal Server version 6.1; version 6.1 on WebSphere Application Server, version 7.0; or version 7.0 development tool feature, as appropriate. Not available with Rational Business Developer.
  2. HATS supports Dojo versions 1.4.1 and 1.5.0 included in the required development tools listed in the System requirements section.
  3. Rational Application Developer V8.0.3, or later, is required for HATS Dojo support on WebSphere Application Server V8.
  4. HATS Dojo widget support requires one of the following web browsers:
    • Apple Safari
    • Google Chrome
    • Microsoft Internet Explorer (V8 or later)
    • Mozilla Firefox
  5. HATS support for RESTful web services requires JAX-RS support included in:
    • WebSphere Application Server Version 6.1 Feature Packs.
    • WebSphere Application Server Version 7.0 Feature Pack for Web 2.0 and Mobile.
    • WebSphere Application Server Version 8.0 includes the required JAX-RS support and no additional feature packs are required.
  6. HATS applications that use 5250W connections require the WebFacing Server.
  7. HATS 5250 print support requires one of the following, as appropriate:
    • iSeries Access for Web V5R4 available as part of the iSeries Access Family
    • System i Access for Web 6.1 available as part of the System i Access Family
    • IBM i Access for Web 7.1 available as part of the IBM i Access Family.
  8. The HATS administrative console is only supported with browsers supported by WebSphere Application Server. For more information about the WebSphere Application Server requirements, see the System requirements section for the Web runtime.
  9. For the rich client runtime:
    • Lotus Expeditor 6.2 also requires:
      • Lotus Expeditor Desktop Development Utilities feature.
      • The appropriate Device Runtime Environment.
      • Core JVM Feature - J2SE
    • Lotus Expeditor 6.2.1 and 6.2.2 also requires:
      • Lotus Expeditor Desktop Development Utilities feature.
  10. HATS bidirectional applications require one of the following web browsers:
    • Firefox V3.4, or later, or V4 (including future mod levels and fix packs)
    • Internet Explorer V6 with SP1, V7, V8, or V9 (including future mod levels and fix packs)
  11. Adobe Acrobat Reader V9.x, or later, for the Getting Started PDF linked to on the installation launchpad and for host printing.
  12. If using Tivoli Access Manager for Web Express Logon support, V6.0.x, or later, or V6.1.x or later is required.

Related information

System Requirements for HATS

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Host Access Transformation Services
Documentation

Software version:

8.0, 8.0.0.1, 8.0.0.2, 8.0.0.3, 8.0.0.4

Operating system(s):

AIX, HP-UX, IBM i, Linux, Linux iSeries, Linux pSeries, Linux zSeries, Solaris, Windows, z/OS

Reference #:

7019102

Modified date:

2013-10-15

Translate my page

Machine Translation

Content navigation