IBM Support

Exchange Server agent terminates due to configuration initialization failure

Troubleshooting


Problem

ITCAM agent for Microsoft Exchange Server fails to start. Agent log shows following error: CTIRA_SIT_PATH evironment variable not found. CtMain: EXITING due to configuration initialization failure

Symptom

Agent log <host>_ex_kexcma_*_01.log shows following messages:

4F1F2782.00F1-25C8:kntctagt.cpp,3380,"CheckConfigSettings") CTIRA_SIT_PATH evironment variable not found.

(4F1F2782.00F2-25C8:kntctagt.cpp,616,"CtMain") CtMain: EXITING due to configuration initialization failure

(4F1F2782.00F3-25C8:kntctagt.cpp,1404,"InvokeFW") ErrorHandler: Error code: 000004bc

(4F1F2782.00F4-25C8:kntctagt.cpp,1412,"InvokeFW") ErrorHandler: TERMINATION

Cause

This problem can be caused by corrupted Windows registry keys for the agent. The agent does not initialize properly because it cannot read the configuration settings in the registry.

Diagnosing The Problem

Check following registry key to ensure that correct agent configuration settings exist:

HKEY_LOCAL_MACHINE\SOFTWARE\Candle\KEX\Ver610\<agent_machine_Name>

Check settings under 'Environment' and 'Configuration' keys for corruption.

If you are unsure, try the resolution in the "Resolving the problem" section.

Resolving The Problem

Run following procedure to resolve the issue.

1. Delete HKEY_LOCAL_MACHINE\SOFTWARE\Candle\KEX\Ver610\<HOSTNAME> registry key.

2. Start the agent. Agent will re-create this registry entry on startup.

3. Check if the agent started successfully.

[{"Product":{"code":"SSDKXQ","label":"Tivoli Composite Application Manager for Microsoft Applications"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Microsoft Exchange Server Agent - 5724B98EO","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3.0;6.3.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21590475