Troubleshooting
Problem
secureMain failure: KCI0526E Cannot determine Installation Owner ID Multiple User IDs found on key directories User IDs: candle root.
Symptom
secureMain runs and completes, however KCI0526E is issued
Cause
The error message is documented in the ITM 6.2 messages documentation.
http://pic.dhe.ibm.com/infocenter/tivihelp/v15r1/topic/com.ibm.itm.doc/sc23-7969-00.pdf
The secureMain error highlights that the program (secureMain) is unable to determine the Installation Owner ID, because Multiple User IDs are found on key directories. Locking down the subdirectories with users and groups which are not part of the ITM Installation user will cause a problem.
Environment
UNIX IBM Tivoli Monitoring operating system installations.
Diagnosing The Problem
KCI0526E Cannot determine Installation Owner ID Explanation: This is an informational message and does not require further action. Typically, this type of message clarifies some aspect of system behavior during normal operations.
The secureMain utility does not change a directory or file owner, only the file permissions. Directory and File ownership is the responsibility of the system administrator.
Resolving The Problem
We looked at a working system where the ITM Home and logs directory were owned by root and group system. secureMain was run by the root UserID and the error message is not issued. On another system where the error is presented by secureMain, we found the root UserID did not own or was not a member of a group which was associated with many subdirectories in the ITM / Candle Home Directory. secureMain issued the error as a warning.
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Document Information
Modified date:
17 June 2018
UID
swg21636237