Troubleshooting
Problem
After installing Primavera Work Order Tracking becomes unavailable
Symptom
When trying to use the Work Order Tracking or Work Order Tracking (PV) Applications the following error is displayed on page instead of the application.
"el = MAINDOC.getElement("mx111"); if(el) el.style.display=""; el = MAINDOC.getElement("mx123"); if(el) el.style.display=""; el = MAINDOC.getElement("mx135"); if(el) el.style.display=""; el = MAINDOC.getElement("mx189"); if(el) el.style.display=""; el = MAINDOC.getElement("mx200"); if(el) el.style.display=""; el = MAINDOC.getElement("mx211"); if(el) el.style.display=""; el = MAINDOC.getElement("mx222"); if(el) el.style.display=""; el = MAINDOC.getElement("mx233"); if(el) el.style.display=""; "
Cause
This is caused by missing the step during the installation which references the Primavera API in the Application Server CLASSPATH.
Resolving The Problem
To resolve the problem please do the following
1) From WebSphere click on your Maximo Server under Application Servers
2) Click Server Infrastructure -> Java and Process Definition -> Process Definition.
3) In the ClassPaths field enter
For Remote mode: Enter the path to the intgclient.jar file.
For Local mode: Enter the paths to all .jar files from the Primavera Integration API lib folder.
4) For local mode, enter -Dprimavera.bootstrap.home=Primavera API root in the
Generic JVM arguments field.
For more information please refer to the Primavera Installation Guide
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Document Information
Modified date:
17 June 2018
UID
swg21606997