Supported versions of Java with IBM Lotus Products

Technote (FAQ)


Question

What versions of Java are supported with IBM Lotus products?

Answer

Java 6 is supported in Lotus Notes®/Domino 8.5 on all client and server platforms except for Mac. (Note: Java 6 is also known as JDK 1.6 and JDK 1.6.0).
Java 5 is supported in Lotus Notes®/Domino 8. (Note: Java 5 is also known as JDK 1.5 and JDK 1.5.0). For related information see the topics in the Notes/Domino 8.x release notes titled:

"Notes/Domino 8 upgrade to JDK (Java Development Kit) 1.5"
"System i: Software requirements"


Product Browser Versions Supported Java Client Versions Supported Java Server Versions Supported Comments

Notes/Domino 8.5 IE 6.0 (XP)
IE 6.0, 7.0 (XP, Vista)
Firefox 3 (XP, Vista)
W/32 IBM JDK/JRE 1.6 W/32 IBM JDK/JRE 1.6
Firefox 3.0 (SLED 10, RHEL 5) Linux Sun JRE 1.6 Linux: IBM JRE 1.6
zLinux (OS/390) IBM JDK 1.5
Firefox 3.0 (OS X 10.5)
Safari 3.0
Java 1.5 for Mac OS X 10.5 zSeries (OS/390) IBM JDK 1.6
iSeries (IBM i5/OSTM V5R4) IBM JDK 1.6

Notes/Domino 8 IE 6.0 (XP)
IE 6.0, 7.0 (XP, Vista)
Firefox 1.5, 2.0 (XP)
W/32 IBM JDK/JRE 1.5 W/32 IBM JDK/JRE 1.5
Version 8.0.1 Release Notes
Firefox 1.5, 2.0 (RHEL 5 desktop)
Firefox 1.8 (SLED 10 XGL2)
Linux Sun JRE 1.5 Linux: IBM JRE 1.5
zLinux (OS/390) IBM JDK 1.5
zSeries (OS/390) IBM JDK 1.5
iSeries (IBM i5/OSTM V5R4) IBM JDK 1.5
Notes/Domino 7 QuickPlace 7
Sametime 7
IE 6 SP1 W/32 IBM JDK/JRE 1.4.2 W/32 IBM JDK/JRE 1.4.2
Linux Sun JRE 1.4.2 Linux: IBM JRE 1.4.2
zLinux (OS/390) IBM JDK 1.4.2
zSeries (OS/390) IBM JDK 1.4.2
iSeries (AS/400) IBM JDK 1.4.2
Notes/Domino 6.0.x/6.5x (WebMail) IE 5.5, IE 6
Netscape 4.7x
Sun Solaris: Sun JRE 1.3.1 Sun Solaris: Sun JRE 1.3.1 Solaris Platform only
W/32 IBM JDK 1.3.1 W/32 IBM JVM 1.3.1
Linux: IBM JRE 1.3.1
zLinux (OS/390) IBM JDK 1.1.8
zSeries (OS/390) IBM JDK 1.1.8
iSeries (AS/400) IBM JDK 1.1.8
Domino Web Access IE 5.5 SP2, IE 6 SP1
Mozilla 1.4.1. 1.7 (Red Hat Linux Clients Only)
See Comments See Comments JVM is only used in Chat session which is dependant on Sametime JVM Requirements
Learning
Management System (LMS) 1.0.3/1.0.4
IE 5 SP2, IE 6 SP1 Sun Java 1.4.x Sun JRE 1.4.x Sun Java 1.3.x not supported
Workplace Collaboration Services 2.5.x IE 5.5 SP2
IE 6 SP1
Netscape 6.2
Sun JVM 1.4.1
IBM JDK 1.4.2
MS JVM 1.1
Sun JVM 1.4.1
IBM JDK/JRE 1.4.2
MS JVM
Netscape 6.2 Learning only
Mozilla 1.4 Linux
Mozilla 1.4 Windows
Sun 1.4.2
Sun 1.4.2
Sun 1.4.2
Sun 1.4.2
Lotus Workplace 2.0.x IE 5.5 SP2
IE 6 SP1
Netscape 6.2
Sun JVM 1.4.1
IBM JDK 1.4.2
MS JVM 1.1
Sun JVM 1.4.1
IBM JDK/JRE 1.4.2
MS JVM
Netscape 6.2 Learning only
Mozilla 1.4 (Red Hat Linux Clients Only) Sun 1.4.2 Sun 1.4.2
WebSphere Portal 5.x IE 5.x, 6
Netscape Communicator 6.2, 7.0
Mozilla 1.4.1,Mozilla 1.4 (Red Hat Linux Clients Only)
Sun 1.4.2 IBM JVM 1.3.1
Sun 1.4.2
Domino and Extended Products Portlets IE 6
Sun JVM 1.4.1
IBM JDK 1.4.1
MS JVM 1.1.8
Sun JVM 1.4.1
IBM JDK/JRE 1.4.1
MS JVM 1.1.8
Mozilla 1.4.1 (Red Hat Linux Clients Only) Sun JVM 1.4.1 Sun JVM 1.4.1
Collaborative Services See Sametime Requirements See comments See Comments JVM Requirements are dependant on Sametime JVM Requirements. No known incompatibilities with JVM
Sametime 8.0 Firefox 1.5 Windows XP, Windows 2000, Windows Vista, RedHat Enterprise Linux (RHEL) 4.0, SuSE Linux Enterprise Desktop (SLED) 10

Firefox 2.0 Windows XP, Windows 2000, Windows Vista, RedHat Enterprise Linux (RHEL) 4.0, SuSE Linux Enterprise Desktop (SLED) 10

Internet Explorer 6.0 and 7.0 on Windows XP Professional, Windows XP Professional 64-bit, Windows 2000, Windows Vista

Safari 2.0 on Macintosh OSX 10.4.x
IBM or Sun JRE 1.4.2, 1.5 IBM or Sun JRE 1.6 for Web Conferencing FIPS restriction - 1.4.2 VMs will not be supported for FIPS

Refer to release notes for more information:

http://publib.boulder.ibm.com/infocenter/sametime/v8r0/topic/com.ibm.help.sametime.802.doc/Home/strn8.pdf
QuickPlace 3.x IE 5.5 SP2, IE 6 SP1
Netscape 4.7.9
IE 5.1 (Macintosh)
JDK1.1.8 JDK1.1.8 R5 releases are based on JDK1.1.8
QuickPlace 6.5.1

(Lotus Team Workplace)
IE 5.5 SP2, IE 6 SP1
Mozilla 1.4.1 (Red Hat Linux Clients Only)
IBM JVM 1.3.1, IBM JVM 1.4.1 JRE 1.3.1 , IBM JRE 1.4.1 TW651: Developer should use JDK 1.3.1 or JDK 1.4.1 when creating customization and Placebots

from QP 6.51 Release Notes: Supported on Red Hat Linux only
Lotus Virtual Classroom (LVC) See Sametime and Quickplace Requirements See Comments See Comments JVM requirements are dependant on Sametime and Quickplace

Domino R5 (WebMail) IE 5.5, IE 6 W/32: Sun JDK 1.1.8 W/32: Sun JDK 1.1.8 Sun Java 1.4.x not supported
Solaris: Sun JDK 1.1.8 Solaris JVM 1.1.8
IBM AIX: IBM JRE 1.1.8 IBM AIX: IBM JRE 1.1.8
Linux: Sun JRE 1.1.8 Linux: Sun JRE 1.1.8
zSeries (OS/390) IBM JDK 1.1.8
iSeries (AS/400) IBM JDK 1.1.8

Related information

A simplified Chinese translation is available


    Cross reference information
    Segment Product Component Platform Version Edition
    Organizational Productivity- Portals & Collaboration IBM Sametime Lotus Sametime Server 7.0, 6.5.1
    Messaging Applications IBM iNotes Not Applicable 7.0, 6.5
    Messaging Applications Lotus End of Support Products Lotus QuickPlace 7.0
    Messaging Applications IBM Notes Lotus Notes Mac OS X, Windows 8.5, 8.0, 7.0, 6.5, 6.0, 5.0
    Messaging Applications Lotus End of Support Products Lotus Learning Management System
    Messaging Applications Lotus End of Support Products Workplace Collaboration Services

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

IBM Domino

Software version:

5.0, 6.0, 6.5, 7.0, 8.0, 8.5

Operating system(s):

AIX, IBM i, Linux, Solaris, Windows, z/OS

Reference #:

1188789

Modified date:

2009-08-14

Translate my page

Machine Translation

Content navigation