Technote (troubleshooting)
Problem(Abstract)
Using taskrunner or the Process Solution Installer to install a package the install fails when copying isccommontask.war.
Symptom
Cannot update Maximo Base Services
Cause
This can be caused by previous failed install attempts.
Diagnosing the problem
To determine this is the cause of your issue you can check the Deploy_ISCcommon_Tasks_War.err logs in c:\ibm\smp\solution\logs\LTA_WAR_Package for the following error
File to transfer C:\IBM\SMP/temp/isccommontasks.war already exists as a directory on the target system.
Directory with same name as C:\IBM\SMP/temp/isccommontasks.war must be removed from the target system.
Resolving the problem
To resolve this problem you must first remove the isccommontasks.war using the following steps
1) Open a command prompt and change the directory to C:\IBM\SMP\jacl\solutions
2) Run the following command replacing the values with the correct values for you configuration
ISCRemoveHandler.bat <WAS_SERVER> <WAS_REMOTE_USER> <WAS_REMOTE_PASSWORD> <WAS_HOME> <WAS_USER> <WAS_PASSWORD> isccommontasks.war
3) Once successfully removed attempt your install/configuration again with the Process Solutions installer or the Task Runner.
| Segment | Product | Component | Platform | Version | Edition |
|---|---|---|---|---|---|
| Systems and Asset Management | IBM Maximo Asset Management Essentials | ||||
| Systems and Asset Management | Tivoli Asset Management for IT | ||||
| Systems and Asset Management | Tivoli Change and Configuration Management Database | ||||
| Systems and Asset Management | Tivoli Service Request Manager |
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