InfoSphere Warehouse 9.5.1 system requirements for application servers

Preventive Service Planning


Abstract

This document lists the hardware, software, disk space, and memory that are required to install the application server components for InfoSphere Warehouse 9.5.1.

Content

Requirements for the application server

Ensure that your computer meets the following requirements before you install the application server components of InfoSphere Warehouse.

Note: InfoSphere Warehouse does not support the installation of both clients and servers on the same computer in a production environment. For production environments, the operating systems that are supported by the data server and application server are not the same operating systems that are supported by the clients. The only exception is the ODBO cubing services client, which is supported on Windows 2003.

Hardware and software

For detailed information about supported hardware and software for WebSphere, see:
http://www.ibm.com/support/docview.wss?rs=180&uid=swg27007642
Table 1. System requirements for the application server
Operating system Minimum prerequisites Number of bits Hardware
AIX Version 5.3 and 6.1
  • AIX 5.3 Service Pack 5300-04-01 is required by WebSphere 6.1
  • minimum C++ runtime level: xlC.rte 8.0.0.8 and xlC.aix50.rte 8.0.0.8
64 IBM eServer servers with POWER technology
Red Hat Enterprise Linux V4
  • 64-bit RPMs for gcc and libstdc++ are required
  • Update 2
64 x86-64 (AMD64, Intel EM64T)
Red Hat Enterprise Linux V5
  • 64-bit RPMs for gcc and libstdc++ are required
64 x86-64 (AMD64, Intel EM64T)
SuSE LINUX Enterprise Server 9 (SLES 9) Either Service Pack 4, or SP3 and required maintenance 64 x86-64 (AMD64, Intel EM64T)
SuSE LINUX Enterprise Server 10 (SLES 10) Either Service Pack 1 or required maintenance 64 x86-64 (AMD64, Intel EM64T)
Solaris 9 and Solaris 10 The following patches are also required:
  • 111711-12
  • 111712-12
For Solaris 9: Patch 122300-11 is required if raw devices are used. For Solaris 10: Patch 125100-07, if raw devices are used.
64 Systems based on UltraSPARC processor
HP-UX 11iv2 and 11iv3 N/A 64 Integrity Series systems
Windows Server 2003 Standard, Enterprise and Datacenter Editions. Service Pack 1, and R2 32 A Pentium or Pentium-compatible (x86) CPU is required.
Windows Server 2003 Standard, Enterprise, and Datacenter Editions Service Pack 1, and R2 64 AMD64 or Intel EM64T
  1. DB2 Database Partitioning Feature users on Linux on System z: If you want to run the DB2 Database Partitioning Feature on Linux on System z, you must install it from one of the following products:
    • The IBM InfoSphere Warehouse Base Edition. This includes DB2 and the Database Partitioning Feature. It also includes some InfoSphere Warehouse tools but those tools do not run on Linux on System z.
    • The IBM Base Warehouse Feature for DB2. This includes the Database Partitioning Feature. It also includes some InfoSphere Warehouse tools but those tools do not run on Linux on System z.
  2. Solaris 9 users: WebSphere Application Server 6.1 is only available in a 32-bit version. On the 64-bit version of Solaris, the InfoSphere Warehouse configuration tool sets up the 32-bit WebSphere server. For details of this setup, see the WebSphere documentation.
  3. HP-UX users: This product uses HP Runtime Environment for J2SE HP-UX 11i platform, adapted by IBM for IBM Software, Version 1.4.2.

Web browsers supported by InfoSphere Warehouse Administration Console: The Administration Console was certified with Internet Explorer 6.0 with SP 1 and Internet Explorer V7.0 (Windows), and Firefox V1.5 and V2.0.

Web browsers supported by WebSphere Application Server: The administrative console for WebSphere Applications Server supports Internet Explorer 6.0 with SP 1 (Windows), Mozilla 1.7.8, and Firefox V1.5.

Disk space

Temporary space for installable download images (Passport Advantage only)

Before installing this product, Passport Advantage customers must download the installation images to the target computer. These images contain the installation executable files for the components you are installing. This space is different from the space needed to run the installation program.

Approximately 2.7 GB of disk space is recommended for the installation images of the application server components.

On AIX and HP-UX, you must have enough disk space for the installable images for the entire product, even if you are not installing all the components. This is approximately 7.5 GB.

Temporary space for running the installation program

Approximately 550 MB of disk space is recommended.

Permanent space for the installed components

Approximately 2 GB of disk space is recommended for WebSphere, the InfoSphere Warehouse Administration Console, and the IBM Alphablox administration tool. If you are installing WebSphere into a 64-bit instance, you will need an additional 500 MB.

Memory

Memory for installing the product

A minimum of 1 GB of memory is recommended to install the application server.

Memory for running the product

A minimum of 1 GB of memory is the minimum amount of memory required to run the application server alone. If you run the data warehouse server components on the same computer, 2 GB of memory is recommended.

If you add more components to the same computer, you must have more memory to run them in addition to the memory reserved for the application server.

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

InfoSphere Warehouse

Software version:

9.5.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Software edition:

Advanced, Base, Developer, Enterprise, Intermediate, Starter

Reference #:

1305579

Modified date:

2010-03-19

Translate my page

Machine Translation

Content navigation