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Unable to load TADDM Discovery Management Console (GUI) after upgrade

Troubleshooting


Problem

DMC hangs starting up

Symptom

java console log contains errors similar to

.. GET http://myHost:9430/cdm/images/login_bckgr_top.png [HTTP/1.1 404 Not Found 15s]

this message will show for many images under dist/deploy-tomcat

Cause

dist/deploy-tomcat/*.war files not deployed correctly

Resolving The Problem

1) stop TADDM

2) backup the deploy-tomcat directory to somewhere other than deploy-tomcat (eg. /tmp)

3) in deploy-tomcat you will see various *.war files, eg;

ls *.war
axis.war cdm.war GetTaddmVersion.war images.war install.war
ProactiveIn.war rest.war ROOT.war

Each one of these war files will have a corresponding directory name.

You can delete the directory as long as a war file exists. Delete all directories for which there is a war file. This will cause tomcat to redeploy each war file on next start up.

Do not delete any directory that does NOT have a corresponding war file.

4) start TADDM

5) confirm the missing files are there and that you can now launch the UI.

[{"Product":{"code":"SSPLFC","label":"Tivoli Application Dependency Discovery Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

TADDM

Document Information

Modified date:
17 June 2018

UID

swg21670862