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MustGather: Read first for WebSphere DataPower SOA Appliances

 Technote (troubleshooting)
 
Problem(Abstract)
MustGather documents aid in problem determination and save time resolving Problem Management Records (PMRs). These documents contain a list of the documentation you should gather so WebSphere DataPower Support can diagnose your specific problem. These documents might also include diagnostic tips that will aid in diagnosing and solving problems.
 
Cause
Collecting MustGather data early, even before opening the PMR, helps WebSphere DataPower Support quickly determine if:
  • Symptoms match known problems (rediscovery)
  • There is a non-defect problem that can be identified and resolved
  • There is a defect that identifies a workaround to reduce severity
  • Locating root cause can speed development of a code fix
 
Resolving the problem
IBM provides support for these IBM WebSphere DataPower SOA Appliance products:
  • WebSphere DataPower Integration Appliance XI50
  • WebSphere DataPower XML Security Gateway XS40
  • WebSphere DataPower XML Accelerator XA35

Required: Gathering information for IBM entitlement to open a PMR
Gathering general problem description information
Gathering component specific information
Opening a WebSphere DataPower Support PMR
Exchanging information with IBM support
General hints and tips




Required: Gathering information for IBM entitlement to open a PMR


Gather the following information needed to entitle your PMR:
  • Serial number of the appliance
  • Firmware version
    • Use the WebGUI Navigation Bar Status > System > Version Information
  • IBM customer numbers
  • A valid contact e-mail address and phone number
  • Severity of this issue to your business

    NOTE: Set the severity of your problem based on the Severity Levels table found in the following technote: WebSphere DataPower Extended Maintenance and Support Services.



Gathering general problem description information


Gather the following general problem information:
  • A complete description of the problem, including the following:
    • List of steps to recreate problem
    • Capture images of the screen to help describe the steps
    • Error messages
    • Any changes to installed firmware version
  • Exported Error Report- see the following section about collecting MustGather data through the WebGUI or command line interface.



Gathering component specific information


Click on the problem or issue that best describes your situation. This will provide you with a listing of the documentation that the support team requires to diagnose your problem.

WebSphere DataPower MustGather documents
Collecting data: WebSphere DataPower SOA Appliances problem determination
Collecting data on the command line: WebSphere DataPower SOA Appliances problem determination
WebSphere DataPower SOA Appliance does not respond to connection requests
WebSphere DataPower SOA Appliance: Ethernet port test
Documentation for ITCAM SOA and WebSphere DataPower problem determination
Documentation for ITCAM System Edition for WebSphere DataPower problem determination
WebSphere DataPower SOA Appliance presents a power supply message: "System power supply #_ has failed"
Collecting data: WebSphere DataPower SOA Appliances with WTX Maps



Opening a WebSphere DataPower Support PMR


More information on opening Problem Management Records (PMRs) can be found in Contacting IBM WebSphere DataPower SOA Appliance Support.



Exchanging information with IBM support



You can update your PMR in one of the following ways:

General hints and tips


Search for known problems from the WebSphere DataPower SOA Appliances support site.

Download the latest firmware.

Download and view product documentation.

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Document information
 Product categories:
 Software
 Business Integration and Optimization
 Application Integration and Connectivity
 WebSphere DataPower SOA Appliances
 General
 Operating system(s):
  Firmware
 Software version:
  3.6.1, 3.7.1, 3.7.2, 3.7.3, 3.8
 Software edition:
  Edition Independent
 Reference #:
  1269260
 IBM Group:
 Software Group
 Modified date:
 2008-08-15

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