Required and optional software and hardware for OmniFind Enterprise Edition, Version 8.4

Technote (FAQ)


Question

Before you install IBM OmniFind Enterprise Edition, Version 8.4, ensure that you have the required software and hardware.

Answer

If you plan to install or upgrade to OmniFind Enterprise Edition, Version 8.5, be sure to review the system requirements at http://www.ibm.com/support/docview.wss?rs=63&uid=swg27010937.



Memory models
When you install OmniFind Enterprise Edition, you choose a memory configuration that is appropriate for your expected workload. To optimize performance, different memory configurations are installed for small, medium, and large enterprise search systems. If you install the software in a multiple server configuration, you must specify the same memory model on all enterprise search servers.

For information about the minimum hardware requirements for each model, and for guidelines on selecting a memory model that is appropriate for your expected workload, see Memory models for enterprise search.

Disk space requirements
Shown below are the minimum disk space required to install the enterprise search server software. Note that more space is needed to run an enterprise search system.


Version 8.4 900 MB for the enterprise search software, plus 1300 MB of temporary disk space.
Version 8.4 Fix Pack 1 1400 MB for the enterprise search software, plus 1600 MB of temporary disk space

The disk space requirements for running an enterprise search system can vary and depend on the number of documents to be crawled, the types of data sources to be crawled, and how documents are parsed, indexed, and queried. Disk space requirements are also influenced by how regularly you build and update indexes.

For a multiple server configuration, the space requirements affect the index server. The ES_NODE_ROOT directory requires the most disk space on your system.

For assistance with minimizing the amount of space required for data that is stored by the DB2 crawler, see Configuring the DB2 crawler to minimize disk space requirements.

Supported operating systems

  • IBM AIX 5L (64-bit systems)
    • AIX 5.2, Maintenance Level 7
    • AIX 5.3, Maintenance Level 3

    AIX requires the April 2006 IBM C++ Runtime Environment Components for AIX. To download, see the download document.
  • Linux (32-bit systems)
    • Red Hat Enterprise Linux Advance Server 4.0, Update 2; requires compat-libstdc++-33-3.2.3-47.3
    • Novell SUSE Linux Enterprise Server 10
    • Novell SUSE Linux Enterprise Server 9 with Service Pack 2 (United Linux SP2); requires libstdc++-3.3.3-43.24 compat-2004.7.1-1.2

  • Microsoft Windows (32-bit systems)
    • Microsoft Windows Server 2003 Enterprise Edition with Service Pack 1
    • Microsoft Windows Server 2003 Enterprise Edition with Service Pack 2 (requires OmniFind Enterprise Edition Version 8.4 Fix Pack 1)
    • Microsoft Windows Server 2003 Enterprise Edition R2 (requires OmniFind Enterprise Edition Version 8.4 Fix Pack 1)

  • Solaris operating environment (64-bit systems)
    • Solaris 9, kernel SunOS 5.9; requires SunOS 5.9 Patch 118558-09

      To verify that you have the correct patch, enter the following command:

      showrev -a |grep 118558

      If the command does not return information, install the patch by using the Solaris Management Console or the patchadd utility.

Required Web Application Server software
    IBM WebSphere Application Server includes the application server, plug-in, and IBM HTTP Server. The recommended version is WebSphere Application Server 6.0.2.

    The OmniFind Enterprise Edition and OmniFind Enterprise Starter Edition packages include WebSphere Application Server 6.0 and you can choose to have this software installed when you run the installation program.

    Important:
    • Only 32-bit versions of WebSphere Application Server are supported. You cannot use a 64-bit Java Virtual Machine (JVM), which is supported by WebSphere Application Server, for enterprise search.
    • Do not install WebSphere Application Server Network Deployment Edition. OmniFind Enterprise Edition requires the WebSphere Application Server base edition.

    WebSphere Application Server 6.0 Refresh Pack 2, which is included as a separate CD image, upgrades WebSphere Application Server 6.0 to version 6.0.2. If you upgrade from a previous release of OmniFind Enterprise Edition, upgrade to WebSphere Application Server 6.0.2 before you install the enterprise search software. If you install OmniFind Enterprise Edition as a new system, install Refresh Pack 2 after you install the enterprise search software.

    Supported versions on AIX, Linux, and Windows systems:
    • IBM WebSphere Application Server Network Deployment 5.1.1.3. This version is supported for backward compatibility purposes. Beginning with OmniFind Enterprise Edition 8.3, no versions of the Network Deployment edition later than version 5.1.1.3 are supported.
    • WebSphere Application Server 6.0.2, base edition (recommended)
    • WebSphere Application Server 6.1, base edition (requires OmniFind Enterprise Edition Version 8.4 Fix Pack 1)

    Supported version on a Solaris system:
    • WebSphere Application Server 6.0.2, base edition
    • WebSphere Application Server 6.1, base edition (requires OmniFind Enterprise Edition Version 8.4 Fix Pack 1)
    Note: If you install OmniFind Enterprise Edition Version 8.4 Fix Pack 1 on a system where you previously installed WebSphere Application Server Version 6.1, the fix pack installation program detects the WebSphere Application Server version and deploys the appropriate enterprise search Web applications.

Required software for data sources
    The OmniFind Enterprise Edition installation program can install connectors that enable many WebSphere Information Integrator Content Edition sources to be searched. For other types of data sources, you must install products that enable the sources to be searched.

    For detailed information about the different types of data sources that are supported, and which versions of the products are supported, see OmniFind Enterprise Edition, Version 8.4 supported data sources.

    WebSphere Information Integrator Content Edition 8.3
    Support for many sources, such as Hummingbird, FileNet, and Documentum, can be installed when you install OmniFind Enterprise Edition.

    To support Microsoft SharePoint Services sources or WebSphere Portal Document Manager sources, you must install connectors after you install OmniFind Enterprise Edition. For instructions on installing these connectors, see Installing Content Edition connectors after you install enterprise search.

    DB2 Universal Database for AIX, Linux, Windows, and Solaris
    To crawl DB2 UDB sources, the DB2 crawler needs DB2 UDB Administration Client 8.2. To ensure that the DB2 crawler can work with the Administration Client, you run the escrdb2.sh (or escrdb2.vbs) setup script on the crawler server after you install the DB2 Administration Client.

    IBM Lotus Domino Server
    A Lotus Domino Server is required if you plan to collect data from Lotus Notes, Domino Document Manager, or Lotus QuickPlace sources.

    For name-to-address resolution over TCP/IP, crawlers that use the Notes remote procedure protocol (NRPC) use the Domino libraries as a Lotus Notes client. You install these libraries by installing Lotus Domino Server on the enterprise search crawler server. To ensure that the Notes crawler can work with the Domino libraries, you run the escrnote.sh (or escrnote.vbs) setup script on the crawler server after you install the Domino libraries.

    To use native security when crawling and searching Lotus Domino sources, install and configure Lotus Domino 6.0.2 CF2 or later or Lotus Domino 7.0 on the crawler server.
      IBM DB2 Information Integrator for Content for AIX, Windows, and Solaris, or IBM DB2 Content Manager Toolkit for Linux
      The DB2 Content Manager crawler uses the Java connector for Content Manager to access DB2 Content Manager servers. You install this connector by installing one of the following products on the crawler server:
      • IBM DB2 Information Integrator for Content 8.3 for AIX, Linux, Windows, or Solaris
      • IBM DB2 Information Integrator for Content 8.2 for AIX, Windows, or Solaris
      • IBM DB2 Content Manager Toolkit 8.2 for Linux

      To ensure that the DB2 Content Manager crawler can work with DB2 Content Manager servers, you run the escrcm.sh (or escrcm.vbs) setup script on the crawler server after you install the Java connector for Content Manager.
        IBM WebSphere Information Integrator Classic Federation for z/OS
        The DB2 crawler can use this software to crawl VSAM, IMS, CA-Datacom, and Software AG Adabas databases.

        IBM WebSphere Information Integrator Standard Edition
        (Formerly IBM DB2 Information Integrator Standard Edition 8.2.)
        The DB2 crawler can use this software to crawl DB2 UDB, Oracle, and Microsoft SQL Server databases.
          Note: You do not need this software if you use the JDBC crawler. The JDBC crawler can access these types of databases through Type 4 JDBC drivers.

        WebSphere MQ version 5.3 Java Messaging libraries
        To crawl DB2 Universal Database databases through the event publishing feature of DB2 Information Integrator Event Publisher Edition, the DB2 crawler needs the Java Messaging libraries of WebSphere MQ. You can install these libraries from the WebSphere MQ installer. If the DB2 crawler does not use event publishing, the WebSphere MQ libraries are not required.

        To ensure that a DB2 crawler that uses event publishing works with the libraries, you run the escrdb2.sh (or escrdb2.vbs) setup script on the crawler server after you install the WebSphere MQ libraries.

      Required versions of Java
        Software Development Kit for Java 1.4.2 Service Release 5 (SR5)
        The SDK for Java 1.5 is not supported.
        Enterprise search requires the IBM Software Development Kit (SDK) for Java 1.4.2, Service Release 5 (SR5), to compile Java applications that are created with the enterprise search application programming interfaces (APIs). The SDK for Java 1.5 is not supported. The SDK for Java is not required to install enterprise search.

        The sample search application in the ES_INSTALL_ROOT/samples directory must run in a JRE version 1.4 environment. WebSphere Application Server and WebSphere Portal both provide the JRE version 1.4.

      Supported Web browsers
        To use the information center, enterprise search administration console, and sample search application for enterprise search, the following Web browsers are supported:
        • Microsoft Internet Explorer Version 6 and Version 7
        • Mozilla Firefox Version 1.7 and higher

        On some platforms, other browsers can be used; however, some functionality might not be available for older browser levels or other browser types.

      Related information

      Supported data sources

      Rate this page:

      (0 users)Average rating

      Add comments

      Document information


      More support for:

      OmniFind Enterprise Edition

      Software version:

      8.4

      Operating system(s):

      AIX, Red Hat Linux, Solaris, SuSe Linux, Windows Server 2003

      Reference #:

      1240681

      Modified date:

      2007-02-16

      Translate my page

      Machine Translation

      Content navigation