System Requirements for Rational Application Developer for WebSphere Software version 7.5.x

Preventive Service Planning


Abstract

This document serves to supplement the installation documentation by summarizing the system requirements for IBM Rational Application Developer for WebSphere Software version 7.5.x.

Content


Hardware
Linux
Microsoft Windows
Hosted development environments
Supported web browsers
Supported application servers
Supported database servers
Supported JREs


See Change History for updates.

GLOSSARY:

Hardware: The Hardware on which the product is supported.

Operating System: The operating system on which the product is supported.

RFE: Request for Enhancement. A change request focused on support for the platform or operating system.

VRMF: VRMF is the product release numbering format that is being implemented throughout the IBM and the Rational product lines. Review education document 7008656 for a explanation of the VRMF - Maintenance Delivery Vehicle (MDV) terminology used by Rational products.



Minimum hardware requirements

Rational Application Developer for WebSphere Software V7.5.x
Component
Minimum requirement
Processor
Intel Pentium III 800 MHz or higher recommended
Display
1024 x 768
Memory
1GB RAM minimum; 2GB RAM recommended

Disk space

3.5GB minimum for installing Rational Application Developer and additional disk space for development resources (minimum disk space can be reduced if optional features and run times are not installed).



Linux

Rational Application Developer for WebSphere Software V7.5.x
Hardware
Operating system
Comments
Desktop
x86-32
SUSE Desktop 10
Red Hat Desktop 5
Red Hat Desktop 4
Server
x86-32
x86-64
Red Hat Enterprise Server 5
See note below about 64 bit versions
Red Hat Enterprise Server 4
See note below about 64 bit versions
SUSE Enterprise Server 10
See note below about 64 bit versions
SUSE Enterprise Server 9
See note below about 64 bit versions


Note: Review technote 1263677 for important details about support for 64-bit operating systems.

Microsoft Windows

Rational Application Developer for WebSphere Software V7.5.x
Hardware
Operating system
Comments

x86-32

x86-64
Windows 7 -
Professional and Ultimate Editions
Supported as of 7.5.5

See note below about 64 bit versions
Windows Server 2008 -
Enterprise and Standard Edition
R2 supported as of 7.5.5

See note below about 64 bit versions
Windows Vista -
Business, Enterprise and Ultimate Edition
See note below about 64 bit versions
Windows Server 2003 -
Enterprise and Standard Edition
32 bit only
Windows XP Professional
See note below about 64 bit versions


Note: Review technote 1263677 for important details about support for 64-bit operating systems.

Hosted development environments

Rational Application Developer for WebSphere Software V7.5.x
Product
Version
Comments
Citrix
Citrix XenApp 6.0
Citrix XenApp 5.0
Presentation Server 4.5
Presentation Server 4
Other virtualization environments:
* For information about support for Rational Application Developer on all other virtualization environments, see the following technote: 1515607



Web browsers

Rational Application Developer for WebSphere Software V7.5.x
Web browser
Version
Comments
Firefox
5 and greater
Support added in RAD 7555
4
Support added in RAD 7554
3
2
Mozilla
1.7
1.6
Internet Explorer
9
Support added in RAD 7554
8
7
6 SP1


Supported application servers

Rational Application Developer for WebSphere Software V7.5.x
Product
Version
Comments
WebSphere Application Server 6.0.x
6.0.x
Web 2.0 FEP
WebSphere Application Server 6.1.x
6.1
Web 2.0 FEP
WS FEP
EJB 3.0 FEP
WebSphere Application Server 7.0
7
Web 2.0 FEP
WebSphere Portal Server
6
6.1


Supported databases

Rational Application Developer for WebSphere Software V7.5.x
Database
Version
Comments
CloudScape
5.1
DB2 UDB
7.2
Support Deprecated - see technote 27013438
8.1
8.2
9.1
9.5
9.7
DB2 UDB iSeries
5R2
5R3
5R4
DB2 for z/OS
7
V8
Compatibility Mode
V8
New-Function Mode
V9
Derby
10.0
10.1
10.2
10.3
Generic JDBC
1.0
Informix
9.2
9.3
9.4
10.0
11.1
MySQL
4.0
4.1
Oracle
8
9
10
11g
SQL Server
2000
2005
Sybase
12.x
15

JREs

Rational Application Developer for WebSphere Software V7.5.x
Product
Version
Comments
IBM JRE
6.0
SUN JRE
6.0
Important: If you install the product into an existing Eclipse instance that does not use the IBM Runtime Environment for Java 6 (JRE), then you cannot use the following product features:
  • WebSphere Application Server development tools
  • WebSphere Portal Server development tools
  • Java EE Connector (J2C/JCA) development tools


Change History
Change History
20 January 2010 Corrected reference to Informix
18 December 2009 Updated for Version 7.5.5 release; added Windows 7 support and 2008 R2 support
19 October 2009 Added IE8 support
02 June 2009 Added note about 64 bit operating systems and specified WAS bit database supplied
07 January 2008 Added Minimum Hardware Requirements
19 November 2008 Removed SCA FEP - not supported in 7.5
13 November 2008 Initial release

Related information

Rational Application Developer System Requirements List

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Application Developer for WebSphere Software
Documentation

Software version:

7.5, 7.5.1, 7.5.2, 7.5.3, 7.5.4, 7.5.5, 7.5.5.1, 7.5.5.2, 7.5.5.3, 7.5.5.4, 7.5.5.5

Operating system(s):

Linux, Windows

Reference #:

1327294

Modified date:

2009-06-02

Translate my page

Machine Translation

Content navigation