A login exception occurs using Alphablox V9.5 with Apache Tomcat level 5.5.26 or higher.

Technote (troubleshooting)


Problem(Abstract)

If you install Alphablox Version 9.5 and Apache Tomcat 5.5.26 or higher, and select to use Alphablox security for logins, then user login attempts will fail.

Symptom

The following login exception occurs:


javax.security.auth.login.LoginException: unable to find LoginModule class: com.alphablox.security.jaas.AlphabloxLoginModule



Cause

The Alphablox V9.5 Installation Guide states support for Apache Tomcat version 5.5.17. Apache Tomcat 5.5.26 and newer maintenance levels have not yet been tested with Alphablox V9.5.

Resolving the problem

To work around the problem when using Tomcat level 5.5.26 or higher, move Alphablox security jar file (aasextensions.jar) from TOMCAT_HOME/server/lib to TOMCAT_HOME/common/lib and restart Tomcat server.


If using the above copy bypass, then until Alphablox support provides a formal fix for this problem, each time you install Alphablox maintenance, you should repeat the above bypass steps to ensure the new version of the jar is copied to required location.

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

DB2 Alphablox

Software version:

9.5

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

1376881

Modified date:

2009-05-07

Translate my page

Machine Translation

Content navigation