WebSphere Business Modeler V7.0 software and hardware requirements - Windows

Product documentation


Abstract

Supported software configuration options for WebSphere Business Modeler Basic and Advanced V7.0 on Microsoft Windows platforms.

Content

Before you open a problem report with the support team for WebSphere Business Modeler or any of the following supported products, install the minimum product levels that are listed in the following table.

When a Fix Pack or a patch becomes available for a supported product, you may install and run it. WebSphere Business Modeler will support that Fix Pack or patch, unless stated to the contrary in the following table.

When a new version of a supported product becomes available, before installing the new version verify that this version is specified in the following table. If the product version is not listed in the table, IBM cannot confirm the accuracy of performance, compatibility, or any other claims related to that version.

To install and run WebSphere Business Modeler as a standalone product, you must meet all the requirements stated below.

Package Sharing Following is a sample list of products that can share a package group with Modeler V7.0: Note: If using any of the above products, please check the hardware/software requirements. This list is not exhaustive but represents a list of products often used with WebSphere Business Modeler
Operating system (one of the following) and hardware requirements
  • Windows XP with Service Pack 2 or later
  • Windows Vista Business (32-bit)
  • Windows Vista Enterprise (32-bit)
  • Processor Pentium 4 1.4 GHz or higher
  • Available RAM 1 GB (2 GB recommended)
  • Available Disk Space 1.6 - 2.5 GB, depending on the installation options
  • Display Minimum 1024 by 768 resolution (1280 by 1024 or higher recommended)
  • You must have administrator privileges on your operating system to install WebSphere Business Modeler. These privileges are not required to run WebSphere Business Modeler after it is installed
General Software Preqrequisites One of the following Web browsers installed as your default system browser:
    • Microsoft Internet Explorer, Version 6.0 SP2
    • Microsoft Internet Explorer, Version 7.0
    • Mozilla Firefox, Version 3.0
  • Adobe Flash Player 10.0.2, or later, installed in system browser

For older browsers or other browser types, some documentation functionality might not be available and the direct deployment feature cannot be used.

To view and print PDF documents included with WebSphere Business Modeler and in its online help system, you need the following Adobe software:
  • Adobe Acrobat Reader, Version 4.05 or later (you can download Adobe Acrobat Reader from http://www.adobe.com/)
  • Adobe Acrobat Web browser plug-in
Adobe Acrobat Reader is available for download from adobe.com
Software prerequisites for team support and model versioning using CVS

If you set up a CVS server, it must be compatible with Eclipse 3.4. For detailed information about compatibility between CVS and Eclipse, visit CVS FAQ.

CVS for Linux and UNIX is available at www.nongnu.org/cvs/. For Windows, you can download CVSNT from www.cvsnt.org. Refer to these sites for information about how to install and configure your CVS team repository, and how to set up user access and passwords.

Desktop virtualization support VMware ESX and ESXi 4.0
Software prerequisites for team support and model versioning using IBM Rational ClearCase If you set up a Rational ClearCase server, in order to use:
  • Rational ClearCase ClearCase native views, you need to install Rational ClearCase Version 7.0.1 or 7.1 or Version 2003.06.15 for Windows
  • Rational ClearCase ClearCase Web-based views, you need the stand-alone Rational ClearCase Remote Client Version 7.1 and Rational ClearCase Version 7.1, including Rational CM server
NOTE: The plug-in version of Rational ClearCase Remote Client is not supported for this purpose.
NOTE: To use ClearCase 7.1.1 requires upgrade to WebSphere Business Modeler V7.0.0.2.
Software requirements for sharing project assets To use the asset repository support provided by WebSphere Business Modeler, you need to install Rational Asset Manager server, Version 7.1.0.1 or higher (Version 7.2 is recommended).
Software requirement for interactive process design feature To use the interactive process design feature of WebSphere Business Modeler to verify the design of processes for deployment, an installation of a WebSphere Process Server V7.0 test server with Business Space must be available. Use of IBM WebSphere Business Monitor V7.0 is optional.
Java Runtime Environment When you install WebSphere Business Modeler, it automatically configures the correct Java™ Runtime Environment (JRE). Do not reconfigure your Eclipse environment to use a different JRE.
Software prerequisites for testing process deployment To verify the design of business processes on a test server (managed deployment environment), business analysts must ensure that they have the required software installed on their computers. An IT administrator needs to set up a test server (or managed deployment environment) that includes the required server components.

If the business analysts expect to test business measures along with their business processes, then a monitoring server component must be included in the managed deployment environment.

To simplify the testing experience for business users, the IT administrator can point to Lotus Webform Server from the managed deployment environment. The Business Space can then display forms in the process verification environment, so business analysts do not have to install Lotus Forms Viewer on the same computer as WebSphere Business Modeler to verify their process design.


Products required for five or fewer business users
If you plan to have five or fewer users performing the process testing, then see the table 1 below for which software prerequisites apply.


Products required for more than five business users
If you plan to have more than five users performing the process testing, then see the table 2 below for which software prerequisites apply.

Prerequisites for enhanced simulation performance DB2 Express 9 is supported for use with IBM WebSphere Business Modeler Version 7.0.
For the minimum DB2 hardware prerequisites, refer to the DB2 Express 9 documentation.

The more RAM and disk space you have available for the DB2 database and for WebSphere Business Modeler, the better your simulation performance will be.

To run WebSphere Business Modeler with DB2 Express 9, it is recommended that you use a computer with two separate hard disks: one to store the database table and the other to store the database logs. This recommendation applies whether the database is installed on your computer or on a remote server.





Table 1: Products required for five or fewer business users
If you plan to have five or fewer users performing the process testing, then the following software prerequisites apply.

Computers for business analysts (clients)
Managed deployment environment (server)
Required Software
Optional software
Required Software
Optional Software
  • WebSphere Business Modeler Advanced V7.0
  • Adobe Flash Player version 10.0.2 or later
  • Lotus Forms Viewer version 3.5.1
  • Mozilla Firefox version 3.0 or Microsoft Internet Explorer v7 or Microsoft Internet Explorer v6.0 SP2
  • To customize forms in WebSphere Business Modeler, install the Lotus Forms Designer feature when you install WebSphere Business Modeler
  • WebSphere Integration Developer V7.0 with the following features installed:

    - WebSphere test environment
    - Business Space powered by WebSphere v7.0

    Important: To troubleshoot deployment problems, you must be done using an installation of WebSphere Integration Developer v7.0 that is distinct from the test server
  • If the testing of business measures is required, include the WebSphere Business Monitor development toolkit v7.0
  • Lotus Webform Server version 3.5.1
  • If testing will include implemented services, WebSphere Service Registry and Repository at a level supported by the server

    Note: Business analysts can test the deployment of services without a WebSphere Service Registry and Repository server if the WSDLs imported into WebSphere Business Modeler contain a single operation and include the PortType and the endpoint information.

Table 2: Products required for more than five business users
If you plan to have more than five users performing the process testing, then see the table below for which software prerequisites apply.


Computers for business analysts (clients)
Managed deployment environment (server)
Required Software
Optional software
Required Software
Optional Software
  • WebSphere Business Modeler V7.0
  • Adobe Flash Player version 10.0.2 or later
  • Lotus Forms Viewer version 3.5.1
  • Mozilla Firefox version 3.0 or Microsoft Internet Explorer v7 or Microsoft Internet Explorer v6.0 SP2
  • To customize forms in WebSphere Business Modeler, install the Lotus Forms Designer feature when you install WebSphere Business Modeler
  • WebSphere Process Server V7.0 with the Business Space powered by WebSphere version 7.0
  • For troubleshooting deployment problems, WebSphere Integration Developer V7.0.
  • If business measures will be tested along with business processes, WebSphere business Monitor version 7.0
  • Lotus Webform Server version 3.5.1
  • If testing will include implemented services, WebSphere Service Registry and Repository at a level supported by the server




Related information
Detailed system requirements
WebSphere Business Modeler Advanced V7.0 Information Center

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere Business Modeler Advanced
Documentation

Software version:

7.0

Operating system(s):

Windows

Software edition:

Advanced, Basic

Reference #:

7017629

Modified date:

2010-07-15

Translate my page

Machine Translation

Content navigation