WebSphere Application Server V6.0.2 detailed system requirements

Product documentation


Abstract

The list below identifies Supported Software options for IBM WebSphere Application Server V6.0.2.

Content

Back to all V6.0.2 detailed system requirements

WebSphere Application Server - Supported Prerequisites

This page describes the minimum product levels you need installed before opening a problem report with the WebSphere Application Server support team. Because other products frequently ship fixes, updates, and new releases, it is not possible to test every configuration. In general, you can install and run with updates to supported products if those updates are forward compatible.

WebSphere Application Server Version 6.0.2

+ Product is included with this WebSphere edition

 
Operating Systems supported with 32-bit WebSphere Application Server
(See footnote 2 and 3)
WebSphere Application Server platform:
Notes
AIX®
HP
Linux® AMD/Intel®
Linux S/390® System z9 zSeries®
Linux on Power
OS/400®
Sun
Windows®
z/OS®
AIX 7.1 with Recommended Maintenance package 7100-00-01 (minimum WebSphere Application Server level is 6.0.2.41)
AIX 7.1 product site link
X (See Related Information)
AIX 6.1 with Recommended Maintenance package 6100-00-02-0750
AIX 6.1 product site
X
(See Related Information)
see footnote 10
 
AIX 5L 5.1 with Recommended Maintenance package 5100-05
AIX 5L product site
X
 
 
     
 
 
 
 
 
AIX 5L 5.2 with Recommended Maintenance package 5200-02 or 5200-03
AIX 5L product site
X
 
 
     
 
 
 
 
 
AIX 5L 5.3 or 5.3 with Recommended Maintenance package 5300-01
AIX 5L product site
X
 
 
     
 
 
 
AIX APAR IY58143 is required
 
HP-UX 11iv1 with Quality Pack of December 2004 plus required HP-UX patches for Java™
HP-UX 11i product site
 
X
 
     
 
 
 
Review relevant OS requirements from the HP Patch Information web site
  OS/400 V5R2 or i5/OS V5R3, V5R4 or V6R1        
X
      (See Related Information) 
 
Red Flag Advanced Server 4.1
Red Flag Advanced Server 4.1 product site
 
 
X
     
 
 
 
- Supported in China only
- Support for Red Flag is only available through the IBM China support centers
 
Red Flag Data Center 5.0
Red Flag Data Center 5.0 product site
 
 
X
     
 
 
 
- Supported in China only
- Support for Red Flag is only available through the IBM China support centers
- Reference Tech Notes #1244762, #1244763 and #1244764 before installation
 
Red Hat® Enterprise Linux AS 3.0 Update 2, 3 or 4
Red Hat Enterprise Linux product site
 
 
X
X 
X 
 
 
 
 
 
 
Red Hat Enterprise Linux ES 3.0 Update 2, 3 or 4
Red Hat Enterprise Linux product site
 
 
X
 
 
 
 
 
 
 
 
Red Hat Enterprise Linux WS 3.0 Update 2, 3 or 4
(supported for application design, development, and testing only; no support for production use)
Red Hat Enterprise Linux product site
 
 
X
 
 
 
 
 
 
 
 
Red Hat Enterprise Linux AS 4.0
Red Hat Enterprise Linux product site
 
 
X
X 
X 
 
 
 
 
Special note regarding 31-bit kernel support for this version of Linux, see footnote 3
 
Red Hat Enterprise Linux ES 4.0
Red Hat Enterprise Linux product site
 
 
X
 
 
 
 
 
 
 
Red Hat Enterprise Linux WS 4.0
(supported for application design, development, and testing only; no support for production use)
Red Hat Enterprise Linux product site
 
 
X
 
 
 
 
 
 
Red Hat Enterprise Linux 5.0
Red Hat Enterprise Linux product site
X
X
X
Release notes for WebSphere Application Server Version 6.0.2 on the Red Hat Enterprise Linux, Version 5 operating system.
 
Solaris 8 with the latest Patch Cluster
Sun product site
 
 
 
     
X
 
 
- See footnote 9
 
Solaris 9 with the latest Patch Cluster
Sun product site
 
 
 
     
X
 
 
- See footnote 9
 
Solaris 10 with the latest Patch Cluster
Sun product site
 
 
 
     
X
 
 
See footnote 9
 
SUSE Linux Enterprise Server 8 SP3 or SP4
SUSE Linux product site
 
 
X
X
X
 
 
 
 
 
 
SUSE Linux Enterprise Server 9 or 9 SP1
SUSE Linux product site
 
 
X
X
X
 
 
 
 
Special note regarding 31-bit kernel support for this version of Linux, see footnote 3
 
SUSE Linux Enterprise Server 10
SUSE Linux product site
 
 
X
X
X
 
 
 
 
- Reference Tech Notes #1247425 before installation
- Special note regarding 31-bit kernel support for this version of Linux, see footnote 3
 
Windows® 2000 Advanced Server SP4
 
 
 
     
 
X
 
 
 
Windows 2000 Server SP4
 
 
 
     
 
X
 
 
 
Windows 2000 Professional SP4
(supported for application design, development, and testing only; no support for production use)
 
 
 
     
 
X
 
 
 
Windows Server 2003 or 2003 SP1 Datacenter
 
 
 
     
 
X
 
 
 
Windows Server 2003 or 2003 SP1, Enterprise
 
 
 
     
 
X
 
 
 
Windows Server 2003 or 2003 SP1, Standard
 
 
 
     
 
X
 
 
 
Windows XP Professional SP1a or SP2
(supported for application design, development, and testing only; no support for production use)
 
 
 
     
 
X
 
 
 
z/OS® 1.4, 1.5, 1.6, 1.7, 1.8,1.9, 1.10, or 1.11
z/OS product site
 
 
 
 
 
 
 
 
X
WAS 6.0.2.35 (or later) fixpack is required fo x/OS 1.11.
See footnote 8.
 
z/OS.e 1.4, 1.5, 1.6, 1.7 or 1.8
z/OS product site
 
 
 
 
 
 
 
 
X
See footnote 8.
 
Operating Systems supported with 64-bit WebSphere Application Server
(See footnote 4)
WebSphere Application Server platform:
Notes
AIX
HP
Linux AMD/Intel
Linux System z9 zSeries
Linux on Power
OS/400
Sun
Windows
z/OS
AIX 7.1 with Recommended Maintenance package 7100-00-01 (minimum WebSphere Application Server level is 6.0.2.41)
AIX 7.1 product site link
X (See Related Information)
AIX 6.1 with Recommended Maintenance package 6100-00-02-0750
AIX 6.1 product site
X
(See Related Information)
see footnote 10
 
AIX 5L 5.2 with Recommended Maintenance package 5200-06
AIX 5L product site
X
 
 
     
 
 
 
 
AIX 5L 5.3 with Recommended Maintenance package 5300-02
AIX 5L product site
X
 
 
     
 
 
 
 
HP-UX 11iv2 Update 2
HP-UX 11i product site
 
X
 
     
 
 
 
See footnote 5
 
Red Hat Enterprise Linux AS 3.0 Update 3 or 4
Red Hat Enterprise Linux product site
 
 
X
 
X 
 
 
 
 
See footnote 6
 
Red Hat Enterprise Linux ES 3.0 Update 3 or 4
Red Hat Enterprise Linux product site
 
 
X
 
 
 
 
 
 
See footnote 6
 
Red Hat Enterprise Linux AS 4.0
Red Hat Enterprise Linux product site
 
 
X
 
X 
 
 
 
 
See footnote 6
 
Red Hat Enterprise Linux AS 4.0 Update 1
Red Hat Enterprise Linux product site
 
 
 
X
 
 
 
 
 
See footnote 6
 
Red Hat Enterprise Linux ES 4.0
Red Hat Enterprise Linux product site
 
 
X
 
 
 
 
 
 
See footnote 6
Red Hat Enterprise Linux 5.0
Red Hat Enterprise Linux product site
X
X
X
Release notes for WebSphere Application Server Version 6.0.2 on the Red Hat Enterprise Linux, Version 5 operating system.
 
SUSE Linux Enterprise Server 9 or SP1
SUSE Linux product site
 
 
X
 
 
 
 
 
 
See footnote 6
 
SUSE Linux Enterprise Server 9 SP1
SUSE Linux product site
 
 
 
X
X
 
 
 
 
See footnote 6
 
SUSE Linux Enterprise Server 10
SUSE Linux product site
 
 
X
X
X
 
 
 
 
- Reference Tech Notes #1247425 before installation
- See footnote 6
 
Windows Server 2003 or 2003 SP1, Enterprise
 
 
 
     
 
X
 
See footnote 6
 
Windows Server 2003 x64 Editions
 
 
 
     
 
X
 
See footnote 7
 
Web Servers
Refer to the information center article, Installing Web server plug-ins.
WebSphere Application Server platform:
Notes
AIX
HP
Linux AMD/Intel
Linux S/390 System z9 zSeries
Linux on Power
OS/400
Sun
Windows
z/OS
 
Apache Server 2.0.49 or 2.0.52
Apache Server product site
X
X
X
X
X
X
X
X
X
- IBM provides plug-in binaries for the Apache Web server on AIX, HP, Linux, Solaris, and Windows
- On Solaris x64 the plug-in binary is 32-bit
- z/OS interoperates with this off platform Web server
 
IBM HTTP Server for z/OS
IBM HTTP Server for z/OS
 
 
 
 
 
 
 
 
X
Ships with the z/OS and z/OS.e Operating System
  IBM HTTP Server 2.0.47.1
IBM HTTP Server product site
X
X
X
X
X
X
X
X
X
- IBM provides plug-in binaries for the IHS Web server on AIX, HP, Linux, Solaris (excluding x64), and Windows
- HP patch PHSS_26946 is required
- z/OS interoperates with this off platform Web server
  IBM HTTP Server 6.0
IBM HTTP Server product site
X
X
X
X
X
X
X
X
X
- IBM provides plug-in binaries for the IHS Web server on AIX, HP, Linux, Solaris (excluding x64), and Windows
- HP patch PHSS_26946 is required
- Reference Tech Note #1190201 before installing on AIX 5L 5.1
- z/OS interoperates with this off platform Web server
  IBM HTTP Server 6.0.1
IBM HTTP Server product site
X
X
X
X
X
X
X
X
X
- IBM provides plug-in binaries for the IHS Web server on AIX, HP, Linux, Solaris (excluding x64), and Windows
- Included with WebSphere Application Server 64-bit CDs
- z/OS interoperates with this off platform Web server
  IBM HTTP Server 6.0.2
IBM HTTP Server product site
X
X
X
X
X
X
X
X
X
- IBM provides plug-in binaries for the IHS Web server on AIX, HP, Linux, Solaris, and Windows
- On Solaris x64 the plug-in binary is 64-bit
- z/OS interoperates with this off platform Web server
  IBM HTTP Server for iSeries™ (powered by Apache)
IBM HTTP Server for iSeries product site
         
X
      IBM provides plug-in binaries for the IBM HTTP Server for iSeries (powered by Apache) which supports Apache 2.0.47
 
Internet Information Services 5.0 or 6.0
Internet Information Services 5.0 product site
Internet Information Services 6.0 product site
X
X
X
X
X
X
X
X
X
- IBM provides plug-in binaries for the IIS Web server on Windows
- z/OS interoperates with this off platform Web server
 
Lotus® Domino® Enterprise Server 6.0.3, 6.0.5, 6.5.1, or 6.5.4
Lotus Domino product site
X
X
X
X
X
X
X
X
X
- IBM provides plug-in binaries for the Lotus Domino Web server on AIX, Linux, Solaris (excluding x64), and Windows
- z/OS interoperates with this off platform Web server
 
Sun ONE Web Server 6.0 SP7 or SP9
Sun product site
X
X
X
X
X
 
X
X
X
- IBM provides plug-in binaries for the Sun One Web server on AIX, HP, Linux, Solaris (excluding x64), and Windows
- z/OS interoperates with this off platform Web server
 
Sun Java System Web Server 6.1 SP1 or SP3
Sun product site
X
X
X
X
X
 
X
X
X
- Support is provided, if at all, for the HTTP server functionality of this server only
- IBM provides plug-in binaries for the Sun Java System Web server on AIX, HP, Linux, Solaris (excluding x64), and Windows
- z/OS interoperates with this off platform Web server
 
Databases and Transaction Managers
WebSphere Application Server platform:
Notes
AIX
HP
Linux AMD/Intel
Linux S/390 System z9 zSeries
Linux on Power
OS/400
Sun
Windows
z/OS
 
CICS® TS 1.3, 2.2, 2.3, 3.1
CICS Transaction Server product site
 
 
 
 
 
 
 
 
X
 
+ Cloudscape™ 5.1.60.24
Cloudscape V5.1 product site
X
X
X
X
X
X
X
X
X
- Available for Samples and development
- Can be used for production with the appropriate license
+ Derby 10.0.2
Derby product site
X
X
X
X
X
X
X
X
X
- Available for development
- Not supported in production
  IBM DB2® for iSeries™ 5.2, 5.3 or 5.4
DB2 for iSeries product site
X
X
X
X
X
X
X
X
X
 
  DB2 for z/OS V7 or V8
DB2 for z/OS product site
X
X
X
X
X
X
X
X
X
- Requires DB2 Connect if using the Legacy CLI driver.
- The Universal driver can connect directly to DB2 on z/OS
DB2 for z/OS V9 or V9.1
DB2 for z/OS product site
X
  DB2 for Linux, UNIX®, and Windows see document #7009348 for supported levels and editions
X
X
X
X
X
 
X
X
 
 
 
DB2 Information Integrator 8.1 FP6a, 8.1 FP7a, 8.1 FP8, 8.1 FP9, 8.1 FP10, 8.1 FP11, 8.1 FP12, 8.2, 8.2 FP1, 8.2 FP2, 8.2 FP3, 8.2 FP4a or 8.2 FP5
DB2 Information Integrator product site
X
X
X
 
 
 
X
X
 
 
 
Information Management System V8 or V9
IMS product site
 
 
 
 
 
 
 
 
X
 
 
Informix® Dynamic Server 7.31, 9.3, 9.4, 9.4C5 or 10.00C1
Informix Dynamic Server product site
X
X
X
X
X
 
X
X
X
 
 
Oracle 8i Standard/Enterprise Release 3 - 8.1.7.4
Oracle Database product site
X
X
X
X
X
 
X
X
X
See JDBC Driver Manager section
 
Oracle 9i Standard/Enterprise Release 2 - 9.2.0.4, 9.2.0.5 or 9.2.0.6
Oracle Database product site
X
X
X
X
X
 
X
X
X
- See JDBC Driver Manager section
- 9.2.0.6 is recommended
 
Oracle 10g Standard/Enterprise Release 1 - 10.1.0.3
Oracle Database product site
X
X
X
X
X
 
X
X
X
- See JDBC Driver Manager section
Oracle 10g Standard/Enterprise Release 2 - 10.2.0.2
Oracle Database product site
X
X
X
X
X
X
X
X
-- Requires WebSphere Application Server Fix Pack 6.0.2.15 or later
--See JDBC Driver Manager section
 
SQL Server Enterprise 2000 SP 3a
Microsoft® SQL Server 2000 product site
X
X
X
X
X
 
X
X
X
See JDBC Driver Manager section
 
Sybase Adaptive Server Enterprise 12.0.0.8
Sybase Adaptive Server Enterprise product site
X
X
X
X
X
 
X
X
X
Requires jConnect 5.5 EBF 11656 or later
 
Sybase Adaptive Server Enterprise 12.5.1 or 12.5.2
Sybase Adaptive Server Enterprise product site
X
X
X
X
X
 
X
X
X
Requires jConnect 5.5 EBF 11656 or later
 
JDBC Driver Managers
(For driver types, see footnote 1)
WebSphere Application Server platform:
Notes
AIX
HP
Linux AMD/Intel
Linux S/390 System z9 zSeries
Linux on Power
OS/400
Sun
Windows
z/OS
 
Application Connectivity to DB2 for z/OS Feature (i.e., the DB2 Standalone type 4 XA Universal JDBC Driver)
DB2 UDB product site
 
 
 
 
 
 
 
 
X
 
  DataDirect SequeLink JDBC 5.4
X
X
X
X
X
 
X
X
 
- Supports SQL Server Enterprise Edition
- Support for this JDBC driver is deprecated and will be removed in a future release
+ IBM WebSphere embedded SequeLink JDBC 5.4
X
X
X
X
X
 
X
X
 
- Supports SQL Server Enterprise Edition
- Support for this JDBC driver is deprecated and will be removed in a future release
  DataDirect Connect JDBC 3.4
X
X
X
X
X 
 
X
X
X
Supports SQL Server Enterprise Edition
DataDirect Shadow z/Direct JDBC Driver 6.1.1
X
X
X
Supports DB2 for z/OS V7 and V8
+ IBM WebSphere embedded Connect JDBC 3.4
X
X
X
X
X
 
X
X
X
Supports SQL Server Enterprise Edition
  DB2 Driver for JDBC and SQLJ 3.1
X
X
X
X
X
 
X
X
 
  DB2 Universal JDBC Driver 2.2, 2.3, 2.5 or 2.6
X
X
X
X
X
 
X
X
 
WebSphere / SQLJ applications require DB2 UDB V8.1 or V8.2 clients
  DB2 Universal JDBC Driver from DB2 z/OS V7 or V8
 
 
 
 
 
 
 
 
X
 
  DB2 Legacy CLI-based JDBC Driver
X
X
X
X
X
 
X
X
 
 
  DB2 Legacy for z/OS JDBC Driver V7 or V8
 
 
 
 
 
 
 
 
X
 
  IMS JDBC Connector V8 or V9
 
 
 
 
 
 
 
 
X
 
  Informix JDBC Driver 2.21 JC6 or 3.00 JC1
Informix JDBC product site
X
X
X
X
X
 
X
X
X
Driver 3.00 is recommended for IDS 10.00C1
  Microsoft SQL Server 2000 JDBC Driver 2.2.0037
Microsoft SQL Server 2000 product site
X
X
X
X
 
 
X
X
 
- Supports SQL Server Enterprise Edition
- Support for this JDBC driver is deprecated and will be removed in a future release
  Oracle 9i or 10g JDBC Driver
Oracle JDBC product site
X
X
X
X
X
 
X
X
X
- The Oracle 10g JDBC driver is supported with both Oracle 10g and 9i database servers
- The Oracle 9i JDBC driver is supported with both Oracle 9i and Oracle 8i database servers
  IBM Toolbox for Java/JTOpen JDBC Driver 4.3
Toolbox for Java product site
X
X
X
X
X 
X
X
X
X
This is the recommended JDBC driver for connecting from WebSphere Application Server on non-OS/400 platforms to DB2 on iSeries
  OS/400 Native JDBC Driver
 
 
 
 
 
X
 
 
 
 
  Sybase jConnect 5.5 EBF 11656 or 6.0 EBF 12284
Sybase jConnect product site
X
X
X
 
 
 
X
X
X
 
 
Web Browsers
(required for administration/configuration, sample program execution and launch pad. There is no restriction nor certification of Web browsers on clients that connect the server to display content)
WebSphere Application Server platform:
Notes
AIX
HP
Linux AMD/Intel
Linux S/390 System z9 zSeries
Linux on Power
OS/400
Sun
Windows
z/OS
 
Internet Explorer 6.0 SP 1 (on Windows)
X
X
X
X
X
X
X
X
X
 
 
Mozilla 1.4 or 1.7
Mozilla 1.x product site
X
X
X
X
X
X
X
X
X
 
 
Java
The WebSphere-supplied Java 2 SDK is required for both the run time and any remote Java clients
WebSphere Application Server platform:
Notes
AIX
HP
Linux AMD/Intel
Linux S/390 System z9 zSeries
Linux on Power
OS/400
Sun
Windows
z/OS
+ IBM 32-bit SDK, Java 2 Technology Edition, V1.4.2 SR2
X
 
X
X
X
 
 
X
 
On Windows/x86 and Linux/x86, there is an optional Java Virtual Machine mode generally referred to as 'J9'. It is not the default operating mode. The J9 mode is for use with debugging tools only, and is not supported for use in production environments. For additional information on J9 please refer to technote #1221478.
  IBM 32-bit SDK, Java 2 Technology Edition, V1.4.2 for iSeries          
X
      Included with OS/400 or i5/OS
+ HP SDK for J2SE HP-UX 11i platform, adapted by IBM for IBM Software, Version 1.4.2 SR2
 
X
 
     
 
 
 
32-bit for PA-RISC and 64-bit for Itanium 2 are provided 
+ IBM 32-bit SDK for Solaris, Java 2 Technology Edition, Version 1.4.2 SR2
 
 
 
     
X
 
 
 
+ IBM SDK 1.4.2
 
 
 
     
 
 
X 
The Service and maintenance for the SDK will be provided via the WebSphere Application Server for z/OS product
+ IBM 64-bit SDK, Java 2 Technology Edition, V1.4.2 SR2
X
 
X
X
X
 
 
X
 
 
 
LDAP Servers
WebSphere Application Server platform:
Notes
AIX
HP
Linux AMD/Intel
Linux S/390 System z9 zSeries
Linux on Power
OS/400
Sun
Windows
z/OS
  IBM Tivoli® Directory Server 5.1, 5.2 or 6.0
IBM Tivoli Directory Server product site
X
X
X
X
X
X
X
X
X
 
  IBM z/OS Security Server 1.4, 1.5, 1.6, 1.7, 1.8 or 1.9
IBM z/OS Security Server product site
X
X
X
X
  X
 
X
X
X
Ships with the z/OS Operating System
  IBM z/OS.e Security Server 1.4, 1.5, 1.6, 1.7 or 1.8
IBM z/OS.e Security Server product site
X
X
X
X
  X
 
X
X
X
Ships with the z/OS.e Operating System
 
Lotus Domino Enterprise Server 6.0.3, 6.0.5, 6.5.1 or 6.5.4
Lotus Domino product site
X
X
X
X
X
X
X
X
X
 
 
Novell eDirectory 8.7.3 or 8.8
Novell eDirectory product site
X
X
X
X
X
 
X
X
X
 
 
Sun ONE Directory Server 5.1 SP3 or 5.2
Sun product site
X
X
X
X
X
 
X
X
X
 
 
Windows Active Directory 2000 or 2003
Windows Active Directory 2000 product site
Windows Active Directory 2003 product site
X
X
X
X
X
 
X
X
X
 
 
JMS Provider
WebSphere Application Server platform:
Notes
AIX
HP
Linux AMD/Intel
Linux S/390 System z9 zSeries
Linux on Power
OS/400
Sun
Windows
z/OS
 
IBM WebSphere MQ 5.3 CSD 8, CSD 9 or CSD 10
IBM WebSphere MQ 5.3 product site
X
X
X
X
 
X
X
X
 
Available in the form of an external JMS provider as an alternative to the embedded JMS provider, which is included with the application server.
 
IBM WebSphere MQ 6.0
IBM WebSphere MQ 6.0 product site
X
X
X
X
X
X
X
X
X
Available in the form of an external JMS provider as an alternative to the embedded JMS provider, which is included with the application server.
IBM WebSphere MQ 7.0
(see footnote 11)
X
X
X
X
X
X
X
X
X
Available in the form of an external JMS provider as an alternative to the embedded JMS provider, which is included with the application server.
 
IBM WebSphere MQ 5.3.1
IBM WebSphere MQ 5.3 product site
 
 
 
 
 
 
 
 
X
Available in the form of an external JMS provider as an alternative to the embedded JMS provider, which is included with the application server. 
 
Security
WebSphere Application Server platform:
Notes
AIX
HP
Linux AMD/Intel
Linux S/390 System z9 zSeries
Linux on Power
OS/400
Sun
Windows
z/OS
 
Tivoli Access Manager 5.1 for trust association interceptor
Tivoli Access Manager product site
X
X
X
X
X
X
X
X
X
Related information Trust associations
 
Tivoli Access Manager 5.1 for enhanced trust association interceptor (support for Subject creation)
Tivoli Access Manager product site
X
X
X
X
X
X
X
X
X
Related information Trust association interceptor support for Subject creation
 
Tivoli Access Manager 5.1 or 6.0 for Java Authorization Contract for Containers (JACC)
Tivoli Access Manager product site
X
X
X
X
X
X
X
X
X
Related information Authorization in WebSphere Application Server
 
Third Party ORBs
WebSphere Application Server platform:
Notes
AIX
HP
Linux AMD/Intel
Linux S/390 System z9 zSeries
Linux on Power
OS/400
Sun
Windows
z/OS
 
Borland's VisiBroker 6.0 or 6.5
X
 
 
     
X
X
X
Detailed platform coverage and documentation
 
Iona's Orbix Standard Edition 6.1 or 6.2
Iona's Orbix product site
X
 
 
     
X
X
X
Detailed platform coverage and documentation
 
Java 2 Platform, Standard Edition (J2SE) Version 1.4.2 by Sun Microsystems Inc.
Sun J2SE product site
X
 
 
     
X
X
X
Detailed platform coverage and documentation

For information regarding the supported WebSphere Application Server programming model, see the Version 6.0 Information Center and click WebSphere Application Server in the navigation pane. Refer to the Java 2 platform, Enterprise Edition (J2EE) specification of the Products overview view, and the API documentation section of the Reference view.
 
Footnotes:
  1. Supported JDBC driver types:
    Vendor Driver Type Remarks
    IBM
     
     
     
    DB2/CLI 2  
    DB2 Driver for JDBC and SQLJ 3.1 2, 4
    DB2/Universal 2, 4  
    IBM Toolbox for Java/JTOpen 4.3 4  
    OS/400 Native 2  
    DataDirect Technologies SequeLink 5.4 3  
    DataDirect Technologies Connect JDBC 3.4 4  
    DataDirect Technologies Shadow z/Direct 6.1.1 2 Supports DB2 for z/OS V7 and V8
    Oracle
     
    OCI 2 Requires ojdbc14.jar from either the Oracle 10g JDBC driver or the Oracle 9i JDBC driver
    Thin 4 Requires ojdbc14.jar from either the Oracle 10g JDBC driver or the Oracle 9i JDBC driver
    Informix 2.21 JC6 or 3.00 C1 4 Driver 2.21 is not supported with IDS 10.00UC1
    Microsoft® SQL Server 2000 4  
    Sybase jConnect 5.5 4  
  2. For AIX Power PC, Solaris SPARC, and HP-UX PA-RISC platforms, WebSphere Application Server has been tested as a 32-bit application on a 32-bit kernel and on 64-bit machines booted with 64-bit kernels; however, 64-bit mode is not exploited.
  3. For zSeries, WebSphere Application Server has only been tested as a 31-bit application on 64-bit machines booted with a 64-bit kernel; however, 64-bit mode is not exploited. WebSphere Application Server as a 31-bit application on 31-bit or 64-bit machines booted with 31-bit kernel is not supported.
  4. Version 6.0.1 and 6.0.2 introduces 64-bit exploitive runtime support for selected operating systems. Its Java virtual machine exploits the 64-bit processors and operating environment. For additional information refer to Information center articles What is new for installers and What is new for developers.
  5. HP refers to the 64-bit version of the OS running on Itanium 2.
  6. Linux refers to the 64-bit version of the OS running on Power, AMD Opteron, Intel EM64T, IBM System z9 and zSeries platforms.
  7. Windows refers to the Windows Server 2003 x64 editions supporting AMD Opteron and Intel EM64T platforms.
  8. WebSphere Application Server will continue to convert mixed-case passwords to upper-case passwords if you are using SAF for Local OS registries. If you are using LDAP configurations, you will be able to take advantage of mixed-case passwords.
  9. Solaris is supported on SPARC and x64, where x64 refers to the 64-bit version of the OS running on AMD Opteron and Intel EM64T platforms. On x64 the minimum supported OS version is Solaris 10, and WebSphere Application Server is a 32-bit application while the included WebSphere Edge Components and IBM HTTP Server are 64-bit applications.
  10. WebSphere Application Server 6.0.2.25 is required for AIX 6.1.
  11. Information about using WebSphere MQ as the JMS Provider for WebSphere Application Server Version 6.0.2

Back to top

Cross reference information
Segment Product Component Platform Version Edition
Application Servers Runtimes for Java Technology Java SDK
Application Servers WebSphere Application Server for z/OS General z/OS 6.0.2

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere Application Server
General

Software version:

6.0.2

Operating system(s):

AIX, HP-UX, IBM i, Linux, Solaris, Windows, i5/OS

Software edition:

Base

Reference #:

7007256

Modified date:

2010-09-08

Translate my page

Machine Translation

Content navigation