System Requirements for WebSphere MQ for Solaris, V5.3

Product documentation


Abstract

This document contains System Requirements for WebSphere MQ for Solaris, V5.3.

Content

Operating Systems See also the section entitled "Solaris Patches" below.
  • Sun Solaris 7
  • Sun Solaris 8
  • Sun Solaris 9
  • Sun Solaris 10
Connectivity
  • Alebra Brixton PU2.1 SNA server. Release 4.1.2
  • SNAP-IX V6.2 or later
  • TCP/IP
  • SSL
    • Supported Cryptographic Hardware
      • The nCipher nFast card is supported on Solaris 2.7 and Solaris 2.8 using the BHAPI plug-in under BSAFE 4.0 interface
Databases Where IBM WebSphere MQ is acting as the transaction manager - see note under Transaction Monitors.
  • Non-Java applications using MQBEGIN or equivalent
    • IBM DB2 V7.2
    • IBM DB2 V8.1 + FP2 (at L030120 or later) on Solaris 8 & 9
    • IBM DB2 V8.2
    • Oracle 8iR3, Oracle 9iR1 and Oracle 9iR2
      (Both 32-bit and 64-bit databases are supported when using Oracle's 32-bit client libraries.
    • Oracle 10g Release 1 (10.1.0) - WebSphere MQ Fix Pack 11 (CSD11) is required
    • Sybase 12 or 12.5
  • Java™ applications using qmgr.begin and JDBC
    • IBM DB2 V7.2
    • IBM DB2 V8.2
    • Oracle 8.1.6
    • Oracle 8.1.7
    • Oracle 9.2.0.4, JDK 1.4.1, Solaris 8, WebSphere MQ CSD06
    • Oracle 9.2.0.4, JDK 1.4.1, Solaris 9, WebSphere MQ CSD06
    • Oracle 10g Release 1 (10.1.0) - WebSphere MQ Fix Pack 11 (CSD11) is required
Compilers
  • Sun WorkShop 5.0
  • Forte Developer 6
  • Forte Developer 6 update 2
  • Sun ONE Studio 7
  • Sun ONE Studio 8, Compiler Collection
  • Sun ONE Studio 9, Compiler Collection
  • Micro Focus Server Express, V2.0.10, V2.0.11 & V2.2 (V2.2 with Solaris 8 & 9)
Java
  • Solaris Java SDK 1.4 and either JDK V1.4.1.02 with CSD04 (Solaris 8 & 9) or JDK V1.4.2 with CSD08 (Solaris 8 & 9) or JDK V1.4.2 with CSD10 (Solaris 10).
    (Sun Java 2 SDK, Standard Edition Version 1.4 required for SSL support using Java as it provides the necessary JSSE class files.)
  • Solaris Java 2 Standard Edition, for the Solaris Operating Environment, SDK 1.3.1
    (Provided that the Sun Java 2 SDK, Standard Edition Version 1.3.1 plus the addition of JSSE classfiles can be obtained, this is also a suitable environment under which SSL support using Java can be run with the exception of certificate checking against Certificate Revocation Lists (CRLs) which requires full JDK implementation at V1.4.)
  • IBM Developer Kit for Windows, Java 2 Technology Edition V5.0 (SR1 or above) [Only if the JDK is supplied with another IBM product]
Application Servers
  • IBM WebSphere Application Server V5.1
  • IBM WebSphere Application Server V6.0.2
  • IBM WebSphere Application Server V6.1 (please see this page for more details)
  • BEA WebLogic Server 8.1 + SP3 on WebSphere MQ v5.3 + FP10 on Solaris 8 & 9 and Sun's JDK 1.4x to support EJB's (including MDB's) and JMS only (with BEA's CR211194)
Transaction Managers Where one of these transaction monitor products is acting as the transaction manager and IBM WebSphere MQ is acting as a resource manager, it's recommended that you contact the transaction monitor vendor in the first instance for support.
  • WebSphere MQ V5.3 provides an extended transactional client for this platform.
  • The minimum supported level of TXSeries (CICS) is V5.0, plus PTF 1 and e-fix 1.
  • TXSeries V4.3, V5.0 and V5.1 (FP12 must be applied with V5.1).
    (Note: COBOL transactions are only supported with TXSeries 5.0 when the applied maintenance is CSD05 or later. See this page for more details).
  • BEA Tuxedo, V6.4 or V6.5 or V8.0 or V8.1
(The above are the minimum required supported levels. See general notes below.)
DCE
  • IBM DCE 3.1 for Solaris 7
  • IBM DCE 3.1 for Solaris 8
  • IBM DCE 3.2.00.0000 for Solaris 8
  • IBM DCE 3.2.00.0000 for Solaris 9

To enable users to run the WebSphere MQ supplied DCE send, receive or message exits, this must be the US domestic version supporting DES encryption.
Solaris Patches The statement under "Notes" below regarding the reason why these recommendations are being made. It is now highly likely that the patches listed below have been replaced by newer revisions. The best general approach is to stay up-to-date with routine maintenance as recommended by the Solaris software manufacturer.
    • Sun Solaris 7
      • 107171-02, 107544-03, 106950-16, 106327-11, 106300-10, 106541-18, 106980-17
    • Sun Solaris 8
      • 108827-32, 111177-06, 108434-02, 111327-02, 108528
    • Sun Solaris 9
      • There are no specific recommendations for patches for Solaris 9.
    • Sun Solaris 10
      • There are no specific recommendations for patches for Solaris 10.

Notes:

  1. Where patches for a product are specified, this means that these patches were required to resolve problems found during testing and should therefore be considered as the minimum necessary maintenance level. Further maintenance should be applied in accordance with the guidance of the relevant software manufacturer.


Change History
Last updated: 30 September 2006
  • 5 September 2005: Added support for Oracle 10g.
  • 2 December 2005: Modifications to the format.
  • 16 December 2005: Added support for Sun ONE Studio 9.
  • 18 January 2006: References to WebSphere MQ 5.3 FP8 and FP9 have been changed to FP10.
  • 09 February 2006: Added support for TXSeries V5.1.
  • 30 September 2006: Added JDK V1.4.2 with CSD10 (Solaris 10) in the Java section.
  • 14 June 2007: Added IBM Java 5 support.
  • 22 November 2007: Added support for IBM WebSphere Application Server V6.1.
  • 25 October 2012: Updated expiry date.

Related information

All WebSphere MQ System requirements
Recommended Updates
WebSphere MQ Library

Original publication date

2005/6/29

Product Alias/Synonym

WMQ MQ

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere MQ
Documentation

Software version:

5.3

Operating system(s):

Solaris

Reference #:

7006275

Modified date:

2007-06-14

Translate my page

Machine Translation

Content navigation