System Requirements for WebSphere MQ for HP-UX, V5.3

Product documentation


Abstract

This document contains system requirements for WebSphere MQ for HP-UX, V5.3.

Content

Operating Systems
  • HP-UX 11.0 with relevant Year 2000 fixes
  • HP-UX 11i (for example 11.11)
  • WebSphere MQ v5.3+ FP10 on HP11iv2 (HP11.23) on PA-RISC (DB2 8.1 requires at a minimum FP10)
Connectivity
  • HP SNAplus2
  • TCP/IP
  • SSL
    • Supported Cryptographic Hardware
      • The Rainbow Cryptoswift card is supported on HP-UX 11 using the BSAFE 3.0 interface
Databases Where IBM WebSphere MQ is acting as the transaction manager - see note under Transaction Monitor.
  • Non-Java applications using MQBEGIN or equivalent
    • Oracle 8iR3, Oracle 9iR1, Oracle 9iR2 and Oracle10gR1 (FP12 must be applied with Oracle10gR1)
    • IBM DB2 V7.2
    • IBM DB2 V8.1 + FP2 (at L030120 or later) with HP-UX 11i
    • IBM DB2 V8.2
  • Java™ applications using qmgr.begin and JDBC
    • IBM DB2 V7.2, WebSphere MQ CSD06
    • IBM DB2 V8.2, WebSphere MQ CSD06
    • Oracle 8.1.6, WebSphere MQ CSD06
    • Oracle 8.1.7, WebSphere MQ CSD06
    • Oracle 9.2.0.4, JDK 1.3.1, HP-UX 11.00, WebSphere MQ CSD06
    • Oracle 9.2.0.4, JDK 1.3.1, HP-UX 11i, WebSphere MQ CSD06
    • Oracle10gR1 (FP12 must be applied with Oracle10gR1)
Compilers
  • HP-UX ANSI C compiler
  • HP aC++ Versions C.03.27, C.03.30, C.03.33 & A.03.45 (Available as Patch PHSS_28756)
  • Micro Focus Server Express, V2.0.10, V2.0.11 & V2.2
  • Fully patched HP DDCE/9000 application development tools

Releases of 'HP C and C++ softbench' that are compatible with the C and C++ compilers listed above could be used.
Java
  • HP-UX SDK, for the Java platform, v1.3.1
    (Provided that the HP-UX SDK, for the Java 2 platform Version 1.3.1 (supplied with the MQ product) plus the addition of JSSE classfiles can be obtained, this is also a suitable environment under which SSL support using Java can be run with the exception of certificate checking against Certificate Revocation Lists CRLs which requires full JDK implementation at V1.4.)
  • HP-UX SDK for Java V1.4 and JDK V1.4.1.01 with CSD04
    (HP-UX SDK, for the Java 2 platform Version 1.4.0 is required for SSL support using Java as it provides the necessary JSSE classfiles.)
  • HP-UX SDK for Java V1.5
  • IBM Developer Kit for Windows, Java 2 Technology Edition V5.0 (SR1 or above) [Only if the JDK is supplied with another IBM product]

To use JDBC/XA with a Java client, you will need to use the v1.3.1 of the JDK, as this will not work with v1.4.x. The JDK provider has no plans to make the required changes for v1.4.x
Application Servers
  • IBM WebSphere Application Server V5.1
  • IBM WebSphere Application Server V6.0.2
  • IBM WebSphere Application Server V6.1 (see this page for more details)
  • BEA WebLogic Server 8.1 with WebSphere MQ v5.3 + FP10 on HP-UX 11i + SP4 and HP's JDK 1.4.2 to support EJB's (including MDB's) and JMS only
Transaction Managers Where one of these transaction monitor products is acting as the transaction manager and IBM WebSphere MQ is acting as a resource manager, it's recommended that you contact the transaction monitor vendor in the first instance for support.
  • BEA Tuxedo, V6.4, V6.5 or V8.1
  • TXSeries 5.0 (see note below) and V5.1 (FP12 must be applied with V5.1).
    (Note: COBOL transactions are only supported with TXSeries 5.0 when the applied maintenance is CSD05 or later. this page for more details).
DCE
  • The HP DCE/9000 version appropriate for the level of HP-UX operating system in use, provided this is compatible with DCE V1.4.1 as supplied for HP-UX V10.10. To enable users to run the WebSphere MQ-supplied DCE send, receive or message exits, this must be the US domestic version supporting DES encryption.

It is critical to apply HP service, patches are listed in the Release Note delivered with the HP DCE software; however for the latest information, contact the local HP support center. DCE names and security modules for WebSphere MQ are provided as part of the WebSphere MQ for HP-UX product.

Notes:

  1. Where patches for a product are specified, this means that these patches were required to resolve problems found during testing and should therefore be considered as the minimum necessary maintenance level. Further maintenance should be applied in accordance with the guidance of the relevant software manufacturer.


Change History
Last updated: 1 February 2007
  • 2 December 2005: Modifications to the format.
  • 18 January 2006: References to WebSphere MQ 5.3 FP8 & FP9 have been changed to FP10.
  • 9 February 2006: Added support for TXSeries V5.1 and Oracle10gR1.
  • 1 February 2007: Added support for HP-UX SDK for Java V1.5.
  • 14 June 2007: Added IBM Java 5 support.
  • 22 November 2007: Added support for IBM WebSphere Application Server V6.1.
  • 25 July 2012: Updated this document's expiry date to keep document published.
  • 25 July 2014: Updated expiry date as there are current Service Extensions.

Related information

WebSphere MQ System requirements
WebSphere MQ Recommended Fixes
WebSphere MQ library

Original publication date

2005/6/29

Product Alias/Synonym

WebSphere MQ WMQ

Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere MQ
Documentation

Software version:

5.3

Operating system(s):

HP-UX

Reference #:

7006274

Modified date:

2007-02-01

Translate my page

Machine Translation

Content navigation