IBM Support

PM89914: CORRECTIONS ARE NEEDED TO THE DOCUMENTATION IN THE INFORMATION CENTER FOR IBM WEBSPHERE APPLICATION SERVER VERSION 7.0.

Fixes are available

8.0.0.8: WebSphere Application Server V8.0 Fix Pack 8
7.0.0.31: WebSphere Application Server V7.0 Fix Pack 31
8.5.5.2: WebSphere Application Server V8.5.5 Fix Pack 2
7.0.0.33: WebSphere Application Server V7.0 Fix Pack 33
8.0.0.9: WebSphere Application Server V8.0 Fix Pack 9
8.5.5.3: WebSphere Application Server V8.5.5 Fix Pack 3
7.0.0.35: WebSphere Application Server V7.0 Fix Pack 35
8.5.5.4: WebSphere Application Server V8.5.5 Fix Pack 4
8.0.0.10: WebSphere Application Server V8.0 Fix Pack 10
7.0.0.37: WebSphere Application Server V7.0 Fix Pack 37
8.5.5.5: WebSphere Application Server V8.5.5 Fix Pack 5
8.5.5.6: WebSphere Application Server V8.5.5 Fix Pack 6
8.0.0.11: WebSphere Application Server V8.0 Fix Pack 11
8.5.5.7: WebSphere Application Server V8.5.5 Fix Pack 7
7.0.0.39: WebSphere Application Server V7.0 Fix Pack 39
8.5.5.8: WebSphere Application Server V8.5.5 Fix Pack 8
8.0.0.12: WebSphere Application Server V8.0 Fix Pack 12
8.5.5.9: WebSphere Application Server V8.5.5 Fix Pack 9
7.0.0.41: WebSphere Application Server V7.0 Fix Pack 41
8.5.5.10: WebSphere Application Server V8.5.5 Fix Pack 10
8.5.5.11: WebSphere Application Server V8.5.5 Fix Pack 11
8.0.0.13: WebSphere Application Server V8.0 Fix Pack 13
7.0.0.43: WebSphere Application Server V7.0 Fix Pack 43
8.5.5.12: WebSphere Application Server V8.5.5 Fix Pack 12
8.0.0.14: WebSphere Application Server V8.0 Fix Pack 14
8.5.5.13: WebSphere Application Server V8.5.5 Fix Pack 13
7.0.0.45: WebSphere Application Server V7.0 Fix Pack 45
8.0.0.15: WebSphere Application Server V8.0 Fix Pack 15
7.0.0.45: Java SDK 1.6 SR16 FP60 Cumulative Fix for WebSphere Application Server
7.0.0.31: Java SDK 1.6 SR15 Cumulative Fix for WebSphere Application Server
7.0.0.35: Java SDK 1.6 SR16 FP1 Cumulative Fix for WebSphere Application Server
7.0.0.37: Java SDK 1.6 SR16 FP3 Cumulative Fix for WebSphere Application Server
7.0.0.39: Java SDK 1.6 SR16 FP7 Cumulative Fix for WebSphere Application Server
7.0.0.41: Java SDK 1.6 SR16 FP20 Cumulative Fix for WebSphere Application Server
7.0.0.43: Java SDK 1.6 SR16 FP41 Cumulative Fix for WebSphere Application Server
8.5.5.14: WebSphere Application Server V8.5.5 Fix Pack 14

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as documentation error.

Error description

  • This APAR describes the issues that customers encountered with
    IBM WebSphere Application Server Version 7.0. These issues were
    resolved as information center updates in June 2013.
    

Local fix

  • N/A
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server                                      *
    ****************************************************************
    * PROBLEM DESCRIPTION: This APAR provides a cumulative list    *
    *                      of the documentation issues for         *
    *                      May 2013 that affect users of IBM       *
    *                      WebSphere Application Server Version    *
    *                      7.0.                                    *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    The Information Centers for WebSphere Application Server
    Version 7.0 need to reflect customer enhancement requests
    received in problem management records (PMRs). These
    enhancements can include fixing technical inaccuracies or
    clarifying vague information.
    

Problem conclusion

  • Note: We update our information centers monthly. The following
    Version 7.0 modifications were included in the June 2013
    update to the Information Centers. To access the latest
    on-line documentation, go to the product library page at
    http://www.ibm.com/software/webservers/appserv/library and
    select the version and product that is appropriate for your
    WebSphere Application Server environment.
    
    The following Version 7.0 issues will be addressed:
    
    ID: PM89914
    Problem: The information centers do not indicate that
    traceSpec is read left to right, so what is furthest out
    (right) in the traceSpec has final say.  By putting *=info at
    the end, that sets everything back to info level and undoes
    anything done before it (*=xxx where xxx is any level at the
    end will overRide all items before it.
    
    Resolution: The topics "Log level settings" and "Enabling
    trace at server startup" were updated to include the following
    information:
    
    The clauses included in a trace specification are read in the
    order they appear in the string. Therefore, if multiple
    variations of the *=info clause are included in a trace
    specification, the last value specified is the value that
    determines the trace level that the system logs. If
    you specify *=info as the last clause, tracing occurs at the
    info level regardless of other clauses that are specified
    in the trace string. For example, specifying the
    following trace string:
    
    *=info:PMGR=all:*=info:com.ibm.ws.sm.*=all
    
    is equivalent to simply specifying:
    
    *=all
    
    Because the final clause overrides all clauses that were
    specified ahead of it in the string.
    
    These same updates were made to the Version 8.0, and 8.5
    Information Centers.
    -------------
    ID: 749201
    Problem: There is a high volume of customer calls requesting
    guidance on excluding
    files and processes from antivirus processing.  The WebSphere
    Application Server information center is lacking guidance on
    this issue and needs an update.
    
    Resolution:  Topic, Tuning security performance, is updated.
    The, About this task, section of this topic is updated to read
    as follows:
    Important: Performance degradation may be experienced on
    platforms running antivirus software. Performance Degradation
    may vary between antivirus software vendor and/or features
    that are enabled. WebSphere ??Application Server has no unique
    dependencies or special requirements when using antivirus
    software. Contact your antivirus vendor for information on how
    this impact may be mitigated.
    
    This update applies also to the Version  6.1, 8.0, and 8.5 of
    the information center.
    ---------------
    ID: 749471
    Problem: Step 3 of the topic "Ensuring that servers use the
    latest available WebSphere MQ resource adapter maintenance
    level" has missing parenthesis in a Jython script example.
    Also, Step 4 in this topic is missing an important
    notification to indicate that when you run the Step 3 script
    against a profile that is part of a network deployment
    configuration, the script updates all profiles that need
    updating in that configuration.
    
    Resolution: The example in Step 3 of topic "Ensuring that
    servers use the latest available WebSphere MQ resource adapter
    maintenance level" is corrected, and the following note is
    added to Step 4:
    
    Note: If you run the script against a profile that is part of
    a network deployment configuration, the script updates all
    profiles that need updating in that configuration.
    
    This update also applies also to the Version  8.0, and 8.5
    Information Centers.
    -------------
    ID: 749973
    Problem: Topic "Disabling or enabling a high availability
    manager" is missing important information concerning the
    disabling of the high availability manager.  This topic needs
    to add information to ensure that when the high availability
    manager is disabled, it is disabled for all servers in the
    core group.
    
    Resolution: The following AVOID TROUBLE is updated added to
    this topic:
    
    Avoid trouble: When you disable the high availability manager,
    make sure that you disable it  for all the servers in a core
    group so that all members are disabled. Do not disable the
    high availability manager for select members of the core
    group. For more information, see the following documents:
    - Section "2.1.6.1 High availability is not needed" of the
    "Best Practices for Large WebSphere Topologies" document
    
    - Section "6.3.3 Partitioned cell with HA manager-disabled core
    group topology" of the "Techniques for Managing Large
    WebSphere Installations" Redbooks publication.
    
    This update also applies to the Version 8.0 and 8.5
    Information Centers.
    -----------------
    ID: 749495
    Problem: The DESERIALIZE_ASYNCH_CONTEXT login configuration
    applies to asynchronous beans.  Any operation that requires
    token validation in the lognModules configured in the
    DESERIALIZE_ASYNC_CONTEXT login configuration can result in
    the API repeatedly throwing the TokenExpiredException.  This
    important information is missing from the information center.
    
    Resolution: Topic "System login configuration entry settings
    for Java Authentication and Authorization Service" is updated
    with the following description:
    
    DESERIALIZE_ASYNCH_CONTEXT
    Processes login requests for asynchronous beans.
    
    The DESERIALIZE_ASYNCH_CONTEXT configuration is used for
    asynchronous beans only. The scheduler utilizes the
    asynchronous beans alarm manager for "Deferred Start", which
    allows serialization and deserialization of the J2EE context.
    This login configuration is used when using asynchronous
    beans, Scheduler, and EJB Timers.
    CAUTION: The DESERIALIZE_ASYNCH_CONTEXT login configuration
    has a limitation. Any operation that requires token validation
    in the lognModules configured in the DESERIALIZE_ASYNC_CONTEXT
    login configuration can result in the API repeatedly throwing
    the TokenExpiredException.
    
    This update also applies to the Version  6.1, 8.0,and 8.5
    Information Centers.
    -----------------
    ID: 750848
    Problem: The table in the topic "Ways to install enterprise
    applications or modules" does not mention that you can also
    use the
    com.ibm.websphere.management.application.AppManagementHelper.wra
    pModule API to wrap a WAR file into an EAR file.
    
    Resolution: Mention of this API has been added to this topic.
    
    This update also applies to the Version 7.0 and 8.0 Information
    Centers.
    -----------------
    ID: 751026
    Problem: In the topic "update command", users might get
    confused about which multiple maintenance packages are acually
    installed with the update command based on the return codes.
    
    Resolution: The following information has been added to the
    "update command" topic:
    
    When istalling multiple maintenance packages silently,
    sometimes not all maintenance packages are installed. Check
    the Selected Maintenance Package Path in the updatelog.txt
    file to view which maintenance packages are actually installed
    by UPDI.
    
    This update also applies to the Version 7.0 and 8.0
    Information Centers.
    ------------------
    ID: 751327
    Problem: After restoring files from a backup package/folder
    containing the backup package, the timestamp of the files was
    more recent than other packages installed.  This condition
    caused the uninstaller to select the wrong package during
    uninstall.  The uninstaller uses timestamps of the  backup
    packages to determine the most recent package.  There is a
    need to inform users of this processing when uninstalling
    maintenance packages.
    
    Resolution: Topic "Uninstalling maintenance packages, interim
    fixes, fix packs, and refresh packs" is updated.
    Specifically, the following sentence is added to the Step 5
    example of using the update installer to uninstall the
    maintenance package:
    
    If no backup.package is specified, a default of the last
    installed maintenance package will be used. The Update
    Installer determines the last installed maintenance package by
    timestamp.
    
    This update also applies to the Version Version 6.1
    Information
    Center.
    

Temporary fix

Comments

APAR Information

  • APAR number

    PM89914

  • Reported component name

    WEBSPHERE APP S

  • Reported component ID

    5724J0800

  • Reported release

    700

  • Status

    CLOSED DOC

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2013-05-28

  • Closed date

    2013-07-02

  • Last modified date

    2013-08-09

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

Applicable component levels



Document information

More support for: WebSphere Application Server
General

Software version: 7.0

Reference #: PM89914

Modified date: 09 August 2013