Supported IBM and third-party software with TXSeries for Multiplatforms 7.1 on Microsoft Windows

Flash (Alert)


Abstract

The following table lists the IBM and third-party software supported for use with TXSeries for Multiplatforms 7.1 on Microsoft Windows.

Content

This page provides information about the levels of IBM and third-party software that run with TXSeries 7.1. However, since every possible combination of products cannot be tested, we suggest that you also contact the third-party vendor to verify that a particular product is supported for use with TXSeries. Maintenance levels listed below are minimum levels. TXSeries is not tested with every maintenance level of every product; we generally assume vendors do not cause regressions in their patches/SPs/FPs/CSDs/PTFs. If you use later maintenance levels and experience problems, please test with the levels specified below before contacting your IBM support representative.
For information on the support policy statement for TXSeries fixes, click here.

Products that do not appear in the following tables have not been tested with TXSeries 7.1. TXSeries is periodically tested with additional third-party products and the information in this page is updated accordingly.

TXSeries is a 32-bit product. All libraries linked with TXSeries must be 32-bit libraries. Most vendors offering 64-bit versions of their products provide 32-bit client libraries. On 64-bit UNIX operating systems, TXSeries runs in 32-bit compatibility mode where support is noted in the operating system entry in the table below.

Note

  1. Since interaction between releases of operating systems, software products, and TXSeries is very complex, information on this page can possibly conflict with information that is provided by product vendors. If you notice such an inconsistency or if you experience unanticipated problems, consult your vendor's product support and notify your IBM support representative.
  2. IBM recommends that you maintain your TXSeries system environments at the latest fix pack level. See TXSeries for Multiplatforms support policy statement for more details.

Operating System :

Software
OS
Version
Software Version
Notes
Microsoft Windows Server
2003



2003 SP2 1



Standard and Enterprise editions are supported with Windows Server 2003 and Windows Server 2008.

Windows XP SP2 and VISTA are supported only as development platforms.

1 Only 32-bit operating system is supported for Windows 2003.
2 Windows 2008 R2 is supported in 32-bit compatibility mode.
2008
2008 R1 SP1
2008 R2 SP1 2


Compilers :

Software
Software Version
Notes
Microsoft Visual Studio .NET
2005
2008
Only C & C++ compilers are supported.
Rational Developer for SystemZ 1

7.5
7.6
8.0.3
  • Only IBM COBOL & PL/I are supported from this bundle.
  • The alternate physical map option for BMS applications is supported with TXSeries 7.1 FP1.
  • RDz 8.0.3 is supported with TXSeries 7.1 Fix Pack 3.

1 Supported on Windows XP SP2 and Windows VISTA only.
MicroFocus Net Express COBOL
5.0
5.1
Only 32-bit version is supported.
IBM J2SE SDK
1.5 SR7

Databases :

Software
Software Version
Notes
IBM DB2 UDB
9.1.3
9.5
9.7
10.1
TXSeries 7.1 Fix Pack 1 is required for DB2 9.7.
DB2 10.1 is supported with TXSeries 7.1 Fix Pack 3.
Oracle
10.2.0.3
11.1.0.7
11.2.0.1
Oracle as file manager is supported only with Oracle 10.2.0.3.

Oracle 11.1.0.7 is supported only on Windows 2003.

Oracle 11.2.0.1 is supported on Windows 2003 and Windows 2008. Refer to the technote on issues related to XA_CLOSE.
Microsoft SQL Server
2005
2008
Microsoft SQL Server 2005 is supported on Windows 2003.

Microsoft SQL Server 2008 is supported on Windows 2008.

Note : All databases are tested and supported with the Client versions shown under the "Software Version" column.

Communication Software :

Software
Software Version
Notes
IBM Communication Server
6.1.3
6.4
IBM Communication Server 6.4 is supported on Windows 2008.

Clients :

Software
Software Version
Notes
IBM CICS Universal Client Any supported version of IBM CICS Universal Client. Refer to CUC System Requirements page for more details.
IBM CICS Transaction Gateway Any supported version of IBM CICS Transaction Gateway. Refer to CTG System Requirements page for more details.

APAR PK81606 on CTG V7.2 is required for using IPIC.

Integration Middleware :

Software
Software Version
Notes
IBM WebSphere MQ Any supported version of IBM WebSphere MQ Refer to IBM WebSphere MQ System Requirements page for more details.


Change History:
  • 20th Jan 2010 : Added support for RDz 7.6 in compilers section.

Rate this page:

(0 users)Average rating

Document information


More support for:

TXSeries
Maintenance

Software version:

7.1

Operating system(s):

Windows

Software edition:

All Editions

Reference #:

1379892

Modified date:

2010-09-07

Translate my page

Machine Translation

Content navigation