System Requirements for WebSphere MQ for AIX V5.3

Product documentation


Abstract

This document contains system requirements for WebSphere MQ for AIX V5.3.

Content

Operating Systems
  • AIX V5.3
  • AIX V5.2 (32 bit and 64 bit kernel)
  • AIX V5.1 with PTFs: U476879, U477366, U477367 and U477368
  • AIX V4.3.3 with relevant Year 2000 fixes

For SSL please refer to note 4 below.
Connectivity
  • IBM eNetwork Communications Server for AIX, V6.0 and V6.1
  • TCP/IP
  • SSL
    • Supported Cryptographic Hardware:
      • The IBM FC 4963 card is supported on AIX 4.3.3 using the PKCS #11 interface
      • The IBM e-business Cryptographic Accelerator (#4960) card is supported in AIX 5.1 using the PKCS #11 interface
      • WebSphere MQ V5.3 running on AIX now supports the nCipher nForce 300 card. This is supported on AIX 5.1 and AIX 5.2
Databases Where IBM WebSphere MQ is acting as the transaction manager - see note under Transaction Monitor.
  • Non-Java applications using MQBEGIN or equivalent
    • Oracle 8iR3, Oracle 9iR1 and Oracle 9iR2
      (Both 32-bit and 64-bit databases are supported when using Oracle's 32-bit client libraries).
    • Oracle 10g Release 1 (10.1.0) - WebSphere MQ Fix Pack 11 (CSD11) is required
    • IBM DB2 V7.2
    • IBM DB2 V8.1 + FP2 (030120 or later)
    • IBM DB2 V8.2
    • Sybase 12 and 12.5
  • Java™ applications using qmgr.begin and JDBC
    • IBM DB2 V7.2
    • IBM DB2 V8.2
    • Oracle 8.1.6
    • Oracle 8.1.7
    • Oracle 9.2.0.4, JDK 1.4.1, AIX 5.1, WebSphere MQ CSD06
    • Oracle 9.2.0.4, JDK 1.4.1, AIX 5.2, WebSphere MQ CSD06
    • Oracle 10g Release 1 (10.1.0) - WebSphere MQ Fix Pack 11 (CSD11) is required
Compilers
  • 32-bit applications
    • IBM C for AIX, V5 or V6
    • IBM VisualAge C++ Professional for AIX, V5.1 and VisualAge C/C++ Professional for AIX Version 6.0 and IBM XL C/C++ Enterprise Edition V7.0 for AIX
      (Use the VisualAge C/C++ v6.0 and IBM XL C/C++ Enterprise Edition V7.0 for AIX compiler option "-q namemangling=v5" for C++ to get all the WebSphere MQ symbols resolved while linking the libraries.)
    • Micro Focus Server Express, V2.0.10, V2.0.11, V2.2 & V4.0
      (Before compiling WebSphere MQ applications with Micro Focus Server Express V2.2, ensure that WebSphere MQ maintenance is applied to CSD04 level or later. See this page for more details).
    • IBM COBOL Set for AIX V1.1 & V2.0
  • 64-bit applications (see SupportPac entitled "MACS: WebSphere MQ Client Libraries for AIX (64-bit)", available from this page)
    • IBM C for AIX, V5 or V6
    • IBM VisualAge C++ Professional for AIX, V5.1 and VisualAge C/C++ Professional for AIX Version 6.0 and IBM XL C/C++ Enterprise Edition V7.0 for AIX
      (Use the VisualAge C/C++ v6.0 and IBM XL C/C++ Enterprise Edition V7.0 for AIX compiler option "-q namemangling=v5" for C++ to get all the WebSphere MQ symbols resolved while linking the libraries.)
    • Micro Focus Server Express, V2.0.11, V2.2 SP1 with FP10 & V4.0
      • Before compiling 64-bit WebSphere MQ applications with Micro Focus Server Express, ensure that the latest client libraries and header files are downloaded.
      • Before preparing your COBOL programs to run with WebSphere MQ, the path where your COBOL compiler is setup needs to added to your environment variables.
      • MACS SupportPac should be installed over WebSphere MQ 5.3 CSD07 or above to work with 64-bit applications.

WebSphere MQ for AIX, V5.3 supports applications using POSIX draft 4 and draft 10 threads, but not draft 7.
Java
  • 32-bit
    • IBM AIX Developer Kit, Java 2 Technology Edition, Version 1.3.1, 32-bit version for POWER
      (Provided that the IBM AIX Developer Kit, Java 2 Technology Edition, Version 1.3.1, 32-bit plus the addition of IBM JSSE classfiles can be obtained as included within an alternate IBM product, this is also a suitable environment under which SSL support using Java can be run with the exception of certificate checking against Certificate Revocation Lists CRLs which requires full JDK implementation at V1.4.)
    • IBM 32-bit SDK for AIX, Java 2 Technology Edition, Version 1.4, 32-bit
      (WebSphere MQ maintenance must be at least CSD04. IBM AIX Developer Kit, Java 2 Technology Edition, Version 1.4, 32-bit is required for SSL support using Java as it provides the necessary IBM JSSE classfiles.)
  • 64-bit
    • IBM AIX Developer Kit, Java 2 Technology Edition, Version 1.3.1, 64-bit version for POWER
      (Restrictions: See note 1 below)
Application Servers
  • IBM Websphere Application Server V5.1
  • IBM Websphere Application Server V6.0.2
  • IBM Websphere Application Server V6.1 (See this page for more details.)
  • BEA WebLogic Server 8.1 + SP2 on WebSphere MQ V5.3 + FP7 on AIX 5.x and IBM JDK 1.4x to support EJB's (including MDB's) and JMS only.
    (The above are the minimum required supported levels. See general notes below)
Transaction Managers Where one of these transaction monitor products is acting as the transaction manager and IBM WebSphere MQ is acting as a resource manager, it's recommended that you contact the transaction monitor vendor in the first instance for support.
  • TXSeries V4.3, V5.0 and V5.1(FP9 must be applied with V5.1)
    (Note: COBOL transactions are only supported with TXSeries 5.0 when the applied maintenance is CSD05 or later. See this page for more details.)
  • BEA Tuxedo, V6.4 or V6.5
  • BEA Tuxedo V8.0 & V8.1 (32bit only) on WebSphere MQ V5.3 + FP9 or later on AIX 5.x. At FP9 WebSphere MQ V5.3 APAR IY69467 is also required
DCE
  • IBM DCE V3.1 & V3.2

To enable users to run the WebSphere MQ supplied DCE send, receive or message exits, this must be the US domestic version supporting DES encryption.

Notes:

  1. The following restrictions apply when using IBM AIX Developer Kit, Java 2 Technology Edition, Version 1.3.1, 64-bit version for POWER:
    • AIX v5.2 64-bit OS patch level ML-01 must be applied.
    • IBM AIX Developer Kit Service Release 6 must be applied.
    • WebSphere MQ maintenance must be at least CSD05.
    • Only client applications are supported. Server bindings mode is not supported.
    • There is no support for SSL-encrypted MQI channels from the Java client to the WebSphere MQ server.
  2. TXSeries v5.1 with WebSphere MQ Extended Transaction Client (XAClient):
    • WebSphere MQ V5.3 client + CSD03 + WebSphere MQ V5.3 XAClient +FP09
    • If user exit 15 provided with WebSphere MQ V5.3 is to be used with the XAClient, APAR IY72218 needs to be applied.
  3. Where a patches for a product are specified, this means that these patches were required to resolve problems found during testing and should therefore be considered as the minimum necessary maintenance level. Further maintenance should be applied in accordance with the guidance of the relevant software manufacturer.
  4. For SSL function on AIX 5.1, 5.2 & 5.3 please use C Set ++ v 6.0.0.3 (Runtime).


Change History
Last updated: 18 May 2006
  • 4 August 2005: Added support for Micro Focus Server Express V4.0
  • 5 September 2005: Added support for Oracle 10g
  • 7 November 2005: Added support for IBM COBOL Set for V2.0
  • 2 December 2005: Modifications to the format.
  • 13 December 2005: Clarified Tuxedo support.
  • 18 January 2006: References to WebSphere MQ 5.3 FP8 & FP9 have been changed to FP10.
  • 18 May 2006: Added note 4.
  • 22 November 2007: Added support for IBM WebSphere Application Server V6.1.
  • 24 September 2012: Updated expiry date.
  • 23 September 2014: Updated expiry date.

Related information

WebSphere MQ System requirements
Recommended Updates

Original publication date

2005/6/9

Product Alias/Synonym

WMQ MQ

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere MQ
Documentation

Software version:

5.3

Operating system(s):

AIX

Reference #:

7006357

Modified date:

2007-03-28

Translate my page

Machine Translation

Content navigation