System Requirements for WebSphere MQ for Linux Intel v5.3

Product documentation


Abstract

This document contains system requirements for WebSphere MQ for Linux Intel v5.3.

Content

Operating Systems
  • Any Linux distribution running on Kernel 2.4 with glibc version 2.2 (or a later version of glibc) using LinuxThreads
    • The WebSphere MQ installation uses Red Hat Package Manager, so this must also be present on the system.
    • The Linux distributions, which have been tested, and which are known to meet the prerequisite levels are Caldera Open Linux Server 3.1.1, SuSE SLES-7, RedHat Professional 7.3 and Turbo Linux Server 7.0.
    • The following Linux distributions which meet these prerequisite levels have also been tested with WebSphere MQ for Linux for Intel, V5.3 with Fix Pack 10 applied: Red Hat Enterprise Linux 3.0 AS/ES/WS (Update 1 or later), SUSE Linux Enterprise Server 8.0, Red Flag Advanced Server Release 4.1. Full details of support for these platforms are contained in the memo.ptf of Fix Pack 10 and later, and are also available from the following link: WebSphere MQ V5.3 for Linux for Intel support for SuSE Linux Enterprise Server 8 (SLES8)
  • SUSE Linux Enterprise Server 9, NLPOS9 FP1 and IRES V2
    • Full details of support for SUSE Linux Enterprise Server 9 are available from the following link: sles9.readme.txt
Connectivity
  • TCP/IP
    The following packages are also required for support of SSL channels
    • libgcc-3.0
    • libstdc++3-3.0
  • IBM Communications Server for Linux, Version 6.0
Databases Where IBM WebSphere MQ is acting as the transaction manager - see note under Transaction Monitors.
  • Non-Java applications using MQBEGIN or equivalent
    • IBM DB2 V7.2
    • IBM DB2 V8.1 + FP2 (at L030120 or later)
    • IBM DB2 V8.2
    • Oracle 9iR1
    • Oracle 9iR2
    • Oracle 10gR1 (FP12 must be applied with Oracle 10gR1).
Compilers
  • GNU C Compiler (gcc) and g++ V2.95.2 or V3 compiler
  • libstdc ++ Version 3.0 (for C++ programming)
Java
  • IBM Developer Kit for Linux, V1.3.1
    (Provided that the IBM Developer Kit for Linux, Java 2,Technology Edition, Version 1.3.1, 32-bit version plus the addition of IBM JSSE classfiles can be obtained as included within an alternate IBM product, this is also a suitable environment under which SSL support using Java can be run with the exception of certificate checking against Certificate Revocation Lists (CRLs) which requires full JDK implementation at V1.4.)
  • IBM Linux Java SDK V1.4; JDK V1.4.1 (CSD04 or above) and JDK 1.4.2 (CSD10 or above).
    (IBM 32-bit SDK for Linux on Intel architecture, Java 2 Technology Edition, Version 1.4.0 is supplied with the WebSphere MQ product and is required for SSL support using Java as it provides the necessary IBM JSSE classfiles.)
  • Java 2 Platform, Standard Edition version 1.4.2 from Sun Microsystems with CSD10
  • IBM Developer Kit for Windows, Java 2 Technology Edition V5.0 (SR1 or above) [Only if the JDK is supplied with another IBM product]
Application Servers
  • IBM WebSphere Application Server V5.1
  • IBM WebSphere Application Server V6.0.2
  • IBM WebSphere Application Server V6.1 (see this page for more details)
  • BEA WebLogic Server 8.1 with WebSphere MQ v5.3 + FP10 on RHEL AS Release 3 Update 3 on Intel + SP4 and BEA WebLogic JRockit (TM) 1.4.2 to support EJB's (including MDB's) and JMS only
Transaction Monitors Where one of these transaction monitor products is acting as the transaction manager and IBM WebSphere MQ is acting as a resource manager, it is recommended that you contact the transaction monitor vendor in the first instance for support.
  • WebSphere MQ V5.3 provides an extended transactional client for this platform.

Notes:

  1. Where patches for a product are specified, this means that these patches were required to resolve problems found during testing and should therefore be considered as the minimum necessary maintenance level. Further maintenance should be applied in accordance with the guidance of the relevant software manufacturer.


Change History
Last updated: 9 February 2006
  • 22 August 2005: Added support for NLPOS9 FP1
  • 6 September 2005: Added support for IRES V2
  • 2 December 2005: Modifications to the format.
  • 18 January 2006: References to WebSphere MQ 5.3 FP8 & FP9 have been changed to FP10.
  • 2 February 2006: Clarified Kernel 2.4 support.
  • 9 February 2006: Added support for Oracle 10gR1.
  • 19 May 2007: Added IBM Developer Kit for Windows, Java 2 Technology Edition V5.0 (SR1 or above) [Only if the JDK is supplied with another IBM product]
  • 22 November 2007: Added support for IBM WebSphere Application Server V6.
  • 24 July 2012: Updated expiry dates to keep current.
  • 19 June 2014: Updated expiry date to keep current

Related information

All WebSphere MQ System requirements
WebSphere MQ Recommended Updates
WebSphere MQ Library

Original publication date

2005/6/30

Product Alias/Synonym

WMQ MQ

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere MQ
Documentation

Software version:

5.3

Operating system(s):

Linux

Reference #:

7006300

Modified date:

2005-07-01

Translate my page

Machine Translation

Content navigation