System Requirements for WebSphere MQ 6.0 on Windows

Product documentation


Abstract

This document contains system requirements for WebSphere MQ 6.0 on Windows.

Content

Operating Systems
  • Microsoft Windows 2000 Professional Server or Advanced Server (with SP4) [see notes 1 and 6]
  • Microsoft Windows XP Professional with SP1 or later (including x64 Editions) [see notes 1 and 6]
  • Microsoft Windows Server 2003 with SP1 or later (Standard, Enterprise, Standard x64 and Enterprise x64 Editions) [see notes 1 and 6]
  • Microsoft Windows Server 2003 R2 with SP1 or later (Standard, Enterprise, Standard x64 and Enterprise x64 Editions) [see notes 1 and 6]
  • Microsoft Vista (Ultimate, Enterprise and Business Editions) [see notes 1 and 9]
  • Microsoft Windows Embedded Point of Service 1.0 [see note 15]
Hardware Requirements
  • Windows x86 or x64 technology-compatible PC hardware, capable of running the required level of a compatible operating system with enough storage to meet the combined requirements of the programming prerequisites, WebSphere MQ, the access methods and the application programs.
Java™ and JMS Client
  • 32-bit
    • IBM Developer Kit for Windows, Java 2 Technology Edition V1.4.2. (IBM 32-bit SDK for Windows, Java 2 Technology Edition V1.4.2 is supplied with the WebSphere MQ product and is required for SSL support using Java because it provides the necessary JSSE class files.)
    • Java 2 Platform, Standard Edition V1.4.2 from Sun Microsystems, Inc. [see note 1]
    • IBM Developer Kit for Windows, Java Technology Edition V1.3.1 [Only if the JDK is supplied with another IBM product; SSL support requires JDK V1.4.2 or above]
    • IBM Developer Kit for Windows, Java 2 Technology Edition V5.0 (SR1 or above) [Only if the JDK is supplied with another IBM product]
    • Java 2 Platform, Standard Edition V5.0 (SR1 or above) from Sun Microsystems, Inc.
    • IBM Developer Kit for Windows, Java 2 Technology Edition V6.0 (SR3 or above) [see note 17]
    • IBM SDK for DesktopEE 6.5 M2 [see notes 17 and 18]
  • 64-bit
    • IBM 64-bit SDK for Windows Java 2 Technology Edition V5.0 (SR1 or above) [Only if the JDK is supplied with another IBM product; [see notes 1 and 10]
Databases Where IBM WebSphere MQ is acting as the transaction manager.
  • IBM DB2 Universal Database V8.2
  • IBM DB2 V9.1 for Linux, UNIX, and Windows (JDBC/XA not supported) [see note 7]
  • IBM DB2 V9.5 for Linux, UNIX, and Windows [see note 19]
  • Informix Dynamic Server (IDS) V9.40 with Client SDK V2.90
  • Informix Dynamic Server (IDS) V10 with Client SDK V2.90
  • Oracle 9i, Release 2 with Patch Set 4 (V9.2.0.5) [see note 3]
  • Oracle 10g Release 1
  • Oracle 10g Release 2
  • Sybase Adaptive Server Enterprise (ASE) V12.5.1 ESD#1
Compilers
  • Microsoft Visual Studio 2008 [see note 15]
  • Microsoft Visual Studio 2005
    • Microsoft Visual C++ 2005
    • Microsoft Visual C# 2005
    • Microsoft Visual Basic .NET 2005
  • Microsoft Visual Studio .NET 2003
    • Microsoft Visual C++ .NET 2003
    • Microsoft Visual C# .NET 2003
    • Microsoft Visual Basic .NET 2003
  • Microsoft Visual Basic V6
  • IBM VisualAge COBOL Enterprise V3.0.1
  • Micro Focus Net Express V4.0 (COBOL)
  • Micro Focus Net Express V5.0 (COBOL)
Connectivity
  • IBM Communications Server for Windows V6.1.2
  • IBM Personal Communications V5.7 (part of IBM Host Access Client Package (HACP), V4.0)
  • Microsoft Host Integration Server 2004
  • Microsoft Host Integration Server 2000
  • Attachmate myEXTRA! Presentation Services, V7.11
  • Attachmate EXTRA! Enterprise 2000
  • Attachmate EXTRA! Personal Client V6.7
  • TCP/IP (provided by the operating system; IP V6 feature provided on Windows XP with Service Pack 1 or later and Windows Server 2003)
  • NetBIOS (provided by the operating system)
  • Sequenced Package Exchange (SPX) (provided by the operating system)
  • WebSphere MQ client applications (built using WMQ V6.0 or WMQ V5.3 FP10 refresh or later client libraries) are supported on the Citrix MPS V3.0
Application Servers
  • IBM WebSphere Application Server V5.1 (for Windows 2000 Server, Windows 2000 Advanced Server and Windows 2003 Standard Edition and Enterprise Edition)
  • IBM WebSphere Application Server, including the WebSphere Application Server client container, V6.0.2 (see this document and note 14 for more information)
  • IBM WebSphere Application Server, including the WebSphere Application Server client container, V6.1 (see this document and note 14 for more information)
  • IBM WebSphere Application Server, including the WebSphere Application Server client container, V7.0 (see this document and note 14 for more information)
  • BEA WebLogic Server 8.1 + SP4 on Windows 2000 and Sun's JDK 1.4x [see note 14]
Transaction Manager Where one of these products is acting as the transaction manager and IBM WebSphere MQ is acting as a resource manager, it's recommended that you contact the transaction manager vendor in the first instance for support
  • IBM TXSeries V5.1
  • IBM TXSeries V6.1 & V6.2 [see notes 12 and 13]
  • BEA Tuxedo V8.1 (Windows 2000 Advanced Server and Windows Server 2003 Enterprise Edition)
  • BEA WebLogic Server 8.1 + SP4 on Windows 2000 and Sun's JDK 1.4x [see note 14]
  • MTS/COM (at the same level as the operating system)
SOAP Support
  • Microsoft Internet Information Services (for running .NET services) on Windows 2000
  • Microsoft .NET Framework V1.1 (redistributable)
  • Microsoft .NET Framework SDK V1.1 or Microsoft Visual Studio .NET 2003 (for deploying Microsoft .NET services);
  • Microsoft .NET Framework SDK V2.0
  • Microsoft .NET Framework SDK V3.0 and V3.5 [see note 15]
  • IBM Developer Kit for Windows, Java 2 Technology Edition V1.4.2 (supplied with WebSphere MQ)
  • Apache Axis V1.1 (supplied with WebSphere MQ)
Cryptography Cards Refer to the Cryptography Card List for WebSphere MQ v6 and v7 document for further information.

Notes:

  1. WebSphere MQ V6 64-bit Windows (toleration) support:
    - WebSphere MQ V6 64-bit Windows (toleration) is applicable at WebSphere MQ V6.0.2.1 or later.
    - WebSphere MQ V6.0.2.0 or lower versions only support 32-bit operating systems.
    - Only 32-bit versions of programming languages are supported.
    - For information on the installation of the service delivery which supports Windows 64-bit operating systems please see section 2.3 of the readme which accompanies the service delivery. This can be found here. This has details of the installation of the Microsoft Visual C++ 2005 redistributable package which must be installed before the service delivery.
  2. Only DB2 and Oracle are supported for JDBC and XA usage.
  3. For Oracle 9i, Release 2 with Patch Set 4 (V9.2.0.5) patch 3501955 is required.
  4. The 'MQ Explorer' tooling is supported on the following Windows environments: Windows 2000 Professional; Windows 2000 Server; Windows 2000 Advanced Server; Windows XP Professional; Windows Server 2003 Standard Edition; and Windows Server 2003 Enterprise Edition.
  5. Microsoft Windows 2000 Professional, Server or Advanced Server, are not supported by WebSphere MQ Extended Security Edition v6.0.
  6. The WebSphere MQ Explorer tooling is only supported running inside the eclipse version installed as part of the WebSphere MQ V6 install or running inside the WebSphere Message Broker V6 installed eclipse environment. Note that running inside the WebSphere Message Broker V6 eclipse environment requires MQ version 6.0.1.0 or later. Also, WebSphere MQ Explorer tooling is only supported with IBM Java 1.4.2 or IBM Java 1.5.
  7. WebSphere MQ 6.0.2.0 or later is required.
  8. For details of the Support Statement for JCA (on WebSphere MQ V6.0.2.1 or later only) please see here.
  9. WebSphere MQ Client V6.0.2.1 or later required (Server is not supported).
  10. WebSphere MQ only supports Java/JMS in Clients mode on Windows 64-bit platform (i.e. Bindings mode is not supported).
  11. Defect support is available for virtualization environments (for VMware see here) where they relate to releases of this platform already supported by WebSphere MQ. Unless stated elsewhere in the system requirements, WebSphere MQ has not been specifically tested in virtualization environments. WebSphere MQ Support is therefore unable to assist in issues related to configuration and setup, or issues that are directly related to the virtualization environment itself.
  12. WebSphere MQ V6.0.2.1 or later is required.
  13. The resiliency feature of TXSeries V6.1/V6.2 is not supported with WMQ v6. For more details, please refer to
    XA Resiliency feature of TXSeries V6.1/V6.2 doesn't work with WMQ as RM.
  14. The use of the WebSphere MQ classes for JMS in EJBs and MDBs is fully supported. The WebSphere MQ base classes for Java are supported with restrictions - for more details see, Using WebSphere MQ Java Interfaces in J2EE/JEE Environments
  15. WebSphere MQ V6.0.2.4 or later is required.
  16. WebSphere MQ Explorer tooling is supported with Java 5.0.
  17. WebSphere MQ V6.0.2.5 or later is required.
  18. The use of SSL and other JSSE functionality is not supported.
  19. WebSphere MQ V6.0.2.6 or later is required.


Change History
Last updated: 30 April 2008
  • 27 July 2005: Changed Oracle 10g to Oracle 10g Release 1
  • 26 October 2005: Modifications to the format & minor clarifications.
  • 16 November 2005: Clarified Microsoft .NET Framework version support.
  • 1 December 2005: Clarified that Windows XP requires SP1 or later.
  • 6 March 2006: Added support for Citrix MPS V3.0.
  • 5 April 2006: Added note 6.
  • 2 May 2006: Added support for IBM SDK V5.0.
  • 27 June 2006: Added note 7.
  • 28 June 2006: Added Microsoft Windows Server 2003 R2 in Operating Systems.
  • 6 July 2006: Added support for Oracle 10g Release 2
  • 14 August 2006: Added Enterprise Edition to Microsoft Windows Server 2003 R2 (Standard Edition or Enterprise Edition).
  • 31 October 2006: Added support for Microsoft .NET Framework SDK V2.0.
  • 14 December 2006: Added support for Microsoft Visual C++ .NET 2005, Microsoft Visual C# .NET 2005, and Microsoft Visual C++ 2005.
  • 25 January 2007: Updated Microsoft Visual Studio 2003 and 2005 compiler sections.
  • 6 February 2007: Added support for IBM DB2 Universal Database V9.1 (JDBC/XA not supported).
  • 30 March 2007: Added notes 1 and 9 (WebSphere MQ V6.0.2.1 feature updates).
  • 18 April 2007: Added with SP1 or later in Operating Systems.
  • 19th June, 2007: Added Microsoft Vista support and renamed IBM DB2.
  • 3rd September, 2007: Added support for IBM 64-bit SDK for Windows Java 2 Technology Edition V5.0 (SR1 or above).
  • 22 November 2007: Added support for IBM WebSphere Application Server V6.
  • 18 December 2007: Added Micro Focus Net Express V5.0 (COBOL).
  • 10 March 2008: Added virtualization note.
  • 3 April 2008: Added support for TXSeries V6.1 and V6.2.
  • 30 April 2008: Clarified SSL support is not available with JDK 1.3.1.
  • 10 July 2008: In the Transaction Manager section added the IBM WebSphere Application Server V6.0.2 and V6.1 entries.
  • 10 October 2008: Added note 15.
  • 17 October 2008: Added support for Microsoft Visual Studio 2008.
  • 10 November 2008: Added support for IBM WebSphere Application Server, including the WebSphere Application Server client container, V7.0.
  • 13 November 2008: Added support for Microsoft Windows Embedded Point of Service 1.0.
  • 22 December 2008: Added the Cryptography Cards section.
  • 5 January 2009: Added support for Microsoft .NET Framework SDK V3.0 and V3.5.
  • 9 March 2009: Added note 16.
  • 13 March 1009: Added to note 6, WebSphere MQ Explorer tooling is only supported with IBM Java 1.4.2 or IBM Java 1.5.
  • 7 April 2009: Added support for IBM SDK for DesktopEE 6.5 M2
  • 7 April 2009: Added support for IBM Developer Kit for Windows, Java 2 Technology Edition V6.0.
  • 27 July 2009: Added support for IBM DB2 V9.5 for Linux, UNIX, and Windows.
  • 2 May 2012: Updating expiry date.
  • 6 May 2014: Updating expiry date.

Related information

WebSphere MQ Library
All WebSphere MQ system requirements
Recommended fixes

Original publication date

2005/6/27

Product Alias/Synonym

WMQ MQ

Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere MQ
Documentation

Software version:

6.0

Operating system(s):

Windows

Reference #:

7006266

Modified date:

2007-04-19

Translate my page

Machine Translation

Content navigation