IAM3: WebSphere Message Broker - Node for log4j

Downloadable files


IAM3 provides the ability to use the log4j logging framework from within your Message Broker flows.

Download Description

This SupportPac allows a message flow to log information using the log4j logging framework. This way it is possible to set a log level for each log message and any destination target that can be defined using log4j.

The target as well as the runtime log level can be configured independent from the flow in the log4j configuration file.

Possible Uses
Use this SupportPac if you need a more flexible log mechanism than the Trace node provides.

New in this Release
New in 1.2.2
• Support for IBM Integration Bus V10.0.
• ESQL initLog4j now only returns true if initialization was successful.
New in 1.2.1b
• Support for IBM Integration Bus v9.0
New in 1.2.1
• Improving performance when handling big messages.
• Rework on the XMLLF output style.
• LoggerName and LogLevel can be set by using LocalEnviroment.
• LocalEnvironment supported in LogText.
Fixed bugs in version 1.2.1:
• Node fails to log Environment and LocalEnvironment values correctly.

Author: Matthias Nieder, Global Business Services, IBM Germany
Category: 2
Released: 18Nov08
Last updated: 15Jul15
Current SupportPac Version: 1.2.2
»Please note that the version number shown in the right-hand pane is the version of the MQ or WBI product that this SupportPac applies to. The date is the last webpage refresh.

To view the complete portfolio of WebSphere MQ SupportPacs please visit the WebSphere MQ SupportPacs homepage.


This SupportPac requires:
• WebSphere Message Broker V6.1 or
• WebSphere Message Broker V7.0
• WebSphere Message Broker V8.0
• IBM Integration Bus V9.0
• IBM Integration Bus V10.0

WebSphere Message Broker V6.0 should also work.

Installation Instructions

To install this SupportPac:
1. Copy iam3.zip to a temporary directory.
2. Unzip the file and follow the instructions in the User’s guide IAM3.pdf.

If you encounter problems after upgrading the Message Broker Toolkit to a new version:
1. Look into $TOOLKIT_INSTALL_DIR\configuration\org.eclipse.update.
2. Save a version of the file platform.xml.
3. Edit the file platform.xml as follows:
Replace the line:
<site enabled="true" policy="USER-EXCLUDE" updateable="true" list="Log4jLoggingPlugin/" url="platform:/base/">
<site enabled="true" policy="USER-EXCLUDE" updateable="true" url="platform:/base/">
4) Restart the toolkit with the -clean option.

iam3.pdf US English 228498

Download package

Download RELEASE DATE LANGUAGE SIZE(Bytes) Download Options
iam3.zip 15 Jul 2015 US English 196606 HTTP

Technical support

Category 2 SupportPacs are provided in good faith and AS-IS. There is no warranty or further service implied or committed and any supplied sample code is not supported via IBM product service channels.

You may submit a question and return email address using the 'rate this page' below, but a response is not guaranteed.

Please read the license information contained within the zip file of this SupportPac to determine if you want to use it.

Cross reference information
Segment Product Component Platform Version Edition
Business Integration WebSphere Message Broker AIX, HP-UX, Linux, Solaris, Windows, z/OS 6.1, 7.0, 8.0

Document information

More support for:

IBM Integration Bus

Software version:

9.0, 10.0

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows, z/OS

Reference #:


Modified date:


Translate my page

Content navigation