IAM2: WebSphere Message Broker Toolkit – ESQL Code Coverage

Downloadable files


WebSphere Message Broker - ESQL Code Coverage

Download Description

This SupportPac consists of a Perl script that generates a code coverage analysis report. A user trace log file and a source code file are required as input resources. The generated report is a plain text file which shows a high level analysis of what percentage of the source code was executed, and also gives a details of which lines of code were executed, and which were not.

Possible Uses
Very useful for large projects to identify the code coverage of test cases, for example in a nightly build and test environment.

Skill Level Required
ESQL development with WebSphere Message Broker v6.0, v6.1, v7.0, v.8.0, v9.0 and v10.0.

New in this Release
• WebSphere Message Broker v8 support.

Authors: Torsten Schaefer, Matthias Kabala, Global Business Services, IBM Germany
Category: 2
Released: 20May08
Last Updated: 22Oct15
Current SupportPac Version: 1.0.5
»Please note that the version number shown in the right-hand pane is the version of the MQ or WBI product that this SupportPac applies to. The date is the last webpage refresh.

To view the complete portfolio of WebSphere MQ SupportPacs please visit the WebSphere MQ SupportPacs homepage.


Perl V5.8.6 or higher. A version of Perl is included with most UNIX and Linux installations, and with Mac OS X. On Windows, use ActivePerl.

Installation Instructions

Extract the zip file.

iam2.pdf US English 23152

Download package

Download RELEASE DATE LANGUAGE SIZE(Bytes) Download Options
iam2.zip 22 Oct 2015 US English 146188 HTTP

Technical support

Category 2 SupportPacs are provided in good faith and AS-IS. There is no warranty or further service implied or committed and any supplied sample code is not supported via IBM product service channels.

You may submit a question and return email address using the 'rate this page' below, but a response is not guaranteed.

Please read the license information contained within the zip file of this SupportPac to determine if you want to use it.

Cross reference information
Segment Product Component Platform Version Edition
Business Integration IBM Integration Bus 10.0, 9.0

Document information

More support for:

WebSphere Message Broker

Software version:

6.0, 6.1, 7.0, 8.0

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows, z/OS

Reference #:


Modified date:


Translate my page

Content navigation