IA9C: WebSphere Business Integration Message Broker - Get Environment Variables

Downloadable files


Abstract

SupportPac IA9C allows access to operating system, Java runtime and message broker runtime environment variables within a WBI MB message-flow.

Download Description

SupportPac IA9C allows access to operating system, Java runtime and message broker runtime environment variables within a WBI MB message-flow.

Possible Uses
The GetEnv node can be used to:
• Dynamically reference the runtime broker, message-flow, execution group and other names, within a message flow, with out having to modify ESQL code.
• Provide a level of abstraction and configurability to message flows by dynamically referencing operating system environment variables.
• Dynamically reference Java runtime properties, within a message flow, without having to modify ESQL code.

Skill Level Required
Users of the SupportPac should have a good understanding of WBI MB development and deployment operations.

New in this Release
• Updated for WebSphere Message Broker V8.

DETAILS
Author: Matthew Courtois, WebSphere Enablement Team, San Diego, USA
Category: 3
Date released: 15Dec05
Last updated: 03Apr13
Current version: 3.0
»Please note that the version number shown in the right-hand pane is the version of the MQ or WMB product that this SupportPac applies to. The date is the last webpage refresh.

To view the complete portfolio of WebSphere MQ SupportPacs please visit the WebSphere MQ SupportPacs homepage.

Prerequisites

The SupportPac requires WebSphere Message Broker V6 or later on one of the following platforms:
» AIX
» Solaris
» Linux
» HP-UX
» Windows ( XP, Server, Vista, 7)

Installation Instructions

To install the SupportPac:

Extract the IA9C.zip to a temporary location.

Runtime Installation for WMB v6.1, v7.0 and v8.0:
1. Stop the broker on which you will install the GetEnv node.
2. Create a directory if you haven't already got one for this purpose. Add the directory to the LILPATH by using the mqsichangebroker command.
3. Put IA9C/jpluginx/GetEnvNode.jar file in the directory.
4. Start the broker to implement the change and to ensure that the existence of the new file is detected.

CAUTION: Do not put the GetEnvNode.jar file in the WebSphere Message Broker installation directory, as it could be overwritten by the broker.

WMB v6.1 Toolkit Installation:
• Copy the IA9C\com.ibm.supportpacs.GetEnv directory to the <wmbtk_root>\WMBT610\plugins directory, where <wmbtk_root> is the root installation directory for your Message Broker Toolkit v6.1.

WMB v7.0 Toolkit Installation:
• Copy the IA9C\com.ibm.supportpacs.GetEnv_3.0.0.jar file to the <wmbtk_root>\WMBT700\plugins directory, where <wmbtk_root> is the root installation directory for your Message Broker Toolkit v7.0.

WMB v8.0 Toolkit Installation:
• Copy the IA9C\com.ibm.supportpacs.GetEnv_3.0.0.jar file to the <wmbtk_root>\WMBT8001\plugins directory, where <wmbtk_root> is the root installation directory for your Message Broker Toolkit v8.0.

URL LANGUAGE SIZE(Bytes)
ia9c.pdf US English 196019

Download package


Download RELEASE DATE LANGUAGE SIZE(Bytes) Download Options
ia9c.zip 26/04/2011 US English 286720 HTTP

Technical support

Category 3 WebSphere MQ (MQSeries) SupportPacs are supplied under the standard terms and conditions provided by the International Program License Agreement (IPLA) and thus, carry program defect service.

If you encounter what you believe to be a defect with the SupportPac you may request Program Services, by reporting the problem via the same defect reporting channel you use for the WebSphere MQ or WebSphere Business Integration product/s with which you are using the SupportPac. These products must themselves have service support.

Please read the license file that accompanies it, to determine if you want to use it. No proof of Entitlement or License Information is required to use this SupportPac.

This SupportPac has service support for as long as the WebSphere Message Broker V6 or later remains in service. Refer to the WebSphere product lifecycle pages for the relevant service information. It is only supported with MQ platforms which are themselves supported.

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere Message Broker
SupportPac

Software version:

6.1, 7.0, 8.0

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

4011189

Modified date:

2013-04-03

Translate my page

Machine Translation

Content navigation