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MustGather: Read first when collecting troubleshooting data for CICS products

 Technote (troubleshooting)
 
Problem(Abstract)
MustGather documents aid in problem determination and save time resolving problem management records (PMRs). These documents contain a list of the documentation you should gather so CICS Support can diagnose your specific problem. These documents also include diagnostic tips that will aid in diagnosing and solving problems.
 
Cause
Collecting MustGather data early, even before opening a PMR, helps IBM Support quickly determine if:
  • Symptoms match known problems (rediscovery).
  • There is a non-defect problem that can be identified and resolved.
  • There is a defect that identifies a workaround to reduce severity.
  • Locating root cause can speed development of a code fix.
 
Resolving the problem
Gather the following general information for every problem record:
  1. A complete description of the problem, including the following:
    • When did the problem first occur?
    • Is the problem a one time failure or reoccurring?
    • Was software or hardware maintenance applied?
    • Did the failure occur while doing a specific task?
    • Is the failure occurring in more than one address space?
  2. CICS product version, release, and maintenance level
  3. Operating system version, release, and maintenance level
  4. Related products version, and release levels
  5. A valid contact phone number and email address

Then gather component specific information after selecting a product:


CICS TS for z/OS       CICS TS for VSE/ESA    CICS Tools for z/OS    

CICS Tools for z/OS components

Click on the CICS Tool that you are experiencing the problem with. This will display all MustGather documents currently available for the product. Each MustGather document is for a specific type of problem and provides you with a listing of the documentation that the support team requires to diagnose the problem.
CICS Business Event Publisher for MQSeries
CICS Performance Analyzer for z/OS

 

 
Cross Reference information
Segment Product Component Platform Version Edition
Host Transaction ProcessingCICS Business Event Publisher for MQSeriesDocumentationz/OS1.2
Host Transaction ProcessingCICS Performance Analyzer z/OS1.4, 2.1
 
Product Alias/Synonym
CICSPA CICS PA CICS BEP CBEP BEP
 
 
 

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Document information
 Product categories:
 Software
 Host Transaction Processing
 Transaction Servers
 CICS Transaction Server
 Miscellaneous
 Operating system(s):
  z/OS
 Software version:
  2.3, 3.1, 3.2
 Reference #:
  1248702
 IBM Group:
 Software Group
 Modified date:
 2008-11-26

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