CICS Transaction Server for z/OS 3.1 detailed system requirements

Product documentation


Abstract

The tables in this document identify supported operating systems and the hardware and software requirements for CICS Transaction Server for z/OS (CICS TS) V3.1. There are also related CICS links at the bottom of this document under Related Information.

Content

CICS TS V3.1 Supported Operating Systems
CICS TS V3.1 Hardware Requirements
CICS TS V3.1 Software Requirements
CICS TS V3.1 Related Information


CICS TS V3.1 Supported Operating System

z/OS
  • z/OS V1.4 or later.


CICS TS V3.1 Hardware Requirements
z/OS
  • z/OS V1.4 (5694-A01), or later. Note that CICS will not initialize in an environment with a lower level of operating system installed.
  • The basic requirement is for a processor that supports the prerequisite operating system and has sufficient processor storage to meet the requirements of the operating system, CICS TS V3.1, the application programs, the access methods, and all other software being run. This includes the IBM zSeries 990.
  • Parallel Sysplex support
  • CICS support for data sharing can be used to access data in IMS databases, DB2 databases, VSAM datasets, CICS Temporary Storage, coupling facility data tables, or named counters.
  • If you want to exploit the WS-Security capability, which relies upon the z/OS Integrated Cryptographic Services Facility (ICSF), then appropriate zSeries cryptographic hardware is required. See below:

Here is a breakdown of the ICSF commands that are called from the WS-Security code, and what is required (according to the z/OS V1.4.0 ICSF System Programmer's Guide):

Encryption:

For S/390 G5 and G6 Enterprise Servers and zSeries 800 and 900 the Cryptographic Coprocessor Feature is required for the following functions:
Random number generator (CSNBRNG)
Multiple Clear Key Import (CSNBCKM)
Encipher (3DES) - (CSNBENC)
PKA Encrypt (CSNDPKE)

Encipher (AES) - (CSNBSYE) - For S/390 G5 and G6 Enterprise Servers and zSeries 800 and 900 the Cryptographic Coprocessor Feature is required.
- For zSeries 990 CP Assist for Cryptographic Functions is required.

Decryption:

Decipher (3DES) - (CSNBDEC) - For S/390 G5 and G6 Enterprise Servers and zSeries 800 and 900 the Cryptographic Coprocessor Feature is required.
Decipher (AES) - (CSNBSYD) - For S/390 G5 and G6 Enterprise Servers and zSeries 800 and 900 the Cryptographic Coprocessor Feature is required.
- For zSeries 990 CP Assist for Cryptographic Functions is required.
PKA Decrypt (CSNDPKD) - - For S/390 G5 and G6 Enterprise Servers and zSeries 800 and 900 the Cryptographic Coprocessor Feature is required.

Generating signatures:

One-Way Hash Generate (CSNBOWH) - For S/390 G5 and G6 Enterprise Servers and zSeries 800 and 900 the Cryptographic Coprocessor Feature is required.
- For zSeries 990 CP Assist for Cryptographic Functions is required.
PKA Key Token Build (CSNDPKB) - No special hardware requirements.
Digital Signature Generate (CSNDDSG) - For S/390 G5 and G6 Enterprise Servers and zSeries 800 and 900 the Cryptographic Coprocessor Feature is required.

Verifying Signatures:

Digital Signature Verify (CSNDDSV) - This service routes requests to the Cryptographic Coprocessor Feature or PCI X Cryptographic Coprocessor.
On the zSeries 990, if a PCI Cryptographic Accelerator is active, then commands will be routed there.


There are some notes in the z/OS V1.7 ICSF System Programmer's Guide, which give details about some of these commands that are called.

The following services are available when running on a z990, z890 or z9-109 without a PCI X Cryptographic Coprocessor or Crypto Express2 Coprocessor :
Digital Signature Verify (CSNDDSV) - This service requires a PCI Cryptographic Accelerator.
PKA Decrypt (CSNDPKD) - This service requires a PCI Cryptographic Accelerator.
PKA Encrypt (CSNDPKE) ZERO-PAD formatting only - This service requires a PCI Cryptographic Accelerator.
PKA Key Token Build (CSNDPKB)
Symmetric Key Decipher (CSNBSYD and CSNBSYD1) - This service requires CP Assist for Cryptographic Functions.
Symmetric Key Encipher (CSNBSYE and CSNBSYE1) - This service requires CP Assist for Cryptographic Functions.
  • Katakana Terminal Devices. Because CICS has to issue certain messages in mixed-case, the product is not supported with displays or terminal emulators that are restricted to the non-extended single-byte character set (SBCS) Katakana part of code page 930.



CICS TS V3.1 Software Requirements
Language Environment (LE)

  • The Language Environment (LE) library SCEERUN must be available to CICS during CICS initialization, by inclusion in either the STEPLIB concatenation or the LNKLIST.
Java™
  • For Java™ application programs, enterprise beans, or the Web Services Assistant, the IBM SDK for z/OS, Java 2 Technology Edition, featuring persistent reusable JVM technology, Version V1.4 (5655-I56). This must be at the V1.4.2 level. The IBM SDK for z/OS, Java 2 Technology Edition, V1.4, is available, at no charge, on tape or by download from:http://www.s390.ibm.com/java/
  • For developing Java programs (including enterprise beans) for use with CICS TS V3.1, the members of the WebSphere Studio family V5, and Rational Application Developer V6, are supported.
  • Note that IBM 64-bit SDK for z/OS, Java 2 Technology Edition, V1.4 (5655-M30), is not supported.

WS-Security
  • IBM XML toolkit for z/OS V1.9 is required. This is a no charge product (5655-J51). You can download the toolkit from the following site:
    http://www.ibm.com/servers/eserver/zseries/software/xml/
    • You must install version 1.9. Later versions do not work with Web Services Security support in CICS.
    • The toolkit is an MVS feature and should be installed in the SMP/E zone for MVS.
    • Specify a valid keyring on the KEYRING system initialization parameter.
    • Apply the PTFs for APARs PK65352 and PK97657 to CICS, which change the required version of the toolkit from V1.7 to V1.9.
    See the CICS TS V3.1 information center Software Requirements section for more details.
Application Servers

  • WebSphere Application Server V5.0 or later is necessary
  • For deployment of Enterprise Java Beans (EJB's). The component to be used is the Application Server Toolkit (ASTK) for Windows. Note that the Application Assembly Tool (AAT) is no longer supported. Note that the ASTK is also included in WebSphere Studio Enterprise Developer V5.1. A copy of this product is shipped with CICS TS V3.1 as a marketing promotion, and so can be used for this deployment: but note that, in this marketing promotion, it is unsupported. CICS TS V3.1 will interoperate with WebSphere Application Server (any platform) V5 and V6. This applies directly for customers using RMI/IIOP for interoperability, and with CICS Transaction Gateway V5.0 or later for those using JCA.
  • WebSphere Application Server V 5.0 or later is necessary
LDAP
  • JNDI support for enterprise beans can be provided by the LDAP server provided in SecureWay Security Server and licensed as part of the base z/OS operating system.

Databases
  • IMS Database Manager V8 (5655-C56)
    IMS Database Manager V9 (5655-J38), and later
  • DB2 Universal Database(UDB) Server for OS/390 V6.1 (5645-DB2)
    • For SQLJ/JDBC support, with PTF for APAR PQ84783
    • Does not support DB2 Group Attach
  • DB2 Universal Database Server for OS/390 V7.1 (5675-DB2)
  • DB2 Universal Database for z/OS V8.1 (5625-DB2), and later
JMS Provider
Tivoli Decision Support
Tivoli Business Systems Manager
CICS Universal Client
CICS Transaction Gateway
SMP/E
  • SMP/E for z/OS and OS/390 V3.1 or later.
Information Center
  • The Information Center is supported on:
    • Microsoft Windows 2000 Server, Advanced Server, Professional (32-bit)
    • Windows XP Professional (32-bit)
    • Linux Red Hat Enterprise V3.0 (AS), 32-bit
    • Linux SUSE Enterprise V8 and V9, 32-bit
    • AIX® V5.2 and V5.3, 32 bit
Server Installation only
  • z/OS V1.4, or later
  • Linux Red Hat Enterprise V3.0 for zSeries
  • Linux SUSE Enterprise V8 or V9 for zSeries
For Browsing the Information Center
  • A browser that supports HTML V4.0 and the Document Object Model (DOM) standard, Suitable browsers include:
    • For Windows: Internet Explorer V6.0, or later; Mozilla V1.7, or later
    • For AIX or Red Hat Linux; Mozilla V1.7, or later
    • For SUSE Linux: Mozilla V1.7, or later, Konqueror(SUSE Linux System Browser, in basic mode only). However, note that for accessibility purposes, screen readers may impose restrictions on browser choice.
    • PDF files shipped with the Information Center have been generated using Adobe Acrobat Distiller V6.0 at the Acrobat V6.0 (PDF 1.5) level. They can be read using Adobe Acrobat Reader V5.0, but Reader V6.0 is necessary if the accessibility features of Distiller V6.0 are required.
Supporting Levels of CICS Tools and Related Products
  • CICS Interdependency Analyzer for z/OS (CICS IA) V1.3, with PTF for APAR PQ95065, can be used with CICS TS V3.1. A further PTF later in 2005 will provide exploitation of new function.
  • CICS IA V1.1 and V1.2 do not run with CICS TS V3.1.
  • A future release of CICS Performance Analyzer for z/OS (CICS PA) will support CICS TS V3.1. CICS PA V1.3 will not support SMF 110 data from CICS TS V3.1.
  • CICS Performance Monitor (CICS PM) for z/OS V1.1 does not support CICS TS V3.1. CICS PM V1.2, with service applied, provides toleration support for CICS TS V3.1, at the CICS TS V2.3 level. There are no plans to exploit CICS TS V3.1 data.
  • IBM Tivoli OMEGAMON XE for CICS and IBM Tivoli OMEGAMON II for CICS with required service, will support CICS TS V3.1 from its general availability. Note that this support does not include exploitation of the new function of CICS TS V3.1.
  • CICS VSAM Recovery V3.2 or V3.3 provides recovery support for VSAM files processed by CICS TS V3.1. No PTF is required.
  • CICS Business Event Publisher for MQSeries V1.2, with service applied, can be used with CICS TS V3.1.
  • CICS Online Transmission Time Optimizer for z/OS V1.1 can be used with CICS TS V3.1. No PTF is required.
  • IBM Session Manager for z/OS V1.1 or V1.2 can be used with CICS TS V3.1. No PTF is required.
  • CICS VSAM Transparency for z/OS V1.1 can be used with CICS TS V3.1. No PTF is required.
  • CICS VSAM Copy for z/OS V1.1, with service applied, can be used with CICS TS V3.1.
  • CICS Batch Application Control for z/OS V1.1, with service applied, can be used with CICS TS V3.1.
  • MQSeries Integrator Agent for CICS Transaction Server V1.1 does not run with CICS TS V3.1.
  • Fault Analyzer for z/OS and OS/390 V3.1, with PTF UQ77156 for APAR PQ74048, or Fault Analyzer for z/OS V4.1, or Fault Analyzer for z/OS V5.1, can be used with CICS TS V3.1.
  • Debug Tool for z/OS V5.1, with PTF for APAR PQ94401, can be used with CICS TS V3.1.
Compatibility

CICS TS V3.1 Related Information


Detailed System Requirements for all CICS TS products

CICS Transaction Server V3.1 Information Center

CICS Transaction Server V3.1 Release Guide

Program Directory for CICS Transaction Server V3.1

Finding CICS Preventive Service Planning (PSP) Buckets

z/OS Consolidated Service Testing reports - quarterly reports with information on product level testing

Announcement Letter for CICS Transaction Server V3.1

CICS Support Page

CICS Transaction Server and CICS Tools compatibility with z/OS 1.13

Product Alias/Synonym

CICS/TS CICS TS CICS Transaction Server

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

CICS Transaction Server
Installation

Software version:

3.1

Operating system(s):

z/OS

Reference #:

7006364

Modified date:

2012-06-14

Translate my page

Machine Translation

Content navigation