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ANR4728E and ANR1776I UPDATE DATAMOVER failure messages

Troubleshooting


Problem

The UPDATE DATAMOVER command is used to update a data mover to an NAS device in order to perform ndmp backups. The command fails with the ANR4728E and ANR1776I messages.

Symptom

The Tivoli Storage Manager server activity log shows the following messages :

2013-01-22 12:24:32 ANR2017I Administrator ADMIN issued command: UPDATE DATAMOVER NASMACHINENAME pas=?***? (SESSION: 4752)
2013-01-22 12:24:32 ANR4728E Server connection to file server 192.168.10.11 failed. Please check the attributes of the file server specified during definition of the datamover. (SESSION: 4752)
2013-01-22 12:24:32 ANR1776I Data mover NASMACHINENAME has been updated, however a connection to the data mover failed. Please check the attributes of the file server specified in the update command. (SESSION: 4752)

Cause

The UPDATE DATAMOVER command requires the NAS userid and password, these are case sensitive.

Diagnosing The Problem

A Tivoli Storage Manager server trace (SPI) will show trace entries listed below::

========================TRACE EXTRACT=========================
01:15:44.130 [625717][admdmvr.c][1908][ConnectToDataMover]:Attempting NDMP connection to NAS datamover 192.168.10.11
01:15:44.131 [625717][ndmpspi.c][833][spiTrace]: Entering ndmpSessInit.
01:15:44.131 [625717][ndmpspi.c][869][spiTrace]: Allocated New NDMP Session descriptor 11b413c98 and Cmd descriptor 11b9e30b8.
01:15:44.132 [625717][ndmpspi.c][943][spiTrace]: Attempting to connect to NDMP filer 192.168.10.11 on port 10000 as user: NDMP_Admin.
01:15:44.134 [625717][../../unix/ndmpconn.c][396][spiTrace]: Begin polling ....
01:15:44.221 [625717][ndnotify.c][100][spiTrace]: Received NDMP_NOTIFY_CONNECTED message .
01:15:44.222 [625717][ndnotify.c][123][spiTrace]: CONNECT: Connection refused, Reason: Connection refused..
01:15:44.222 [625717][ndmpsdk.c][696][spiTraceDetail]: Exiting from ndmpProcessRequests rc = 0..
01:15:44.223 [625717][ndmpspi.c][985][spiTrace]: NDMP Connection Refused by NDMP Server.
01:15:44.223 [625717][ndmpspi.c][4109][spiTrace]: Entering ndmpSessTerm, handle: 11b413c98.
01:15:44.223 [625717][ndmpspi.c][4161][spiTrace]: Returning from ndmpSessTerm, handle: 11b413c98.
01:15:44.224 [625717][admdmvr.c][1973][ConnectToDataMover]:NDMP connection failed to NAS datamover 192.168.10.11, RC = 4
=================================================================

Resolving The Problem

It was observed that the password for the NAS userid used by Tivoli Storage Manager had expired on the NAS device.
Use the respective NAS commands on the NAS console to reset the NAS userid password. Then ensure that the correct userid and password are provided on the 'update datamover' command.

Note that the userid and password are case sensitive.

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21638648