IBM Support

How to manually add the 'Controller' shortcut link (plus "Consolidate my financial information") into Cognos Connection, when using Cognos BI

Troubleshooting


Problem

Administrator has installed IBM Cognos 8 BI to a dedicated BI-only server.
Administrator would like to add the links to Controller 8 in Cognos Connection, so that the users can launch the Controller 8 legacy 'Web client' from the link.

Symptom

When a user launches Cognos Connection (http://BI-SERVER/cognos8) there is no icon (menu item / Controller link) to launch Controller directly from the website.

In other words:
(1) There is no menu item called "Consolidate my financial information" with which to launch Controller (see below for picture of what they expected it to look like):


(2) There is also no menu item called 'Controller' (underneath 'Launch') from which to also launch Controller (see below for picture of what they expected it to look like):

Cause

By design:
  • a standard IBM Cognos 8 BI server will not have the 'Controller' connection enabled/visible
  • the Controller connection is enabled by installing the Controller 'Gateway Integration Enabler' to the BI server (or gateway server)
    • TIP: This software component enables the gateway to direct requests to the Report Server and IBM Cognos 8 Controller components.
    • It is selectable (during the Controller installation wizard) inside the section 'Gateway Components - Gateway Integration Enabler'

However, there are several scenarios where it is not possible to install the 'integration enabler' in the normal way:
  • Administrator is using a mixture of versions (for example Controller 8.5 and Cognos BI 8.4.1) which does not allow the installation to the same folder - see separate IBM Technote 1414473 for more information
  • Administrator would prefer to manually add the Controller link

Environment

This Technote specifically relates to the scenario where the customer is using:
  • Old version of Controller (for example 8.x)
  • IBM Cognos 8 BI installed on a dedicated (no Controller installed) application or gateway server.
For similar instructions when using more modern versions of Controller (with Cognos Analytics) see separate IBM Technote #0958909.

Resolving The Problem

For most customers, the link should be installed automatically as part of the Controller software installation wizard (see above).

However, if you wish to add the link manually then you should:

  • Install Cognos connection integration enabler to a separate 'test' folder
  • Copy the file '\webapps\p2pd\WEB-INF\services\controllerStudio.xml' from this 'test' folder to the same location within the 'production' Cognos 8 BI installation
  • Restart the Cognos 8 service
The Controller link points to the IIS virtual directory 'controller'. Therefore, if you have a 'distributed' (multi-server) installation, then make sure that there is a valid IIS redirect for this virtual directory.

Steps:

  1. Logon to any Windows system (for example a test desktop PC) as an administrator
  2. Locate the Controller installation media, and launch the Controller installation wizard (issetup.exe)
  3. In the 'Installation Location' section, choose a unique folder (for example 'C:\Program Files\cognos\c8.5_Gateway_Integration_Enabler')
  4. In the 'Component Selection' section, ensure that ALL components are selected (ticked)
  5. After the software has installed, open the folder <installation_location>\webapps\p2pd\WEB-INF\services\
  6. Copy the file 'controllerStudio.xml' to the Cognos 8 BI / gateway server
  7. If you wish to, you can now uninstall this temporary Controller software from your 'test' PC, using the Start Menu icon.
  8. Logon to the Cognos 8 BI / gateway server as an administrator
  9. Copy the file 'controllerStudio.xml' into the folder <installation_location>\webapps\p2pd\WEB-INF\services\
  10. Ensure that there are no users on the Cognos BI / Controller systems (short period of downtime)
  11. From the 'Start Menu', launch 'Cognos Configuration'
  12. Click the 'restart service' icon (or alternatively, simply reboot the entire server)
  13. Test
 

TIP: The 'Controller' link simply redirects the client device to the following website (on the Cognos 8 BI / gateway server): http://BI-SERVER/cognos8/controller.



Therefore, if the link does not work, then ensure that the IIS virtual directory 'Controller' is correctly configured on the gateway server, by performing the following steps:
  1. Logon to the BI/gateway server as an administrator
  2. Right-click on 'My Computer' and choose 'manage'
  3. Expand 'Services and Applications' - 'Internet Information Services' - 'Web Sites' - 'Default Web Site' - 'cognos8'
  4. Ensure that there is a virtual directory 'Controller' underneath 'cognos8'
  5. Right-click on 'Controller' and choose properties
  6. Check that this is set to 'A redirection to a URL', and that the value of this is pointing to the correct location.
  7. For example, if the Client Distribution Server (CDS) is located on the same server, then this would be '/cognos8/controllerbin/ccr.exe'. However, if the CDS is on a different server then it would be similar to 'http:/NEWSERVER/cognos8/controllerbin/ccr.exe'.

TIP: For more information on this topic, see separate IBM Technote #1345587.

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Historical Number

1020320

Document Information

Modified date:
10 July 2019

UID

swg21345546