IBM Support

Moving a Visual Studio.NET project under SourceSafe to ClearCase while retaining history

Technote (FAQ)


Question

How can I migrate a Microsoft® Visual Studio.NET (7.x and 8.x) project currently under source control within Microsoft Visual SourceSafe 6.0 to IBM® Rational® ClearCase®, while retaining history.

Answer

Here is the procedure to complete the migration of a Visual Studio.NET (7.x and 8.x) project (that's currently under source control in Visual SourceSafe 6.0) to ClearCase. This procedure will retain the project history after moving the project to ClearCase source control. The below instructions contain two phases that must be completed for a successful migration.




INSTRUCTIONS:


PHASE 1 of 2

1. Ensure that SourceSafe is the current source code control provider.

8.x (VS.NET 2005)

In VS.NET, click Tools > Options > Source Control > Plug-in Selection
Ensure that Microsoft Visual SourceSafe is the selected source code control plug-in.




7.x (VS.NET 2003)

Check to ensure that the ProviderRegKey data value within the Windows Registry is set to Microsoft Visual SourceSafe as the active source code control (SCC) provider.

a. Click Start > Run and type: regedit
b. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\SourceCodeControlProvider
c. Ensure the ProviderRegKey= Software\Microsoft\SourceSafe




2. Recursively checkout the project(s) to be migrated and the solution.

Note: At a minimum you should checkout the solution.sln and any project.*proj files.





3. Open VS.NET and open the solution.


4. Click File > Source Control > Change Source Control.


5. Individually select and then Unbind the solution and the project(s).



6. Recursively checkin the project(s) in Visual SourceSafe.



7. Close VS.NET




PHASE 2 of 2

1. Ensure that Rational ClearCase is the current source code control provider.

8.x (VS.NET 2005)

In VS.NET, click Tools > Options > Source Control > Plug-in Selection
Ensure that Rational ClearCase is the selected source code control plug-in.




7.x (VS.NET 2003)

Change the ProviderRegKey data value within the Windows Registry to point to IBM Rational ClearCase as the active source code control (SCC) provider.

a. Click Start > Run and type: regedit
b. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\SourceCodeControlProvider
c. Change the ProviderRegKey= Software\Atria\ClearCase




2. Export\import the solution and project(s) using the ClearCase utilities clearexport_ssafe and clearimport


3. Open VS.NET and open the solution ( File > Open Solution and browse to the solution.sln within your view/VOB context).


4. Click File > Source Control > Change Source Control.


5. Connect\Rebind the solution and the project(s).

8.x (VS.NET 2005)

For V@.NET 2005, you may not need to manually rebind. Simply open the project in VS.NET 2005, close VS.NET 2005, and then opened it again. Source code control with ClearCase should be functional.


7.x
(VS.NET 2003)




6. You will be prompted to checkout the .sln and .*proj files to complete the server binding change.





Once the binding is complete, the projects will be under ClearCase source code control with all of its previous history retained.


Related information

About Visual Studio.NET bindings and ClearCase
Disabling ClearCase and Visual Studio .NET integration
About Visual Studio Source Control Bindings messages

Document information

More support for: Rational ClearCase
Integrations: Visual Studio.NET

Software version: 7.0, 2003.06.15, 2003.06.16

Operating system(s): Windows

Reference #: 1222507

Modified date: 27 November 2008


Translate this page: