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IBM Tivoli Composite Application Manager for Transactions Internet Service Monitoring 7.4 Interim Fix 3 README Tivoli Composite Application Manager for Transactions 7.4.0.0 7.4.0.0-TIV-CAMIS-IF0003 Readme

Fix Readme


Abstract

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Content

Readme file for: 7.4.0.0-TIV-CAMIS-IF0003
Product/Component Release: 7.4.0.0
Update Name: 7.4.0.0-TIV-CAMIS-IF0003
Fix ID: 7.4.0.0-TIV-CAMIS-AIX-IF0003, 7.4.0.0-TIV-CAMIS-LINUX-IF0003, 7.4.0.0-TIV-CAMIS-SOLARIS-IF0003, 7.4.0.0-TIV-CAMIS-WINDOWS-IF0003, 7.4.0.0-TIV-CAMIS-MULTIPLATFORM-IF0003-AdministratorsGuide
Publication Date: 4 Feb 2014
Last modified date: 4 Feb 2014

Download location

To download this update, you must first login to IBM Fix Central. Once logged in, you may select from the individual download packages.
http://www.ibm.com/support/fixcentral/

Below is a list of components, platforms, and file names that apply to this Readme file.

Fix Download for AIX

Product/Component Name: Platform: Fix:
Tivoli Composite Application Manager for Transactions AIX
7.4.0.0-TIV-CAMIS-AIX-IF0003
Tivoli Composite Application Manager for Transactions AIX
7.4.0.0-TIV-CAMIS-MULTIPLATFORM-IF0003-AdministratorsGuide

Fix Download for Linux

Product/Component Name: Platform: Fix:
Tivoli Composite Application Manager for Transactions Linux
7.4.0.0-TIV-CAMIS-LINUX-IF0003
Tivoli Composite Application Manager for Transactions Linux
7.4.0.0-TIV-CAMIS-MULTIPLATFORM-IF0003-AdministratorsGuide

Fix Download for Solaris

Product/Component Name: Platform: Fix:
Tivoli Composite Application Manager for Transactions Solaris
7.4.0.0-TIV-CAMIS-SOLARIS-IF0003
Tivoli Composite Application Manager for Transactions Solaris
7.4.0.0-TIV-CAMIS-MULTIPLATFORM-IF0003-AdministratorsGuide

Fix Download for Windows

Product/Component Name: Platform: Fix:
Tivoli Composite Application Manager for Transactions Windows
7.4.0.0-TIV-CAMIS-WINDOWS-IF0003
Tivoli Composite Application Manager for Transactions Windows
7.4.0.0-TIV-CAMIS-MULTIPLATFORM-IF0003-AdministratorsGuide

Prerequisites and co-requisites

This upgrade for ITCAM for Transactions Internet Service Monitoring may be applied to the following base versions.

  • 7.4.0.0
Note: Supported base versions include interim fixes applied to any of the above release levels.

For up-to-date ITCAM for Transactions v7.4 software prerequisites, please visit:
Prerequisites for ITCAM for Transactions V7.4

For additional download packages or ITM support information, visit the ITM support portal at:
http://www.ibm.com/support/entry/portal/Overview/Software/Tivoli/Tivoli_Monitoring_V6

Known issues

Non APAR Defect 13042 - ISM agent doesn't start after upgrading Windows Box

Problem Description
The Windows ISM agent is stopped after an upgrade.
Root cause
The installer does not support changes to define old and new agent registry keys.
Workaround
Reconfigure the ISM agent after the upgrade to resolve the problem.

Non APAR Defect 10767 - ISM support file upgrades overwrites ismconfig.props

Problem Description
ISM support files upgrades overwrite ismconfig.props. Note: ISM monitor props files are NOT overwritten.
Root cause
The installer does not support not overwriting ismconfig.props.
Workaround
Backup the ismconfig.props file before performing an upgrade of ISM support.

Known limitations

Change of Summarized Data

Problem Description
After upgrading earlier versions of the ISM application, summarized data may not be visible, since the summarization behaviour has changed. This issue can be resolved by re-summarizing your existing detailed data. Please refer to this technote for more information.

Remote Deployment to Windows Running MTEMS

Problem Description
Attempting to remotely deploy the ISM agent to a Windows machine actively running the Manage Tivoli Enterprise Monitoring Services (MTEMS) program fails. Before remote deploying, please close the MTEMS program on the target machine.

SOAP Monitor Does Not Support Nested Arrays or multiRef Values

Problem Description
The SOAP monitor is unable to handle parameters containing nested (two or more dimension) arrays or those that are referenced externally in the 'multiRef' style.

Installation information

For AIX, if upgrading from an ISM 6.0.1 release, you must uninstall the product and perform a new install. This does not apply for other ISM 6 releases. For more information, refer to the following support document:
http://www-01.ibm.com/support/docview.wss?uid=swg21321186

For Linux 64-bit, if upgrading from the original ISM 7.1.0.0 release with no fix packs applied, you must uninstall the 7.1.0.0 ISM component and perform a new install. This does not apply to other releases. For more detailed information, refer to the following support document:
http://www-01.ibm.com/support/docview.wss?uid=swg21330976

For Windows installation, if you encounter the message "Another version of this product is already installed" follow the instructions in the following support document to diagnose and resolve the problem. Note that although this technote refers to ITM, the diagnosing and resolving steps are applicable to ITCAM for Transactions Internet Service Monitoring.
http://www-01.ibm.com/support/docview.wss?uid=swg21587068

Prior to installation

The update installer should perform the following steps for you automatically. You can, if necessary, perform them manually.

  1. Stop ITM agents and infrastructure (including TEMS and TEPS).
  2. Ensure the Databridge and Monitors have stopped.

1. Stop ITM agents and infrastructure (including TEMS and TEPS):
The ITM agents and infrastructure only need to be stopped when either the application support packages are being installed or ISM is being installed on the ITM machine. If ISM is being installed on a machine that does not contain any ITM infrastructure, the ITM infrastructure does not need to be stopped.

Use the Manage Tivoli Enterprise Monitoring Services (MTEMS) dialog or the command line tools (`ITM\bin\tacmd` or `ITM/bin/itmcmd`) to stop any running ITM agents or infrastructure (including TEMS and TEPS).

On Windows systems, you can start the MTEMS application from your Start menu or by running `ITM\InstallITM\kinconfg.exe`. Alternatively, if you have installed ITM, use the command `ITM\bin\tacmd stopAgent <type>`.

On UNIX systems, you can run MTEMS using the `ITM/bin/itmcmd manage` command. Alternatively, use the commands `ITM/bin/itmcmd agent stop <type>` and `ITM/bin/itmcmd server stop <TEMS name>`.

2. Ensure the Databridge and Monitors have stopped:
When the KISAgent is stopped, it automatically signals for the monitors and databridge to be shutdown. If this does not occur or has been disabled by configuration changes, you may need to perform this step manually.

On Windows systems use the Windows Services dialog to look for any 'NCO * Internet Service Monitor' services. To stop the databrige and monitors ensure that each of these 'NCO *' services are stopped.

On UNIX systems run `ps -ef |grep nco_m_` and issue a `kill <pid>` command for each entry shown. If the databridge or monitors were heavily loaded, they may take some time to shutdown. You may also use `kill -9 <pid>` to immediately stop the databridge or monitors, but this may result in loss or corruption of data being processed.

Installing

This maintenance package is applied directly to the Tivoli Enterprise Management Agent (TEMA). In addition, apply application support from this interim fix to the following ITM components:

  • - Tivoli Enterprise Management Servers (TEMS), including any remote or failover TEMS configurations
  • - Tivoli Enterprise Portal Server (TEPS)
  • - Tivoli Enterprise Portal (TEP), including any locally installed desktop TEP clients

On Windows systems, extract the files from the archive and double-click WINDOWS\setup.exe. Follow the prompts to install the update.

On UNIX systems, extract the installer from the archive using the tar -xvf <filename.tar> command. Then, execute the installer using the ./install.sh command. Follow the prompts to install the update.

It is also possible to deploy this interim fix remotely using ITM TEMS depot and tacmd AddBundles command. For more information, please refer to the ITCAM for Transactions v7.4.0.0 Installation and Configuration Guide, available here:
http://publib.boulder.ibm.com/infocenter/tivihelp/v24r1/topic/com.ibm.itcamt.doc_7.4.0.0/rt/Install_Guide/remotedeploy.html

Installing application support for TEPS/TEMS
For each monitoring agent installed, you must install agent-specific application support on IBM Tivoli Monitoring components. You can choose to install application support on all components at one time, or you can install the application support on components separately. If installing components separately, the following order is recommended:

  1. Tivoli Enterprise Monitoring Server
  2. Tivoli Enterprise Portal Server
  3. Tivoli Enterprise Portal Desktop Client
  4. Tivoli Enterprise Portal Server Browser client (for Linux and UNIX Only)
The procedure for installing agent-specific application support on the components is similar to installing the monitoring agent. The main difference is to select the application support components required.

Note: When installing application support any ITM components on the current machine will be automatically stopped, including any TEMS or TEPS. Follow the Starting and stopping servers and agents guide to manually stop ITM agents and infrastructure. You should warn other users before beginning the installation.

For step by step application support installation information refer to the documentation:
Installing Internet Service Monitoring on Windows systems
Installing on Linux or UNIX systems

Performing the necessary tasks after installation

A successful installation modifies the ISM version to 7.4.0.0. Ensure that the Version of Internet Service Monitoring in the MTEMS is '07.40.00.03'.

On Windows the installation logs are written to the following directory:
ITM\InstallITM\

On Unix the installation logs are written to the following directory:
ITM/logs/

Troubleshooting installation problems from the Support site

For more detailed information, refer to the Installation and Configuration Guide:
http://publib.boulder.ibm.com/infocenter/tivihelp/v24r1/topic/com.ibm.itcamt.doc_7.4.0.0/ism/dita/ag/topic/ISM_install_chapter.html

Uninstalling if necessary

This maintenance package cannot be rolled back.

On Windows, you must run the following command prior to uninstalling the product to remove the Windows Services created during the install:
ITM\TMAITM6\ism\platform\win32\bin\preuninstall.cmd
The product may then be removed using the Control Panel's Add/Remove Programs.

On UNIX,the product may be removed using the script:
ITM/bin/uninstall.sh

For detailed instructions, please refer to the ITCAM for Transactions v7.4.0.0 Installation and Configuration Guide, available here:
http://publib.boulder.ibm.com/infocenter/tivihelp/v24r1/topic/com.ibm.itcamt.doc_7.4.0.0/ism/dita/ag/topic/ISM_uninstall_chapter.html

Additional information

The Secure Hash Algorithm 1 (SHA1) checksum of the images are as follows:
7.4.0.0-TIV-CAMIS-AIX-IF0003.tar 4a0f97fdbea8e98139384a24ea3df93cfb40fb2f
7.4.0.0-TIV-CAMIS-LINUX-IF0003.tar 38fc18058492fdc95d01fa4aac0442c8d5f369d3
7.4.0.0-TIV-CAMIS-Multiplatform-IF0003-AdministratorsGuide.pdf e769c2bf7933f0c78baf8d8496654e91fc0a0c47
7.4.0.0-TIV-CAMIS-SOLARIS-IF0003.tar d8a3130e5356195a8735f801c79693bdfe9cf312
7.4.0.0-TIV-CAMIS-WINDOWS-IF0003.zip 1984abc21213ea44cba2d05ce9aceb81d48b0ecf

New Features

The following new features are included in ITCAM for Transactions Internet Service Monitoring 7.4 Interim Fix 3:

  • Multi user ISM configuration - RFE 13434 - Multi user ISM configuration.

List of fixes

A) APAR Content:

IV44842 ISM monitors such as HTTPS and SOAP may crash on AIX
IV46127 HTTP and HTTPS Core dumps.
IV46773 Invalid data passed into the KISAgent can cause a core dump
IV46786 SOAP monitor can create duplicate namespaces in SOAP messages
IV47366 ismconfig is unable to connect to ITM using secure ports
IV49848 NTP monitor returns incorrect offset values
IV49869 Large cookies can cause TRANSX ISM monitor to crash with core
IV50219 ISM NCO__M_ may produce core file when ISM agent is stopped, if monitor is too slow to stop
IV52160 Failure retests do not get executed on the SIP monitor
IV52162 ISM SIP monitor can crash at the end of a test
IV53691 NTLM doesn't work with Long DomainName host combos

From superseded fixes:

N/A
B) Additional Non APAR Defects:

19176 improper message for Resync Agent - Resyncing an this agent will cause locally stored profiles to be removed
18874 ismconfig cli failed to copy profile
19744 the later ismconfig gui overwrites the previous gui's the same named profile under specific steps
19745 the later ismconfig gui can not display the previous gui created element for the same profile under specific steps
19769 The profile still exist after cancelling copy profile.
19771 The profile still exist after cancelling creating profile
19901 Failure to delete and copy ISM profiles on ISM Configuration GUI
20061 The parameters and Regexp data lost in the transx http step after reopen the ISM GUI.

From superseded fixes:

N/A
C) Enhancements

19790 Add new CLIConfig command to bulk unlock profiles
From superseded fixes:

N/A

Document change history


Version Date Description of change
1.0 31 Jan 2014 Initial Version
1.1 4 Feb 2014 Added Administrators Guide


















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Document Information

Modified date:
04 February 2014

UID

isg400001744