IBM Support

Policy Agent repetitively cancelled by TCPIP

Troubleshooting


Problem

The Policy Agent (PAGENT) job starts normally. However, after 5 minutes, the TCPIP stack cancels the job, then restarts it. This repeats every 5 minutes.

Cause

The PAGENT job is listed in the AUTOLOG section of the TCPIP profile. PORT statements are defined to reserve the two PolicyPerfMonitorForSDR ports for the PAGENT job. Since only one of these is used by the server as a listen socket, the AUTOLOG function detects that the other port does not have an active listen and is forcing a recycle of the job.

Resolving The Problem

Follow these steps to prevent the problem:

  1. Verify that PolicyPerfMonitorForSDR has been configured for the Policy Agent. If that is not being used, remove the associated PORT statements (or at least, do not associate them with the Policy Agent's address space name).

  2. Verify that the ports being reserved match those coded in the /etc/services file for pagentQosListener and pagentQosCollector (normally 1700 and 1701, respectively).

  3. The PORT 1701 TCP statement (or whatever port was configured for pagentQosCollector) should have the NOAUTOLOG keyword coded. This will prevent the AUTOLOG process from cancelling PAGENT when there is not a listen socket open for that port (which is the normal and expected state).

[{"Product":{"code":"SSSN3L","label":"z\/OS Communications Server"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"All","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"1.6;1.7;1.8;1.9;1.10;1.11;1.12;1.13;2.1;2.2;2.3","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Product Synonym

TCP/IP TCP CS390 CS/390

Document Information

Modified date:
15 June 2018

UID

swg21188689