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Indexing the History table for ClearQuest

Technote (FAQ)


Question

How can I index the History table to help improve performance in IBM® Rational® ClearQuest®?

Cause

When databases become large, performance can drop for various actions.

Prior to ClearQuest 7.0.0.0, the History table is not indexed by default when creating databases. The queries run against that table can return results in a linear fashion, incrementally slowing the database over time as the size increases.


Answer

If the ClearQuest databases were created with software versions prior to 7.0.0.0, these indexes likely do not exist. To potentially increase the performance on databases, apply an index to the History table. The following is an example of SQL code used to create an index for each. This can be done with PDSQL or the vendor command line tools.


create index history_entity_idx on history (entitydef_id, entity_dbid);


This activity is available for IBM DB2®, Oracle, and Microsoft® SQL Server™. For more information on creating indexes for the back end databases, refer to your database administrator (DBA).



BACKING UP FILES

Always make new database back-ups of your schema repository and user databases prior to making schema changes and performing database upgrades. Failure to create back-up copies can limit your ability to recover from a an upgrade failure, design change issues or other unforeseen failures.

Related information

How to index the Attachments tables for ClearQuest

Document information

More support for: Rational ClearQuest
Database Configuration/Connectivity - Non vendor specific

Software version: 7.0, 7.0.0.1, 7.0.0.2, 7.0.0.3, 7.0.0.4, 7.0.1, 7.0.1.1, 7.0.1.2, 7.0.1.3, 7.1, 2003.06.00, 2003.06.13, 2003.06.14, 2003.06.15, 2003.06.16

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: 1127710

Modified date: 28 January 2009