IBM Support

Server upgrade to V6 or V7 hangs after choosing language

Troubleshooting


Problem

A Tivoli Storage Manager server is upgraded to V6 via console mode. The installation process hangs with the following message : "Preparing CONSOLE Mode Installation"

Symptom

The installation is run with the root user ID in console mode using the following command :
./install.bin -i console

The install starts, the language is selected (2 - English), and then the message "Preparing CONSOLE Mode Installation..." is logged and no further message. For example :

# ./install.bin -i console
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
Launching installer...
=======================================================================
Choose Locale...
----------------
1- Deutsch
->2- English
3- Espa ol
4- Fran ais
5- Italiano
6- Portugu s (Brasil)
CHOOSE LOCALE BY NUMBER: 2
=======================================================================
Tivoli Storage Manager (created with InstallAnywhere)
-----------------------------------------------------------------------
Preparing CONSOLE Mode Installation...

Cause

The AIX system is incorrectly configured for DNS resolution.

Diagnosing The Problem

In this case, the installation actually does not hang but is slow to resolve the host name because of the misconfigured DNS. The installation process eventually continued to run after one hour.
To confirm the cause of the problem, verify that other processes such as telnet or putty login are also slow to connect. Verify the contents of the /etc/netsvc.conf file. For example :

hosts=local, bind

This entry indicates that a DNS is used.

Resolving The Problem

Correct the misconfigured name resolution in /etc/hosts, or in the /etc/netsvc.conf or other network-related configuration files. Use the AIX "nslookup <hostname>" command to confirm the proper configuration. Retry the Tivoli Storage Manager server upgrade after the AIX name resolution is corrected.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21669150