Application fails when 'America/Chicago' time zone is used in settings.xml file

Technote (FAQ)


Question

In IBM® Workplace™ Collaborative Learning 2.7, the default preference value of "America/New_York" in the settings.xml "time zone" field works. The value of the timezone="CST" field also works. However, when the settings.xml timezone field is set to "America/Chicago", the Learning application fails.

The following types of failure occur:

-- The following error message displays when trying to access Learning Management portlets such as the Offerings Catalog, Manage Resources, and Manage Reports:

    "The application is currently not functioning."
-- Learning Management portlets such as Skills Management, Career Development, and Enrollments and Invitations see nothing but a blank screen and the title.

-- Various error messages display in the My Learning portlets such as the following in the My Schedule portlet:
    "???WSWS3422E: Error: Cannot instantiate com.ibm.wkplc.learning.lms.service.webservice.ScheduledActivityAPIService.???"

Cause

An array of time zones is hard-coded into the Learning application. This array is used to validate the time zone entry in the settings.xml file. "CST" is present in this array but "America/Chicago" is not. As a result, "America/Chicago" is not considered a valid time zone entry.

Answer

This issue was reported to Quality Engineering as SPR# MBAM7B4SCB and is expected to be fixed in a future Workplace Learning release (2.7.0.1c). Until then, the recommended workaround is to use the value, "CST", instead of "America/Chicago".


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Document information


More support for:

Lotus End of Support Products
Workplace Collaborative Learning

Software version:

2.7

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

1294456

Modified date:

2008-04-30

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