IBM Support

SQL30081N when creating ODBC data source for TDW

Troubleshooting


Problem

Using the DB2 Database Assistant to create an ODBC source, the remote DB2 instance cannot be discovered/contacted. The following error is seen: The search for databases on the network failed.

Cause

Entire error message is:

SQL30081N A communication error has been detected. Communication protocol being used: "TCP/IP". ....... Protocol specific error code(s): "10060", "*", "*". SQLSTATE=08001

The remote instance hasn't been setup to listen for TCP/IP connections.

Resolving The Problem

<SVCENAME> in the dbm cfg has to be set to an open port and db2comm needs to be set to tcpip in the db2 registry. On the remote DB2 server machine issue the following commands:

db2 update dbm cfg using <SVCENAME> 50002 (or any other open port)
db2set -all
db2set db2comm=tcpip
db2stop force
db2start

Retry the DB2 database discovery/ODBC source creation.

[{"Product":{"code":"SS9PG5","label":"Tivoli Data Warehouse"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF025","label":"Platform Independent"},{"code":"PF033","label":"Windows"}],"Version":"2.2.2;2.2.3","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
17 June 2018

UID

swg21177166