Rational RequisitePro, version 7.1.1.3 (7.1.1 Fix Pack 3)

Downloadable files


Abstract

This document provides download and installation information for IBM® Rational® RequisitePro®, version 7.1.1.3 (7.1.1 Fix Pack 3).

Download Description

This fix pack is an update for Rational RequisitePro version 7.1.1.

Authorized Problem Analysis Reports (APARs) fixed in this release

This fix pack is cumulative. It includes all fixes from the previous fix packs for version 7.1.1. For information on APARs fixed in this release, see

Fixes in Rational RequisitePro version 7.1 releases.



To search for information on APARs, see the Web site: Rational Brand Support Troubleshooting.

Prerequisites

Rational RequisitePro version 7.1.1, 7.1.1.1, or 7.1.1.2

System requirements

For information about the hardware and software requirements for Rational RequisitePro, see the system requirements document.

For additional details, see the following Rational Support techdocs:


Supported languages and globalization
For information about supported languages, translation, and multicultural support for Rational RequisitePro, see Supported languages and globalization at the Rational RequisitePro information center.

Compatibility information

Compatibility issues with earlier versions:
This version of Rational RequisitePro can only be installed on a computer with the same version or a compatible version of other Rational products. When you upgrade Rational RequisitePro, you must upgrade other Rational products on your computer to the same version or a compatible version. For more information, see Rational Software Development Platform - Team versions 7.0.2 and 7.1 or contact Rational Support.
When accessing Rational RequisitePro projects from different computers on your network, it is possible to access version 7.1.x and 7.1.0.x projects with 7.1.1.3 clients. It is also possible to access version 7.1.1.3 projects with 7.1.x and 7.1.0.x clients.
To determine the version of the Rational products that are installed on your system, you can open IBM Installation Manager and click File > View Installed Packages.
The integration of Rational RequisitePro 7.1.1.3 with Rational Requirements Composer requires the installation of Rational Requirements Composer version 2.0.0.1 or later.

Installation Instructions

To upgrade to 7.1.1.3, download the update repository, extract it to a local server (creating a local repository), add that repository to Installation Manager on computers on your network, and use the Update feature to perform the installation. See instructions below.


Before beginning the upgrade, close Rational RequisitePro. If you are upgrading an installation with the Web components (RequisiteWeb), perform the following tasks:
  • Use your Windows Computer Management to stop the following services:
    • IBM HTTP Server 6.1 - RationalSDLC
    • IBM WebSphere Application Server V6.1 - RWP ReqWeb Servlet
  • Copy the catalog.txt file and store it elsewhere in your file system. By default, this file is located here:
    C:\Program Files\IBM\RationalSDLC\RequisitePro\ReqWeb\projects
  • If you previously specified an alternate installation location, copy the config.txt file and store it elsewhere in your file system. By default, this file is located here:
    C:\Program Files\IBM\RationalSDLC\profiles\profile2\installedApps\ DefaultNode\ReqWeb.ear\ReqWeb.war\WEB-INF\classes\
  • If you previously customized the Rational Web Platform for RequisiteWeb, as described in Configuring the IBM Rational Web Platform, make copies of the httpd.conf, ssl.conf files, and any other files you modified.

After you finish upgrading the RequisiteWeb installation, restore your copy of the catalog.txt and other backup files to the directories in which they were previously located.

Downloading the update repository and updating locally

  1. Download the repository zip file from the download package table in this document.

  2. Extract files to a directory on a local server that you want to use as the update repository.

  3. On each computer that has Rational RequisitePro installed, start the IBM Installation Manager by selecting Start > All Programs > IBM Installation Manager > IBM Installation Manager.

  4. In Installation Manager, click File > Preferences and click Add Repository. Enter the path to the local update repository and click OK. Click OK to close the Preferences window.

  5. Click Update. The Installation Manager checks for updates. If a new version of Installation Manager is available, you must install it before you can continue the Rational RequisitePro installation. Click Yes at prompt to update Installation Manager. If your Installation Manager is current, go to step 7.

  6. Click OK at the prompt to restart Installation Manager. Click Update.

  7. On the Update Packages page, select the package group IBM Rational SDLC and click Next.

  8. Select the fix pack release and click Next.

  9. If prompted, accept the license agreement and click Next.

  10. If prompted, select features you want to install and click Next.

  11. At the Review summary information page, click Update.

  12. When the update completes and you are informed that packages were installed successfully, click Finish to close the Update Packages windows.

  13. Close the IBM Installation Manager.


    See the article Using IBM Installation Manager for Enterprise Deployment and the related Installation Manager documentation or contact Support for assistance.

    For information on deploying Rational RequisitePro in an enterprise environment, see the IBM Installation Manager Enterprise articles.

Download package

Access the FTP site in the table below, and follow the instructions above in "Downloading the update repository and updating locally".


Download RELEASE DATE LANGUAGE SIZE(Bytes) Download Options
7.1.1.3-RATL-RRP-WIN-FP03.zip 8/18/2010 English 247707957 FTP

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational RequisitePro
Installation

Software version:

7.1.1.3

Operating system(s):

Windows

Reference #:

4027607

Modified date:

2010-12-06

Translate my page

Machine Translation

Content navigation