IBM Explorer for z/OS

User's Guide

Version 3 Release 0
IBM Explorer for z/OS

User's Guide

Version 3 Release 0
Contents

Tables .................................................................. v

IBM Explorer for z/OS User's Guide ...... vii
Who should read this book ................. vii

Chapter 1. Overview of IBM Explorer for z/OS .............................................. 1

Chapter 2. Configuring system connections .................................................. 3
Defining connection credentials .......... 3
Managing SSL security and certificates 4
Configuring a z/OS FTP system connection 5
Configuring a z/OSMF system connection 7

Chapter 3. Perspectives ................. 11
The z/OS perspective .................. 11
The Resource perspective .................. 12
The Remote System Explorer perspective 12

Chapter 4. Tasks .................. 15
Accessing resources on local and remote systems .... 15
Creating local JCL files ........ 15
Using the IBM z/OS Management Facility ........................................... 16
  Configuring a z/OSMF system connection 16
  Viewing the output of an active job 18
  Deleting or cancelling an active job 18
Working with data sets .................. 19
  Creating a new data set .................. 19
  Creating a new data set member 21
Data set actions .................. 21
Editing data sets .................. 23
Submitting a batch job .................. 26
Updating and installing software .......... 27
  Using the composite update site 27
  Adding a new software update site 28
Checking for, and installing, software updates 29
Enabling automatic updates ........ 30
Removing an existing software update site 31
Removing an installed software plug-in 32
Reverting to a previous installation configuration 33
Importing a list of software update sites 34
Exporting a list of software update sites 35
Select or deselect software sites to check for available software 36

Working with system connections .......... 37
Configuring a z/OS FTP system connection 37
Configuring a proxy server .................. 39
Configuring a z/OSMF system connection 40
Defining connection credentials .................. 41
Connecting to a system that is already defined 42
Connecting automatically at startup 44
Using shared connections .................. 46
Updating a system connection .................. 47
Exporting connections ........ 47
Removing a default setting from a category or connection ........ 48
Deleting a system connection .................. 49
Disconnecting from a system .................. 50
Working with z/OS UNIX files .................. 50
  Changing z/OS UNIX file and directory permissions .................. 50
  Creating a new z/OS UNIX file .................. 51
  Creating a new z/OS UNIX directory .................. 51
  Editing z/OS UNIX files .................. 52

Chapter 5. z/OS views ................. 55
The Console view .................. 55
The Data Sets view .................. 55
The Error Log view .................. 56
The Host Connections view .................. 58
The Jobs view .................. 59
The z/OS Jobs view .................. 60
The z/OS UNIX Files view .................. 61
The Properties view .................. 62
Shortcut keys .................. 62

Chapter 6. How to provide feedback ........ 65

Appendix. Accessibility features for z/OS Explorer .................. 67

Notices ........................................... 69
Copyright license .................. 72
Trademark acknowledgments .................. 72

Index ........................................... 75

Index ........................................... 77

© Copyright IBM Corp. 2008, 2016
## Tables

1. Data set types and actions .......................... 22  
2. Edit menu actions ..................................... 24  
3. View context menu actions ........................... 25  
4. Edit menu actions ..................................... 52  
5. View context menu actions ........................... 53  
6. Console icons and descriptions ........................ 55  
7. Data set types and icons ............................. 56  
8. Job icons .............................................. 60  
9. Shortcut key combinations ............................ 62
IBM Explorer for z/OS User's Guide

This document discusses the non-RSE usage of IBM® Explorer for z/OS® (z/OS Explorer). It describes in detail all of non-RSE perspectives, views, and tasks. For RSE usage in z/OS Explorer, see Generic RSE User’s Guide (SC27-8432) and RSE for z/OS User’s Guide (SC27-8433).

The following names are used in this manual:
- *IBM Explorer for z/OS* is called *z/OS Explorer*.
- *Remote System Explorer* is called *RSE*.
- *z/OS UNIX System Services* is called *z/OS UNIX*.
- *IBM Developer for z Systems™* (previously known as Rational® Developer for z Systems) is called *IDz*.
- *Application Delivery Foundation for z Systems* (previously known as Problem Determination Tools and Rational Developer for z Systems) is called *ADFz*.

Who should read this book

This document is intended for developers and system programmers who are using any of the products in the IBM Explorer for z/OS family. The z/OS Explorer provides access to basic z/OS resources and functions. z/OS Explorer also provides a workbench that can be used to install additional compatible Eclipse-based products to provide a powerful platform to access z/OS subsystems and develop and debug z/OS applications.

This document describes perspectives, views, and steps to complete different non-RSE tasks in IBM Explorer for z/OS.
Chapter 1. Overview of IBM Explorer for z/OS

The IBM Explorer for z/OS (z/OS Explorer) provides a framework to manage your system connections, your z/OS artifacts, and projects and resources.

z/OS Explorer is an Eclipse-based integration platform for z/OS users. It enables the integration of a wide variety of solutions using IBM, vendors, or customer plug-ins. z/OS Explorer is extendable by using the IBM repository of compatible products to fulfill each user's roles and responsibilities. For example, z/OS Explorer, powered by IBM product plug-ins from the repository can provide a single workbench with the ability to develop, and test CICS®, DB2®, WebSphere® MQ, IMS™, and batch applications and manage related subsystems.

IBM Explorer for z/OS Aqua delivers extensible workstation connectivity to key z/OS functions with the following features:

Rich views and functions
Give simple and secure access to z/OS data sets, IBM zSeries File System (zFS) files, and Job Entry Subsystem (JES) jobs and output. With the views and functions, you can create new members, edit and submit JCL, review job output—even for active jobs with a z/OMSF connection. Use the APIs to enhance your own plug-ins.

Connection framework
Provides consistent configuration, change, and sharing of all system connections, including to FTP and z/OSMF. Plug-in developers can add new connection types using the z/OS Explorer SDK. Benefit from single sign-on, SSL, password phrases, proxy servers, and more.

Delivery and deployment options
z/OS Explorer is available as an Eclipse-based Rich Client Platform (RCP) executable, and a plug-in for inclusion in compatible RCPs. The z/OS Explorer plug-in is also prepackaged with CICS Explorer®, IBM Developer for z Systems (previously known as Rational Developer for z Systems), and IMS Enterprise Explorer.

IBM repository of compatible products
Can be accessed directly from z/OS Explorer so users can choose IBM products to create their custom workbench. The repository currently includes plug-ins for Application Delivery Foundation for z Systems, CICS Explorer, CICS Tools, IMS Enterprise Suite Explorer for Development, Rational Team Concert™, and WebSphere MQ Explorer.

Application development
IBM Developer for z Systems, an integrated, multiplatform development environment with modern, simple-to-use application development solutions for the enterprise and Rational team Concert™ which provides collaborative development and change management capabilities, can be accessed along with plug-ins for CICS, problem determination, and data management tools.

Entitlement
z/OS Explorer is available for use by all customers with a license for a supported version of z/OS. Third-party software vendors and customers can integrate their plug-ins with z/OS Explorer with no IBM product dependency, other than z/OS.
Chapter 2. Configuring system connections

Before you can start to use z/OS Explorer, you must define a connection credential and create a system connection. You can find additional information about system connections in the Tasks section in this help.

Note: z/OS Explorer uses the Java networking stack. Before version 3.1.1.1, z/OS Explorer used the -Djava.net.preferIPv4Stack=true system property to ensure that only IPv4 sockets were used. From version 3.1.1.1, both IPv4 and IPv6 sockets are supported for connections within z/OS Explorer.

Defining connection credentials

When you connect to a system, your credentials, that is, your user ID and password or pass phrase, are sent to the system for authentication. After you define a credential, you can use it on all systems that share the credential without reentering the details every time. You must have at least one credential before you can connect to a system.

Before you begin

Ensure that you have all your system connection details and that you have the correct level of authorization to connect to your system.

Procedure

1. On the main menu for the workbench, click Window > Manage Connections. The Host Connections view opens. The available categories in the Host Connections view depend on the plug-ins that are installed in the z/OS Explorer.
2. Click Add in the Credentials section to add a new credential. The New Credentials window opens.
3. Create your credential. You can create credentials in any of the following ways:
   • Select Username and Password from the drop-down box and enter the credentials name, user ID, and the password or passphrase. If you do not type a name, then the default name that is used is the same as the User ID. Select the Save Password check box to save the password.

      Note: You might have a single user ID, but use different passwords for different systems. In this case, you can define multiple credentials, each one having the same user ID but with a different credential name and password or pass phrase. Alternatively you can choose to define one credential, but not to save the password or pass phrase, in which case you are required to enter them when you connect to a system.
   • Select Username with Multi-Factor Authentication from the drop-down box and enter the credentials name and user ID. This type of credential can be used with some supported connection types such as a CMCI connection in CICS Explorer. Each new connection attempt prompts you for a new password or passphrase. In the Password or Passphrase field, you must specify your password or passphrase coupled with an authentication token. Ask your system administrator how to concatenate your password or passphrase and the authentication token.
• Select **Certificate from Keystore** from the drop-down box, choose a certificate, and enter the appropriate user ID. The keystore contains client certificates that identify the machine to others. To define a keystore file, go to **Window > Preferences > Explorer > Certificate management**. In the **Keystore details** field, to use the same file for both keystore and truststore, select the **Use same details as for truststore** check box. To use a different file, leave the check box cleared and enter the path and file name of the keystore, and the passphrase.

• Insert a smart card and then select **Certificate from Smart card** from the drop-down box, choose a certificate, and enter the appropriate user ID. A smart card is a hardware device that requires a software driver. To configure smart card support system, go to **Window > Preferences > Explorer > Certificate management**. In the **Smart card details** field, select **Use Windows cryptography services** for the Windows operating system, which uses the standard Windows cryptography mechanism. To use a PKCS11 driver (mandatory on Mac OS and Linux operating systems), select **Use PKCS11 driver** and specify the driver path and PIN.

**Note:** You can use certificate credentials for SSL-secured connections on supported connection types.

4. Click **OK** to save the credential or **Cancel** to cancel the process and close the window without saving the credential.

**What to do next**

You can click **Add** in the Connections section of the Host Connections view to configure a system connection.

### Managing SSL security and certificates

You can make the connection between z/OS Explorer and your systems more secure by using the Secure Sockets Layer (SSL).

**Before you begin**

This procedure assumes that you have a working knowledge of SSL.

**Procedure**

1. Use the appropriate method to open the Preferences window:
   - Windows or Linux: Click **Window > Preferences** on the workbench menu bar.
   - **OS X:** Click **IBM Explorer for z/OS > Preferences** on the main menu.
2. Expand **Explorer** and click **Certificate management**.
3. Clear the checkbox **Disable certificate management for secure connections**.
4. In the **Trust store details section** field, enter the full path and file name of the file where the certificates are saved. You can also click **Browse** to navigate to the file.
5. In the **Pass phrase** field, enter the password for this truststore. The default passphrase for the z/OS Explorer generated file is `changeit`.
6. In the **Store type** field, select the format of the keystore file. The type of the z/OS Explorer generated file is `JKS`
7. To use the same file for both keystore and truststore, select the check box **Use same details as for trust store**. To use a different file, leave the check box cleared and enter the path and file name of the keystore, and the passphrase.

8. In the **Smart card details** field, select **Use Windows cryptography services** for the Windows operating system, which uses the standard Windows cryptography mechanism. To use a PKCS11 driver (mandatory on Mac OS and Linux operating systems), select **Use PKCS11 driver** and specify the driver path and PIN.

9. If you are instructed by your network administrator, select the correct protocol for your organization in the **Secure socket protocol** field.

10. Click **Apply** and **OK** to save your settings and close the window.

**Results**

Connections to systems can now be defined by using SSL security.

**What to do next**

Set up your system connections. For more information, see .

**Note:** If your organization uses shared system connections, you can load or import the shared connections, which include details of the selected SSL options. If you load the connections, only your administrator can change the connection, including the SSL options. For more information, see “Using shared connections” on page 46.

**Related concepts:**

“Connecting to a system that is already defined” on page 42

When you have defined your system connections there are a number of ways in which you can activate a connection to a system.

---

### Configuring a z/OS FTP system connection

You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

**Before you begin**

You must have at least one connection credential before you can connect to a system. A credential is a repository for a user ID and password combination. For more information, see Defining connection credentials.

**Note:** For z/OS Explorer to successfully obtain the required spool files, the FTPDATA configuration file for the server must specify JESINTERFACELEVEL 2. For more information about the JESINTERFACELEVEL parameter, see z/OS Communications Server: IP Configuration Reference.

**About this task**

By default, the z/OS FTP connection initiates a passive FTP mode connection. You can specify that the connection initiates an active FTP mode connection when you add or edit a z/OS FTP connection. For example, you might do this if your system restricts passive FTP mode connections.
Procedure

1. Click Window > Manage Connections from the main menu for the workbench. The Host Connections view is displayed.
   
   If your connections are preconfigured, the connections are listed under the categories in the view. If not, the categories are empty. Each z/OS FTP connection is associated with a credential (but not the z/OSMF connection). The credential is shown in parentheses after the connection name.

2. In the Connections section, select the z/OS FTP category and click Add.

3. In the Add z/OS FTP Connection window, enter the FTP host name of your server in the Host name field. As you type, the characters up to the end of the first qualifier are inserted in the Name field. For example, if you enter myserver.example.ibm.com in Host name, myserver is displayed in Name.

4. Optional: To specify a different name, type the name that you require in Name.

5. Optional: To use active FTP mode, select the Active Transfer mode check box.

6. Optional: Select the local and remote character sets to use during file transfer. Use these character sets to override the conversion table defaults of the FTP server when transferring untagged files in ASCII transfer mode. When you save tagged files, if specified, the local code page overrides the default setting for the local encoding. You can also select the file translation table that is located in a data set or z/OS UNIX file. For more information about FTP translation tables, see SBDATACONN (FTP client and server) statement.

7. Optional: You can choose to associate a credential with the connection now. Right-click the connection name and hover over Set Credentials to show the credentials available. Click the credential that you want to use for the connection.

8. Complete the other fields for your organization.

9. Click Save and Close to save the configuration without connecting or click Save and Connect to save the configuration and connect immediately. If you click Save and Connect, the Signon window is displayed, where you must select an existing credential to use with this connection, or define a new credential.

Results

The connection and associated credential are displayed in the Host Connections view.

What to do next

When you connect, z/OS Explorer tries to connect to the system that you configured.

If the connection is successful, the connection name is displayed in the workbench window next to a green icon.

If the connection is not successful, the connection name is displayed in workbench window next to a red icon. An error message is displayed in the workbench status bar providing a reason for the failure. Check the values in the fields, correct any errors, and try to connect again.

Related concepts:

"Connecting to a system that is already defined” on page 42

When you have defined your system connections there are a number of ways in which you can activate a connection to a system.
Configuring a z/OSMF system connection

The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

Before you begin

z/OSMF in z/OS Explorer uses the z/OS jobs REST interface. For details of the RACF® authorizations that are required, see the “Required authorizations” section in the z/OS jobs REST interface in IBM z/OS Management Facility Programming Guide.

You must have at least one connection credential before you can connect to a host system. A credential is a repository for a user ID and password combination. For more information, see Defining connection credentials.

Procedure

1. Click Window > Manage Connections from the workbench menu bar. The Host Connections view is displayed.
   If your connections are preconfigured, you see the connections that are listed under the categories in the view. If not, the categories are empty. In the Host Connections view, one connection is defined in each category type. Each connection is associated with a credential, except for the z/OS FTP connection. The credential is shown in brackets after the connection name.
2. In the Connections section, select the z/OSMF category and click Add. The Add Connection window opens.
3. In the **Host name** field, enter the host name of your z/OSMF server. As you type, the characters up to the end of the first qualifier are inserted in the **Name** field. So if your host name is myserver.example.ibm.com then the name would display as myserver.

4. Enter the port number. As you type, the port number is appended to the **Name** field, so the name is displayed as something like myserver:20332.

5. Optional: You can specify a different name by over typing the name in the **Name** field.

6. By default the z/OSMF connection also sets up an FTP connection on port 21. If you previously defined a different FTP connection, select it from the FTP Connection list.

7. Complete the other fields for your organization, and click **OK**.

8. Click **Save and Close** to save the configuration without connecting or click **Save and Connect** to save the configuration and connect immediately. If you click **Save and Connect**, you are presented with the Signon window, where you must select an existing credential to use with this connection, or define a new credential.

**Results**

The connection and associated credential are displayed in the Host Connections view.

**What to do next**

When you connect, the z/OS Explorer tries to connect to the system that you configured.

If the connection is successful, the connection name is displayed in the workbench window next to a green icon.

If the connection is not successful, the connection name is displayed in workbench window next to a red icon. An error message is displayed in the workbench status bar providing a reason for the failure. Check the values in the fields, correct any errors, and try to connect again.

**Related concepts:**

“Connecting to a system that is already defined” on page 42

When you have defined your system connections there are a number of ways in which you can activate a connection to a system.

**Related tasks:**

“Configuring a z/OS FTP system connection” on page 5

You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

“Exporting connections” on page 47

You can export one or more connections to an external file to back them up or to share with other users. If you save the connection file on a shared disk, or upload it to a web server, users can load the connection details into their z/OS Explorer. Any changes to the shared connection file are picked up automatically the next time the user starts z/OS Explorer.
As an alternative to defining your own connections, you can share a set of connections that are stored in a central location. You can load or import the shared connections into your copy of z/OS Explorer. Sharing connections means that the connections can be managed centrally, and any changes to the connections file are picked up automatically the next time z/OS Explorer starts.
Chapter 3. Perspectives

A perspective is a layout of one or more views in the workbench. You can decide how you want to lay out the views in the z/OS Explorer and save the layout as a new perspective. z/OS Explorer provides three default perspectives: Resource, z/OS and Remote System Explorer. These topics describe the perspectives and explain how to work with perspectives to meet your operational requirements.

The z/OS perspective

The default z/OS perspective consists of a set of views for the management of your z/OS artifacts. The active perspective name is displayed on a button in the shortcut bar. You must have an active FTP or z/OSMF connection to view z/OS data.

The z/OS perspective consists of the following views that provide z/OS information:

- Data Sets view
- Jobs view
- z/OS UNIX Files view

The Console view provides a history of the actions you performed, such as submitting a job, or changing and saving a file. The area in the center of the perspective is the editor area. When you edit a file, the file contents are displayed in this area.

You can tailor the perspective by adding new views, removing existing views, moving around views, or changing the size of views. When you close z/OS Explorer, any changes you made to the perspective are saved, and next time z/OS Explorer starts, your tailored perspective is displayed.

You can restore the perspective to its last saved configuration at any time by clicking Window > Reset Perspective on the main menu for the workbench. You can reset the supplied perspectives to their default configuration by clicking Restore Defaults on the Perspectives pane in the Preferences window.

You can create and save multiple perspectives. For example, you might want to set up a perspective that shows only some of the views.

**Note:** When you save a perspective, you save only the layout of the views and editors in the workbench. If you change the width of a column in a view, that change is applied to that column in every perspective that contains the view. Any filter attributes you set are retained when you switch to another perspective or view.

**Related concepts:**

"The Data Sets view” on page 55

When you are connected to a z/OS system, the Data Sets view lists all the data sets that you are authorized to view and that match the data set name qualifier you specify. You can open a data set to view the members. You can edit Partitioned Data Set (PDS) members that contain text, but you cannot edit PDS members that contain binary code.
The Jobs view lists the completed and running jobs that you are authorized to view and that match the job name prefix and owner ID that you specify. The number of jobs you can see in the view depends on the JESENTRYLIMIT value that is set in the FTP server; the default value is 200. You can expand a job in the view to show the ddnames that are associated with the spool files, and open the spool files in an editor view to show the content.

The z/OS UNIX Files view shows the zFS file system structure and contents. The files are shown in a tree structure and you can expand the tree to show individual files.

Related reference:

The Console view provides a history of the actions you have performed, such as submitting a job, or changing and saving a file.

The Resource perspective

The Resource perspective consists of a set of views for the management of projects and the resources that they contain. The active perspective name is displayed on a button in the shortcut bar.

If the Resource perspective is not active, you can open it in one of the following ways:

- Click the Open Perspective icon, then click Resource.
- From the main menu for the workbench, click Window > Open Perspective > Other. In the Open Perspective window, select Resource, then click OK.

You can tailor the perspective by adding new views, removing existing views, moving around views, or changing the size of views. When you close z/OS Explorer, any changes you made to the perspective are saved, and next time z/OS Explorer starts, your tailored perspective is displayed.

You can restore the perspective to its last saved configuration at any time by clicking Window > Reset Perspective on the main menu for the workbench. You can reset the supplied perspectives to their default configuration by clicking Restore Defaults on the Perspectives pane in the Preferences window.

You can create and save multiple perspectives. For example, you might want to set up a perspective that shows only some of the views.

Note: When you save a perspective, you save only the layout of the views and editors in the workbench. If you change the width of a column in a view, that change is applied to that column in every perspective that contains the view. Any filter attributes you set are retained when you switch to another perspective or view.

The Remote System Explorer perspective

The default Remote System Explorer (RSE) perspective consists of a set of views for the management of the artifacts of your remote systems. The active perspective name is displayed on a button in the shortcut bar. A tree of available systems is displayed in the Remote System view. You can use the tree to
navigate to files, jobs, and open a TSO shell. To view RSE data, you must have a remote system daemon on the host system. If you can connect to z/OS systems by using FTP or z/OSMF only, the RSE view is not populated with data, and you must switch to the z/OS perspective.

The RSE perspective consists of the following views:

- Remote Systems view
- Team view
- Properties view
- Remote Scratchpad view
- Remote Edit History view

The area in the center of the perspective is the editor area. When you edit a file, the file contents are displayed in this area.

You can tailor the perspective by adding new views, removing existing views, moving around views, or changing the size of views. When you close z/OS Explorer, any changes you made to the perspective are saved, and next time z/OS Explorer starts, your tailored perspective is displayed.

You can restore the perspective to its last saved configuration at any time by clicking **Window > Reset Perspective** on the main menu for the workbench. You can reset the supplied perspectives to their default configuration by clicking **Restore Defaults** on the Perspectives pane in the Preferences window.

You can create and save multiple perspectives. For example, you might want to set up a perspective that shows only some of the views.

**Note:** When you save a perspective, you save only the layout of the views and editors in the workbench. If you change the width of a column in a view, that change is applied to that column in every perspective that contains the view. Any filter attributes you set are retained when you switch to another perspective or view.

For more information about RSE usage, see *Generic RSE User Guide* and *RSE for z/OS User’s Guide*. 

Chapter 3. Perspectives  13
Chapter 4. Tasks

These tasks illustrate how you can set up and use z/OS Explorer to interact with and manage your z/OS jobs.

Accessing resources on local and remote systems

In the RSE perspective, you can explore and search files on local systems. You can also connect to and work with remote systems. For more information about the remote systems, see RSE for z/OS User’s Guide.

Creating local JCL files

You can create and edit a JCL file in your local workspace from the Resource perspective. When the JCL file is complete, you can submit the job, or copy the file to a partitioned data set using your local procedures.

Before you begin

If you have not already done so, switch to the Resource perspective. You do not need to be connected to an FTP or z/OSMF server on your host system to create a JCL file, but you must have an active connection before you can submit a job. For more information, see the related links later in this topic.

About this task

This task creates a new Job Submission project and a then new JCL file in your local workspace. If you already have a Job Submission project in your workspace, you can go straight to step 3 in the following procedure.

Procedure

1. Right-click anywhere in the Project Explorer view and click New > Project. The New Project wizard opens. Expand the z/OS folder and click New Job Submission project. Click Next.
2. In the Create a Job Submission project wizard, enter the name that you want to give your project, and click Finish. The project appears in the Project Explorer view.
3. Right-click the project and click New > File to open the New File wizard. The parent project that you chose is selected but you can select a different project if you want.
4. In the File Name field, enter the name of the JCL file to create. The file name must have a suffix of .jcl, for example: terminal.jcl. Click Finish.
5. Optional: Enable the autosave feature by clicking Window > Preferences > JCL > Editor > Autosave.

What to do next

The JCL file is created in the project and opens in the JCL editor. The JCL editor is similar to the supplied data set editor but with the ability to use different colors to identify different text elements in the JCL. You can change the colors in the editor preferences page by right-clicking anywhere in the JCL editor and clicking...
Preferences. The JCL Editor Preferences page is displayed. You can select an element and change the color and text style.

z/OS Explorer Version 3.0.1 and later support JCL languages features that are introduced in z/OS V2R1 and V2R2. You can see some highlights and annotations in the JCL editor.

Related tasks:
Configuring a z/OS FTP system connection
You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

“Configuring a z/OSMF system connection” on page 7
The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

Using the IBM z/OS Management Facility
The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-browser based management console for z/OS. These topics explain the additional functions that is available when you are connected to a z/OSMF system.

Configuring a z/OSMF system connection
The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

Before you begin
z/OSMF in z/OS Explorer uses the z/OS jobs REST interface. For details of the RACF authorizations that are required, see the "Required authorizations" section in the z/OS jobs REST interface in IBM z/OS Management Facility Programming Guide.

You must have at least one connection credential before you can connect to a host system. A credential is a repository for a user ID and password combination. For more information, see Defining connection credentials.

Procedure
1. Click Window > Manage Connections from the workbench menu bar. The Host Connections view is displayed.
   If your connections are preconfigured, you see the connections that are listed under the categories in the view. If not, the categories are empty. In the Host Connections view, one connection is defined in each category type. Each connection is associated with a credential, except for the z/OS FTP connection. The credential is shown in brackets after the connection name.
2. In the Connections section, select the z/OSMF category and click Add. The Add Connection window opens.
3. In the **Host name** field, enter the host name of your z/OSMF server. As you type, the characters up to the end of the first qualifier are inserted in the **Name** field. So if your host name is `myserver.example.ibm.com` then the name would display as `myserver`.

4. Enter the port number. As you type, the port number is appended to the **Name** field, so the name is displayed as something like `myserver:20332`.

5. Optional: You can specify a different name by over typing the name in the **Name** field.

6. By default the z/OSMF connection also sets up an FTP connection on port 21. If you previously defined a different FTP connection, select it from the FTP Connection list.

7. Complete the other fields for your organization, and click **OK**.

8. Click **Save and Close** to save the configuration without connecting or click **Save and Connect** to save the configuration and connect immediately. If you click **Save and Connect**, you are presented with the Signon window, where you must select an existing credential to use with this connection, or define a new credential.

**Results**

The connection and associated credential are displayed in the Host Connections view.

**What to do next**

When you connect, the z/OS Explorer tries to connect to the system that you configured.

If the connection is successful, the connection name is displayed in the workbench window next to a green icon.

If the connection is not successful, the connection name is displayed in workbench window next to a red icon. An error message is displayed in the workbench status bar providing a reason for the failure. Check the values in the fields, correct any errors, and try to connect again.

**Related concepts:**

- "Connecting to a system that is already defined” on page 42

**Related tasks:**

- "Configuring a z/OS FTP system connection” on page 5
  You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

- "Exporting connections” on page 47
  You can export one or more connections to an external file to back them up or to share with other users. If you save the connection file on a shared disk, or upload it to a web server, users can load the connection details into their z/OS Explorer. Any changes to the shared connection file are picked up automatically the next time the user starts z/OS Explorer.
As an alternative to defining your own connections, you can share a set of connections that are stored in a central location. You can load or import the shared connections into your copy of z/OS Explorer. Sharing connections means that the connections can be managed centrally, and any changes to the connections file are picked up automatically the next time z/OS Explorer starts.

Viewing the output of an active job

When z/OS Explorer is connected through FTP you can use the Jobs view to see all the active jobs you have on the system. If you have a z/OSMF connection you can also view the output of active jobs while they are running.

Before you begin

If you have not already done so, switch to the z/OS perspective. You must have a z/OSMF connection to your host system before you can view the output of an active job. For more information, see the related links later in this topic.

About this task

This task describes how to view the output of an active job.

Procedure

In the Jobs view, navigate to the active job that you want to view. Choose from the following actions:

- Double-click, or right-click and click Open, the active job.
- Expand the job in the Jobs view to show all the job output files. Double-click the job output file. Alternatively right-click the file and click Open.

Results

The Job Editor opens. If you clicked the job output file, the Job Editor shows only the job output. If you clicked the active job, the Job Editor shows all files for the active job.

You can refresh the Jobs Editor content at any time by pressing F5. If the job ended, the message The job is no longer active is received.

Related tasks

Deleting or cancelling an active job

When z/OS Explorer is connected through FTP you can use the Jobs view to see all the active jobs you have on the system. If you have a z/OSMF connection you can also delete or cancel an active job.
Before you begin

If you have not already done so, switch to the z/OS perspective. You must have a z/OSMF connection to your host system before you can cancel an active job. For more information, see the related links later in this topic.

About this task

This task describes how to delete or cancel an active job.

Procedure

In the Jobs view, navigate to the active job that you want to cancel. Right-click and click Delete or Cancel.

Results

A confirmation dialog is displayed. Click Yes to perform the action.

Related tasks

“Configuring a z/OSMF system connection” on page 7

The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

---

Working with data sets

There are a number of actions you can perform against data sets. These topics explain the actions an how to work with data sets.

Creating a new data set

You can create a new data set using the z/OS Explorer. You can create a Partitioned Data Set (PDS), Partitioned Data Set Extended (PDSE or Library data set), or a Sequential data set.

Before you begin

Ensure that you are in the z/OS perspective.

Ensure that you are connected to an FTP server on your host system. For more information, see the related links later in this topic.

About this task

This task creates a new PDS, PDSE, or sequential data set.

Procedure

1. Open the New Data Set wizard by using one of the following choices:
   a. If you want to create a new source, or JCL data set, use one of the following methods:
      • Right-click in the Data Sets view and click New Source or JCL Data Set.
• Click the down arrow on the New wizard icon on the z/OS Explorer toolbar. Click Other and expand the z/OS folder. Click Source or JCL Data Set. Click Next.

• On the Eclipse menu bar, click File > New > Other to open the New Project wizard. Expand the z/OS folder. Click Source or JCL Data Set. Click Next.

b. If you want to create any other type of data set, use one of the following methods:

• Right-click in the Data Sets view and click New Data Set.

• Click the down arrow on the New wizard icon on the z/OS Explorer toolbar. Click Other and expand the z/OS folder. Click Data Set. Click Next.

• On the Eclipse menu bar, click File > New > Other to open the New Project wizard. Expand the z/OS folder. Click Data Set. Click Next.

The New Data Set wizard opens. If you selected to create a source or JCL data set, go to step 3.

2. The New z/OS Data Set page contains a list of data set types that are predefined. In the Data Set Name field, enter the name of the new data set. The name must have at least two qualifiers, for example; NEW.JCL. Select one of the predefined data set types, if required, and click Next. The New z/OS Data Set Characteristics page opens.

3. If you selected a predefined data set type, the fields are prefilled. However, you can click Back and change the values if required. If the fields are not prefilled, you must specify the data set characteristics according to your requirements. See your z/OS documentation for information on data set characteristics.

   When you have set, or confirmed, the data set characteristics, click Next. The New z/OS Data Set - System-Managed Storage page opens.

4. Optional: Specify the System-Managed Storage class IDs. If you do not know the IDs for these fields, ask your storage administrator. Click Finish. The new data set is created and is shown in the Data Sets view.

What to do next

The data set is now ready for use, but see the following restrictions. For information about adding a new member to a data set, see the topic “Creating a new data set member” on page 21.

Restriction: In some cases, the results might not be as expected because of limitations in FTP. The following problems have been identified:

• If you attempt to create a data set, and the primary allocation you define is greater than the space available, you might receive a “permission denied” error rather than a more appropriate error.

• If you attempt to create a sequential data set with the same name as an existing PDS, you might receive an error stating that no member was specified on the STOR command.

• If you set the data class, on the last wizard screen, to a value that does not exist, the data set is created but you might receive no warning to say that the data class is not valid.
If you enter invalid characters in a field on the last wizard screen, the data set creation fails but you might not receive any reason information.

Related tasks:
“Configuring a z/OS FTP system connection” on page 5
You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

Creating a new data set member
You can create a new Partitioned Data Set (PDS) member using the z/OS Explorer. You can edit the PDS member and copy and paste content from other PDS members.

Before you begin
Ensure that you are in the z/OS perspective.

Ensure that you are connected to an FTP server on your host system. For more information, see the related links later in this topic.

About this task
This task creates a new data set member in an existing PDS.

Procedure
1. In the Data Sets view, right-click the PDS file where you want to create the new member and click New data Set Member. The Create data set member dialog opens.
2. The Data Set Name field contains the name of the PDS where the member will be created. You can over type the name to change the location. In the File name field, type the new member name and click Finish.

What to do next
The new member is added to the data set. To see the member, you must refresh the Data Sets view. You can now open the new member and add content. For information about editing data sets, see “Editing data sets” on page 23.

Related tasks:
“Configuring a z/OS FTP system connection” on page 5
You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

Data set actions
You can use the Data Sets view in the z/OS perspective to select data sets and perform actions against them. You invoke actions by using the menu that is displayed when you right-click a data set. The available actions depend on the type of data set.

The following table lists the types of data sets and the actions that are available for each data set type.
<table>
<thead>
<tr>
<th>Data set type</th>
<th>Action</th>
</tr>
</thead>
</table>
| Partitioned data set (PDS)    | - **Delete** Delete one or more selected data sets. You can select PDSs and sequential data sets, but you cannot include data set members.  
                              | - **New Data Set Member** Create a new member in the PDS.             
                              | - **Copy Qualified Name** Copy the fully qualified name of one or more selected data sets to the clipboard. |
| PDS member                    | - **Delete** Delete one or more selected data set members. You can select members from different PDSs.  
                              | - **New Data Set Member** Create a new member in the PDS.             
                              | - **Open** Open the data set member for browsing or editing. When changes are complete, click the **Save** icon to save the changes.  
                              | - **Copy Qualified Name** Copy the fully qualified name of one or more selected data set members to the clipboard. You can select members from different PDSs.  
                              | - **Submit** Submit the data set member for processing as a JCL job. The job number is displayed in the workbench status bar. You can view the job output in the Jobs view. |
| Sequential data set           | - **Delete** Delete one or more selected data sets. You can select PDSs and sequential data sets, but you cannot include data set members.  
                              | - **Open** Open the data set for browsing or editing. When changes are complete, click the **Save** icon to save the changes.  
                              | - **Add** Create a new sequential data set.                          
                              | - **Copy Qualified Name** Copy the fully qualified name of one or more selected data sets to the clipboard.  
                              | - **Submit** Submit the data set for processing. The job number is displayed in the workbench status bar. You can view the job output in the Jobs view. |
Table 1. Data set types and actions (continued)

<table>
<thead>
<tr>
<th>Data set type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Migrated data set</td>
<td>• <strong>Recall</strong> Recall the data set.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> When you recall migrated VSAM data sets, all the data set components are recalled. However, if you recall the data or index component, the warning icon is displayed by the file to indicate that you must refresh the Data Sets view to see the combined components in the view.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Copy Qualified Name</strong> Copy the fully qualified name of one or more selected data sets to the clipboard.</td>
</tr>
<tr>
<td>VSAM data set</td>
<td>• <strong>Copy Qualified Name</strong> Copy the fully qualified name of one or more selected data sets to the clipboard.</td>
</tr>
<tr>
<td>Data sets not found or volume not available</td>
<td>No actions possible.</td>
</tr>
</tbody>
</table>

**Editing data sets**

You can open a file and edit the contents using the z/OS Explorer. You can edit only text Partitioned Data Set (PDS) members or text sequential data sets.

**About this task**

The data set editor is a text editor that you can use to view or edit a data set.

**Important:** Use the data set editor to open only JCL or job log files of relatively small size, for example a few MB. When a file is downloaded for display in the z/OS Explorer, the file is stored in the Java® heap, which has a finite size limit. If you attempt to download a large file, for example a system dump data set, this can cause Java OutOfMemoryError messages. If this situation occurs, restart z/OS Explorer and view the file by using ISPF.

When you open a file to edit, z/OS Explorer places a copy of the file in your local workspace. If the file is busy on the host, for zFS files and sequential data sets, z/OS Explorer still takes a copy, but for PDS members, an error message is displayed. It is possible for a file to change after z/OS Explorer took the copy, for example, another user made and saved changes on the host. In this situation, when you save the file, a warning is displayed in the toolbar of the view, and you must choose whether to overwrite the file on the host, or cancel your changes and return to the data set editor.

**Note:** In the rare situation where a file changes on the host but the change does not affect the date, time, or size information about the file, a warning is not displayed and your changes will overwrite the file on the host. Be aware of this possibility, for example, when you edit sequential data set files, or PDS members that do not have any statistics.

**Procedure**

In the Data Set view, click the data set you want to open and perform one of the following actions:

• Right-click and click **Open**.
• Double-click the data set.

Results

The data set opens in the data set editor.

When you first open the file for editing, the file opens in the editor view in the workbench edit area.

The workbench status bar displays more details about the file.

When you edit files, you must be aware of the cursor position. PDS members have a record length of 80 characters, but the editor does not prevent you from entering more than 80 characters in a single line.

To display line numbers in the editor, right-click the gray vertical bar at the left-side of the view, then click Show Line numbers in the menu.

If a file references a data set name, for example DSN=USER290.NEWJCL(OUT), you can open that data set in another editor view. Press the Ctrl key and hover over the name to change the text to a hyperlink that you can click to open the data set in another editor view.

When you change a file, an asterisk is placed in front of the file name in the view tab. The asterisk indicates that the file contents have changed but have not been saved.

What to do next

You can now edit the file.

Note: The data set editor does not recognize the format of the file that you are editing. If your file contains Job Control Language (JCL) instructions, do not use tab characters, or your job will fail. To ensure that you do not use tab characters, you can use the following steps to change the global settings for all text editors in your application.

1. Use one of the following methods to open the JCL Editor pane in the Preferences window:
   • Windows and Linux: Click Window > Preferences > Explorer > JCL Editor.
   • OS X: Click IBM Explorer for z/OS > Preferences > Explorer > JCL Editor.
2. In the JCL Editor pane, click the Text Editors link.
3. In the Text Editors pane, select Insert spaces for tabs and click OK.

The following editing actions are available from the Edit menu on the main menu for the workbench, or the right-click menu options in the view:

Table 2. Edit menu actions

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
<th>Keyboard shortcut (Windows and Linux)</th>
<th>Keyboard shortcut (OS X)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo typing</td>
<td>Undo the last change in the editor</td>
<td>Ctrl+Z</td>
<td>cmd+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Redo the previous change that was undone</td>
<td>Ctrl+Y</td>
<td>shift+cmd+Z</td>
</tr>
</tbody>
</table>
Table 2. Edit menu actions  (continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
<th>Keyboard shortcut (Windows and Linux)</th>
<th>Keyboard shortcut (OS X)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Copies the currently selected text or element to the clipboard and removes the element. On elements, the remove is not performed before the clipboard is pasted.</td>
<td>Ctrl+X</td>
<td>cmd+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the currently selected text or elements to the clipboard</td>
<td>Ctrl+C</td>
<td>cmd+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Paste the current content as text to the editor, or as a sibling or child element to the currently selected element.</td>
<td>Ctrl+V</td>
<td>cmd+V</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete the current text or element selection.</td>
<td>Delete key</td>
<td>Delete key</td>
</tr>
<tr>
<td>Find Next</td>
<td>Finds the next occurrence of the currently selected text.</td>
<td>Ctrl+K</td>
<td>cmd+K</td>
</tr>
<tr>
<td>Find Previous</td>
<td>Finds the previous occurrence of the currently selected text.</td>
<td>Ctrl+Shift+K</td>
<td>shift+cmd+K</td>
</tr>
<tr>
<td>Incremental Find Next</td>
<td>Starts the incremental find mode. After invocation, enter the search text. As you type the cursor moves to the character position after the cursor position that matches the text you type. The text you type is shown in the status bar.</td>
<td>Ctrl+J</td>
<td>cmd+J</td>
</tr>
<tr>
<td>Incremental Find Previous</td>
<td>Starts the incremental find previous mode. After invocation, enter the search text. As you type the cursor moves to the character position before the cursor position that matches the text you type.</td>
<td>Ctrl+Shift+J</td>
<td>shift+cmd+J</td>
</tr>
<tr>
<td>Show Tooltip Description</td>
<td>Not in use</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Word Completion</td>
<td>Proposes word completions for the current string based on all words found in any open editor.</td>
<td>Alt+/</td>
<td>ctrl+.</td>
</tr>
</tbody>
</table>

Table 3. View context menu actions

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
<th>Keyboard shortcut (Windows and Linux)</th>
<th>Keyboard shortcut (OS X)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo typing</td>
<td>Undo the last change in the editor</td>
<td>Ctrl+Z</td>
<td>cmd+Z</td>
</tr>
<tr>
<td>Revert File</td>
<td>Revert the content of the current editor back to the content of the last saved file. Disabled if the editor does not contain unsaved changes.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td>Save the content of the current editor. Disabled if the editor does not contain unsaved changes.</td>
<td>Ctrl+S</td>
<td>cmd+S</td>
</tr>
<tr>
<td>Show In</td>
<td>Not in use</td>
<td>Alt+Shift+W</td>
<td></td>
</tr>
</tbody>
</table>
Table 3. View context menu actions (continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
<th>Keyboard shortcut (Windows and Linux)</th>
<th>Keyboard shortcut (OS X)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Copies the currently selected text or element to the clipboard and removes the element. On elements, the remove is not performed before the clipboard is pasted.</td>
<td>Ctrl+X</td>
<td>cmd+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the currently selected text or elements to the clipboard</td>
<td>Ctrl+C</td>
<td>cmd+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Paste the current content as text to the editor, or as a sibling or child element to the currently selected element.</td>
<td>Ctrl+V</td>
<td>cmd+V</td>
</tr>
<tr>
<td>Shift Right</td>
<td>Increments the level of indentation of the currently select lines.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Shift Left</td>
<td>Decrements the level of indentation of the currently select lines.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

When your edits are complete, to save your changes, clicking the **Save** icon on the z/OS Explorer toolbar.

To close the editor, click the **Close** icon in the editor tab. If there are any unsaved changes, the Save resource dialog is displayed so that you can choose whether to save your changes.

### Submitting a batch job

You can submit one or more batch jobs from the z/OS Explorer. You can submit the jobs from the Data Sets view or submit a job from the data set editor.

### About this task

You can use the Data Sets view to submit one or more jobs without needing to open the files.

You can use the data set editor to open a file, make changes, and then submit the changed file from the editor. You can then choose whether to save the changes to the file.

### Procedure

- To submit a job from the Data Sets view, use the following procedure:
  1. Open the Data Sets view and navigate to the file or files that you want to submit. To submit multiple files, use Ctrl+click (cmd+click for OS X) to select the files. You can select members from different data sets and sequential files, and submit them all at the same time.
  2. Right-click a selected file and click **Submit**.

  The selected files are submitted.

- To submit a job from the data set editor, use the following procedure:
  1. Open the Data Sets view and navigate to the file that you want to change and submit.

26 IBM Explorer for z/OS : User’s Guide
2. Double-click the file, or right-click and click **Open**. The file opens in the data set editor.

3. Make any changes you want then right-click in the editor and click **Submit**.
   You can then save the file, or close it without saving.

   The file is submitted.

**Results**

A confirmation message, including the job number, is shown in the status bar. The job is shown in the Jobs view when that view is refreshed.

**Updating and installing software**

You can use the facilities provided by the Eclipse platform to update your z/OS Explorer or other compatible product software, for example CICS Explorer, or add new software plug-ins, for example CICS tools.

For z/OS Explorer Version 2.1 and later, you can use the composite update site to keep up to date with new versions of z/OS Explorer and to add new tools and plug-ins to your z/OS Explorer environment. For more information, see “Using the composite update site.”

The update site for the z/OS Explorer is already coded in the product. You can see the site address on the Installed Software page in the Software Updates window.

If you choose not to use the composite update site, you need to specify the address of your preferred update site, either on your local machine or a remote location. You can add multiple update sites, each containing one or more software downloads.

**Using the composite update site**

You can use the composite update site to update your z/OS Explorer or other compatible product software, or add new software plug-ins such as additional tools.

For z/OS Explorer Version 2.1 and later, you can use the composite update site, which simplifies the installation of updates to z/OS Explorer software plug-ins. When a composite update site is present and you click **Help > Install New Software**, software plug-ins for additional tools are listed as well as z/OS Explorer.

The update site for z/OS Explorer is already coded in the product. You can see the site address in the Available Software Sites pane on the Preferences window.

If you are using the z/OS Explorer SDK and you installed the SDK by using the composite update site, you can click **Help > Check for Updates** to check for new versions of the z/OS Explorer and any tools you have installed. If you installed the SDK by downloading the compressed file, the composite update site is not available.

The URLs of composite update sites include the version number of z/OS Explorer or other compatible product software that they relate to. For example, if the composite update site URL contains the version number 5.1, you will receive any modification and fix updates for Version 5 Release 1 of the product, but not any new releases or versions. Eclipse, and therefore z/OS Explorer or other compatible
product software, always offers the latest available version when you check for updates. If you choose to not accept an update, you will NOT be notified if a new fix level (for instance 5.1.0.1) becomes available. For example, if you have version 5.1.0.0 and are offered a modification level update to version 5.1.1.0 but decline it, you will NOT be notified if fix level 5.1.0.1 becomes available.

You are always offered the very latest code that is available in the whole composite update site. If you declined a new fix level, you must check manually whether any new updates are available. Click Help > Install New Software and remove the option that selects only the latest versions of software. You will receive all updates to any tools you have installed (such as IBM CICS Configuration Manager) that are compatible with the version of z/OS Explorer that the composite update site relates to. Review the version numbers before upgrading a component.

If you want to control the updates that end users can move to for both z/OS Explorer and plug-ins, you need to remove the composite update site from z/OS Explorer and select another site manually. For more information, see “Adding a new software update site.”

**Adding a new software update site**

Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

**Before you begin**

You must know the web site address (URL) or local file system location of the update site that you want to add.

**Procedure**

1. Use the appropriate method to open the Preferences window:
   - Windows or Linux: Click Window > Preferences on the workbench menu bar.
   - OS X: Click IBM Explorer for z/OS > Preferences on the main menu.
2. In the Preferences window, expand Install/Update, then click Available Software Sites.
3. In the Available Software Sites pane, click Add.
4. In the Add Site window, specify the location of the update site in one of the following ways:
   - If the update site is located on the web, type the website address (URL) of the site into the Location field. Alternatively, paste or drag and drop a URL from a web browser.
   - If the update site is in your local file system, including a CD, click Local and select the directory location of the site.
   - If the update site is in your local file system but is packaged as a .jar or .zip file, click Archive to locate and select the name of the file.
5. Click OK.

**Results**

The update site is added to the list of available software and the site is checked to find available software at that site. The progress icon in the workbench is displayed while the update site is being checked. Do not click the site URL while
the process is continuing, because an error might be displayed, although the process will continue. When the progress icon goes, the process is complete.

If no software is found at the site, an error is displayed. Remove the site and add a valid site.

When you install new software and you select the new software update site in the Available Software pane in the Install window, the new software found is displayed in a tree format. For more information about installing software updates, see the related links.

Related tasks:

"Checking for, and installing, software updates"
You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.

"Removing an existing software update site” on page 31
You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

"Importing a list of software update sites” on page 34
You can import a list of software update sites that have been exported previously by using the Available Software Sites pane in the Preferences window.

"Exporting a list of software update sites” on page 35
You can export one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.

"Select or deselect software sites to check for available software” on page 36
You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

Checking for, and installing, software updates
You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.

About this task
To check for software updates, you use the Installed Software tab of the Installation Details window. To install software updates, you use the Available Updates wizard.

Procedure
1. Click Help > Install New Software on the workbench menu.
2. In the Install window, click the What is already installed link. The Installation Details window is displayed. The Installed Software tab lists the plug-ins that are currently installed.
3. Select the items for which you want to check for software updates from the list on the Installed Software tab.
4. Click Update. If updates are available, they are displayed in the Available Updates wizard.
5. In the Available Updates wizard, select the software items to update. You can select one or more items to install. Each time you select an item, the compatibility of the checked items is compared with your current system. If the selection is not compatible, an error message is displayed and you cannot update the software. You must select other items to find a compatible selection.
6. If the selected items have license agreements to be reviewed, click **Next**.
   Carefully review the license agreements for the updated items. If the terms of all these licenses are acceptable, check **I accept the terms in the license agreements**. Do not proceed to download the items if the license terms are not acceptable.

7. If the license agreements are acceptable, or if the selected items did not have license agreements to review, click **Finish**. The download and installation of the updates begins.

8. Some items might be digitally signed by the company that provides them. You can use the digital signature to verify more easily that the features and plug-ins that are about to be downloaded and installed are coming from a trusted supplier. You might be prompted to verify digitally signed content once the signature is detected.

   **Attention:** Because of the possibility of harmful or even malicious software, download only software from parties that you trust.

9. When all the software is downloaded successfully and the necessary files installed into the product, you are prompted to restart z/OS Explorer. Click **Yes** when asked to exit and restart the workbench for the changes to take effect.

**Results**

z/OS Explorer restarts with the latest updates installed.

**Related tasks:**
- "Adding a new software update site" on page 28
- "Removing an existing software update site" on page 31
- "Importing a list of software update sites" on page 34
- "Exporting a list of software update sites" on page 35
- "Select or deselect software sites to check for available software" on page 36

**Enabling automatic updates**

You can specify that enhancements and fixes are downloaded automatically as they become available by using the Automatic Updates pane on the Preferences window.

**Procedure**

1. Use the appropriate method to open the Preferences window:
   - Windows or Linux: Click **Window > Preferences** on the workbench menu bar.
   - OS X: Click **IBM Explorer for z/OS > Preferences** on the main menu.
2. In the Preferences window, expand Install/Update and click **Automatic Updates**.

3. In the Automatic Updates pane, select **Automatically find new updates and notify me** to enable automatic updates. You can then select options in the following sections:
   - Update schedule: Choose when to look for updates.
   - Download options: When updates are available, choose whether to receive notifications only, or to download updates automatically and receive notifications.
   - When updates are found: Choose when to be notified about new updates.

4. Click **Apply** or **OK**.

**Results**

`z/OS Explorer` automatically checks for updates at the selected time, and downloads the updates, or notifies you, depending on the options selected. You can turn off automatic updates at any time by opening the Automatic Updates pane and clearing the **Automatically find new updates and notify me** check box.

**Removing an existing software update site**

You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

**Procedure**

1. Use the appropriate method to open the Preferences window:
   - Windows or Linux: Click **Window > Preferences** on the workbench menu bar.
   - OS X: Click **IBM Explorer for z/OS > Preferences** on the main menu.

2. In the Preferences window, expand **Install/Update** and click **Available Software Sites**.

3. In the Available Software Sites pane, click and highlight the existing software update site that you want to remove. You can use Ctrl+click (cmd+click for OS X) or Shift+click to select more than one site.

   **Note:** Do not use the check boxes to select the required software update site. Any check box selections on this pane are ignored for this action.

4. Click **Remove**.

5. Click **OK**.

**Results**

The site is removed from the list of available sites.

**Related tasks:**

- “Adding a new software update site” on page 28
  Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

- “Checking for, and installing, software updates” on page 29
  You can check for software updates for `z/OS Explorer`, other compatible product software, or installed plug-ins, then use a wizard to install any updates.
Removing an installed software plug-in

You can uninstall and remove an existing plug-in by using the Installation Details window.

Before you begin

Before you uninstall a plug-in, you must close all perspectives associated with the plug-in. Failure to do so might cause an error and you might have to reinstall z/OS Explorer.

Procedure

1. Click Help > Install New Software on the workbench menu. The Install window opens.
2. In the Install window, click the What is already installed link. The Installation Details window opens. The Installed Software tab shows a list of the software installed.
3. Select the software that you want to uninstall. Click Uninstall.
4. In the Uninstall window, click Finish. A progress bar is displayed in the workbench status bar until the process completes.
5. When you are prompted to restart z/OS Explorer, click Yes.

Results

The software plug-in is uninstalled from z/OS Explorer and removed from the list of installed software. z/OS Explorer restarts to complete the action.

Related tasks:

- Adding a new software update site on page 28
- Checking for, and installing, software updates on page 29
- Importing a list of software update sites on page 34
- Exporting a list of software update sites on page 35
You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

Reverting to a previous installation configuration

As you install, upgrade, and uninstall software in z/OS Explorer, configuration snapshots are kept in a history. You can revert to a previous configuration to back out the results of an unsuccessful installation, upgrade, or uninstall. You can also revert z/OS Explorer to a previous version. However, you must have access to an update site because when you upgrade the z/OS Explorer product, previous versions are not saved.

Before you begin

If you used IBM Installation Manager to install, upgrade, or uninstall software in z/OS Explorer, you can revert to a previous version by using the rollback feature, and you do not need to use the following procedure.

Important: It is a limitation of Eclipse that before you can revert to a previous version of z/OS Explorer, you must have access to an update site that includes the required version.

To download the update site, use the following steps:
1. For the Product Group field, select Other Software and for Product, select IBM Explorer for z/OS. For the Installed Version and Platform fields, select All, then click Continue.
2. Select Browse for fixes and click Continue.
3. Select the update site at the level you want to revert to and click Continue.
4. Download the update site to your workstation. Do not uncompress the file. z/OS Explorer requires a compressed file.
5. In z/OS Explorer, add the update site by using Help > Software Updates on the workbench menu. For more information, see “Adding a new software update site” on page 28.

You can now revert z/OS Explorer to the required level.

About this task

This example task shows you how to revert z/OS Explorer to a previous configuration.

Procedure
1. Click Help > Install New Software on the workbench menu. The Install window opens.
2. Click the What is already installed link. The Installation Details window opens. The Installation History tab shows a list of the previous configurations.
3. Select the configuration that you want to revert to. When you select a configuration, another pane shows the content in that configuration.

Attention: The oldest entry in the list of previous configurations represents the initial z/OS Explorer installation. This configuration has no contents. Do not revert to this configuration. If you do, z/OS Explorer fails and must be completely reinstalled.
4. Click **Revert**. The Revert Software Configuration confirmation dialog is displayed.

5. Click **Yes** to confirm, and when asked to exit and restart the workbench for the changes to take effect.

**Results**

z/OS Explorer reverts to the selected configuration and restarts.

**Related tasks:**

- “Adding a new software update site” on page 28
- “Checking for, and installing, software updates” on page 29
- “Removing an existing software update site” on page 31
- “Importing a list of software update sites”
- “Exporting a list of software update sites” on page 35
- “Select or deselect software sites to check for available software” on page 36

**Importing a list of software update sites**

You can import a list of software update sites that have been exported previously by using the Available Software Sites pane in the Preferences window.

**Procedure**

1. Use the appropriate method to open the Preferences window:
   - Windows or Linux: Click **Window > Preferences** on the workbench menu bar.
   - OS X: Click **IBM Explorer for z/OS > Preferences** on the main menu.
2. In the Preferences window, expand **Install/Update** and click **Available Software Sites**.
3. In the Available Software Sites pane, click **Import**.
4. In the Import Sites window, locate and select the file that contains the list of exported update sites, and click **Open**.

**Results**

The update sites in the file are imported into the product and are added to the list in the Available Software Sites pane.

**Related tasks:**
Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.

You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

You can export one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.

You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

Exporting a list of software update sites

You can export one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.

Procedure

1. Use the appropriate method to open the Preferences window:
   • Windows or Linux: Click Window > Preferences on the workbench menu bar.
   • OS X: Click IBM Explorer for z/OS > Preferences on the main menu.

2. In the Preferences window, expand Install/Update and click Available Software Sites.

3. In the Available Software Sites pane, click and highlight one or more software update sites that you want to export. You can use Ctrl+click (cmd+click for OS X) or Shift+click to select more than one site.

   Note: Do not use the check boxes to select the required software update sites. Any check box selections on this pane are ignored for this action.

4. Click Export.

5. In the Export Sites dialog, select a destination for the exported file. You can provide a new file name or keep the default name.

6. Click Save.

Results

Details of the selected sites are exported to your local file system.

Related tasks:

Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.
You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

You can import a list of software update sites that have been exported previously by using the Available Software Sites pane in the Preferences window.

You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

Select or deselect software sites to check for available software

You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

About this task

This example task shows you how to use the Available Software Sites dialog to select or deselect sites to check for available software updates. All sites registered in z/OS Explorer are shown in the list in the Available Software Sites dialog.

Procedure

1. Click Help > Install New Software on the menu bar. The Install window opens.
2. Click the What is already installed link. The Installation Details window opens. The Installed Software tab shows a list of the installed software.
3. In the Installation Details window, select or deselect software to check for updates.
4. Click Update. z/OS Explorer searches the update site for a newer version of the code. Note that the update site must be defined in the Preferences page. See the related links for information on adding a new software update site.

Results

The sites selected are displayed in the Available Software page. The sites are the only ones that are checked for software updates.

Related tasks:

“Adding a new software update site” on page 28
Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

“Checking for, and installing, software updates” on page 29
You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.

“Removing an existing software update site” on page 31
You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

“Importing a list of software update sites” on page 34
You can import a list of software update sites that have been exported previously by using the Available Software Sites pane in the Preferences window.
You can export one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.

Working with system connections

These example tasks illustrate how you can configure and change your system connections.

Configuring a z/OS FTP system connection

You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

Before you begin

You must have at least one connection credential before you can connect to a system. A credential is a repository for a user ID and password combination. For more information, see Defining connection credentials.

Note: For z/OS Explorer to successfully obtain the required spool files, the FTP.DAT.A configuration file for the server must specify JESINTERFACELEVEL 2. For more information about the JESINTERFACELEVEL parameter, see z/OS Communications Server: IP Configuration Reference.

About this task

By default, the z/OS FTP connection initiates a passive FTP mode connection. You can specify that the connection initiates an active FTP mode connection when you add or edit a z/OS FTP connection. For example, you might do this if your system restricts passive FTP mode connections.

Procedure

1. Click Window > Manage Connections from the main menu for the workbench. The Host Connections view is displayed.
   If your connections are preconfigured, the connections are listed under the categories in the view. If not, the categories are empty. Each z/OS FTP connection is associated with a credential (but not the z/OSMF connection). The credential is shown in parentheses after the connection name.
2. In the Connections section, select the z/OS FTP category and click Add.
3. In the Add z/OS FTP Connection window, enter the FTP host name of your server in the Host name field. As you type, the characters up to the end of the first qualifier are inserted in the Name field. For example, if you enter myserver.example.ibm.com in Host name, myserver is displayed in Name.
4. Optional: To specify a different name, type the name that you require in Name.
5. Optional: To use active FTP mode, select the Active Transfer mode check box.
6. Optional: Select the local and remote character sets to use during file transfer. Use these character sets to override the conversion table defaults of the FTP server when transferring untagged files in ASCII transfer mode. When you save tagged files, if specified, the local code page overrides the default setting for the local encoding. You can also select the file translation table that is located in a data set or z/OS UNIX file. For more information about FTP translation tables, see SBDATACONN (FTP client and server) statement.
7. Optional: You can choose to associate a credential with the connection now. Right-click the connection name and hover over **Set Credentials** to show the credentials available. Click the credential that you want to use for the connection.

8. Complete the other fields for your organization.

9. Click **Save and Close** to save the configuration without connecting or click **Save and Connect** to save the configuration and connect immediately. If you click **Save and Connect**, the Signon window is displayed, where you must select an existing credential to use with this connection, or define a new credential.

**Results**

The connection and associated credential are displayed in the Host Connections view.

**What to do next**

When you connect, z/OS Explorer tries to connect to the system that you configured.

If the connection is successful, the connection name is displayed in the workbench window next to a green icon.

If the connection is not successful, the connection name is displayed in workbench window next to a red icon. An error message is displayed in the workbench status bar providing a reason for the failure. Check the values in the fields, correct any errors, and try to connect again.

**Related concepts:**
- “Connecting to a system that is already defined” on page 42
- When you have defined your system connections there are a number of ways in which you can activate a connection to a system.

**Related tasks:**
- “Configuring a z/OSMF system connection” on page 7
- The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

- “Exporting connections” on page 47
- You can export one or more connections to an external file to back them up or to share with other users. If you save the connection file on a shared disk, or upload it to a web server, users can load the connection details into their z/OS Explorer. Any changes to the shared connection file are picked up automatically the next time the user starts z/OS Explorer.

- “Using shared connections” on page 46
- As an alternative to defining your own connections, you can share a set of connections that are stored in a central location. You can load or import the shared connections into your copy of z/OS Explorer. Sharing connections means that the connections can be managed centrally, and any changes to the connections file are picked up automatically the next time z/OS Explorer starts.
Configuring a proxy server

Service updates for the z/OS Explorer are available on a pre-configured download site on the internet. Your organization might require you to connect to the internet through a proxy server. You can use the Preferences dialog to define a proxy server.

Before you begin

Before proceeding, ensure that you have all the details including the address and port number for your proxy server.

Note: Proxy bypass does not work if you have configured a SOCKS proxy server.

Procedure

1. Use the appropriate method to open the Preferences window:
   - Windows or Linux: Click Window > Preferences on the workbench menu bar.
   - OS X: Click IBM Explorer for z/OS > Preferences on the main menu.
2. Expand General and click Network Connections. The Network Connections pane is displayed in the Preferences window.
3. Select the schema for the proxy type, HTTP, HTTPS, you want to configure and click Edit.
4. Type the address of the proxy, and the port number, in the dialog. If the proxy server requires authentication, select the Enable proxy authentication check box and enter your user name and password. Click OK to close the dialog.
5. Optional: If you have defined a proxy but one or more of the servers you are connecting to does not use the proxy, you must configure a proxy bypass. Click Add Host to open the Proxy bypass hosts dialog. Enter the server host name, for example; mvs23.production.com and click OK. All connections to the configured server will now go direct and not use the proxy.
6. Click Apply to save the configuration.
7. The Active Provider field indicates whether the proxy is used. Select the appropriate setting. There are three choices that can be selected:
   - Native
     Any settings that were discovered in the OS are used. Native is the default setting. When this option is active, no proxy check boxes are selected.
   - Manual
     Any proxy servers defined in this view are used. When this option is active, all proxy check boxes are selected.
   - Direct
     All connections are opened without using proxy servers. When this option is active, no proxy check boxes are selected.
8. Click OK to close the dialog.

What to do next

If you selected Manual in the Active Provider field, the next time z/OS Explorer connects to the internet the connection will go through the proxy server.
Configuring a z/OSMF system connection

The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

Before you begin

z/OSMF in z/OS Explorer uses the z/OS jobs REST interface. For details of the RACF authorizations that are required, see the "Required authorizations" section in the z/OS jobs REST interface in IBM z/OS Management Facility Programming Guide.

You must have at least one connection credential before you can connect to a host system. A credential is a repository for a user ID and password combination. For more information, see Defining connection credentials.

Procedure

1. Click Window > Manage Connections from the workbench menu bar. The Host Connections view is displayed.

   If your connections are preconfigured, you see the connections that are listed under the categories in the view. If not, the categories are empty. In the Host Connections view, one connection is defined in each category type. Each connection is associated with a credential, except for the z/OS FTP connection. The credential is shown in brackets after the connection name.

2. In the Connections section, select the z/OSMF category and click Add. The Add Connection window opens.

3. In the Host name field, enter the host name of your z/OSMF server. As you type, the characters up to the end of the first qualifier are inserted in the Name field. So if your host name is myserver.example.ibm.com then the name would display as myserver.

4. Enter the port number. As you type, the port number is appended to the Name field, so the name is displayed as something like myserver:20332.

5. Optional: You can specify a different name by over typing the name in the Name field.

6. By default the z/OSMF connection also sets up an FTP connection on port 21. If you previously defined a different FTP connection, select it from the FTP Connection list.

7. Complete the other fields for your organization, and click OK.

8. Click Save and Close to save the configuration without connecting or click Save and Connect to save the configuration and connect immediately. If you click Save and Connect, you are presented with the Signon window, where you must select an existing credential to use with this connection, or define a new credential.

Results

The connection and associated credential are displayed in the Host Connections view.
What to do next

When you connect, the z/OS Explorer tries to connect to the system that you configured.

If the connection is successful, the connection name is displayed in the workbench window next to a green icon.

If the connection is not successful, the connection name is displayed in workbench window next to a red icon. An error message is displayed in the workbench status bar providing a reason for the failure. Check the values in the fields, correct any errors, and try to connect again.

Related concepts:
“Connecting to a system that is already defined” on page 42
When you have defined your system connections there are a number of ways in which you can activate a connection to a system.

Related tasks:
“Configuring a z/OS FTP system connection” on page 5
You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

“Exporting connections” on page 47
You can export one or more connections to an external file to back them up or to share with other users. If you save the connection file on a shared disk, or upload it to a web server, users can load the connection details into their z/OS Explorer. Any changes to the shared connection file are picked up automatically the next time the user starts z/OS Explorer.

“Using shared connections” on page 46
As an alternative to defining your own connections, you can share a set of connections that are stored in a central location. You can load or import the shared connections into your copy of z/OS Explorer. Sharing connections means that the connections can be managed centrally, and any changes to the connections file are picked up automatically the next time z/OS Explorer starts.

Defining connection credentials

When you connect to a system, your credentials, that is, your user ID and password or pass phrase, are sent to the system for authentication. After you define a credential, you can use it on all systems that share the credential without reentering the details every time. You must have at least one credential before you can connect to a system.

Before you begin

Ensure that you have all your system connection details and that you have the correct level of authorization to connect to your system.

Procedure

1. On the main menu for the workbench, click Window > Manage Connections. The Host Connections view opens. The available categories in the Host Connections view depend on the plug-ins that are installed in the z/OS Explorer.
2. Click Add in the Credentials section to add a new credential. The New Credentials window opens.
3. Create your credential. You can create credentials in any of the following ways:
• Select **Username and Password** from the drop-down box and enter the credentials name, user ID, and the password or passphrase. If you do not type a name, then the default name that is used is the same as the User ID. Select the **Save Password** check box to save the password.

**Note:** You might have a single user ID, but use different passwords for different systems. In this case, you can define multiple credentials, each one having the same user ID but with a different credential name and password or pass phrase. Alternatively you can choose to define one credential, but not to save the password or pass phrase, in which case you are required to enter them when you connect to a system.

• Select **Username with Multi-Factor Authentication** from the drop-down box and enter the credentials name and user ID. This type of credential can be used with some supported connection types such as a CMCI connection in CICS Explorer. Each new connection attempt prompts you for a new password or passphrase. In the **Password or Passphrase** field, you must specify your password or passphrase coupled with an authentication token. Ask your system administrator how to concatenate your password or passphrase and the authentication token.

• Select **Certificate from Keystore** from the drop-down box, choose a certificate, and enter the appropriate user ID. The keystore contains client certificates that identify the machine to others. To define a keystore file, go to **Window > Preferences > Explorer > Certificate management**. In the **Keystore details** field, to use the same file for both keystore and truststore, select the **Use same details as for truststore** check box. To use a different file, leave the check box cleared and enter the path and file name of the keystore, and the passphrase.

• Insert a smart card and then select **Certificate from Smart card** from the drop-down box, choose a certificate, and enter the appropriate user ID. A smart card is a hardware device that requires a software driver. To configure smart card support system, go to **Window > Preferences > Explorer > Certificate management**. In the **Smart card details** field, select **Use Windows cryptography services** for the Windows operating system, which uses the standard Windows cryptography mechanism. To use a PKCS11 driver (mandatory on Mac OS and Linux operating systems), select **Use PKCS11 driver** and specify the driver path and PIN.

**Note:** You can use certificate credentials for SSL-secured connections on supported connection types.

4. Click **OK** to save the credential or **Cancel** to cancel the process and close the window without saving the credential.

**What to do next**

You can click **Add** in the Connections section of the Host Connections view to configure a system connection.

**Connecting to a system that is already defined**

When you have defined your system connections there are a number of ways in which you can activate a connection to a system.

**Connecting to a system from the Host Connections view**

After you define your system connections, you can activate a connection from the Host Connections view.
Before you begin

Before you connect to a system, you must have at least one connection configured.

Procedure
1. If the Host Connections view is not open, click **Window > Manage Connections** on the main menu for the workbench to open the view.
2. In the Host Connections view, expand the tree in the Connections section and locate the system that you want to connect to.
   
   For a default connection in a connection category, you can just locate the connection category. For more information about default connections, see “Connecting automatically at startup” on page 44.
3. Either select the system, then click **Connect**, or right-click the system, then click **Connect** on the menu.
   
   To connect to a default connection in a connection category, either select the connection category, then click **Connect**, or right-click the connection category, then click **Connect** on the menu.
   
   z/OS Explorer attempts to connect to the system you select. If you were already connected to the system you selected, z/OS Explorer reconnects.
4. Optional: If you did not previously enter your password or pass phrase, use the dialog to enter it, then click **OK**.

What to do next

If the connection is successful, the connection name is displayed in the connection status bar in the lower-right corner of the workbench. For an SSL connection, the **Secure Connection** icon is displayed. For a non-SSL connection, the **Connected** icon is displayed.

If the connection is not successful, the connection name is displayed in the connection status bar and the **Disconnected** icon is displayed. An error message is displayed in the workbench status bar that provides a reason for the failure. Correct any errors as indicated and retry the procedure.

**Related tasks:**

“Updating a system connection” on page 47

If any system connection settings change, you must update the connection details in the Host Connections view to reflect the changes.

**Connecting to a system by using Signon**

When your system connections are defined, you can activate a connection by using Signon in the Explorer menu.

**Before you begin**

Before you can connect to a system, you must have at least one connection configured. The Signon option connects to the system name shown in the connection status bar, which is in the lower-right corner of the workbench. If the system name to which you want to connect is not showing in the connection status bar, select the system name from the list.

Procedure
1. Click **File > Signon** on the main menu for the workbench. z/OS Explorer attempts to connect to the system indicated in the connection status bar.
2. Optional: If you did not previously enter your password or pass phrase, use the dialog to enter it, then click OK.

Results

If the connection is successful, the connection name is displayed in the connection status bar. For an SSL connection, the Secure Connection icon is displayed. For a non-SSL connection, the Connected icon is displayed.

If the connection is not successful, the connection name is displayed in the connection status bar and the Disconnected icon is displayed. An error message is displayed in the workbench status bar that provides a reason for the failure. Check the values in the fields, correct any errors in the connection details, and click Connect to test the corrections.

Connecting to a system from the connection status bar

After you define your system connections, you can activate a connection from the connection status bar.

Before you begin

Before you connect to a system, you must have at least one connection configured. The currently selected system name is shown in the connection status bar, which is in lower-right corner of the workbench.

Procedure

1. Activate the connection in one of the following ways:
   - If the system name that you want to connect to is displayed in the connection status bar, click the icon by the system name.
   - If the system name that you want to connect to is not displayed in the connection status bar, click the arrow by the icon, then click the system that you require.

   z/OS Explorer attempts to connect to the system shown in the connection status bar.

2. Optional: If you did not previously enter your password or pass phrase, use the dialog to enter it, then click OK.

Results

If the connection is successful, the connection name is displayed in the connection status bar. For an SSL connection, the Secure Connection icon is displayed. For a non-SSL connection, the Connected icon is displayed.

If the connection is not successful, the connection name is displayed in the connection status bar and the Disconnected icon is displayed. An error message is displayed in the workbench status bar that provides a reason for the failure. Check the values in the fields, correct any errors in the connection details, and click Connect to test the corrections.

Connecting automatically at startup

You can set one connection in each connection category as the default. You can then connect to the default connection for a category, or use these default connections for automatic connection when you start z/OS Explorer.
About this task

You can set one or more connections as the default, then set whether to connect automatically to the default connections when you start z/OS Explorer.

z/OS Explorer has a single connection category of z/OS, which includes two connection types: z/OS FTP and z/OSMF. You can set one connection in this category as the default.

When additional plug-ins are installed, the corresponding additional connection categories are available and you can set one default connection in each connection category that is shown.

Procedure

1. If the Host Connections view is not open, click **Window > Manage Connections** from the workbench menu to open the view.
2. In the Host Connections view, expand the tree in the Connections section and locate the connection you want to set as default.
3. Right-click the connection, then click **Set as default connection**. Default is shown in parentheses after the connection name and the credentials, and the connection name is shown in parentheses after the connection category.
4. Repeat the previous two steps for each additional connection in a different category that you want to set as default.
5. To connect to the default connections automatically when you start z/OS Explorer, click the **Automatically connect to defaults on startup** icon in the toolbar of the view.

Results

Your change is effective the next time that you start z/OS Explorer.

What to do next

You can stop using a connection automatically at startup in two ways:

- Remove the default setting from the connection.
- Click the **Automatically connect to defaults on startup** icon to stop automatic connection to all default connections.

Related tasks:

- “Connecting to a system from the Host Connections view” on page 42
  After you define your system connections, you can activate a connection from the Host Connections view.
- “Removing a default setting from a category or connection” on page 48
  If a connection is set as default, you can remove that default setting so that it is not used for automatic connection when you start z/OS Explorer.
- “Configuring a z/OS FTP system connection” on page 5
  You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.
- “Configuring a z/OSMF system connection” on page 7
  The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the
connection that is most suitable for the task you are performing.

**Using shared connections**

As an alternative to defining your own connections, you can share a set of connections that are stored in a central location. You can load or import the shared connections into your copy of z/OS Explorer. Sharing connections means that the connections can be managed centrally, and any changes to the connections file are picked up automatically the next time z/OS Explorer starts.

**About this task**

Typically, a system administrator uses z/OS Explorer to define shared connections and export them to a central location where other users can access them. The exported file must have a file type of .pref, for example, connections.pref. Any user with access to the file location can load or import the connections in their copy of z/OS Explorer.

When you load connections, a link is created to an external connections file, and the connections are shown in the Host Connections view. You can view the connections but you cannot change them. If the shared connections file changes, those changes are reflected next time z/OS Explorer starts. If the shared connections file is deleted or moved, the connections are lost from z/OS Explorer.

When you import connections, the connections are copied into your local workspace and the connections are shown in the Host Connections view. If any details of the connection change, you must update them locally. If you import a connection that already exists in z/OS Explorer and is associated with a credential, only the existing connection details are updated; the credential is unchanged.

**Procedure**

1. Start from the Host Connections view. To open this view, click **Window > Manage Connections** on the main menu for the workbench.
2. Click the **Load Connections from file or URL** icon in the toolbar of the view.
3. In the Load Connections window, type, or browse for, the location of the connections file that you want to load or import. The connection file must have a file type of .pref, and the location can be a file path or a URL.
4. Select **Load** or **Import** and click **OK**. The connections are loaded or imported.

**What to do next**

You can now use the loaded or imported connections to connect to a host system. You must have a credential defined before you can connect. If you have not defined any credentials, you are prompted to create one when you attempt to connect. For more information, see the related links.

**Related concepts:**

“Connecting to a system that is already defined” on page 42

When you have defined your system connections there are a number of ways in which you can activate a connection to a system.

**Related tasks:**
When you connect to a system, your credentials, that is, your user ID and password or pass phrase, are sent to the system for authentication. After you define a credential, you can use it on all systems that share the credential without reentering the details every time. You must have at least one credential before you can connect to a system.

### Updating a system connection

If any system connection settings change, you must update the connection details in the Host Connections view to reflect the changes.

#### Before you begin

Ask your system administrator for the changed connection details for the system to which you want to connect, and then use the following procedure.

#### Procedure

1. If the Host Connections view is not already open, click **Window > Manage Connections** on the main menu for the workbench.
2. In the Host Connections view, expand the tree in the Connections section and click the connection that you want to update. Click **Edit**.
3. In the Edit Connection window, change the information as required, and click **OK** to save the changes. If the connection you changed is your current connection, z/OS Explorer attempts to connect to the system with the changed details. If you did not previously enter your password or pass phrase, you are asked to enter it at this time.
   - If the connection you have changed is not your current connection, you must click **Connect** to connect.

#### Results

If the connection is successful, the connection name appears in the connection status bar, which is in the lower-right corner of the workbench. The connection status icon is green, indicating a successful connection.

If the connection is not successful, the connection name appears in the connection status bar, which is in the lower-right corner of the workbench. The connection status icon is red, indicating that the connection was not successful. An error message is displayed in the workbench status bar providing a reason for the failure. Check the values in the fields, correct any errors, and click **Connect** to test the corrections.

### Exporting connections

You can export one or more connections to an external file to back them up or to share with other users. If you save the connection file on a shared disk, or upload it to a web server, users can load the connection details into their z/OS Explorer. Any changes to the shared connection file are picked up automatically the next time the user starts z/OS Explorer.

#### About this task

You can export some or all of your connections to an external file. You can export connections that you created locally, and connections that you have imported. The file can be used by an individual user, or shared among many users.
**Note:** RSE connections cannot be exported with the method specified in this topic. Refer to the Remote System Explorer Profiles topic and the Creating a second profile topic in the Generic RSE User's Guide for creating and duplicating RSE profiles.

**Procedure**

1. Start from the Host Connections view. To open this view, click **Window > Manage Connections** on the main menu of the workbench.
2. Click the **Export Connections to File** icon in the toolbar of the view.
3. In the Export Connections to File window, select the connections that you want to export from the list of locally created and statically imported connections. You can expand and collapse the list, and use the following icons and buttons:
   - **Expand All** icon. Expand the connection types and show all the connections.
   - **Collapse All** icon. Collapse the connections and show only the connection types.
   - **Show Links** icon. Show the connections that are loaded from an external connections file.
   - **Select All**. Select all the connections.
   - **Deselect All**. Deselect all the connections.
4. Optional: Type, or browse for, a location and file name for the exported file in **File Location**. By default, the file is named *my_connections.pref* and is saved in your current workspace. You must use a file type of *pref*.
5. Click **OK**. The selected connections are exported as an XML file with a file type of *pref*. The file is saved at the specified location.

**What to do next**

You can now share your connections with other users. If you place the file in a central location, other users can load or import the connections into their copy of z/OS Explorer.

It is possible, but not advisable, to edit the file in a text editor. If you change the connection information in the file, you must maintain the structure, otherwise the import, or load might fail. The connection IDs are generated and used by z/OS Explorer, and any changes to the IDs might cause the connections to fail.

**Related tasks:**

- [“Using shared connections” on page 46](#)

As an alternative to defining your own connections, you can share a set of connections that are stored in a central location. You can load or import the shared connections into your copy of z/OS Explorer. Sharing connections means that the connections can be managed centrally, and any changes to the connections file are picked up automatically the next time z/OS Explorer starts.

**Removing a default setting from a category or connection**

If a connection is set as default, you can remove that default setting so that it is not used for automatic connection when you start z/OS Explorer.

**About this task**

One connection in each connection category can be set as the default. You can remove the default setting from a connection so that it is not used for automatic connection when you start z/OS Explorer.
Procedure

1. If the Host Connections view is not open, click Window > Manage Connections from the workbench menu to open the view.

2. In the Host Connections view, expand the tree in the Connections section and locate the connection category or connection that is currently set as default.

3. Right-click the connection category or connection, then click Remove from default connections. Default is no longer shown in parentheses after the connection name and the credential.

4. Repeat the previous two steps for each additional connection in a different category that you want to remove the default setting from.

Results

The connection and its associated credentials remain, but it is no longer the default connection for that connection category. Any other connections in a different category that are set as default are unaffected.

Related tasks:

“Connecting automatically at startup” on page 44
You can set one connection in each connection category as the default. You can then connect to the default connection for a category, or use these default connections for automatic connection when you start z/OS Explorer.

“Configuring a z/OS FTP system connection” on page 5
You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

“Configuring a z/OSMF system connection” on page 7
The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

Deleting a system connection

If you no longer need one of your system connections, you can delete it permanently from the z/OS Explorer. You can delete only connections that you have created or imported into z/OS Explorer. You cannot delete connections that are loaded from a shared connection definition file.

Procedure

1. If the Host Connections view is not already open, click Window > Manage Connections on the main menu of the workbench. The Host Connections view is displayed.

2. Expand the tree in the Connections section and click the connection you want to delete.

3. Click Delete.

Results

The connection is removed from the list of connection names.
Disconnecting from a system

To disconnect the z/OS Explorer from your current system connection, you can use the connection status bar or the main menu of the workbench.

Procedure

To disconnect the z/OS Explorer from the current system connection, choose one of the following methods:

- Click the icon in the connection status bar, which is in lower-right corner of the workbench. The icon is green for a non-SSL connection, or a padlock for an SSL connection.
- Click File > Signoff on the main menu of the workbench.

What to do next

The z/OS Explorer is disconnected from the system and the icon in the connection status bar, which is in the lower-right corner of the workbench, changes to a red square. To reconnect, or connect to another system, see the related link.

Related concepts:

"Connecting to a system that is already defined” on page 42

When you have defined your system connections there are a number of ways in which you can activate a connection to a system.

Working with z/OS UNIX files

You can use z/OS Explorer to manage z/OS UNIX files, including creating, changing, and deleting files. These topics explain how to work with z/OS UNIX files.

Changing z/OS UNIX file and directory permissions

Depending on the function you are trying to perform, you might want to change the access permissions for a file or a directory in the z/OS UNIX file system. You can change the permissions using z/OS Explorer.

About this task

This task explains how to change the permissions on a z/OS UNIX file or directory.

Procedure

1. In the z/OS UNIX Files view, right-click the file or directory for which you want to change the permissions and click Properties. The Properties window is displayed, showing the current access settings of the file or directory.
2. If this file is to be exported, you can specify whether the file is treated as ASCII or binary by setting the Transfer mode.
3. Select the access permissions required by selecting or deselecting the Read, Write, and Execute check boxes in the Owner, Group, and Other permission groups.
4. Click Apply to apply the settings without closing the dialog, or click OK to apply the settings and close the dialog.
Results

The access permissions are applied to the file or directory.

Creating a new z/OS UNIX file

You can use z/OS Explorer to create a new file in a directory in your z/OS UNIX file system.

Before you begin

Ensure that you are in the z/OS perspective.

Ensure that you are connected to an FTP server on your host system.

Procedure

1. In the z/OS UNIX Files view, navigate to the directory where you want to create the new file.
2. Right-click the directory name and click New File. The New z/OS file window shows the contents of the selected directory.
3. Optional: Either navigate to a different directory, or type the name of a different directory in the parent directory field. You must type the name of an existing directory.
4. Type the new file name in New file name, then click Finish.

Results

The new file is created in the selected directory and displayed in the z/OS UNIX files view.

Related tasks:

“Configuring a z/OS FTP system connection” on page 5

You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

Creating a new z/OS UNIX directory

You can use z/OS Explorer to create a new directory in your z/OS UNIX file system. You can then edit the member and copy and paste content from other members.

Before you begin

Ensure that you are in the z/OS perspective.

Ensure that you are connected to an FTP server on your host system. For more information, see the related links later in this topic.

Procedure

1. Right-click anywhere in the z/OS UNIX Files view and click New z/OS directory. The New z/OS directory window shows the contents of the home directory.
2. Either navigate to and select the parent directory in the list, or type the name of the parent directory in the parent directory field. You must type the name of an existing directory.
3. Type the new directory name in New directory name, then click Finish.
Results

The new directory is created and displayed in the z/OS UNIX files view.

Related tasks:
“Configuring a z/OS FTP system connection” on page 5

You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

Editing z/OS UNIX files

You can use z/OS Explorer to open a file in your z/OS UNIX file system and edit the contents. When your changes are complete, you can save the file if you are authorized to do so. You can also use the Save As action to save the changes with a different file name or file path.

To open a file for editing, locate the file in the z/OS UNIX Files view. Either double-click the file, or right-click the file then click Open. The file opens in an editor view.

Important: When you open a file for editing, z/OS Explorer places a copy of the file in your local workspace. When you save the file, z/OS Explorer replaces the file in the z/OS UNIX file system with the copy from your workspace. If the file in the file system has changed since z/OS Explorer took the copy, for example, another user has made and saved changes, the file in the file system is overwritten and the other user's changes are lost.

You can refresh the content of the file in your workspace at any time by pressing F5. This action synchronizes your copy with the server copy, but any local changes that you have made but not saved are lost and you must reapply them. If the file has unsaved edits, the refresh action is disabled to avoid you losing your changes.

The workbench status bar shows three fields that provide more details about the file: whether the file is writable, whether the editor is in insert mode, and the current position of the text cursor (row_number : column_number).

Note: A z/OS UNIX file is shown as writable even if the file permission is read-only. This is because you can edit the file and save it with a different name, or in a different location, by using the Save As action.

To display line numbers in the editor, right-click the vertical bar at the left-side of the view, then click Show Line numbers.

When you change a file, an asterisk is displayed in front of the file name in the view title to indicate that the file contents have changed but are not saved.

The following editing actions are available from the Edit menu on the main menu for the workbench, or the right-click menu options in the view:

Table 4. Edit menu actions

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
<th>Keyboard shortcut (Windows and Linux)</th>
<th>Keyboard shortcut (OS X)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo typing</td>
<td>Undo the last change in the editor</td>
<td>Ctrl+Z</td>
<td>cmd+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Redo the previous change that was undone</td>
<td>Ctrl+Y</td>
<td>shift+cmd+Z</td>
</tr>
</tbody>
</table>
### Table 4. Edit menu actions (continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
<th>Keyboard shortcut (Windows and Linux)</th>
<th>Keyboard shortcut (OS X)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Copies the currently selected text or element to the clipboard and removes the element. On elements, the remove is not performed before the clipboard is pasted.</td>
<td>Ctrl+X</td>
<td>cmd+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the currently selected text or elements to the clipboard</td>
<td>Ctrl+C</td>
<td>cmd+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Paste the current content as text to the editor, or as a sibling or child element to the currently selected element.</td>
<td>Ctrl+V</td>
<td>cmd+V</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete the current text or element selection.</td>
<td>Delete key</td>
<td>Delete key</td>
</tr>
<tr>
<td>Find Next</td>
<td>Finds the next occurrence of the currently selected text.</td>
<td>Ctrl+K</td>
<td>cmd+K</td>
</tr>
<tr>
<td>Find Previous</td>
<td>Finds the previous occurrence of the currently selected text.</td>
<td>Ctrl+Shift+K</td>
<td>shift+cmd+K</td>
</tr>
<tr>
<td>Incremental Find Next</td>
<td>Starts the incremental find mode. After invocation, enter the search text. As you type the cursor moves to the character position after the cursor position that matches the text you type. The text you type is shown in the status bar.</td>
<td>Ctrl+J</td>
<td>cmd+J</td>
</tr>
<tr>
<td>Incremental Find Previous</td>
<td>Starts the incremental find previous mode. After invocation, enter the search text. As you type the cursor moves to the character position before the cursor position that matches the text you type.</td>
<td>Ctrl+Shift+J</td>
<td>shift+cmd+J</td>
</tr>
<tr>
<td>Show Tooltip Description</td>
<td>Not in use</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Word Completion</td>
<td>Proposes word completions for the current string based on all words found in any open editor.</td>
<td>Alt+/</td>
<td>ctrl+.</td>
</tr>
</tbody>
</table>

### Table 5. View context menu actions

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
<th>Keyboard shortcut (Windows and Linux)</th>
<th>Keyboard shortcut (OS X)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo typing</td>
<td>Undo the last change in the editor</td>
<td>Ctrl+Z</td>
<td>cmd+Z</td>
</tr>
<tr>
<td>Revert File</td>
<td>Revert the content of the current editor back to the content of the last saved file. Disabled if the editor does not contain unsaved changes.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td>Save the content of the current editor. Disabled if the editor does not contain unsaved changes.</td>
<td>Ctrl+S</td>
<td>cmd+S</td>
</tr>
</tbody>
</table>
Table 5. View context menu actions (continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
<th>Keyboard shortcut (Windows and Linux)</th>
<th>Keyboard shortcut (OS X)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save As</td>
<td>Save the content of the current editor as a different file name, or at a different location. Disabled if the editor does not contain unsaved changes.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show In</td>
<td>Not in use</td>
<td>Alt+Shift+W</td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Copies the currently selected text or element to the clipboard and removes the element. On elements, the remove is not performed before the clipboard is pasted.</td>
<td>Ctrl+X</td>
<td>cmd+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the currently selected text or elements to the clipboard</td>
<td>Ctrl+C</td>
<td>cmd+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Paste the current content as text to the editor, or as a sibling or child element to the currently selected element.</td>
<td>Ctrl+V</td>
<td>cmd+V</td>
</tr>
</tbody>
</table>

When your edits are complete, save your changes:
- To save your changes to the same file, click the **Save** icon on the z/OS Explorer toolbar.
- To save the file with a different file name or in a different location, right-click in the editor view and click **Save As**.

To close the editor, click the **Close** icon in the editor view tab. If you try to close the editor with unsaved file changes, the Save Resource dialog is displayed so that you can choose whether to save your changes.
Chapter 5. z/OS views

These topics provide reference information about the z/OS views.

The Console view

The Console view provides a history of the actions you have performed, such as submitting a job, or changing and saving a file.

The console view is displayed in the z/OS perspective. Every time you submit a job or change a file, an entry is recorded in the Console as a history of your actions.

For a data set entry, you can click the hyperlink to open the data set. For a job entry, you can click the hyperlink to show the completed or running job in the z/OS Job view.

The information shown is not saved when z/OS Explorer closes.

You can use the Timestamp icon to show, or hide, timestamps in the Console view. The action is effective only for entries after the icon is clicked.

A number of icons are available in the Console view:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Clear Console icon" /></td>
<td>The Clear Console icon clears the contents of the console.</td>
</tr>
<tr>
<td><img src="image" alt="Pin icon" /></td>
<td>When you have more than one console active, the Pin icon pins the current console so that it is shown in precedence to all the other consoles.</td>
</tr>
<tr>
<td><img src="image" alt="New console icon" /></td>
<td>The New console icon opens a new console.</td>
</tr>
<tr>
<td><img src="image" alt="Timestamp icon" /></td>
<td>The Timestamp icon displays or hides timestamps for all future entries in the Console view.</td>
</tr>
<tr>
<td><img src="image" alt="Scroll Lock icon" /></td>
<td>The Scroll Lock icon disables or enables scrolling in the Console view.</td>
</tr>
</tbody>
</table>

The Data Sets view

When you are connected to a z/OS system, the Data Sets view lists all the data sets that you are authorized to view and that match the data set name qualifier you specify. You can open a data set to view the members. You can edit Partitioned Data Set (PDS) members that contain text, but you cannot edit PDS members that contain binary code.

Before you can view any data sets, you must be connected to an FTP server on your host system. For further information about configuring system connections, see the related links.
To view data sets, enter the dsname qualifier in the **Qualifier** field and press Enter. You must specify at least the full first-level qualifier.

For non-VSAM files, the Data Sets view shows the same information as when you use the Data Set list utility from ISPF and use the same qualifier. For VSAM files, only a single entry is shown. Data sets are listed by dsname qualifier.

To copy the fully qualified name of one or more data sets, select the required data sets from the list, right-click, then click **Copy Qualified Name**. The names are copied to the clipboard and are available for you to paste to the destination you require, for example an editor or another window.

Each data set type is indicated by an icon. The following table lists types of data sets and their icons:

**Table 7. Data set types and icons.** This table lists the data set types and icons.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Data set type</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Unavailable data set. The data set might be not found or migrated, the volume might not available, or you might not be authorized to access the data set.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Partitioned data set (PDS).</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Partitioned data set member.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Sequential data set.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>VSAM data set.</td>
</tr>
</tbody>
</table>

**Related concepts:**

[“Working with data sets” on page 19](#)

There are a number of actions you can perform against data sets. These topics explain the actions an how to work with data sets.

**Related tasks:**

[“Configuring a z/OSMF system connection” on page 7](#)

The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

**The Error Log view**

The Error Log view is provided for information only and displays the warnings and errors that z/OS Explorer logs.

The log file is for use by your IBM service representative to analyze problems with z/OS Explorer.

To access the Error Log view, click **Window > Show View > Error Log**.

The underlying log file is a .log file stored in the .metadata subdirectory of the workspace.
Typically, the log does not contain errors, and if it does, you might need to contact your IBM Service representative for advice.

The message icons used in the view are shown in the following table:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>i</td>
<td>Information</td>
</tr>
<tr>
<td>!</td>
<td>Warning</td>
</tr>
<tr>
<td>✖</td>
<td>Error</td>
</tr>
<tr>
<td>x</td>
<td>Delete</td>
</tr>
<tr>
<td>!</td>
<td>Filter</td>
</tr>
</tbody>
</table>

The following icons are available in the toolbar of the view:

- **Export Log**
  Export the log file to a new file. The log file can become large, and you might want to delete it. You can use this option to export the file and archive it before you delete the original file.

- **Import Log**
  Import a log file and display it in the Error Log view. For example, you can view a log file that you archived previously.

- **Clear Log Viewer**
  Clear the Error Log view. The log file is not changed. To restore the Error Log view, click **Restore Log**.

- **Delete Log**
  Delete the contents of the log file. You might want to perform this action when the log becomes very large. When the log is deleted, it can not be restored.

- **Open Log**
  Open the current log file in a separate view. If the current log file has been deleted, the icon is not available.

- **Restore Log**
  Restore the log file if you cleared the Error Log view previously.

- **Restore Workspace Log**
  Restore the current log file if you are viewing a previously exported log file.

You can customize the contents of the Error Log view by using the following menu options:

- **Group By**
  Choose how the items in the Error Log view are ordered. You can order them by session, plug-in name, or in the order that they appear in the log file.

- **Filters**
  Choose the type of events to display, the number of events, and the session during which they occur.
Activate on new events
Create a log entry when a new event occurs.

Show text filter
Show or hide the text filter field. You can use the filter text field to search the error log for a specific event by using a simple text string.

The Host Connections view

You can use the Host Connections view to create and manage system connections and login credentials. You can import or load shared connections from an external file or URL, and export connections to a file. You can set default connections, and set whether to connect automatically to default connections at startup.

To open the Host Connections view, click Window > Manage Connections on the main menu for the workbench.

The view shows the default connection category of z/OS and the default connection types of z/OS FTP and z/OSMF. Depending on which additional plug-ins are installed in z/OS Explorer, the view shows the corresponding additional connection categories and connection types.

Each connection that you define can be associated with a credential. The credential is indicated in parentheses after the connection name.

One connection in each connection category can be set as the default. Default is shown in parentheses after the connection name and the credentials, and the connection name is shown in parentheses after the connection category.

You can use the following icons in the toolbar of the view:

- **Expand All** icon .expand_more. Expand the connection types in the view and show all the connections.
- **Collapse All** icon .expand_less. Collapse the connections in the view and show only the connection types.
- **Create Connection** icon . Create a connection. By default, the options to create a z/OS FTP connection and a z/OSMF connection are available. Options to create other connection types are available when the relevant plug-in is installed in z/OS Explorer.
- **Automatically connect to defaults on startup** icon . Connect automatically to the connections that are set as default when z/OS Explorer starts.
- **Show Links** icon .expand_more. Show connections that are loaded from an external connections file.
- **Load Connections from file or URL** icon .expand_more. Load or import connections from an external connections file or URL.
- **Export Connections to File** icon . Export connections to an external connections file.

For more information about working with connections, see the related links.

Related tasks:

- “Configuring a z/OS FTP system connection” on page 5

You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.
The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

You can export one or more connections to an external file to back them up or to share with other users. If you save the connection file on a shared disk, or upload it to a web server, users can load the connection details into their z/OS Explorer. Any changes to the shared connection file are picked up automatically the next time the user starts z/OS Explorer.

As an alternative to defining your own connections, you can share a set of connections that are stored in a central location. You can load or import the shared connections into your copy of z/OS Explorer. Sharing connections means that the connections can be managed centrally, and any changes to the connections file are picked up automatically the next time z/OS Explorer starts.

When you connect to a system, your credentials, that is, your user ID and password or pass phrase, are sent to the system for authentication. After you define a credential, you can use it on all systems that share the credential without reentering the details every time. You must have at least one credential before you can connect to a system.

The Jobs view

The Jobs view lists the completed and running jobs that you are authorized to view and that match the job name prefix and owner ID that you specify. The number of jobs you can see in the view depends on the JESENTRYLIMIT value that is set in the FTP server; the default value is 200. You can expand a job in the view to show the ddnames that are associated with the spool files, and open the spool files in an editor view to show the content.

Since z/OS Explorer Version 3.0.1, you can update the status of a selected job in the job view when you press Refresh or F5 on the job. If a job spool is opened in an editor for that particular job, the job spool is also updated with the latest entries.

Before you can view any jobs, you must be connected to an FTP server on your host system. For more information about configuring system connections, see the related links.

To view jobs, enter the job name prefix in the Job Name field and the owner ID in the User field, then press Enter. You can use one or more wildcards in the Job Name or User fields to refine the results. You can use the following wildcard:
* A single asterisk indicates that at least one character must occupy that position. A single asterisk in the field indicates that zero or more characters can occupy that position. For example:
  - USER290* finds data sets that start with USER290 and that have any character in position eight, for example, USER290A or USER290B.
  - USER* finds data sets that start with USER and that have one or more following characters, for example, USER270, USER280, or USER290.
If JESINTERFACELEVEL is set to 1, the FTP server can retrieve jobs for the signed-on user and for job names starting with the user name only. Therefore, in the Jobs view, the **Job Name** field is set to the user ID with a trailing *, which is not editable, and the **User** field is set to the user ID, which is not editable. A job cannot be expanded because the FTP server cannot return a list of the ddnames if JESINTERFACELEVEL is set to 1. However, you can open the complete job spool, and see the ddnames and the output for each step that combined together.

The Jobs view shows the same information as when you view jobs in the Held Output Queue in ISPF and use the same job name prefix. You can click the **Menu** icon and choose to display all jobs or only output, active, or input jobs.

To copy the fully qualified name of one or more jobs, select the required jobs from the list, right-click, then click **Copy Qualified Name**. The names are copied to the clipboard and are available for you to paste to the destination you require, for example an editor or another window.

Each job is indicated by an icon. The following table lists the icons available in this view:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📀</td>
<td>The Job icon. The icon is followed by the Job name and the Job ID.</td>
</tr>
<tr>
<td>🚂</td>
<td>The icon for a job that has not run successfully.</td>
</tr>
<tr>
<td>🚶</td>
<td>The icon for a job that is running.</td>
</tr>
</tbody>
</table>

**Table 8. Job icons**

**Related tasks:**

"Configuring a z/OS FTP system connection" on page 5
You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.

"Configuring a z/OSMF system connection" on page 7
The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

**The z/OS Jobs view**

When you are connected to a z/OS system the z/OS Jobs view shows all the output data sets for a specified job. The job name can be entered in the Job ID field or the **Link to Selection** button can be selected so that any job that is selected in the Jobs view is automatically displayed in the z/OS Job view. When you select an output data set in the z/OS view, the content of the data set is displayed in the view.

If JESINTERFACELEVEL is set to 1, the job output cannot be retrieved and shown in the z/OS Jobs view.
You can view jobs when you are connected through FTP or z/OSMF. If the job status is ACTIVE, you must be using a z/OSMF connection to view its output or ddnames. See the related link later in this topic for more information about configuring system connections.

To show the output data sets for a job, enter the job ID in the Job ID field. Alternatively, select the Link to Selection button, then select a job in the Jobs view. When the Link to Selection button is selected, clicking a job in the Jobs view shows the output data sets for that job in the z/OS Job view. If you submit a job while the Link to Selection button is selected the job output is shown in the z/OS Job view.

You can refresh the contents of the z/OS Jobs view by pressing F5. If the job is still active, the view is updated. If the job is not active, a message is displayed indicating that the job has completed.

When the content is displayed, the pane scrolls to the last record in the data set.

When you select a data set, if the contents reference a data set name, you can hold down the Ctrl key on the keyboard and hover over the text. The text changes to a hyperlink. Clicking the hyperlink opens the data set in an editor where you can browse or change the content.

**Related tasks:**

“Configuring a z/OSMF system connection” on page 7

The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

---

**The z/OS UNIX Files view**

When you are connected to a z/OS system, the z/OS UNIX Files view shows the zFS file system structure and contents. The files are shown in a tree structure and you can expand the tree to show individual files.

Before you can view any z/OS UNIX files or directories, you must be connected to an FTP server on your host system. For more information about configuring system connections, see the related links.

When you connect to a system, the z/OS UNIX Files view shows the structure tree for the root directory of the z/OS system to which you are connected. To find files, you can expand the branches of the tree, or you can type the path in the Path field in the view menu bar, for example, /u/user290.

If a file name or directory name contains special characters, z/OS Explorer does not display those special characters, but shows them as question marks (?). For example, a z/OS UNIX file name of hello¬¬ is shown as hello?? in the z/OS UNIX view.

To copy the fully qualified name of one or more files or directories, select the required files or directories from the list, right-click, then click **Copy Qualified Name**. The names are copied to the clipboard and are available for you to paste to the destination you require, for example an editor or another window.
Viewing hidden files

By default, the z/OS UNIX Files view shows only files that have a file name. Files with only a file extension are hidden.

To show the hidden files, click the Menu icon ☰ then click Show hidden files.

Related concepts:
- “Working with z/OS UNIX files” on page 50
You can use z/OS Explorer to manage z/OS UNIX files, including creating, changing, and deleting files. These topics explain how to work with z/OS UNIX files.

Related tasks:
- “Configuring a z/OS FTP system connection” on page 5
You must have an FTP or z/OSMF connection to use the views in the z/OS perspective.
- “Configuring a z/OSMF system connection” on page 7
The z/OS Management Facility (z/OSMF) is a product for z/OS that provides support for a modern, web-based management console for z/OS, and extends the functions of the z/OS Explorer. You must have a z/OSMF connection to use the features of z/OSMF. When you define a z/OSMF system, z/OS Explorer attempts to create an FTP connection at the same time. z/OS Explorer then chooses the connection that is most suitable for the task you are performing.

The Properties view

The Properties view displays all the properties, or attributes, of the selected resource.

When you open a view in the IBM Explorer for z/OS, the initial display shows the resources in the chosen scope. The initial view displays only a subset of the properties for the resources. To display all the properties, select a specific resource from the list, and click the Properties view tab.

The Properties view shows all the properties, and their values, for the resource.

The grouping of the properties depends on the resource selected.

Shortcut keys

z/OS Explorer has a number of shortcut keys that can help to increase your productivity.

Table 9. Shortcut key combinations

<table>
<thead>
<tr>
<th>Function</th>
<th>Key combination (Windows and Linux)</th>
<th>Key combination (OS X)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activate editor</td>
<td>F12</td>
<td>cmd+F12</td>
</tr>
<tr>
<td>Close all editors</td>
<td>Ctrl+Shift+W</td>
<td>shift+cmd+W</td>
</tr>
<tr>
<td>Close editor</td>
<td>Ctrl+W</td>
<td>cmd+W</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C or Ctrl+Ins</td>
<td>cmd+C</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td>cmd+X</td>
</tr>
<tr>
<td>Help</td>
<td>F1 (Windows) or Ctrl+F1 (Linux)</td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Key combination (Windows and Linux)</td>
<td>Key combination (OS X)</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-------------------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Maximize active view or editor</td>
<td>Ctrl+M</td>
<td>ctrl+M</td>
</tr>
<tr>
<td>New</td>
<td>Ctrl+N</td>
<td>cmd+N</td>
</tr>
<tr>
<td>Next editor</td>
<td>Ctrl+F6</td>
<td>cmd+F6</td>
</tr>
<tr>
<td>Next perspective</td>
<td>Ctrl+F8</td>
<td>cmd+F8</td>
</tr>
<tr>
<td>Next view</td>
<td>Ctrl+F7</td>
<td>cmd+F7</td>
</tr>
<tr>
<td>Open resource</td>
<td>Ctrl+Shift+R</td>
<td>shift+cmd+R</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td>cmd+V</td>
</tr>
<tr>
<td>Previous editor</td>
<td>Ctrl+Shift+F6</td>
<td>shift+cmd+F6</td>
</tr>
<tr>
<td>Previous perspective</td>
<td>Ctrl+Shift+F8</td>
<td>shift+cmd+F8</td>
</tr>
<tr>
<td>Previous view</td>
<td>Ctrl+Shift+F7</td>
<td>shift+cmd+F7</td>
</tr>
<tr>
<td>Quick access</td>
<td>Ctrl+3</td>
<td>cmd+3</td>
</tr>
<tr>
<td>Quick switch editor</td>
<td>Ctrl+E</td>
<td>cmd+E</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
<td>shift+cmd+Z</td>
</tr>
<tr>
<td>Refresh</td>
<td>F5</td>
<td>F5</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl+S</td>
<td>cmd+S</td>
</tr>
<tr>
<td>Save all</td>
<td>Ctrl+Shift+S</td>
<td>shift+cmd+S</td>
</tr>
<tr>
<td>Select all</td>
<td>Ctrl+A</td>
<td>cmd+A</td>
</tr>
<tr>
<td>Show shortcut keys (Show key assist in OS X)</td>
<td>Ctrl+Shift+L</td>
<td>shift+cmd+L</td>
</tr>
<tr>
<td>Show system menu</td>
<td>Alt+minus sign(-)</td>
<td>shift+cmd+F10</td>
</tr>
<tr>
<td>Show view</td>
<td>Alt+Shift+Q, Q</td>
<td>alt+cmd+Q, Q</td>
</tr>
<tr>
<td>Show view (Error Log)</td>
<td>Alt+Shift+Q, L</td>
<td>alt+cmd+Q, L</td>
</tr>
<tr>
<td>Show view (Outline)</td>
<td>Alt+Shift+Q, O</td>
<td>alt+cmd+Q, O</td>
</tr>
<tr>
<td>Show view (Problems)</td>
<td>Alt+Shift+Q, X</td>
<td>alt+cmd+Q, X</td>
</tr>
<tr>
<td>Show view menu</td>
<td>Ctrl+F10</td>
<td>cmd+F10</td>
</tr>
<tr>
<td>Switch to editor</td>
<td>Ctrl+Shift+E</td>
<td>shift+cmd+E</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
<td>cmd+Z</td>
</tr>
</tbody>
</table>
Chapter 6. How to provide feedback

Your feedback is important for us to improve z/OS Explorer Aqua based products. You can now provide feedback by taking the survey that is enabled in z/OS Explorer.

Normally, you are prompted to take the survey after a specific period of installation. Or, you can launch the survey by clicking Help > Provide Feedback... and choosing the product.

The survey includes the following sections:

• Net Promoter Score (NPS)
• Ratings on the characteristics such as availability or uptime, easy of use, and compatibility with other products.
• Your role
Appendix. Accessibility features for z/OS Explorer

Accessibility features assist users who have a disability, such as restricted mobility or limited vision, to use information technology content successfully.

Overview

z/OS Explorer includes the following major accessibility features:
• Keyboard-only operation
• Operations that use a screen reader
• Color and typeface preferences

z/OS Explorer uses IBM Installation Manager to install the product. You can read about the accessibility features for IBM Installation Manager in IBM Installation Manager documentation.

z/OS Explorer uses the latest W3C Standard, WAI-ARIA 1.0, to ensure compliance with US Section 508 and Web Content Accessibility Guidelines (WCAG) 2.0. To take advantage of accessibility features, use the latest release of your screen reader and the latest web browser that is supported by z/OS Explorer.

The z/OS Explorer online product documentation in IBM Knowledge Center is enabled for accessibility. The accessibility features of IBM Knowledge Center are described in the Accessibility section of the IBM Knowledge Center help.

Keyboard navigation

You can use keyboard shortcuts to navigate the help system and the product without using a mouse. For more information, see the Keyboard shortcuts for the help system in the product topic in z/OS Explorer documentation.

Interface information

The z/OS Explorer online product documentation is available in IBM Knowledge Center, which is viewable from a standard web browser.

PDF files have limited accessibility support. With PDF documentation, you can use optional font enlargement, high-contrast display settings, and can navigate by keyboard alone.

To enable your screen reader to accurately read syntax diagrams, source code examples, and text that contains period or comma PICTURE symbols, you must set the screen reader to speak all punctuation.

Related accessibility information

In addition to standard IBM help desk and support websites, IBM has a TTY telephone service for use by deaf or hard of hearing customers to access sales and support services:

TTY service 800-IBM-3383 (800-426-3383) (within North America)
For more information about the commitment that IBM has to accessibility, see [IBM Accessibility](#).
Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing IBM Corporation North Castle Drive Armonk, NY 10504-1785 U.S.A.

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing Legal and Intellectual Property Law IBM Japan, Ltd. 19-21, Nihonbashi-Hakozakicho, Chuo-ku Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM websites are provided for convenience only and do not in any manner serve as an endorsement of those websites. The materials at those websites are not part of the materials for this IBM product and use of those websites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

Intellectual Property Dept. for Rational Software IBM Corporation Silicon Valley Lab 555 Bailey Avenue San Jose, CA 95141-1003 U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

**Copyright license**

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. © Copyright IBM Corp. 1992, 2017.
If you are viewing this information in softcopy, the photographs and color illustrations may not appear.

**Privacy policy considerations**

IBM Software products, including software as a service solutions, ("Software Offerings") may use cookies or other technologies to collect product usage information, to help improve the end user experience, to tailor interactions with the end user or for other purposes. In many cases no personally identifiable information is collected by the Software Offerings. Some of our Software Offerings can help enable you to collect personally identifiable information. If this Software Offering uses cookies to collect personally identifiable information, specific information about this offering’s use of cookies is set forth below.

This Software Offering does not use cookies or other technologies to collect personally identifiable information.

**Trademarks**

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the web at “Copyright and trademark information” at [www.ibm.com/legal/copytrade.shtml](http://www.ibm.com/legal/copytrade.shtml).

**Terms and conditions for product documentation**

**Applicability**

These terms and conditions are in addition to any terms of use for the IBM website.

**Personal use**

You may reproduce these publications for your personal, noncommercial use provided that all proprietary notices are preserved. You may not distribute, display or make derivative work of these publications, or any portion thereof, without the express consent of IBM.

**Commercial use**

You may reproduce, distribute and display these publications solely within your enterprise provided that all proprietary notices are preserved. You may not make derivative works of these publications, or reproduce, distribute or display these publications or any portion thereof outside your enterprise, without the express consent of IBM.

**Rights**

Except as expressly granted in this permission, no other permissions, licenses or rights are granted, either express or implied, to the publications or any information, data, software or other intellectual property contained therein.

IBM reserves the right to withdraw the permissions granted herein whenever, in its discretion, the use of the publications is detrimental to its interest or, as determined by IBM, the above instructions are not being properly followed.
You may not download, export or re-export this information except in full compliance with all applicable laws and regulations, including all United States export laws and regulations.

IBM MAKES NO GUARANTEE ABOUT THE CONTENT OF THESE PUBLICATIONS. THE PUBLICATIONS ARE PROVIDED “AS-IS” AND WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT, AND FITNESS FOR A PARTICULAR PURPOSE.

Copyright license

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be liable for any damages arising out of your use of the sample programs.

Trademark acknowledgments

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at www.ibm.com/legal/copytrade.shtml.

Adobe and PostScript are trademarks of Adobe Systems Incorporated.

Cell Broadband Engine - Sony Computer Entertainment Inc.

Rational is a trademark of International Business Machines Corporation and Rational Software Corporation, in the United States, other countries, or both.

Intel, Intel Centrino, Intel SpeedStep, Intel Xeon, Celeron, Itanium, and Pentium are trademarks of Intel Corporation in the United States, or other countries, or both.

IT Infrastructure Library is a trademark of Central Computer and Telecommunications Agency

ITIL is a trademark of The Minister for the Cabinet Office

Linear Tape-Open, LTO, and Ultrim are trademarks of HP, IBM Corp., and Quantum

Linux is a trademark of Linus Torvalds

Microsoft, Windows, and the Windows logo are trademarks or registered trademarks of Microsoft Corporation in the United States, or other countries, or both.
Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and other countries.

UNIX is a registered trademark of The Open Group in the United States and other countries.
Index

A
accessibility features 67
Adding a new update site 28

C
Changing z/OS UNIX file and directory permissions 50
Checking for software updates 29
Configuring an FTP system connection FTP 5, 37, 45, 48
Configuring an z/OSMF system connection z/OSMF 7, 16, 40
Configuring T5 Explorer 4
Connecting to a system 42, 43
Connecting to a system from the connection status bar 44
Connecting to a system using Signon 43
Connection status bar 44
Console view 55
Creating a new data set 19
Creating a new data set member 21
Creating a new z/OS UNIX directory 51
Creating a new z/OS UNIX file 51
Creating JCL files offline 15

D
Data Sets view 55
Defining connection credentials 3, 41
Deleting a system connection 49
Deleting or cancelling an active job 19
Disconnecting from a system 50

E
Editing data sets 23
Editing z/OS UNIX files 52
Enabling automatic updates 30
Error Log view 56
Exporting connections 47
Exporting update sites 35, 36

H
Host Connections view 58

I
Importing connections 46
Importing update sites 34
Installing software 27
Installing software updates 29

J
Jobs view 59

M
Managing connections 58
Managing SSL security and certificates 4

P
Perspectives 11, 12
Properties 15
Properties view 62
Proxy server
Defining 39

R
Removing an installed plug-in 32
Removing update sites 31
resource properties 15
Reverting to a previous configuration 33
RSE perspective 13

S
Sample tasks 15
Security and certificate management 4
Sharing connections 46
Signoff 50
Signon 43
Software update sites 28
Submitting a batch job 26
System configuration tasks 37
systems 15

T
The IBM Explorer for z/OS Aqua overview 1
The z/OS Jobs view 60
Tutorial 3

U
Uninstalling a plug-in 32
Updating and installing software 27
Updating connection configurations 47
Updating software 27, 29
Enabling automatic updates 30
Using the IBM z/OS Management Facility 16

V
Viewing the output of an active job 18

W
Working with data sets 19, 55
Adding members 21
Browsing 21
Deleting 21
Editing 21
Opening 21
Recalling 21
Submitting 21
Working with z/OS UNIX files 50

Z
z/OS Explorer shortcut keys 62
z/OS perspective 11
z/OS UNIX view 61
z/OSMF 16

© Copyright IBM Corp. 2008, 2016
# Index

## A
- accessibility features 67
- Adding a new update site 28

## C
- Changing z/OS UNIX file and directory permissions 50
- Checking for software updates 29
- Configuring an FTP system connection
  - FTP 5, 37, 45, 48
- Configuring an z/OSMF system connection
  - z/OSMF 7, 16, 40
- Configuring TS Explorer 4
- Connecting to a system 42, 43
- Connecting to a system from the connection status bar 44
- Connecting to a system using Signon 43
- Connection status bar 44
- Console view 55
- Creating a new data set 19
- Creating a new data set member 21
- Creating a new z/OS UNIX directory 51
- Creating a new z/OS UNIX file 51
- Creating JCL files offline 15

## D
- Data Sets view 55
- Defining connection credentials 3, 41
- Deleting a system connection 49
- Deleting or cancelling an active job 19
- Disconnecting from a system 50

## E
- Editing data sets 23
- Editing z/OS UNIX files 52
- Enabling automatic updates 30
- Error Log view 56
- Exporting connections 47
- Exporting update sites 35, 36

## H
- Host Connections view 58

## I
- Importing connections 46
- Importing update sites 34
- Installing software 27
- Installing software updates 29

## J
- Jobs view 59

## M
- Managing connections 58
- Managing SSL security and certificates 4

## P
- Perspectives 11, 12
- Properties 15
- Properties view 62
- Proxy server
  - Defining 39

## R
- Removing an installed plug-in 32
- Removing update sites 31
- resource properties 15
- Reverting to a previous configuration 33
- RSE perspective 13

## S
- Sample tasks 15
- Security and certificate management 4
- Sharing connections 46
- Signoff 50
- Signon 43
- Software update sites 28
- Submitting a batch job 26
- System configuration tasks 37
- systems 15

## T
- The IBM Explorer for z/OS Aqua overview 1
- The z/OS Jobs view 60
- Tutorial 3

## U
- Uninstalling a plug-in 32
- Updating and installing software 27
- Updating connection configurations 47
- Updating software 27, 29
  - Enabling automatic updates 30
- Using the IBM z/OS Management Facility 16

## V
- Viewing the output of an active job 18

## W
- Working with data sets 19, 55
  - Adding members 21
  - Browsing 21
  - Deleting 21
  - Editing 21
  - Opening 21
  - Recalling 21
  - Submitting 21
- Working with z/OS UNIX files 50

## Z
- z/OS Explorer shortcut keys 62
- z/OS perspective 11
- z/OS UNIX view 61
- z/OSMF 16

© Copyright IBM Corp. 2008, 2016
We appreciate your comments about this publication. Please comment on specific errors or omissions, accuracy, organization, subject matter, or completeness of this book. The comments you send should pertain to only the information in this manual or product and the way in which the information is presented.

For technical questions and information about products and prices, please contact your IBM branch office, your IBM business partner, or your authorized remarketer.

When you send comments to IBM, you grant IBM a nonexclusive right to use or distribute your comments in any way it believes appropriate without incurring any obligation to you. IBM or any other organizations will only use the personal information that you supply to contact you about the issues that you state on this form.

Comments:

Thank you for your support.
Submit your comments using one of these channels:
• Send your comments to the address on the reverse side of this form.
• Send a fax to the following number: 800-555-1213
• Send your comments via email to: phred@us.ibm.com
• Send a note from the web page: http://w3-03.ibm.com/ids/page/636

If you would like a response from IBM, please fill in the following information:

Name
Address
Company or Organization
Phone No.
Email address