Client Installation Guide

Version 3 Release 1
IBM Explorer for z/OS

Client Installation Guide

Version 3 Release 1
Before using this information, be sure to read the general information under "Notices" on page 37.
## Contents

### About this book
- Who should read this book
- Where to find more information about z/OS Explorer

### Chapter 1. Preinstallation tasks

### Chapter 2. Hardware and software requirements

### Chapter 3. Installing z/OS Explorer
- Installing z/OS Explorer by using the IBM Installation Manager
- Installing z/OS Explorer by using an existing IBM Installation Manager
- Installing z/OS Explorer from scratch by using the Installation Manager
- Deploying z/OS Explorer to users without internet access
- Silent installation
- Installing z/OS Explorer by using Eclipse p2
- Installing z/OS Explorer from an existing Eclipse application by using Eclipse p2
- Installing z/OS Explorer from scratch by using Eclipse p2
- Deploying z/OS Explorer to users without internet access

### Chapter 4. Starting z/OS Explorer

### Chapter 5. Installing additional software
- Updating and installing software
- Using the composite update site
- Adding a new software update site
- Checking for, and installing, software updates
- Enabling automatic updates

### Chapter 6. Updating z/OS Explorer
- Updating z/OS Explorer by using the Installation Manager
- Updating z/OS Explorer by using Eclipse p2 update site

### Chapter 7. Installing client updates

### Chapter 8. Uninstalling z/OS Explorer

### Chapter 9. IBM Installation Manager
- Installing Installation Manager
- Starting Installation Manager
- Uninstalling Installation Manager
- Using Installation Manager
- Installation repositories
- Package groups and the shared resource directory

### Appendix. Accessibility features for z/OS Explorer

### Notices
- Copyright license
- Trademark acknowledgments

### Index
About this book

This installation guide provides instructions for installing and updating IBM® Explorer for z/OS® (z/OS Explorer).

This document contains information about the following tasks:
• Preparing for installation
• Installing z/OS Explorer
• Installing the required and optional workstation software

The following name is used in this manual:
• IBM Explorer for z/OS is called z/OS Explorer

This document is maintained between product releases. The new changes, and smaller corrections and additions, are indicated by a “|” change bar in the left margin of the page.

For the most up-to-date versions of the complete documentation, see the z/OS Explorer library page.

Who should read this book

This book is intended for programmers who are installing and configuring z/OS Explorer client on their workstations. To use this book, you must be able to work with at least one of the supported platforms per Software Requirements:
• Microsoft Windows operating system
• Red Hat Linux operating system
• SUSE Linux operating system
• Ubuntu operating system

Where to find more information about z/OS Explorer

This document does not contain information about using z/OS Explorer. For that information, see the online IBM Knowledge Center

For updated documentation and troubleshooting information, see the z/OS Explorer library page.
Chapter 1. Preinstallation tasks

About this task

Before you install the product, complete the following steps:

1. Confirm that your system meets the requirements that are described in the Chapter 2, “Hardware and software requirements,” on page 3 section.

2. Confirm that your user ID meets the following access privileges for installing the product.
   • Your user ID must not contain double-byte characters.
   • To install for all users of the system, you must have an ID that belongs to the Administrators group. If you do not have Administrator privileges, you can only install for the current user.

3. Before installing or uninstalling, disable antivirus and malware detection software.

Note: Some antivirus and malware detection software occasionally locks certain files, especially .dll files. The locking interferes with installation and uninstallation operations. When .dll or other files are locked by these programs, installation and uninstallation operations fail with errors indicating that files might not be removed.
Chapter 2. Hardware and software requirements

For a complete listing of the z/OS Explorer hardware and software requirements including prerequisites and co-requisites, generate reports from Software Product Compatibility Reports.
Chapter 3. Installing z/OS Explorer

You can install z/OS Explorer by using several methods.

The following factors might determine the installation method that you use:
- The format and method by which you access the installation files.
- Whether you are installing onto your own workstation, or making the installation files available to your enterprise.
- Whether you are installing by using the Installation Manager GUI, or installing silently.

You can use the following installation methods to install z/OS Explorer:
- Installing from the Installation Manager
- Installing from Eclipse p2 update site

Note: To install z/OS Explorer, you can run the Installation Manager program in silent mode. For details on running Installation Manager in silent mode, see “Silent installation” on page 8.

Installing z/OS Explorer by using the IBM Installation Manager

IBM Installation Manager is a single installation program that uses remote or local software repositories to install, modify, or update certain IBM products. Use this program to install, update, modify, roll back, and uninstall packages on your computer. The program locates and shows available packages, checks prerequisites and interdependencies, and installs or modifies the selected packages. You also use Installation Manager to uninstall the packages that you installed by using Installation Manager. For more information about the Installation Manager, see Chapter 9, “IBM Installation Manager,” on page 29.

Installing z/OS Explorer by using an existing IBM Installation Manager

About this task

If you have an existing IBM Installation Manager Version 1.8.5.1 or later, install z/OS Explorer by taking the following steps:

Procedure

1. Start the Installation Manager. If you did not install Installation Manager before, download it from the IBM Installation Manager download website. Version 1.8.5.1 or later is required.
2. On the main panel of the Installation Manager, click File > Preferences.
3. On the Preferences panel, click Repositories > Add Repositories.
5. Go back to the main interface of Installation Manager, and click Install.
6. On the Install Packages panel, select IBM Explorer for z/OS and the version number that you purchased, and click Next.

7. If prompted to update IBM Installation Manager to a newer version, to install the update immediately, click Yes, or to install the newer version later, click No.

8. On the Licenses panel, select I accept the terms in the license agreement, and click Next.

9. On the Location panel, specify the directory accordingly:
   
   - If you do not have any other packages already installed on the system, enter the path of the shared resources directory to use in the Shared Resources Directory field.

   **Note:** Select a location on the largest drive for the shared resources directory, because it will be used by every package that you install using Installation Manager, and it cannot be changed after the first package is installed. To change the location of the shared resources directory later, you must uninstall all of the packages and then reinstall them, specifying a new shared resources directory.
   
   - If you are also installing Installation Manager with z/OS Explorer, enter the location to install Installation Manager in the Installation Manager Directory field.

10. On the next Location panel, specify whether to create a new package group to contain the z/OS Explorer package, or to use an existing package group on the system. When you install packages into the same package group, they share a common workbench, and the functionality from the different packages is combined in that workbench. This is known as shell sharing. Packages that are installed into different package groups do not share a workbench and are kept separate from each other. When you have finished making your selections, click Next.

   - To create a new package group for IBM Explorer for z/OS, click Create a new package group, and click Next.

   **Note:** If you are installing on a 64-bit operating system, you can choose whether to create a 32-bit or 64-bit package group by selecting the corresponding radio button below the Installation Directory field. If you select the 32-bit package group, the installed packages run in 32-bit mode. You cannot change the bit mode of an existing package group after it has been created. Some software packages may support only 32-bit or 64-bit modes and can only be installed into a package group configured for the same architecture.

   - To install z/OS Explorer into an existing package group, click Use an existing package group. Then, select the package group into which to install z/OS Explorer. Click Next. If the selected package group is not compatible with z/OS Explorer, you are prompted to select a compatible package group or to create a new package group.

11. On the Features panel, under Translations, select the languages to install for this package group. The user interface and documentation for z/OS Explorer is installed in that language.

   **Notes:**

   - Your choices apply to all of the packages that are installed in this package group.
• In this release of z/OS Explorer, selecting any of the available languages results in the national language translations for all of the languages being installed.

12. On the Features panel, select the features to install, and click Next.
13. On the Summary panel, click Install.
14. Click Finish.

**Installing z/OS Explorer from scratch by using the Installation Manager**

If you start from scratch, install z/OS Explorer by downloading the IM installer for z/OS Explorer.

For a first-time user, install the z/OS Explorer by taking the following steps:

1. Based on your operating system, download the appropriate IM installer for z/OS Explorer from [Mainframe DevOps Downloads](http://public.dhe.ibm.com/ibmdl/).
2. Unzip the IM installer.
3. Run the IM installer. You can run the IM installer as a user install or an administrator install. The administrator install uses a common area that will be available to all users of the PC and requires administrator permissions. The user install uses the home directory of the current user. The administrator install is less common because it is safer to not grant administrator permissions to the installer.
   • To run as a user install:
     – For Windows users, double-click the imLauncherWindowsUser.bat file.
     – For Linux users, double-click the imLauncherLinuxUser.sh file.
     – For OS X users, double-click the InstallerImage_macosx_cocoa_x86_64/Userinst.app.
   • To run as an administrator install:
     – For Windows users, double-click the imLauncherWindows.bat file.
     – For Linux users, double-click the imLauncherLinux.sh file.
     – For OS X users, execute the imLauncherMac.sh file via terminal or double-click the InstallerImage_macosx_cocoa_x86_64/Install.app.
4. Select all available installation packages within IM installer for installation.

**Deploying z/OS Explorer to users without internet access**

You can deploy z/OS Explorer to your users without internet access if you installed z/OS Explorer through the IBM Installation Manager.

To deploy z/OS Explorer through Installation Manager without internet access and control versions of software are available to your users, take the following steps:

1. Install Installation Manager on the desktop.
2. Install IBM Package Utility.
   a. Based on your operating system, download the latest IBM Package Utility from [Installation Manager and Packaging Utility download links](http://public.dhe.ibm.com/ibmdl/).
   b. Install the IBM Package Utility by following the wizard.
   c. Launch the IBM Package Utility and select Copy Packages to get software content from the public IBM site to your own internal site.
   d. Click Open Repository, and enter the update site URL. The URL for z/OS Explorer V3.0 (Eclipse 4.4 Luna) is http://public.dhe.ibm.com/ibmdl/.

Chapter 3. Installing z/OS Explorer

**Note:** You must include http://.

e. From the list of software that is displayed, select the software that you want to copy, and click **Next**.

**Note:** You can install and use the software if you have a license for the product. For example, you can install and use CICS Explorer® if you have a license for CICS®.

f. Enter the target repository which is a file location. The target repository can either be a new location to be created, or an existing repository location.

g. Click **Next** to confirm your selections.

h. Click the button **Copy** to start copying the contents from the IBM update site to the internal repository.

**Note:** You can pause and resume the copy process.

3. After you install IBM Packaging Utility, go to the Installation Manager and click **File > Preferences > Add Repository**, and add the directory of the file repository.config that is included in your internal repository. The file repository.config contains the XML content that describes the repository contents.

4. Click the button **Install** in the Installation Manager and select the tools that you want to install. You can use the button **Update** to update the tools.

After you complete these steps, distribute the software in your internal repository to users in an enterprise.

**Silent installation**

**About this task**

You can install z/OS Explorer in silent mode. When you run Installation Manager in silent mode, its user interface is not available; instead, you use a response file to supply the commands required to install the package.

Running Installation Manager in silent mode is helpful because you can use a batch process to install, update, modify, and uninstall packages through scripts.

These are the three main tasks for silent installation:

1. If you are planning to install silently on multiple systems, copy the installation image to a location on a shared drive or server.
2. Create the response file.
3. Run Installation Manager in silent installation mode.

The following sections explain the task of copying the installation image to a shared drive or server. For the most current information about the remaining tasks (creating response files and running Installation Manager in silent mode to install the package), see the [Managing packages in silent mode with Installation Manager](#).

The [Working in silent mode](#) topic provides detailed information about these topics.
Other installation options such as group installation and a full list of the installation locations for each operating system are described in Installing as an administrator, nonadministrator, or group in the IBM Installation Manager Knowledge Center.

If you plan deployment to many systems at one time, see Using IBM Installation Manager for Enterprise Deployment.

For further information about Installation Manager installation, see Deploying IBM z/OS Explorer Aqua using IBM Installation Manager.

---

**Installing z/OS Explorer by using Eclipse p2**

Eclipse p2 is a component of the Eclipse Equinox project that provides a provisioning platform for Eclipse-based applications. You can use the Eclipse p2 update site to install z/OS Explorer from an existing Eclipse application or from scratch.

### Installing z/OS Explorer from an existing Eclipse application by using Eclipse p2

**About this task**

In this scenario, you can install z/OS Explorer by using an existing Eclipse application.

**Procedure**

1. Start an Eclipse application. If you do not have one, download Eclipse Neon from the Eclipse.org and extract the compressed file to a local drive on your computer.
2. Click Help > Install New Software.
4. Select the features that you want to install, and click Next.
5. Follow the wizard until the product is installed.
6. Select Restart Now when prompted to ensure the z/OS Explorer features are installed and validated by Eclipse.

### Installing z/OS Explorer from scratch by using Eclipse p2

If you start from scratch, install z/OS Explorer by downloading the Eclipse package for z/OS Explorer.

For a first-time user, install the z/OS Explorer by taking the following steps:

1. Based on your operating system, download the appropriate Eclipse package for z/OS Explorer from Mainframe DevOps Downloads.
2. Extract the package and start using z/OS Explorer.
3. To install features from the Eclipse composite update site for z/OS Explorer, take the following steps:
   a. Click Help > Install New Software > Add.

c. Select all available installation packages for installation.

**Deploying z/OS Explorer to users without internet access**

You can deploy z/OS Explorer for other users without internet access. And you can also create a staging area between their users and the IBM site.

To get the tools in the update site and distribute the tools locally within your organization to download and use, take the following steps:

2. Start your Eclipse after the download, and click Help > Install New Software.
3. Select Add to open the Add Repository dialog.
4. Select Archive on the Add Repository dialog to navigate to where you downloaded the package.

**Note:** Select the button Archive instead of Local, because the package you download is a zip archive. The button Local is used for pointing at a folder that has the software.

5. To point to the package downloaded quickly, type the location directly by using the format jar:/file:{path/aqua.n.update.site-yyymmd.zip}!/ for example, jar:file:/C:/temp/aqua.n.update.site-20160510.zip/!
6. Select the tools that you want to install from the list of update site contents.
7. Follow the instructions that are provided to complete the installation.
Chapter 4. Starting z/OS Explorer

Select the right method to start z/OS Explorer based on your operating system.

**Starting z/OS Explorer on Windows**

You can start z/OS Explorer in one of the following ways:

- If you installed z/OS Explorer by using IBM Installation Manager, go to the Windows Start menu and select Start > All Programs > IBM Software Delivery Platform > IBM Explorer for z/OS, or run eclipse.exe from the product installation directory.
- If you installed z/OS Explorer on an existing Eclipse instance by using Eclipse p2 update, run eclipse.exe from the product installation directory.
- If you downloaded the full z/OS Explorer package for Eclipse, run zosexplorer.exe from the product installation directory.

**Starting z/OS Explorer on Linux**

You can start z/OS Explorer in one of the following ways:

- If you installed z/OS Explorer by using IBM Installation Manager, go to the Applications menu and select Applications > IBM Software Delivery Platform > IBM Explorer for z/OS, or run eclipse from the product installation directory.
- If you installed z/OS Explorer on an existing Eclipse instance by using Eclipse p2 update, run eclipse from the product installation directory.
- If you downloaded the full z/OS Explorer package for Eclipse, run zosexplorer from the product installation directory.

**Starting z/OS Explorer on Mac**

You can start z/OS Explorer in one of the following ways:

- If you installed z/OS Explorer by using IBM Installation Manager or the full z/OS Explorer package, go to the Applications menu and select Applications > IBM > zOS_Explorer > IBM Explorer for z/OS, or run IBM Explorer for zOS from the product installation directory.
- If you installed z/OS Explorer on an existing Eclipse instance by using Eclipse p2 update, run IBM Explorer for zOS from the product installation directory.
Chapter 5. Installing additional software

After you install z/OS Explorer, you can use the facilities provided by the Eclipse platform to update your z/OS Explorer or other compatible product software, for example CICS Explorer, or add new software plug-ins, for example CICS tools.

Updating and installing software

You can use the facilities provided by the Eclipse platform to update your z/OS Explorer or other compatible product software, for example CICS Explorer, or add new software plug-ins, for example CICS tools.

For z/OS Explorer Version 2.1 and later, you can use the composite update site to keep up to date with new versions of z/OS Explorer and to add new tools and plug-ins to your z/OS Explorer environment. For more information, see “Using the composite update site.”

The update site for the z/OS Explorer Explorer is already coded in the product. You can see the site address on the Installed Software page in the Software Updates window.

If you choose not to use the composite update site, you need to specify the address of your preferred update site, either on your local machine or a remote location. You can add multiple update sites, each containing one or more software downloads.

Using the composite update site

You can use the composite update site to update your z/OS Explorer or other compatible product software, or add new software plug-ins such as additional tools.

For z/OS Explorer Version 2.1 and later, you can use the composite update site, which simplifies the installation of updates to z/OS Explorer software plug-ins. When a composite update site is present and you click Help > Install New Software, software plug-ins for additional tools are listed as well as z/OS Explorer.

The update site for z/OS Explorer is already coded in the product. You can see the site address in the Available Software Sites pane on the Preferences window.

If you are using the z/OS Explorer SDK and you installed the SDK by using the composite update site, you can click Help > Check for Updates to check for new versions of the z/OS Explorer and any tools you have installed. If you installed the SDK by downloading the compressed file, the composite update site is not available.

The URLs of composite update sites include the version number of z/OS Explorer or other compatible product software that they relate to. For example, if the composite update site URL contains the version number 5.1, you will receive any modification and fix updates for Version 5 Release 1 of the product, but not any new releases or versions. Eclipse, and therefore z/OS Explorer or other compatible product software, always offers the latest available version when you check for updates. If you choose to not accept an update, you will NOT be notified if a new
fix level (for instance 5.1.0.1) becomes available. For example, if you have version 5.1.0.0 and are offered a modification level update to version 5.1.1.0 but decline it, you will NOT be notified if fix level 5.1.0.1 becomes available.

You are always offered the very latest code that is available in the whole composite update site. If you declined a new fix level, you must check manually whether any new updates are available. Click Help > Install New Software and remove the option that selects only the latest versions of software. You will receive all updates to any tools you have installed (such as IBM CICS Configuration Manager) that are compatible with the version of z/OS Explorer that the composite update site relates to. Review the version numbers before upgrading a component.

If you want to control the updates that end users can move to for both z/OS Explorer and plug-ins, you need to remove the composite update site from z/OS Explorer and select another site manually. For more information, see “Adding a new software update site.”

**Adding a new software update site**
Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

**Before you begin**
You must know the web site address (URL) or local file system location of the update site that you want to add.

**Procedure**
1. Use the appropriate method to open the Preferences window:
   - Windows or Linux: Click Window > Preferences on the workbench menu bar.
   - OS X: Click IBM Explorer for z/OS > Preferences on the main menu.
2. In the Preferences window, expand Install/Update, then click Available Software Sites.
3. In the Available Software Sites pane, click Add.
4. In the Add Site window, specify the location of the update site in one of the following ways:
   - If the update site is located on the web, type the website address (URL) of the site into the Location field. Alternatively, paste or drag and drop a URL from a web browser.
   - If the update site is in your local file system, including a CD, click Local and select the directory location of the site.
   - If the update site is in your local file system but is packaged as a .jar or .zip file, click Archive to locate and select the name of the file.
5. Click OK.

**Results**
The update site is added to the list of available software and the site is checked to find available software at that site. The progress icon in the workbench is displayed while the update site is being checked. Do not click the site URL while the process is continuing, because an error might be displayed, although the process will continue. When the progress icon goes, the process is complete.
If no software is found at the site, an error is displayed. Remove the site and add a valid site.

When you install new software and you select the new software update site in the Available Software pane in the Install window, the new software found is displayed in a tree format. For more information about installing software updates, see the related links.

Related tasks:
- “Checking for, and installing, software updates”
  You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.
- “Removing an existing software update site” on page 17
  You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.
- “Importing a list of software update sites” on page 20
  You can import a list of software update sites that have been exported previously by using the Available Software Sites pane in the Preferences window.
- “Exporting a list of software update sites” on page 21
  You can export one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.
- “Select or deselect software sites to check for available software” on page 22
  You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

Checking for, and installing, software updates

You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.

About this task

To check for software updates, you use the Installed Software tab of the Installation Details window. To install software updates, you use the Available Updates wizard.

Procedure

1. Click Help > Install New Software on the workbench menu.
2. In the Install window, click the What is already installed link. The Installation Details window is displayed. The Installed Software tab lists the plug-ins that are currently installed.
3. Select the items for which you want to check for software updates from the list on the Installed Software tab.
4. Click Update. If updates are available, they are displayed in the Available Updates wizard.
5. In the Available Updates wizard, select the software items to update. You can select one or more items to install. Each time you select an item, the compatibility of the checked items is compared with your current system. If the selection is not compatible, an error message is displayed and you cannot update the software. You must select other items to find a compatible selection.
6. If the selected items have license agreements to be reviewed, click Next. Carefully review the license agreements for the updated items. If the terms of
all these licenses are acceptable, check **I accept the terms in the license agreements**. Do not proceed to download the items if the license terms are not acceptable.

7. If the license agreements are acceptable, or if the selected items did not have license agreements to review, click **Finish**. The download and installation of the updates begins.

8. Some items might be digitally signed by the company that provides them. You can use the digital signature to verify more easily that the features and plug-ins that are about to be downloaded and installed are coming from a trusted supplier. You might be prompted to verify digitally signed content once the signature is detected.

   **Attention:** Because of the possibility of harmful or even malicious software, download only software from parties that you trust.

9. When all the software is downloaded successfully and the necessary files installed into the product, you are prompted to restart z/OS Explorer. Click **Yes** when asked to exit and restart the workbench for the changes to take effect.

**Results**

z/OS Explorer restarts with the latest updates installed.

**Related tasks:**

- "Removing an existing software update site” on page 17
  You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

- "Importing a list of software update sites” on page 20
  You can import one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.

- "Select or deselect software sites to check for available software” on page 22
  You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

**Enabling automatic updates**

You can specify that enhancements and fixes are downloaded automatically as they become available by using the Automatic Updates pane on the Preferences window.

**Procedure**

1. Use the appropriate method to open the Preferences window:
   - Windows or Linux: Click **Window > Preferences** on the workbench menu bar.
   - OS X: Click **IBM Explorer for z/OS > Preferences** on the main menu.

2. In the Preferences window, expand Install/Update and click Automatic Updates.
3. In the Automatic Updates pane, select **Automatically find new updates and notify me** to enable automatic updates. You can then select options in the following sections:
   - **Update schedule**: Choose when to look for updates.
   - **Download options**: When updates are available, choose whether to receive notifications only, or to download updates automatically and receive notifications.
   - **When updates are found**: Choose when to be notified about new updates.
4. Click **Apply** or **OK**.

**Results**

*z/OS Explorer* automatically checks for updates at the selected time, and downloads the updates, or notifies you, depending on the options selected. You can turn off automatic updates at any time by opening the Automatic Updates pane and clearing the **Automatically find new updates and notify me** check box.

**Removing an existing software update site**

You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

**Procedure**

1. Use the appropriate method to open the Preferences window:
   - **Windows or Linux**: Click `Window > Preferences` on the workbench menu bar.
   - **OS X**: Click `IBM Explorer for z/OS > Preferences` on the main menu.
2. In the Preferences window, expand **Install/Update** and click **Available Software Sites**.
3. In the Available Software Sites pane, click and highlight the existing software update site that you want to remove. You can use Ctrl+click (cmd+click for OS X) or Shift+click to select more than one site.
   
   **Note**: Do not use the check boxes to select the required software update site. Any check box selections on this pane are ignored for this action.
4. Click **Remove**.
5. Click **OK**.

**Results**

The site is removed from the list of available sites.

**Related tasks**:

- “Adding a new software update site” on page 14
  Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

- “Checking for, and installing, software updates” on page 15
  You can check for software updates for *z/OS Explorer*, other compatible product software, or installed plug-ins, then use a wizard to install any updates.

- “Importing a list of software update sites” on page 20
  You can import a list of software update sites that have been exported previously by using the Available Software Sites pane in the Preferences window.
Removing an installed software plug-in

You can uninstall and remove an existing plug-in by using the Installation Details window.

Before you begin

Before you uninstall a plug-in, you must close all perspectives associated with the plug-in. Failure to do so might cause an error and you might have to reinstall z/OS Explorer.

Procedure

1. Click Help > Install New Software on the workbench menu. The Install window opens.
2. In the Install window, click the What is already installed link. The Installation Details window opens. The Installed Software tab shows a list of the software installed.
3. Select the software that you want to uninstall. Click Uninstall.
4. In the Uninstall window, click Finish. A progress bar is displayed in the workbench status bar until the process completes.
5. When you are prompted to restart z/OS Explorer, click Yes.

Results

The software plug-in is uninstalled from z/OS Explorer and removed from the list of installed software. z/OS Explorer restarts to complete the action.

Related tasks:

"Adding a new software update site” on page 14
Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

"Checking for, and installing, software updates” on page 15
You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.

"Importing a list of software update sites” on page 20
You can import a list of software update sites that have been exported previously by using the Available Software Sites pane in the Preferences window.

"Exporting a list of software update sites” on page 21
You can export one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.

"Select or deselect software sites to check for available software” on page 22
You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.
Reverting to a previous installation configuration

As you install, upgrade, and uninstall software in z/OS Explorer, configuration snapshots are kept in a history. You can revert to a previous configuration to back out the results of an unsuccessful installation, upgrade, or uninstall. You can also revert z/OS Explorer to a previous version. However, you must have access to an update site because when you upgrade the z/OS Explorer product, previous versions are not saved.

Before you begin

If you used IBM Installation Manager to install, upgrade, or uninstall software in z/OS Explorer, you can revert to a previous version by using the rollback feature, and you do not need to use the following procedure.

Important: It is a limitation of Eclipse that before you can revert to a previous version of z/OS Explorer, you must have access to an update site that includes the required version.

To download the update site, use the following steps:

1. For the Product Group field, select Other Software and for Product, select IBM Explorer for z/OS. For the Installed Version and Platform fields, select All, then click Continue.
2. Select Browse for fixes and click Continue.
3. Select the update site at the level you want to revert to and click Continue.
4. Download the update site to your workstation. Do not uncompress the file. z/OS Explorer requires a compressed file.
5. In z/OS Explorer, add the update site by using Help > Software Updates on the workbench menu. For more information, see “Adding a new software update site” on page 14.

You can now revert z/OS Explorer to the required level.

About this task

This example task shows you how to revert z/OS Explorer to a previous configuration.

Procedure

1. Click Help > Install New Software on the workbench menu. The Install window opens.
2. Click the What is already installed link. The Installation Details window opens. The Installation History tab shows a list of the previous configurations.
3. Select the configuration that you want to revert to. When you select a configuration, another pane shows the content in that configuration.
   Attention: The oldest entry in the list of previous configurations represents the initial z/OS Explorer installation. This configuration has no contents. Do not revert to this configuration. If you do, z/OS Explorer fails and must be completely reinstalled.
4. Click Revert. The Revert Software Configuration confirmation dialog is displayed.
5. Click Yes to confirm, and when asked to exit and restart the workbench for the changes to take effect.
Results

z/OS Explorer reverts to the selected configuration and restarts.

Related tasks:

“Adding a new software update site” on page 14
Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

“Checking for, and installing, software updates” on page 15
You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.

“Removing an existing software update site” on page 17
You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

“Importing a list of software update sites”
You can import a list of software update sites that have been exported previously by using the Available Software Sites pane in the Preferences window.

“Exporting a list of software update sites” on page 21
You can export one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.

“Select or deselect software sites to check for available software” on page 22
You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

Importing a list of software update sites

You can import a list of software update sites that have been exported previously by using the Available Software Sites pane in the Preferences window.

Procedure

1. Use the appropriate method to open the Preferences window:
   - Windows or Linux: Click Window > Preferences on the workbench menu bar.
   - OS X: Click IBM Explorer for z/OS > Preferences on the main menu.
2. In the Preferences window, expand Install/Update and click Available Software Sites.
3. In the Available Software Sites pane, click Import.
4. In the Import Sites window, locate and select the file that contains the list of exported update sites, and click Open.

Results

The update sites in the file are imported into the product and are added to the list in the Available Software Sites pane.

Related tasks:

“Adding a new software update site” on page 14
Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

“Checking for, and installing, software updates” on page 15
You can check for software updates for z/OS Explorer, other compatible product
software, or installed plug-ins, then use a wizard to install any updates.

“Removing an existing software update site” on page 17
You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

“Exporting a list of software update sites”
You can export one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.

“Select or deselect software sites to check for available software” on page 22
You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

Exporting a list of software update sites
You can export one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.

Procedure
1. Use the appropriate method to open the Preferences window:
   - Windows or Linux: Click Window > Preferences on the workbench menu bar.
   - OS X: Click IBM Explorer for z/OS > Preferences on the main menu.
2. In the Preferences window, expand Install/Update and click Available Software Sites.
3. In the Available Software Sites pane, click and highlight one or more software update sites that you want to export. You can use Ctrl+click (cmd+click for OS X) or Shift+click to select more than one site.
   
   Note: Do not use the check boxes to select the required software update sites. Any check box selections on this pane are ignored for this action.
4. Click Export.
5. In the Export Sites dialog, select a destination for the exported file. You can provide a new file name or keep the default name.
6. Click Save.

Results
Details of the selected sites are exported to your local file system.

Related tasks:
“Adding a new software update site” on page 14
Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

“Checking for, and installing, software updates” on page 15
You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.

“Removing an existing software update site” on page 17
You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

“Importing a list of software update sites” on page 20
You can import a list of software update sites that have been exported previously
by using the Available Software Sites pane in the Preferences window.

"Select or deselect software sites to check for available software"

You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

**Select or deselect software sites to check for available software**

You can select or deselect one or more update sites in z/OS Explorer to use for updating software, using the Available Software Sites dialog.

**About this task**

This example task shows you how to use the Available Software Sites dialog to select or deselect sites to check for available software updates. All sites registered in z/OS Explorer are shown in the list in the Available Software Sites dialog.

**Procedure**

1. Click Help > Install New Software on the menu bar. The Install window opens.
2. Click the What is already installed link. The Installation Details window opens. The Installed Software tab shows a list of the installed software.
3. In the Installation Details window, select or deselect software to check for updates.
4. Click Update. z/OS Explorer searches the update site for a newer version of the code. Note that the update site must be defined in the Preferences page. See the related links for information on adding a new software update site.

**Results**

The sites selected are displayed in the Available Software page. The sites are the only ones that are checked for software updates.

**Related tasks:**

- "Adding a new software update site” on page 14
  Before you can install new software plug-ins, you must specify the address of the update site, or sites, where the software is located. The sites can be at a remote address, or in a folder on a local machine.

- "Checking for, and installing, software updates” on page 15
  You can check for software updates for z/OS Explorer, other compatible product software, or installed plug-ins, then use a wizard to install any updates.

- "Removing an existing software update site” on page 17
  You can remove software update sites from the list of available software by using the Available Software Sites pane in the Preferences window.

- "Importing a list of software update sites” on page 20
  You can import a list of software update sites that have been exported previously by using the Available Software Sites pane in the Preferences window.

- "Exporting a list of software update sites” on page 21
  You can export one or more update sites to a file by using the Available Software Sites pane in the Preferences window. The file can then be imported into another instance of the product.
Chapter 6. Updating z/OS Explorer

You can update the z/OS Explorer with Installation Manager or p2. To download the latest version and fix pack of z/OS Explorer, visit [Mainframe DevOps Downloads](http://www.example.com). For the APARs fixed and enhancements in each version and fix pack, see [Fix list for IBM Explorer for z/OS](http://www.example.com).

### Updating z/OS Explorer by using the Installation Manager

If you have installed z/OS Explorer by using the Installation Manager, take the following steps:

1. Launch the Installation Manager.
2. Click the button **Update** and select all or none available packages in the package group to install.

   **Note**: If you do not select all packages in the package group to install, the products in the same package group might not be compatible.

3. Follow the instructions that are provided.

### Updating z/OS Explorer by using Eclipse p2 update site

If you have installed z/OS Explorer, update it by using one of the following ways:

- **Check for Updates**
  1. Launch Eclipse.
  2. Click **Help > Check for Updates**.
  3. Select all or none available packages to install, and click **Next**.
  4. Review and confirm the updates, and click **Next**.
  5. Select **I accept the terms of the license agreement**, and click **Finish**.

- **Automatic Update**
  1. Launch Eclipse.
  2. Click **Window > Preferences > Install/Update > Automatic Updates**.
  3. Select **Automatically find new updates and notify me**, and click **OK**.
Chapter 7. Installing client updates

The z/OS Explorer server can be configured to automatically download product updates to the client. When product updates are available, the client is prompted to install the updates when you connect to a remote system.

Before you begin

If user authentication is required to access the code repository for the update, then you must save your user ID and password in IBM Installation Manager.

This type of update supports only modification-level updates. You can use push-to-client to update clients from version 3.1 to version 3.1.1, for example, but not from version 3.1 to version 4.0 and not from version 4.0 to version 4.1.

About this task

If updates for z/OS Explorer are available, the following message is displayed when you connect to a remote system:

The IBM Explorer for z/OS server has been configured to automatically download product updates to the client when you connect to the remote system. Current Product Version shows the product version currently installed on your workstation. A new version will be installed when you click OK.

offeringName

Current Product Version: currentVersionnumber

The offeringName is the product offering name as identified in IBM Installation Manager.

If the server is configured to support product and configuration groups, this message might be preceded by a Choose Product Group window that prompts you to select a product group for updating the client.

Procedure

To install available product updates:

1. If you are prompted to choose a product group, select one from the Choose Product Group window. You can download configurations from the default group or from the group that is associated with this workspace. If you must access and download product updates from another product group, you must connect by using a different workspace. For more information about creating a workspace, see [Switching workspaces](#). A window opens prompting you to install product updates.

2. The z/OS Explorer server can be configured to allow or disallow you to refuse product updates:
   * If the server allows you to refuse product updates, you can click Cancel to close the message without installing the product update. You are prompted again to update the product the next time you connect to the remote system.
• If the server disallows you to refuse product updates, then no **Cancel** button is displayed on the message window. You must click **OK** to continue with the product update. The workbench shuts down and IBM Installation Manager is started to install the product updates.
Chapter 8. Uninstalling z/OS Explorer

About this task

The **Uninstall** option in the Installation Manager can be used to uninstall packages that were previously installed using Installation Manager.

To uninstall the packages, you must log in to the system using the same user account that you used to install the packages.

Procedure

1. Close all of the programs that you installed using Installation Manager.
2. From the main panel of Installation Manager, click **Uninstall**.
3. On the **Uninstall Packages** panel, select the packages to uninstall. Click **Next**.
4. On the **Summary** panel, review the packages you selected to uninstall. To make any changes, click **Back**. To begin the uninstallation process, click **Uninstall**.
5. The **Complete** panel is displayed after the uninstallation finishes and shows the results. Click **Finish**.
IBM Installation Manager is a program that installs z/OS Explorer and other packages on your workstation. It also updates, modifies, and uninstalls these and other packages that you install. A package can be a product, a group of components, or a single component that is designed to be installed with the Installation Manager.

For the most current information about the IBM Installation Manager, see the [Installation Manager product documentation](#).

Installation Manager is an installation management tool that has several time-saving features. It helps you install, update, modify, and uninstall product packages on your computer. It keeps track of what you are about to install, as well as what you have already installed and what is available for you to install. It searches for updates so that you know that you are installing the latest version of a package. It also provides tools for managing licenses for the packages it installs, and for updating and modifying packages.

For information about how to deploy z/OS Explorer to many users, see the information available in the [Enterprise installation articles](#) section of the Installation Manager product documentation.

Use the six wizards in Installation Manager to maintain a package through its lifecycle, as follows:

- The Install wizard walks you through the installation process. You can install a package by accepting the defaults, or you can change the default settings to customize an installation. Before you install a package, you see a summary of your selections throughout the wizard. Using the wizard, you can install one or more packages at one time.

- The Update wizard searches for available updates to packages that you have installed. An update might be a released fix, a new feature, or a new version of the product. Details of the contents of the update are provided in the wizard. You can decide whether to apply an update.

- With the Modify wizard, you can change certain elements of a package that you have installed. During the first installation of the package, you select the features to install. If you require other features later, you can use the Modify wizard to add the features. You can also remove features.

- The Manage Licenses wizard helps you set up the licenses for your packages. Use this wizard to change a trial license to a full license, to set up the servers for floating licenses, and to select the type of license to use for each package.

- The Import wizard adds packages that were installed by using installation tools other than Installation Manager to the list of installed packages. Installation Manager tracks the products that it installs, including selectable features and maintenance updates for products. Earlier versions of some products that can be installed with Installation Manager might have been installed with different installation technology. Installation Manager must import information about existing installations of these products before Installation Manager can modify and update the products.
Note: This wizard is available only after Installation Manager detects a package in a repository that requires this feature.

- The Roll Back wizard enables you to revert to a previous version of a package.
- The Uninstall wizard removes a package from your computer. You can uninstall more than one package at a time.

## Installing Installation Manager

### About this task

IBM Installation Manager is typically installed automatically as part of the z/OS Explorer installation process.

If you need to install IBM Installation Manager by itself, without installing z/OS Explorer, download the Installation Manager from [Installation Manager downloads](#).

1. Change to the directory of the Installation Manager that you installed.
2. To install as administrator for all of the users on the system, run the following command:
   ```
   Windows
   install.exe
   ```
   ```
   Linux
   install
   ```
   To install as a non-administrator for the current user only, run the following command:
   ```
   Windows
   userinst.exe
   ```
   ```
   Linux
   userinst
   ```
3. On the first page of the Install Packages wizard, click Check for Other Versions and Extensions to install the latest available version. If a newer version is available, it is automatically selected for installation. Click Next.
4. On the Licenses page, read the license agreements for IBM Installation Manager. If you agree to the terms of all of the license agreements, click I accept the terms in the license agreements and then click Next.
5. On the Location page, in the Installation Manager Directory field, type the path for the directory where Installation Manager must be installed or accept the default path. Then click Next.
6. On the Summary page, review your choices before starting the installation process. To change your selections, click Back to return to the previous pages. When you are satisfied with your selections, click Install.

## Starting Installation Manager

### About this task

IBM Installation Manager is installed and started automatically when you start the z/OS Explorer installation.
If you need to start Installation Manager manually to update, modify, roll back, or uninstall packages following the installation, do these steps:

**Windows**

1. Open the **Start** menu from the Taskbar.
2. 
   - For an administrator installation, click **All Programs > IBM Installation Manager > IBM Installation Manager**.
   - For a non-administrator installation, click **All Programs > My IBM Installation Manager > IBM Installation Manager**.

**Linux**

1. Open a terminal window.
2. Go to the *Installation Manager install directory/eclipse directory*.
3. Run this command: `./IBMIM`

### Uninstalling Installation Manager

**About this task**

**Note:** You cannot uninstall IBM Installation Manager until all of the packages have been uninstalled.

**Windows**

The IBM Installation Manager must be uninstalled using the Add or Remove Programs panel.

1. Open the **Start** menu from the Taskbar.
2. Select **Control Panel > Add or Remove Programs > IBM Installation Manager**.
3. Click **Remove** and follow the on-screen instructions.

**Linux**

Do these steps to uninstall Installation Manager:

1. Open a terminal window.
2. Run the following command: `/var.ibm/InstallationManager/uninstall/uninstall`

### Using Installation Manager

**Installation repositories**

Installable offerings, or packages, are stored in locations called repositories, which can be on an HTTP web server, shared network drive, physical discs, or a local workstation. Installation Manager retrieves packages from these repositories to install them on your system.

Anytime you start Installation Manager manually from the Windows **Start** menu, you must specify the repositories that contain the packages to be installed. Enter the repository details in the Installation Manager repository preferences so that
Installation Manager knows where to look for them. For more details, see “Setting repository preferences in Installation Manager.”

Some organizations might bundle and host their own product packages within their intranet. For this type of business case scenario, see installing from a repository on an HTTP server. Your system administrators must provide you with the correct URL.

By default, IBM Installation Manager uses an embedded URL in each package that you install to connect to a repository server through the Internet and search for installable packages, such as service updates and new features.

### Setting repository preferences in Installation Manager

**About this task**

If you start Installation Manager manually from the Windows Start menu, for example to install packages from a repository located on a Web server, you must add the repository location in the Installation Manager preferences before you can install the package. Adding the repository locations is done on the Repositories panel of the Preferences window in Installation Manager. By default, Installation Manager uses an embedded URL in each Rational® software development product to connect to a repository server through the Internet and search for installable packages, updates, and new features. Your organization could require you to redirect the repository to use intranet sites.

**Note:** Before starting the installation process, be sure to obtain the installation package repository URL from your administrator.

To add, edit, or remove a repository location in Installation Manager, do the following steps:

1. Start Installation Manager.
2. On the Start page of Installation Manager, click File > Preferences, and then click Repositories. The Repositories page opens, showing any available repositories, their locations, and if they are accessible.
4. On the Add repository window, enter the URL of the repository location or browse to it and enter a file path, and then click OK. The new or changed repository location is listed. If the repository is not accessible, a red X is displayed in the Accessible column.
5. Click OK to exit.

### Package groups and the shared resource directory

When you install z/OS Explorer with IBM Installation Manager, you must choose a package group and a shared resource directory.

**Package groups**

During the installation process, you must specify a package group for z/OS Explorer and any other bundled offerings you are installing. A package group represents a directory in which the packages share resources with other packages in the same group. This is known as shell sharing. When you install z/OS Explorer and any bundled offerings with Installation Manager, you can create a new package group or install the packages into an existing package group. (Some packages might not be able to share a package group, in which case the option to use an existing package group is not available.)
Note: Under most circumstances, when you install multiple packages at the same time, all of the packages are installed into the same package group.

A package group is assigned a name automatically; however, you choose the installation directory for the package group.

After you create the package group by successfully installing a package, you cannot change the installation directory for the package group. The installation directory contains files and resources that are specific to the packages installed into that package group. Other resources in the packages that can potentially be shared by other package groups are placed in the shared resources directory.

Shared resources directory
The shared resources directory is the directory where resources that can be shared by different packages, potentially in different package groups, are stored. Using a common location for these resources allows Installation Manager to install only one copy of each of these resources, thus conserving disk space, rather than installing separate copies of the same resources when they are used by multiple packages.

Important: You can specify the shared resources directory only once: the first time that you install a package. For best results, use the largest drive for this directory. You cannot change the directory location later unless you uninstall all of the packages.
Appendix. Accessibility features for z/OS Explorer

Accessibility features assist users who have a disability, such as restricted mobility or limited vision, to use information technology content successfully.

Overview

z/OS Explorer includes the following major accessibility features:
- Keyboard-only operation
- Operations that use a screen reader
- Color and typeface preferences

z/OS Explorer uses IBM Installation Manager to install the product. You can read about the accessibility features for IBM Installation Manager in IBM Installation Manager documentation.

z/OS Explorer uses the latest W3C Standard, WAI-ARIA 1.0, to ensure compliance with US Section 508 and Web Content Accessibility Guidelines (WCAG) 2.0. To take advantage of accessibility features, use the latest release of your screen reader and the latest web browser that is supported by z/OS Explorer.

The z/OS Explorer online product documentation in IBM Knowledge Center is enabled for accessibility. The accessibility features of IBM Knowledge Center are described in the Accessibility section of the IBM Knowledge Center help.

Keyboard navigation

You can use keyboard shortcuts to navigate the help system and the product without using a mouse. For more information, see the Keyboard shortcuts for the help system in the product topic in z/OS Explorer documentation.

Interface information

The z/OS Explorer online product documentation is available in IBM Knowledge Center, which is viewable from a standard web browser.

PDF files have limited accessibility support. With PDF documentation, you can use optional font enlargement, high-contrast display settings, and can navigate by keyboard alone.

To enable your screen reader to accurately read syntax diagrams, source code examples, and text that contains period or comma PICTURE symbols, you must set the screen reader to speak all punctuation.

Related accessibility information

In addition to standard IBM help desk and support websites, IBM has a TTY telephone service for use by deaf or hard of hearing customers to access sales and support services:

TTY service 800-IBM-3383 (800-426-3383) (within North America)
For more information about the commitment that IBM has to accessibility, see IBM Accessibility.
Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing IBM Corporation North Castle Drive Armonk, NY 10504-1785 U.S.A.

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing Legal and Intellectual Property Law IBM Japan, Ltd. 19-21, Nihonbashi-Hakozakicho, Chuo-ku Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM websites are provided for convenience only and do not in any manner serve as an endorsement of those websites. The materials at those websites are not part of the materials for this IBM product and use of those websites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

Intellectual Property Dept. for Rational Software IBM Corporation Silicon Valley Lab 555 Bailey Avenue San Jose, CA 95141-1003 U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

Copyright license

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. © Copyright IBM Corp. 1992, 2017.
If you are viewing this information in softcopy, the photographs and color illustrations may not appear.

**Privacy policy considerations**

IBM Software products, including software as a service solutions, ("Software Offerings") may use cookies or other technologies to collect product usage information, to help improve the end user experience, to tailor interactions with the end user or for other purposes. In many cases no personally identifiable information is collected by the Software Offerings. Some of our Software Offerings can help enable you to collect personally identifiable information. If this Software Offering uses cookies to collect personally identifiable information, specific information about this offering’s use of cookies is set forth below.

This Software Offering does not use cookies or other technologies to collect personally identifiable information.

**Trademarks**

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the web at “Copyright and trademark information” at [www.ibm.com/legal/copytrade.shtml](http://www.ibm.com/legal/copytrade.shtml).

**Terms and conditions for product documentation**

**Applicability**

These terms and conditions are in addition to any terms of use for the IBM website.

**Personal use**

You may reproduce these publications for your personal, noncommercial use provided that all proprietary notices are preserved. You may not distribute, display or make derivative work of these publications, or any portion thereof, without the express consent of IBM.

**Commercial use**

You may reproduce, distribute and display these publications solely within your enterprise provided that all proprietary notices are preserved. You may not make derivative works of these publications, or reproduce, distribute or display these publications or any portion thereof outside your enterprise, without the express consent of IBM.

**Rights**

Except as expressly granted in this permission, no other permissions, licenses or rights are granted, either express or implied, to the publications or any information, data, software or other intellectual property contained therein.

IBM reserves the right to withdraw the permissions granted herein whenever, in its discretion, the use of the publications is detrimental to its interest or, as determined by IBM, the above instructions are not being properly followed.
You may not download, export or re-export this information except in full compliance with all applicable laws and regulations, including all United States export laws and regulations.

IBM MAKES NO GUARANTEE ABOUT THE CONTENT OF THESE PUBLICATIONS. THE PUBLICATIONS ARE PROVIDED “AS-IS” AND WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT, AND FITNESS FOR A PARTICULAR PURPOSE.

Copyright license

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be liable for any damages arising out of your use of the sample programs.

Trademark acknowledgments

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at www.ibm.com/legal/copytrade.shtml.

Adobe and PostScript are trademarks of Adobe Systems Incorporated.

Cell Broadband Engine - Sony Computer Entertainment Inc.

Rational is a trademark of International Business Machines Corporation and Rational Software Corporation, in the United States, other countries, or both.

Intel, Intel Centrino, Intel SpeedStep, Intel Xeon, Celeron, Itanium, and Pentium are trademarks of Intel Corporation in the United States, other countries, or both.

IT Infrastructure Library is a trademark of Central Computer and Telecommunications Agency

ITIL is a trademark of The Minister for the Cabinet Office

Linear Tape-Open, LTO, and Ultrium are trademarks of HP, IBM Corp., and Quantum

Linux is a trademark of Linus Torvalds

Microsoft, Windows, and the Windows logo are trademarks or registered trademarks of Microsoft Corporation in the United States, or other countries, or both.
Java™ and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and other countries.

UNIX is a registered trademark of The Open Group in the United States and other countries.
Index

A
accessibility features 35
Adding a new update site 14
additional software, Installing 13

C
Checking for software updates 15

D
directory, shared resource 32

E
Enabling automatic updates 16
Exporting update sites 21, 22

G
groups, Package 32

I
Importing update sites 20
Installation Manager 29
Installation Manager, Installing 30
Installation Manager, Setting repository preferences in 32
Installation Manager, Starting 30
Installation Manager, Uninstalling 31
Installation methods 5
Installation repositories 31
Installing software 13
Installing software updates 15
Installing, additional software 13
Installing, Installation Manager 30
Installing, silent 8

M
methods, Installation 5

P
Package groups 32
preferences, Setting in Installation Manager 32
Preinstallation tasks 1
product updates
 IBM Explorer for z/OS 25

R
Removing an installed plug-in 18
Removing update sites 17
repositories, Installation 31

repository preferences, Setting in
 Installation Manager 32
Reverting to a previous configuration 19

S
shared resource directory 32
silently, Installing 8
Software update sites 14
software, Installing additional 13

tasks, Preinstallation 1

U
Uninstalling a plug-in 18
Uninstalling Installation Manager 31
Uninstalling, z/OS Explorer 27
Updating and installing software 13
 Updating software 13, 15
 Enabling automatic updates 16

Z
z/OS Explorer, Uninstalling 27

© Copyright IBM Corp. 2017
Readers’ Comments — We’d Like to Hear from You

IBM Explorer for z/OS
Client Installation Guide
Version 3 Release 1

Publication No. SC27-8434-02

We appreciate your comments about this publication. Please comment on specific errors or omissions, accuracy, organization, subject matter, or completeness of this book. The comments you send should pertain to only the information in this manual or product and the way in which the information is presented.

For technical questions and information about products and prices, please contact your IBM branch office, your IBM business partner, or your authorized remarketer.

When you send comments to IBM, you grant IBM a nonexclusive right to use or distribute your comments in any way it believes appropriate without incurring any obligation to you. IBM or any other organizations will only use the personal information that you supply to contact you about the issues that you state on this form.

Comments:

Thank you for your support.
Submit your comments using one of these channels:
• Send your comments to the address on the reverse side of this form.
• Send a fax to the following number: 800-555-1213
• Send your comments via email to: phred@us.ibm.com
• Send a note from the web page: http://w3-03.ibm.com/ids/page/636

If you would like a response from IBM, please fill in the following information:

________________________________________________________________________
<table>
<thead>
<tr>
<th>Name</th>
<th>Address</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

________________________________________________________________________
<table>
<thead>
<tr>
<th>Company or Organization</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
</tbody>
</table>

________________________________________________________________________
<table>
<thead>
<tr>
<th>Phone No.</th>
<th>Email address</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>