Skip to main content

WebSphere Application Server for z/OS

WebSphere software

System requirements

System requirements

The minimum operating system and hardware requirements must be met on the server to support the basic installation and use of IBM® WebSphere® Application Server for z/OS. These requirements vary for each version and release. For the details on the software and hardware requirements for all versions, click on the links below.

WAS for z/OS V8.5

WAS for z/OS V8

WAS for z/OS V7

Operating System Software Hardware
AIX, HP-UX, IBM i, Linux, Solaris, Windows, z/OS See the detailed software requirements See the detailed hardware requirements

WAS for z/OS V6.1

Operating System Software Hardware
z/OS, z/OS.e z/OS 1.6 (5694-A01), z/OS.e (5655-G52), or operating systems

Communications server (TCP/IP) or equivalent

z/OS UNIX® System Services and the hierarchical file system (HFS)

zSeries® File System (zFS) can be used in addition to the Hierarchical File System (HFS)

Security Server (RACF®) or equivalent security management product

System logger

System SSL security required when using SSL

Workload management in goal mode

Resource recovery services

The following z/OS elements, features, and components are optional:

IBM HTTP Server for z/OS or equivalent.

SecureWay® Security Server Lightweight Directory Access Protocol (LDAP) Server.

If your application environment uses a DB2® database, then DB2 Universal Database® (UDB) Server for OS/390® and z/OS, V7 (5675-DB2), or later, is required (may coexist with existing levels of DB2 programs used by other applications). CICS® Transaction Server (CICS TS)

If your application environment uses CICS TS, (5655-147), then CICS TS for OS/390 V2.2, (5697-E93), or later, is required.

If your application environment accesses CICS TS through the CICS Transaction Gateway (CICS TG) for z/OS, then CICS TG V6.0 or V6.1 (5655-M69) is required.

For details, visit

Information Management System (IMS™) — If your application environment accesses IMS through Java DataBase Connectivity (JDBC), or through IMS Connect/Connector for Java, then IMS V8 (5655-C56), or later, and appropriate maintenance is required. If, however, your application environment uses JCA 1.5, then IMS V9 (5655-J38) or later, and appropriate maintenance is required.

For details, visit
Any hardware that supports z/OS 1.6, or later

WAS for z/OS V6.0

Operating System Software Hardware
z/OS, z/OS.e z/OS 1.4 (5694-A01), z/OS.e (5655-G52), or operating systems

Communications server (TCP/IP) or equivalent

z/OS UNIX® System Services and the hierarchical file system (HFS)

Security Server (RACF®) or equivalent security management product

System logger

System SSL security required when using SSL

Workload management in goal mode

Resource recovery services
Any hardware that supports z/OS 1.4, or later

WAS for z/OS V5.1 - Server

Operating System Software Hardware
z/OS, z/OS.e z/OS (5694-A01) 1.2, or later, z/OS.e (5655-G52) 1.3, or later, operating systems

Communications server (TCP/IP) or equivalent

z/OS UNIX® System Services and the hierarchical file system (HFS)

Security Server (RACF®) or equivalent security management product

System logger

System SSL security required when using SSL

Workload management in goal mode

Resource recovery services.
Any hardware that supports z/OS 1.2, or later

WAS for z/OS V5.1 - Client

Operating System Software Hardware
Windows 2000, Windows 95, Windows 98, Windows NT Microsoft® Windows® 2000; Microsoft Windows NT® 4.0 (with server pack 3, or later); Microsoft Windows 95 (with server pack 1 or 2); or Microsoft Windows 98

Contact IBM

live-assistance

Considering a purchase?


Or call us at:
877-426-3774
Priority code:
109HE03W