WebSphere MQ File Transfer Edition

System Requirements

Tab navigation

WebSphere MQ File Transfer Edition adds file transfer services to WebSphere MQ for reliable, auditable secure file movement. Please see below for System requirements.

WebSphere MQ - File Transfer Edition V7.0.3

For agent and command queue managers:
- WebSphere MQ V6.0 fix pack 6.0.2.4 or later,
For IBM i installations:
- WebSphere MQ V6.0 fix pack 6.0.2.7 (5724H72) plus
- WebSphere MQ Java Messaging and Web Services (5724L26, which
accompanies 5724H72)

- WebSphere MQ V7.0 fix pack 7.0.0.1 or later
For IBM i installations:
- WebSphere MQ V7.0 fix pack 7.0.1.0 or later
- WebSphere MQ V7.1

For coordination queue manager:
- WebSphere MQ V7.0 fix pack 7.0.0.1 or later
For IBM i installations:
- WebSphere MQ V7.0 fix pack 7.0.1.0 or later

- WebSphere MQ V7.1

Operating System Versions supported for WebSphere MQ File Transfer Server and WebSphere MQ File Transfer Client Additional versions supported for WebSphere MQ File Transfer Client only
AIX AIX® 5.3 plus TL04 and appropriate firmware

AIX V6.1

AIX V7.1
AIX 5.2 with Maintenance level 3
HP-UX HP-UX 11i V2 (11.23) (Itanium)

HP-UX 11i V3 (11.31) (Itanium)

HP-UX V11.11 (PA-RISC)

Linux for System x 32-bit:

Red Hat Enterprise Linux (RHEL) V5.0 or later update

Red Hat Enterprise Linux (RHEL) V6.0 or later update

SUSE Linux Enterprise Server (SLES) V9, Service Pack 4 or later

SUSE Linux Enterprise Server (SLES) V10, Service Pack 1 or later

SUSE Linux Enterprise Server (SLES) V11

64-bit:

Red Hat Enterprise Linux (RHEL) V5.3 or later update

Red Hat Enterprise Linux (RHEL) V6.0 or later update

SUSE Linux Enterprise Server (SLES) V9, Service Pack 4 or later

SUSE Linux Enterprise Server (SLES) V10, Service Pack 1 or later

SUSE Linux Enterprise Server (SLES) V11
32-bit:

Red Hat Enterprise Linux (RHEL) V4.0, Update 8 or later

64-bit:

Red Hat Enterprise Linux (RHEL) V4.0, Update 3 or later
Linux for System P 64-bit:

SUSE Linux Enterprise Server (SLES) V9, Service Pack 3

SUSE Linux Enterprise Server (SLES) V10, Service Pack 2

SUSE Linux Enterprise Server (SLES) V11

Red Hat Enterprise Linux (RHEL) V5.0.2 or later update

Red Hat Enterprise Linux (RHEL) V6.0 or later update

Linux for System z 64-bit:

Red Hat Enterprise Linux (RHEL) V5.0 or later update

Red Hat Enterprise Linux (RHEL) V6.0 or later update

SUSE Linux Enterprise Server (SLES) V10 with Service Pack 1, or later

SUSE Linux Enterprise Server (SLES) V11

Solaris

Sun Solaris V10 on SPARC

Sun Solaris V10 on x86-64
Sun Solaris V8 (with SunSolve-recommended Patch Cluster level) on SPARC

Sun Solaris V9 (with SunSolve-recommended Patch Cluster level) on SPARC
Windows 32-bit:

Microsoft Windows XP Professional (Service Pack 2 or later)

Microsoft Windows Server 2003, Service Pack 2 or later
(Standard or Enterprise Edition)

Microsoft Windows Server 2003 R2, Service Pack 1 or later
(Standard or Enterprise Edition)

Microsoft Windows Server 2008
(Standard or Enterprise Edition)

64-bit:

Microsoft Windows Server 2003, Service Pack 2 or later
(Standard or Enterprise Edition)

Microsoft Windows Server 2003 R2, Service Pack 1 or later
(Standard or Enterprise Edition)

Microsoft Windows Server 2008 (Standard or Enterprise Edition)

Microsoft Windows Server 2008 R2 (Standard or Enterprise Edition)
32-bit:

Microsoft Windows 2000 Server

Microsoft Windows 2000 Professional

Microsoft Windows Vista (Business, Edition)

64-bit:

Microsoft Windows Vista (Business, Edition)

Microsoft Windows 7 (Professional or Ultimate Edition)
i5/OS, IBM i IBM Java Version 5.0 at a minimum service release level of SR8a or later, or IBM Java Version 6.0 at a minimum service release level of SR7 or later.

Version 5.4 plus:
  - PASE (5722SS1 Option 33)
  - Qshell (5722SS1 Option 30)
  - PTF 5722SS1 SI35777
  - IBM Developer Kit for Java™, J2SE 5.0
32-bit option (5722JV1 Base + Option 8)
  - IBM Toolbox for Java™ (5722JC1)
and PTF 5722JC1 SI36017
  - Java™ Group PTF SF99291
  - Database Group PTF SF99504

Version 6.1 plus:
  - PASE (5761SS1 Option 33)
  - Qshell (5761SS1 Option 30)
  - PTF 5761999 MF46740
  - IBM Developer Kit for Java™, J2SE 5.0
32-bit option (5761JV1 Base + Option 8)
  - IBM Toolbox for Java™ (5761JC1)
and PTF 5761JC1 SI36020
  - Java™ Group PTF SF99562
  - Database Group PTF SF99601

Version 7.1 plus:
  - Extended Directory Support (5770SS1 Option 3)
  - PASE (5770SS1 Option 33)
  - Qshell (5770SS1 Option 30)
  - IBM Developer Kit for Java™, J2SE 5.0
32-bit option (5761JV1 Base + Option 8)
  - Java™ Group PTF SF99572
  - Database Group PTF SF99701

z/OS z/OS Version 1, Release 6 (1.6) or higher

IBM Java Version 5.0 at a minimum service release level of SR12 or later, or IBM Java Version 6.0 at a minimum service release level of SR9 FP1 or later.

WebSphere MQ for z/OS V6.0 with at least the following fixes PM17997 (6.0.2.10 MQ Java)

WebSphere MQ for z/OS V7.0 fix pack 7.0.1.0 with at least the following fixes: PM03853 and PM00654

WebSphere MQ for z/OS V7.1

Hardware requirements:
Any hardware that is explicitly compatible and fully capable of running the specified operating system, all the corresponding supporting software, and any associated applications unmodified. Responsibility to provide a statement of full compatibility between machines lies with the original equipment provider (if not IBM).
z/OS Hardware requirements:
Any IBM System z processor, capable of running the required level of operating system, that has enough storage to meet the combined requirements of the programming prerequisites, WebSphere MQ for z/OS, the access methods, and the application programs.

Notes:

The prerequisites to run the Web Gateway or the Java Enterprise Edition Database Logger are as follows:

Notes:

1. If you are using WebSphere Application Server Community Edition 2.1 you must apply APAR IC72511 to WebSphere MQ before installing the WebSphere MQ JCA Resource Adapter

The prerequisites to run the standalone database logger are as follows:

Notes:

1. If you are using Oracle 10.2, you must refer to the following technote before you use the database logger: Oracle 10.2 technote

2. If you are using Linux for System z (64-bit) with Oracle 10g then you need to apply APAR IZ66717 to WebSphere MQ before using the database logger

The prerequisites to run the protocol bridge agent are as follows:

The prerequisites to run the WebSphere MQ Explorer plug-in are as follows:

Any platform that is supported for the MQ Explorer by WebSphere MQ. Check the 'Detailed system requirements' page for the required platform at

( WebSphere MQ V7.0 )

 

( WebSphere MQ V7.1 )

 

The prerequisites to run the WebSphere MQ File Transfer Edition Information Center are as follows:

Compatibility:

WebSphere MQ File Transfer Edition supports file transfer to and from server and client installations at any level of WebSphere MQ File Transfer Edition. See the 'Migration, coexistence, and compatibility between different versions' section of the Information Center at http://publib.boulder.ibm.com/infocenter/wmqfte/v7r0/index.jsp?topic=/com.ibm.wmqfte.doc/migration.htm

Contact IBM

Considering a purchase?