IBM United States
Software Announcement 203-186
July 29, 2003

IBM WebSphere Business Integration Server V4.2.1 Enhancements — Investment protection for AIX and new opportunities with HP-UX

 ENUS203-186.PDF (56KB)


At a glance

  • Process management, process integration, workforce management, and enterprise application connectivity is available in a single solution, IBM WebSphere Business Integration Server V4.2.1.
  • Platform enhancement release and tooling support for the Eclipse V2 standard.
  • Customer investment in software and skills for the HP-UX operating system is now protected.
  • WebSphere Business Integration Collaborations and solutions for industry accelerate process implementation.
  • Solutions are tailored to meet specific business integration challenges.
  • Expand and grow your solutions along with your business requirements to solve complex integration problems that require a wide variety of integration capabilities.

For ordering, contact:

Your IBM representative, an IBM Business Partner, or the Americas Call Centers at 800-IBM-CALL (Reference: YE001).

Overview

IBM WebSphere® Business Integration Server is the IBM business integration solution for process integration, workforce management, and enterprise application connectivity.

In V4.2.1, IBM:

  • Adds platform coverage for AIX® V5.2, HP-UX 11i, and Oracle 9i Release 2
  • Embraces the Eclipse V2 standard for tooling to provide a workbench compatible with WebSphere Studio V5
  • Upgrades the options for system monitoring support for WebSphere InterChange Server to include WebSphere Application Server V5
  • Upgrades the adapter components to V2.3.1 to support HP-UX
  • Enhances entitlement for the Adapter Framework and the Data Handler for eXtensible Markup Language (XML)

Refer to the Statement of General Direction for availability intent for WebSphere Business Integration Message Broker V5.

Key prerequisites

Available on the following platforms:

  • AIX
  • Sun Solaris
  • Microsoft™ Windows NT® and Windows® 2000
  • HP-UX

A supported Web server needs to be acquired to deploy the Web-based system monitoring capability of the InterChange Server.

Refer to the respective Hardware requirements and Software requirements sections for details.

Planned availability dates

  • July 31, 2003: Electronic delivery
  • September 5, 2003: Media packs

Description

IBM WebSphere Business Integration delivers five key ingredients essential to automating business processes:

Model

  • Graphically design processes and simulate reconfigurations with minimal need for programming.
  • Apply costs to activity durations, estimate ROI, and perform Before/After Analysis.

Integrate

  • Accelerate time to market for new business processes — Select from a portfolio of prebuilt process templates.
  • Accelerate application connectivity — Select from a portfolio of ready-to-use application adapters.

Connect

  • Programmatically connect key business processes with those of your trading partners outside the firewall.
  • Use industry standard and Web services protocols to cut costs and increase meaningful business communication.

Monitor

  • Track operation of the business on custom dashboards and receive alerts to irregularities.
  • Check the health status of the deployed system via the Internet remotely.

Manage

  • Use fact-based analysis to improve process effectiveness.
  • Actively analyze and improve business processes — Feedback real data into simulations.

IBM WebSphere Business Integration Server V4.2.1, together with complementary integration accelerators and business activity monitoring tools, provide a business integration platform that can be used to:

  • Create and deploy new business processes
  • Synchronize business events in multiple systems
  • Integrate applications on diverse platforms
  • Transform information formats en route between applications
  • Link people into a new business approach

A business integration platform can help you solve a wide range of integration problems, such as:

  • Deploy integration to support an immediate departmental project and counter a competitive business threat.
  • Link a call center rollout around the world to a range of local and central support systems to improve customer satisfaction.
  • Adopt a new application package and speedily connect to other systems with minimum effort.
  • Introduce supply chain management — Connect all parts of the value chain.
  • Create a blueprint for an enterprise-wide integration platform to support your long term strategic initiatives.

IBM WebSphere Business Integration Server is comprised of the following components:

  • IBM WebSphere InterChange Server V4.2.1
  • IBM WebSphere MQ Workflow V3.4
  • IBM WebSphere MQ Integrator® Broker for Multiplatforms V2.1
  • IBM WebSphere Business Integration Toolset V4.2.1

Also included are these components from IBM WebSphere Business Integration Adapters V2.3.1:

  • IBM WebSphere Business Integration Adapter Framework
  • IBM WebSphere Business Integration Adapter for WebSphere MQ
  • IBM WebSphere Business Integration Adapter for WebSphere MQ Workflow
  • IBM WebSphere Business Integration Adapter for WebSphere MQ Integrator Broker
  • IBM WebSphere Business Integration Adapter for JMS
  • IBM WebSphere Business Integration Adapter for Web Services
  • IBM WebSphere Business Integration Data Handler for XML

Limited use licenses for IBM DB2 Universal Database® Enterprise Server Edition V8.1 and IBM WebSphere MQ V5.3.0.2 are included for the needs of the WebSphere Business Integration Server components. Full licenses must be acquired for any purpose other than specified in the license.

New in WebSphere InterChange Server

  • HP-UX 11i support
  • AIX 5.2 support
  • Oracle 9i Release 2 support

New in WebSphere Business Integration Toolset

  • Eclipse V2-based design studio support
  • Plug-in support for WebSphere Studio upgraded to V5
  • System Manager support for WebSphere Application Server V5 as a prerequisite option

New in WebSphere Business Integration Adapters V2.3.1

  • HP-UX 11i support
  • WebSphere InterChange Server 4.2.1 support
  • New and enhanced adapters

With V4.2.1, the entitlement terms and conditions have been enhanced for the WebSphere Business Integration Adapter Framework and the WebSphere Business Integration Data Handler for XML. The entitlement to use five copies of these components in a WebSphere Business Integration Server solution has been changed to allow unlimited use within a single establishment.

The entitlement for the use of a single instance of each adapter included with WebSphere Business Integration Server remains unchanged. Establishment licenses for WebSphere Business Integration Adapters are available separately.

New in WebSphere MQ Workflow V3.4

  • AIX 5.2 support
  • Oracle 9i Release 2 support for AIX and Solaris platforms
  • Solaris 9 support
  • Service Pack 2 to upgrade HACMP support to V4.5
  • IBM Directory Server 5.1 support

A broad range of optional complimentary products that accelerate the delivery of WebSphere Business Integration Server solutions are recommended.

Accelerators for your business success

IBM provides a wide range of complementary products and support packs that make the implementation of WebSphere Business Integration solutions faster and smoother, and that can help organizations realize a faster return on their integration investments.

IBM WebSphere Business Integration Adapters

Connecting to popular commercial application packages is an important and frequent requirement of integration projects. The WebSphere Business Integration Adapters pull information from the various systems that support business activities, such as packaged and legacy applications, databases, customer-facing Web sites, trading partners' systems, and even public information stores on the Web.

IBM WebSphere Business Integration Collaborations

Businesses in many industries are using WebSphere Business Integration implementations to solve a wide range of business challenges. What we have learned is that there is a set of six common application areas that occur in many industries.

  • Customer relationship management (CRM)
  • Enterprise resource planning (ERP)
  • Supply chain management (SCM)
  • Straight-through processing (STP)
  • Mergers and acquisitions
  • Web exploitation

These operational areas are likely to require significant integration of processes and applications that run across a range of critical business functions.

IBM offers a range of tested and proven business-savvy collaborations that provide a ready-to-use set of best-practices processes to resolve common business issues associated with these areas. When combined with the application-savvy WebSphere Business Integration Adapters from IBM, they provide a complete solution for a range of business issues. IBM customers in many industries have solved their integration challenges using IBM ready-to-use collaborations.

IBM WebSphere Business Integration for Industries

For selected industries, IBM has developed a number of specialized implementations of WebSphere Business Integration by making available prebuilt integration for the finance, retail, insurance, distribution, manufacturing, e-commerce and telecommunications, electronics (RosettaNet), and healthcare (HIPAA).

This prebuilt integration includes industry-specific business objects and templates for business process collaborations, workflows, and application adapters for packaged application solutions that are widely used in that industry. These industry-specific business objects and templates leverage the foundation provided in the WebSphere Business Integration platform. WebSphere Business Integration for Industries provides a solution focused on specific industry requirements and can further accelerate project implementation and help improve the return on investment of the integration project.

Withdrawal of V4.2 media pack

The V4.2 media pack is replaced by:

                                                         Part
Description                                              number
 
IBM WebSphere Business Integration                       AF03LML
 Server V4.2.1 multiplatform, multilingual
 media pack (includes support for HP-UX)

Effective September 26, 2003, the following media pack will be withdrawn.

 
                                                         Part
Description                                              number
 
IBM WebSphere Business Integration                       AF03KML
 Server V4.2 multiplatform,
 multilingual media pack

Orders for this part number will not be accepted after the stated effective date of withdrawal.

Statement of General Direction

IBM has announced WebSphere Business Integration Message Broker V5 as the successor to WebSphere MQ Integrator Broker 2.1. For additional information, refer to Software Announcement 203-136 , dated May 20, 2003.

IBM intends to replace the message broker component of WebSphere Business Integration Server with WebSphere Business Integration Message Broker V5 in the next release.

These plans are subject to change without notice, and this disclosure of IBM plans does not create a commitment on IBM's part to complete the development of any product or function, or to meet any planned time frame. IBM reserves the right to modify or terminate its plans regarding these products without notice or liability.

Reference information

For information on IBM WebSphere Business Integration Server V4.2 and product ordering information, refer to Software Announcement 203-064 , dated March 4, 2003.

For more information on the individual products included as part of IBM WebSphere Business Integration Server V4.2.1, refer to:

  • IBM WebSphere Business InterChange Server V4.2.1 and IBM WebSphere Business Integration Toolset V4.2.1, Software Announcement 203-187 , dated July 29, 2003,
  • IBM WebSphere InterChange Server V4.2, IBM WebSphere Business Integration Toolset V4.2, and IBM WebSphere Business Integration Collaborations, Software Announcement 203-060 , dated March 4, 2003, or visit:
  • IBM WebSphere MQ V5.3, Software Announcement 202-074 , dated April 9, 2002
  • IBM WebSphere MQ Workflow V3.4, Software Announcement 203-061 , dated March 4, 2003, or visit:
  • IBM WebSphere Business Integration Adapters V2.3 and V2.3.1, Software Announcement 203-165 , dated June 24, 2003. For information on the IBM WebSphere Business Integration Adapters pricing enhancements, refer to Software Announcement 203-185 , dated July 22, 2003.
  • IBM WebSphere MQ Integrator Broker for Multiplatforms V2.1, Software Announcement 202-129 , dated June 4, 2002, or visit:

For information on IBM WebSphere Business Integration Modeler and Monitor V4.2.3, refer to Software Announcement 203-062 , dated March 4, 2003.

Trademarks

 
WebSphere, AIX, MQ Integrator, and DB2 Universal Database are registered trademarks of International Business Machines Corporation in the United States or other countries or both.
 
Microsoft is a trademark of Microsoft Corporation.
 
Windows and Windows NT are registered trademarks of Microsoft Corporation.
 
Other company, product, and service names may be trademarks or service marks of others.

Hardware requirements

Recommendations for hardware requirements are supplied for guidance only. Specific hardware configuration will be dependent on the exact IBM WebSphere® Business Integration Server V4.2.1 configuration implemented and production loadings.

The following minimum system requirements are recommended for server components:

  • Windows® environment
    • Processor: An IBM eServer xSeries® and Intel®-based system, or equivalent, with a minimum processor speed of 1 GHz, or dual processors each with a minimum speed of 667 MHz, for high availability
    • RAM: 512 MB
    • Disk space: 40 GB; for high availability, a mirrored 9 GB boot disk and a mirrored 18 GB shared disk
  • AIX® environment
    • Processor: An IBM eServer pSeries™ or RS/6000® system with either a uniprocessor or symmetric multiprocessor (SMP) and a minimum processor speed of 375 MHz; for high availability, a SMP with a minimum processor speed of 600 MHz
    • RAM: 512 MB; for high availability, 2 GB
    • Disk space: 40 GB; for high availability, a minimum of four hard disks, each with 36 GB capacity per system
  • Solaris environment
    • Processor: A Sun Microsystems UltraSPARC processor system with a minimum processor speed of 450 MHz
    • RAM: 512 MB
    • Disk space: 40 GB; for high availability, a minimum of four hard disks, each with 18 GB capacity per system
  • HP-UX environment
    • Processor: A Hewlett-Packard HP-9000 processor system with a minimum processor speed of 440 MHz
    • RAM: 512 MB
    • Disk space: 40 GB

The following minimum system requirements are recommended for buildtime components:

  • Windows environment
    • Processor: An IBM xSeries and Intel-based system, or equivalent, with a minimum processor speed of 1 GHz
    • RAM: 512 MB
    • Disk space: 10 GB

Software requirements

The software requirements for IBM WebSphere Business Integration Server V4.2.1 depend on which of the elements of the product components are being used and whether singly or in combination on a particular server.

The general specification of software requirements for use in combination on a single server are:

Operating systems supported in a combined environment:

  • AIX 5.1 or AIX 5.2
  • Windows 2000 with Support Pack 3
  • Windows NT® 4.0 with Support Pack 6a
  • Solaris 8 (2.8)
  • HP-UX 11.11 (11i)

And for combined administrative, configuration, and operational data:

  • IBM DB2 Universal Database® 8.1

Each of the products may, however, be run on its own server. A summary of the software requirements follows for each of the run time components.

IBM WebSphere InterChange Server V4.2.1

Windows environment

  • Operating system: (one of the following):
    • Windows 2000 (Professional Server or Advanced Server) with Service Pack 3
    • Windows NT 4.0 (Workstation or Server) with Service Pack 6a
    • Windows NT Server Enterprise Edition 4.0 with SupportPac™ MC74 for Microsoft™ Cluster support (for high availability support only)
  • Database (one of the following):
    • IBM DB2 Universal Database Enterprise Server Edition 8.1 with Fix Pack 2
    • Oracle RDBMS 8.1.7.2 or 9.2.0.1 (9i)
    • Microsoft SQL Server 7.0 with Service Pack 4
    • Microsoft SQL Server 2000 with Service Pack 3
  • Communication:
    • IBM WebSphere MQ Client and Server V5.3.0.2 with CSD 3
    • WebSphere MQ Internet Pass-thru 1.2 (optional for Remote Agent)
    • Any WebSphere Application Server that supports Enterprise JavaBeans, 1.1 or later (to support IBM WebSphere InterChange Server Access for Enterprise JavaBeans only)
    • A Web application server to support the Web-based System Manager (one of the following):
      • IBM WebSphere Application Server V4.0.5 or V5.0
      • Tomcat V4.1.18 or V4.1.24 (not supported in Double Byte Character Set (DBCS) language environments)
  • E-mail: A simple mail transfer protocol (SMTP) e-mail system (for example, Microsoft Outlook, Microsoft Exchange, or Eudora)
  • Browser to support the Web-based System Manager and to view HTML documents (one of the following):
    • Microsoft Internet Explorer 5.5, or later
    • Netscape Navigator 4.75
  • Java™ compiler (Sun Java Development Kit (JDK) 1.3.1.6 for Windows NT and Windows 2000) required for compiling customer-generated maps and collaborations
  • A DB2®-supported C or C++ compiler to compile DB2 stored procedures
  • Adobe Acrobat 4.05, or later, to view online publications

AIX environment

  • Operating system:
    • IBM AIX 5.1 maintenance level 3 or IBM AIX 5.2
    • HACMP 4.5 (for high availability support only)
  • Database (one of the following):
    • IBM DB2 Universal Database Enterprise Server Edition 8.1 with Fix Pack 2
    • Oracle RDBMS 8.1.7.2 or 9.2.0.1 (9i)
  • Communication:
    • IBM WebSphere MQ Client and Server V5.3.0.2 with CSD 3
    • Any WebSphere Application Server that supports Enterprise JavaBeans 1.1, or later (to support IBM WebSphere InterChange Server Access for Enterprise JavaBeans only)
    • A Web application server to support the Web-based System Manager (one of the following):
      • IBM WebSphere Application Server V4.0.5 or V5.0
      • Tomcat V4.1.18 or V4.1.24 (not supported in DBCS language environments)
  • E-mail: A SMTP e-mail system
  • Browser: Netscape Navigator V4.78i to support the Web-based System Manager and to view HTML documents
  • Java compiler (IBM JDK 1.3.1.6) required for compiling customer-generated maps and collaborations
  • A DB2-supported C or C++ compiler to compile DB2 stored procedures
  • Adobe Acrobat 4.05, or later, to view online publications

Solaris environment

  • Operating system:
    • Solaris 8 (2.8) or Solaris 7 (2.7) with Solaris Patch Report Updates as of October 1, 2002, or later
    • Sun Cluster 2.2 or Veritas Cluster Server 1.3 (for high availability support only)
  • Database (one of the following):
    • IBM DB2 Universal Database Enterprise Server Edition 8.1 with Fix Pack 2
    • Oracle RDBMS 8.1.7.2 or 9.2.0.1 (9i)
  • Communication:
    • IBM WebSphere MQ Client and Server V5.3.0.2 with CSD 3
    • WebSphere MQ Internet Pass-thru 1.2 (optional for Remote Agent)
    • Any WebSphere Application Server that supports Enterprise JavaBeans 1.1, or later (to support IBM WebSphere InterChange Server Access for Enterprise JavaBeans only)
    • A Web application server to support the Web-based System Manager (one of the following):
      • IBM WebSphere Application Server V4.0.5 or V5.0
      • Tomcat V4.1.18 or V4.1.24 (not supported in DBCS language environments)
  • E-mail: A SMTP e-mail system
  • Browser: Netscape Navigator V4.78 to support the Web-based System Manager and to view HTML documents
  • Java compiler (Sun JDK 1.3.1.7) required for compiling customer-generated maps and collaborations
  • A DB2-supported C or C++ compiler to compile DB2 stored procedures
  • Adobe Acrobat 4.05, or later, to view online publications

HP-UX environment

  • Operating system: HP-UX 11.11 (11i) with December 2001 GOLDBASE11i and December 2001 GOLDAPPS11i bundles, patch PHSS_26560 and patches for Java SDK 1.3.1
  • Database (one of the following):
    • IBM DB2 Universal Database Enterprise Server Edition 8.1 with Fix Pack 2
    • Oracle RDBMS 8.1.7.2 or 9.2.0.1 (9i)
  • Communication:
    • IBM WebSphere MQ Client and Server V5.3.0.2 with CSD 3
    • WebSphere MQ Internet Pass-thru 1.2 (optional for Remote Agent)
    • A Web application server to support the Web-based System Manager (one of the following):
      • IBM WebSphere Application Server V4.0.5
      • Tomcat V4.1.18 or V4.1.24 (not supported in (DBCS) language environments)
  • E-mail: A SMTP e-mail system
  • Browser: Netscape Navigator V4.79 to support the Web-based System Manager and to view HTML documents
  • Java compiler (Hewlett-Packard JDK 1.3.1.6) required for compiling customer-generated maps and collaborations
  • A DB2-supported C or C++ compiler to compile DB2 stored procedures
  • Adobe Acrobat 4.05, or later, to view online publications

IBM WebSphere Business Integration Toolset V4.2.1

Windows environment

  • Operating system: Windows 2000 (Professional Server, or Advanced Server) with Service Pack 3.
  • Source code control (One of the following to support CSM source code control and to view HTML documents):
    • Rational® ClearCase® LT 4.2
    • Concurrent Version System (CVS) 1.11
  • Browser to support the Web-based System Manager only (one of the following):
    • Microsoft Internet Explorer 5.5, or later
    • Netscape Navigator 4.75
  • Integrated test environment: A WebSphere InterChange Server must be installed on the same machine as the toolset. A separate instance of the database used as the InterChange Server repository, dedicated to testing purposes only, is also required.
  • Adobe Acrobat 4.05, or later, to view online publications

IBM WebSphere Business Integration Adapters V2.3.1

Refer to the IBM WebSphere InterChange Server 4.2.1 Software requirements section.

IBM WebSphere MQ Integrator® Broker for MultiPlatforms V2.1

The following requirements apply to Message Broker Servers, User Name Servers, and the Command Assistant.

Windows environment

  • Operating system (one of the following):
    • Windows 2000 Server with Service Pack 3
    • Windows NT 4.0 (Workstation or Server) with Service Pack 6a
  • Database (one of the following):
    • IBM DB2 Universal Database 8.1
    • IBM DB2 Universal Database 7.2 with Fix Pack 4
    • IBM DB2 Universal Database 7.1 with Fix Pack 4
    • IBM DB2 Universal Database 6.1 with Fix Pack 8
    • Oracle 8.1.7
    • Microsoft SQL Server 7.0 with Service Pack 3
    • Microsoft SQL Server 6.5 with Service Pack 5a
    • Sybase Adaptive Server Enterprise (ASE) 12 with patch update EBF9641
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3.0.2
    • IBM MQSeries® 5.2 (requires IBM DB2 Universal Database 7.2 or 7.1 with Fix Pack 4)
  • Java requirement: JRE 1.3

AIX environment

  • Operating system (one of the following):
    • IBM AIX 5.1 maintenance level 2
    • IBM AIX 4.3.3
  • Database (one of the following):
    • IBM DB2 Universal Database 8.1
    • IBM DB2 Universal Database 7.2 with Fix Pack 4
    • IBM DB2 Universal Database 7.1 with Fix Pack 4
    • IBM DB2 Universal Database 6.1 with Fix Pack 8
    • Oracle RDBMS 8.1.7
    • Sybase Adaptive Server Enterprise (ASE) 12
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3.0.2
    • IBM MQSeries 5.2 (requires IBM DB2 Universal Database 7.2 or 7.1 with Fix Pack 4)
  • Java requirement: JRE 1.3

Solaris environment

  • Operating system (one of the following):
    • Solaris 8 (2.8) with fix 109147-06
    • Solaris 7 (2.7)
  • Database (one of the following):
    • IBM DB2 Universal Database 8.1
    • IBM DB2 Universal Database 7.2 with Fix Pack 4
    • IBM DB2 Universal Database 7.1 with Fix Pack 4
    • IBM DB2 Universal Database 6.1 with Fix Pack 8
    • Oracle 8.1.7
    • Sybase Adaptive Server Enterprise (ASE) 12 with patch update EBF9641
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3.0.2
    • IBM MQSeries 5.2 (requires IBM DB2 Universal Database 7.2 or 7.1 with Fix Pack 4)
  • Java requirement: JRE 1.3

HP-UX environment

  • Operating system: HP-UX 11i with September 2001 Quality Pack
  • Database (one of the following):
    • IBM DB2 Universal Database 8.1
    • IBM DB2 Universal Database 7.2 with Fix Pack 4
    • IBM DB2 Universal Database 7.1 with Fix Pack 4
    • IBM DB2 Universal Database 6.1 with Fix Pack 8
    • Oracle 8.1.7
    • Sybase ASE 12 with patch update EBF9641
  • Communication:
    • IBM WebSphere MQ 5.3.0.2
    • IBM MQSeries 5.2 (requires IBM DB2 Universal Database 7.2 or 7.1 with Fix Pack 4)
  • Java requirement: JRE 1.3

Transactional support is available in this release on the following databases:

  • IBM DB2 Universal Database 7.2, 7.1, and 6.1 (all platforms)
  • Oracle 8.1.7 (all platforms)

The following requirements apply to the Broker Control Center and the Configuration Manager.

Windows environment

  • Operating system (one of the following):
    • Windows 2000 Server with Service Pack 3
    • Windows NT 4.0 (Workstation or Server) with Service Pack 6a
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3.0.2
    • IBM MQSeries 5.2 (requires IBM DB2 Universal Database 7.2 or 7.1 with Fix Pack 4)

AIX environment

  • Operating system (one of the following):
    • IBM AIX 5.1 maintenance level 2
    • IBM AIX 4.3.3
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3.0.2
    • IBM MQSeries 5.2 (requires IBM DB2 Universal Database 7.2 or 7.1 with Fix Pack 4)

Solaris environment

  • Operating system (one of the following):
    • Solaris 8 (2.8) with fix 109147-06
    • Solaris 7 (2.7)
  • Communication:
    • IBM WebSphere MQ 5.3.0.2
    • IBM MQSeries 5.2 (requires IBM DB2 Universal Database 7.2 or 7.1 with Fix Pack 4)

HP-UX environment

  • Operating system: HP-UX 11i with September 2001 Quality Pack
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3.0.2
    • IBM MQSeries 5.2 (requires IBM DB2 Universal Database 7.2 or 7.1 with Fix Pack 4)

IBM WebSphere MQ Workflow V3.4

The following requirements apply to WebSphere MQ Workflow Servers.

Note: Support for AIX 5.2, HACMP 4.5, and Oracle 9.2.0.1 are provided in IBM WebSphere MQ Workflow V3.4 Service Pack 2. Windows environment

  • Operating system (one of the following):
    • Windows 2000
    • Windows NT 4.0 (Workstation or Server) with Service Pack 6a
    • Windows XP Professional
  • Database (one of the following):
    • IBM DB2 Universal Database 8.1
    • IBM DB2 Universal Database 7.2
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3 with CSD 1
    • IBM MQSeries 5.2 with CSD 5
  • LDAP (one of the following):
    • IBM Directory Server 5.1
    • IBM Directory Server 4.1
    • IBM SecureWay® Directory Server 3.2.2

AIX environment

  • Operating system (one of the following):
    • IBM AIX 5.2
    • IBM AIX 5.1 maintenance level 2
    • IBM AIX 4.3.3
    • For HACMP:
      • IBM AIX 4.3.1 with HACMP 4.2.2
      • IBM AIX 4.3.2 or 4.3.3 with HACMP 4.3.1
      • IBM AIX 5.1 maintenance level 2 or AIX 5.2 with HACMP 4.5
  • Database (one of the following):
    • IBM DB2 Universal Database 8.1
    • IBM DB2 Universal Database 7.2
    • Oracle RDBMS 8.1.7.1, 9.0.1.0, or 9.2.0.1
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3 with CSD 1
    • IBM MQSeries 5.2 with CSD 5
  • LDAP (one of the following):
    • IBM Directory Server 5.1
    • IBM Directory Server 4.1
    • IBM SecureWay Directory Server 3.2.2

Solaris environment

  • Operating system (one of the following):
    • Solaris 9
    • Solaris 8 (2.8)
    • Solaris 7 (2.7)
  • Database (one of the following):
    • IBM DB2 Universal Database 8.1
    • IBM DB2 Universal Database 7.2
    • Oracle 8.1.7.1, 9.0.1.0, or 9.2.0.1
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3 with CSD 1
    • IBM MQSeries 5.2 with CSD 5
  • LDAP (one of the following):
    • IBM Directory Server 5.1
    • IBM Directory Server 4.1
    • IBM SecureWay Directory Server 3.2.2

HP-UX environment

  • Operating system: HP-UX 11.0 or 11i
  • Database (one of the following):
    • IBM DB2 Universal Database 8.1 for HP-UX 11i
    • IBM DB2 Universal Database 7.2 for HP-UX 11.0
    • Oracle 8.1.7.1
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3 with CSD 1
    • IBM MQSeries 5.2 with CSD 5
  • LDAP (one of the following):
    • IBM Directory Server 5.1
    • IBM Directory Server 4.1
    • IBM SecureWay Directory Server 3.2.2

The following requirements apply to WebSphere MQ Workflow Clients.

Note: Support for AIX 5.2 is provided in IBM WebSphere MQ Workflow V3.4 Service Pack 2.

Windows environment

  • Operating system (one of the following):
    • Windows 2000
    • Windows NT 4.0 Workstation
    • Windows XP Professional
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3 client with CSD 1
    • IBM MQSeries 5.2 client with CSD 5
  • Web Application Server (one of the following):
    • IBM WebSphere Application Server 3.5.3 and higher, or 4.0.1 and higher, or 5.0
  • For RMI/IIOP communication:
    • ORB of IBM WebSphere Application Server 3.5.3 and higher, or 4.0.1 and higher, or 5.0
  • For a Portal client: IBM WebSphere Portal Server 4.1.2
  • For user access to the Web: A browser supporting HTML 4 with Cascading Style Sheets (CSS) is required, such as Netscape Navigator 4.7 or later, or Microsoft Internet Explorer 5.5 or 6.0
  • To develop programs using the WebSphere MQ Workflow APIs, one of the following is required:
    • Microsoft Visual C++ 6.0 (for WebSphere MQ Workflow Client APIs for C and C++)
    • IBM JDK 1.2.2 or 1.3 (for WebSphere MQ Workflow Client APIs for Java), or Sun JDK 1.3.1_04 or later
  • To develop programs using the WebSphere MQ Workflow ActiveX controls: Microsoft Visual Basic 6.0
  • Lotus Notes® API 4.5

AIX environment

  • Operating system (one of the following):
    • IBM AIX 5.2
    • IBM AIX 5.1 for PowerProcessor Chip (PPC)
    • IBM AIX 4.3.3
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3 client with CSD 1
    • IBM MQSeries 5.2 client with CSD 5
  • Web Application Server (one of the following):
    • IBM WebSphere Application Server 3.5.3 and higher, or 4.0.1 and higher, or 5.0
  • For RMI/IIOP communication:
    • ORB of IBM WebSphere Application Server 3.5.3 and higher, or 4.0.1 and higher, or 5.0
  • For a Portal client: IBM WebSphere Portal Server 4.1.2
  • For user access to the Web: A browser supporting HTML 4 with CSS is required, such as Netscape Navigator 4.7, or later
  • To develop programs using the WebSphere MQ Workflow APIs, one of:
    • IBM C for AIX 5.0
    • IBM VisualAge® C++ Professional for AIX 5.0
    • IBM JDK 1.2.2 or 1.3 (for WebSphere MQ Workflow Client APIs for Java), or Sun JDK 1.3.1_04, or later

Solaris environment

  • Operating system (one of the following):
    • Solaris 9
    • Solaris 8 (2.8)
    • Solaris 7 (2.7)
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3 client with CSD 1
    • IBM MQSeries 5.2 client with CSD 5
  • Web Application Server (one of the following):
    • IBM WebSphere Application Server 3.5.3 and higher, or 4.0.1 and higher, or 5.0
  • For RMI/IIOP communication:
    • ORB of IBM WebSphere Application Server 3.5.3 and higher, or 4.0.1 and higher, or 5.0
  • For a Portal client: IBM WebSphere Portal Server 4.1.2
  • For user access to the Web: A browser supporting HTML 4 with CSS is required, such as Netscape Navigator 4.7, or later
  • To develop programs using the WebSphere MQ Workflow APIs:
    • Sun Workshop Compiler Professional C/SPARC 4.2 or 5.0
    • Sun Workshop Compiler Professional C++/SPARC 6.2
    • Sun JDK 1.3.1_04 (for WebSphere MQ Workflow Client APIs for Java)

HP-UX environment

  • Operating system: HP-UX 11.0 or 11i
  • Communication (one of the following):
    • IBM WebSphere MQ 5.3 client with CSD 1
    • IBM MQSeries 5.2 client with CSD 5
  • Web Application Server: IBM WebSphere Application Server 4.0.1, or higher
  • For RMI/IIOP communication:
    • ORB of IBM WebSphere Application Server 3.5.3 and higher, or 4.0.1 and higher, or 5.0
  • For user access to the Web: A browser supporting HTML 4 with CSS is required, such as Netscape Navigator 4.7, or later
  • To develop programs using the WebSphere MQ Workflow APIs:
    • HP ANSI C++ Compiler for HP-UX 11
    • IBM JDK 1.2.2 or 1.3 (for WebSphere MQ Workflow APIs for Java), or Sun JDK 1.3.1_04, or later

Order now

To order, contact the Americas Call Centers, your local IBM representative, or your IBM Business Partner.

To identify your local IBM representative or IBM Business Partner, call 800-IBM-4YOU (426-4968).

 Phone:     800-IBM-CALL (426-2255)
 Fax:       800-2IBM-FAX (242-6329)
 Internet:  ibm_direct@vnet.ibm.com
 Mail:      The Americas Call Centers
            Dept. YE001
            P.O. Box 2690
            Atlanta, GA  30301-2690
 
 Reference: YE001

The Americas Call Centers, our national direct marketing organization, can add your name to the mailing list for catalogs of IBM products.

Note: Shipments will begin after the planned availability date.

Trademarks

 
pSeries, the e-business logo, and SupportPac are trademarks of International Business Machines Corporation in the United States or other countries or both.
 
WebSphere, xSeries, AIX, RS/6000, DB2 Universal Database, DB2, MQ Integrator, MQSeries, SecureWay, Lotus Notes, and VisualAge are registered trademarks of International Business Machines Corporation in the United States or other countries or both.
 
Intel is a registered trademark of Intel Corporation.
 
Microsoft is a trademark of Microsoft Corporation.
 
Windows and Windows NT are registered trademarks of Microsoft Corporation.
 
Java is a trademark of Sun Microsystems, Inc.
 
ClearCase and Rational are registered trademarks of IBM Corporation and Rational Software Corporation, in the United States, other Countries or both.
 
Other company, product, and service names may be trademarks or service marks of others.